Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Suspend-resume werkt niet op een ASRock CoreHT met ubuntu 14.04 64-bit  (gelezen 297 keer)

Offline helly

  • Lid
Hoi,

Ik heb een heel aantal dingen geprobeerd die ik heb gevonden op het internet, maar ik ben niet in staat om suspend en resume aan de praat te krijgen. Hibernate werkt echter prima. Misschien kan iemand hier me helpen.

Ik had ubuntu 12.10 32-bit geïnstalleerd en suspend werkte prima met deze versie. Ik heb laatst 14.04 64-bit geinstalleerd en ik ben zeer tevreden met de prestatie  verbeteringen. Het enige ding is dat suspend niet meer werkt en ik wil deze functie echt gebruiken.

Suspend lijkt goed te werken, maar na resume hangt het systeem. Nadat het systeem ge-powered-up is, krijg ik een bevroren scherm (screenshot als voordat het systeem werd uitgeschakeld) en de CPU blijkt niet te lopen. Toetsenbord en muis werken ook niet. Ik moet de uit-knop enkele seconden ingedrukt houden om het systeem uit te schakelen. Het vreemde is dat eens ongeveer 20 keer resume (deels) werkt. Als ik kijk op 'pm-suspend.log', is de laatste regel 'performing suspend'. 'Wake-up' verschijnt nooit ...

Ik neem aan dat het probleem video-kaart gerelateerd is. Ik heb een intel GPU (sandy-bridge), en gebruik de i915 driver. Als ik kms uitschakel (nomodeset of i915.modeset=0 boot optie), lijkt resume te kunnen werken. Alleen video is crappy (vóór suspend) en ik krijg geen video na resume. Maar ik kan inloggen vanuit een ssh shell en het systeem bedienen.

Ik heb een heleboel opties geprobeerd, maar niets schijnt aan mijn probleem op te lossen:
* Verschillende i915 boot opties geprobeerd
* pm-supend quirks geprobeerd
* verschillende modes geprobeerd van /sys/power/pm_test
* s2ram geïnstalleerd en alle opties geprobeerd
* Een heleboel opties in /etc/pm/sleep.d geprobeerd (omdat het systeem van tevoren blijft hangen, worden deze commando's niet uitgevoerd)
* Suspend met alleen tekst scherm en geen X geprobeerd
* Veel kernels (ubuntu kernels en mainline versie 3.9-3.15, zelfs intel drm versies) geprobeerd, maar niets werkte.

Ik hoop dat iemand mij kan helpen met dit probleem. Indien je meer informatie of logfiles nodig hebt, laat het me even weten.

Bij voorbaat dank.
Ivo.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Suspend-resume werkt niet op een ASRock CoreHT met ubuntu 14.04 64-bit
« Reactie #1 Gepost op: 2014/06/28, 10:35:55 »
Is er op de webstek van de moederbordfabrikant, en nieuwer BIOS / UEFI beschikbaar voor je moederbord? Zo ja, installeer het dan. Helpt wel eens bij dit soort problemen....

Offline helly

  • Lid
Re: Suspend-resume werkt niet op een ASRock CoreHT met ubuntu 14.04 64-bit
« Reactie #2 Gepost op: 2014/06/28, 10:39:31 »
Bedankt voor de reactie. Ik heb echter al naar de laatste bios ge-update.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Suspend-resume werkt niet op een ASRock CoreHT met ubuntu 14.04 64-bit
« Reactie #3 Gepost op: 2014/06/28, 10:53:01 »
Probeer het eens met 32-bit Ubuntu 14.04?

Offline helly

  • Lid
Re: Suspend-resume werkt niet op een ASRock CoreHT met ubuntu 14.04 64-bit
« Reactie #4 Gepost op: 2014/07/05, 08:51:35 »
Goeie tip, maar helaas ook niet de oplossing. ik heb ubuntu 14.04 32-bit geprobeerd, maar helaas geeft resume hetzelfde resultaat.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Suspend-resume werkt niet op een ASRock CoreHT met ubuntu 14.04 64-bit
« Reactie #5 Gepost op: 2014/07/05, 10:11:38 »
Ubuntu 12.04 is ook nog een optie.... Die wordt nog ondersteund tot april 2017.

Als dat een goede optie is, dan zou je in april 2016 weer eens kunnen kijken naar Ubuntu 16.04 LTS.

Offline XappX

  • Lid
Re: Suspend-resume werkt niet op een ASRock CoreHT met ubuntu 14.04 64-bit
« Reactie #6 Gepost op: 2014/07/21, 09:09:31 »
Hi,
I did this!!
sudo gedit /var/lib/polkit-1/localauthority/10-vendor.d/com.ubuntu.desktop.pkla
change ->

[Disable hibernate by default in upower]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

[Disable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate
ResultActive=yes

sudo dconf-editor
click on org  ->  gnome  -> settings-deamon  ->  plugins -> power -> change to default or suspend!!
check if ur hav a swap
sudo gedit /etc/fstab -> check ur swap uuid and /dev/sdaX
sudo blkid
cat /proc/swaps
sudo swapon -s
if u dont hav 1 create1
sudo swapoff -a
sudo /sbin/mkswap /dev/sdaX example xda6,4,5…… or gparted
sudo swapon -a
sudo swapon –all –verbose
mountall -v
sudo gedit /etc/default/grub
GRUB_CMDLINE_LINUX=”acpi_sleep=nonvs resume=UUID=your uuid(swap)”
sudo update-grub
sudo gedit /etc/initramfs-tools/conf.d/resume
RESUME=UUID=your uuid(swap)
sudo update-initramfs -u
sudo mountall
Reboot
Good luck
« Laatst bewerkt op: 2014/07/21, 09:31:28 door XappX »

Offline helly

  • Lid
Re: Suspend-resume werkt niet op een ASRock CoreHT met ubuntu 14.04 64-bit
« Reactie #7 Gepost op: 2014/08/21, 16:09:21 »
Iedereen bedankt voor de reacties, maar ik heb uiteindelijk de oplossing voor mijn probleem gevonden en 'suspend'werkt nu weer perfect.

I heb een heel aantal dingen geprobeerd en ben op een gegeven moment een aantal kernel acpi command line parameters gaan proberen. De volgende loste het probleem voor mij op:

acpi_sci=low

I weet niet waarom (misschien is de interrupt laag actief) maar na het toeveogen van deze parameter is suspend nooit meer fout gegaan.

Met vriendelijke groet,
Ivo.