Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Gramps in het Engels starten  (gelezen 358 keer)

Offline jvecht

  • Lid
    • Just Vecht
  • Steunpunt: Ja
Gramps in het Engels starten
« Gepost op: 2014/06/09, 11:33:05 »
Ik gebruik Xubuntu 14.04

Voor de stamboom gebruik ik Gramps in het Nederlands. Die taalkeuze hangt vast samen met de taal vn mijn systeem. Voor familieleden overzee levert dat uitdraaien op in het Nederlands en dat werkt natuurlijk niet. De jongeren beheersen het Nederlands niet meer. Ik had een script om Gramps in het Engels te starten. Die werkte prima, maar nu in 14.04 niet meer. Daarnet nog eens nagelezen of dat  soms anders moet en een ietwat andere opdracht gevonden. Maar die doet het net zo min.

#!/bin/bash
# LANG=en_US.utf8 gramps
LANG=en_US.UTF-8 /usr/bin/gramps

De terminal laat zien:

** (gramps:5862): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-5RhtduBGwD: Verbinding is geweigerd
Het programma start dan toch in het Nederlands op.

Iemand daar een oplossing voor, die in 14.04 wel werkt?


GIMP bundel 2017  25 cursussen met geweldig mooi oefenmateriaal. Lekker lezen of er wat van opsteken!
  Boekje "Werken met Xubuntu" 4000+ downloads!
     Het Helpmij Magazine November 2017

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Gramps in het Engels starten
« Reactie #1 Gepost op: 2014/06/09, 11:58:25 »
In de instellingen van Gramps kun je de taal wijzigen naar Nederlands, als ik me niet vergis.

Offline jvecht

  • Lid
    • Just Vecht
  • Steunpunt: Ja
Re: Gramps in het Engels starten
« Reactie #2 Gepost op: 2014/06/09, 12:43:03 »
Hij doet het standaard in het Nederlands. Dat gaat puik. Maar ik wil de uitdraaien in het Engels voor mensen die geen Nederlands spreken. Dat deed ik door Gramps op te starten met de Engelse locale met het commando wat ik hierboven gaf.  En dat lukt me niet meer. Dat is wel heel erg vervelend.

Het lijkt een bug te zijn: https://gramps-project.org/bugs/view.php?id=7789 Ik heb me er maar bij gezet.

GIMP bundel 2017  25 cursussen met geweldig mooi oefenmateriaal. Lekker lezen of er wat van opsteken!
  Boekje "Werken met Xubuntu" 4000+ downloads!
     Het Helpmij Magazine November 2017

Offline redmar

  • Vertaalteam
  • Steunpunt: Nee
Re: Gramps in het Engels starten
« Reactie #3 Gepost op: 2014/06/09, 18:54:06 »
Je zal de taal en_US.UTF-8 wel niet geïnstalleerd hebben. Je kan altijd 'LANG=C' gebruiken als je het in het Engels wil, dan hoef je niet per se een exacte versie van Engels (US) geïnstalleerd te hebben.

Offline jvecht

  • Lid
    • Just Vecht
  • Steunpunt: Ja
Re: Gramps in het Engels starten
« Reactie #4 Gepost op: 2014/06/09, 19:32:02 »
Thunderbird start anders prima op in het Engels met dezelfde opdracht toen ik eindelijk op het idee kwam het eens bij een ander programma te proberen. Locale -a toont de gewenste taal ook naar behoren.

LANG=C /usr/bin/gramps start Gramps ook niet in het Engels.
« Laatst bewerkt op: 2014/06/09, 19:34:49 door jvecht »
GIMP bundel 2017  25 cursussen met geweldig mooi oefenmateriaal. Lekker lezen of er wat van opsteken!
  Boekje "Werken met Xubuntu" 4000+ downloads!
     Het Helpmij Magazine November 2017

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Gramps in het Engels starten
« Reactie #5 Gepost op: 2014/06/09, 20:24:41 »
Thunderbird start anders prima op in het Engels met dezelfde opdracht toen ik eindelijk op het idee kwam het eens bij een ander programma te proberen. Locale -a toont de gewenste taal ook naar behoren.

LANG=C /usr/bin/gramps start Gramps ook niet in het Engels.


Er is antwoord ;)
https://gramps-project.org/bugs/view.php?id=7789

"Most likely you're misspelling the locale, try en_US.UTF-8. Check /usr/share/locale and make sure that there's a matching directory. On Debian-derived distros you also need to enable locales, see
http://people.debian.org/~schultmc/locales.html [^]
It's also possible that Ubuntu's shell is already defining all of the locale variables; in that case LANG is only a fall-back. You can use LC_ALL instead in that case.

But if it's report output that you want in English, see if the reports that you need have a language option. That will let you run Gramps in Dutch and print those reports in English."

Offline jvecht

  • Lid
    • Just Vecht
  • Steunpunt: Ja
Re: Gramps in het Engels starten
« Reactie #6 Gepost op: 2014/06/09, 21:55:14 »
Ja, ze zijn heel actief! Geweldig. Daar zit ik toch direct te praten met de ontwikkelaars. Dat zal je elders (op andere platforms bedoel ik) toch niet gauw meemaken of heb ik dat nou mis?

De andere spelling had ik al aangepast, zie mijn eerste post. Hielp niet. Die taal optie voor rapporten is een bruikbare oplossing, maar helaas niet in alle gevallen. Ik heb al gereageerd. Nog maar even kijken wat het wordt. Dit zou toch te reproduceren moeten zijn tenzij het alleen zo is in Xubuntu (en zij dat nou net niet hebben draaien).

Wat bedoelen ze nu met LC_ALL? Zo:

LC_ALL /usr/bin/gramps
Dat levert: LC_ALL: opdracht niet gevonden
en LANG=LC_ALL /usr/bin/gramps
levert weer Gramps in het Nederlands
« Laatst bewerkt op: 2014/06/09, 22:04:17 door jvecht »
GIMP bundel 2017  25 cursussen met geweldig mooi oefenmateriaal. Lekker lezen of er wat van opsteken!
  Boekje "Werken met Xubuntu" 4000+ downloads!
     Het Helpmij Magazine November 2017

Offline redmar

  • Vertaalteam
  • Steunpunt: Nee
Re: Gramps in het Engels starten
« Reactie #7 Gepost op: 2014/06/09, 22:21:04 »
Ik denk dat het LC_ALL=C gramps moet zijn. Als tijdelijke oplossing kan je ook een andere gebruiker op je PC aanmaken, en voor dat account de taal op Engels zetten.

Offline jvecht

  • Lid
    • Just Vecht
  • Steunpunt: Ja
Re: Gramps in het Engels starten
« Reactie #8 Gepost op: 2014/06/09, 22:47:49 »
Ik denk dat het LC_ALL=C gramps moet zijn. Als tijdelijke oplossing kan je ook een andere gebruiker op je PC aanmaken, en voor dat account de taal op Engels zetten.

Nee, wat een taaie! Weer gewoon Nederlands. Ik heb al een aparte gebruiker aangemaakt, maar die heeft geen stambomen. Daarvoor zal ik dan de .gramps map uit mijn thuismap moeten overzetten. Dat is een goede workaround, lijkt me. Alleen wat omslachtig.
GIMP bundel 2017  25 cursussen met geweldig mooi oefenmateriaal. Lekker lezen of er wat van opsteken!
  Boekje "Werken met Xubuntu" 4000+ downloads!
     Het Helpmij Magazine November 2017

Offline jvecht

  • Lid
    • Just Vecht
  • Steunpunt: Ja
Re: Gramps in het Engels starten
« Reactie #9 Gepost op: 2014/06/11, 10:05:31 »
De ontwikkelaars van Gramps hebben de oplossing gevonden na het bekijken van de taal-instellingen van mijn Xubuntu 14.04. Hier is hun reactie:
Citaat
So here's your problem:
LANG=en_US.UTF-8
LANGUAGE=nl_NL:en_US:en
LC_ADDRESS=nl_NL.UTF-8
LC_IDENTIFICATION=nl_NL.UTF-8
LC_MEASUREMENT=nl_NL.UTF-8
LC_MONETARY=nl_NL.UTF-8
LC_NAME=nl_NL.UTF-8
LC_NUMERIC=nl_NL.UTF-8
LC_PAPER=nl_NL.UTF-8
LC_TELEPHONE=nl_NL.UTF-8
LC_TIME=nl_NL.UTF-8

As I suggested earlier, the shell is setting all of the localization shell variables except LC_MESSAGES, and for that LANGUAGE is overriding LANG.

If Thunderbird is letting LANG override LANGUAGE they're doing it wrong. LANG is supposed to be the last-resort fallback if nothing else is set.

Try this: LC_ALL=en_US.UTF-8 LANGUAGE=en gramps

Het probleem komt er op neer dat in de opdracht LANGUAGE gebruikt moest worden, want dat heeft voorrang boven LANG.

Mijn simpele scriptje wordt dan:

#!/bin/bash
# LANG=en_US.utf8 gramps
# LANG=en_US.UTF-8 /usr/bin/gramps
LC_ALL=en_US.UTF-8 LANGUAGE=en gramps

De twee regels met het # ervoor zijn de oude verkeerde opdrachten. Het # zorgt er voor dat die opdrachten gezien worden als commentaar. Ik heb ze op die manier bewaard, je weet maar nooit. Nou zien dat ik dit in het LibreMenu opgenomen krijg als aparte opdracht.

Wel leuk nog: dat Thunderbird wel in het Engels opstart met de verkeerde code is volgens de ontwikkelaars eigenlijk fout :D
GIMP bundel 2017  25 cursussen met geweldig mooi oefenmateriaal. Lekker lezen of er wat van opsteken!
  Boekje "Werken met Xubuntu" 4000+ downloads!
     Het Helpmij Magazine November 2017