Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Probleem met het Mounten externe usb device na het veranderen van user id  (gelezen 218 keer)

Offline Emil Sokolowski

  • Lid
  • Steunpunt: Nee
Beste mensen,

Ik loop tegen het volgende probleem aan, na het aanmaken van 2 accounts (uid:1000 emil en Uid:1001 wendy) heb ik de user ID gewijzigd.
User id 1000 emil heb ik veranderd in uid:1026 en wendy heb ik in 1027 veranderd, dit in verband met mijn NAS. Nu kan ik op beide account bij mijn NAS komen op
de juiste mappen en bestanden zonder problemen met de user id.
Nu doet zich het volgende voor, als wendy een usb device aankoppeld kan zij die gewoon benaderen.
Maar als ik dat doe krijg ik een foutmelding 
Citaat
Kon geen map openen voor READER   Er is geen programma toegewezen om dit bestand te openen
Als ik dan naar Nautilus ga en de READER aanklik dan krijg ik
Citaat
Deze locatie kon niet weergeven worden.  U hebt niet de benodigde rechten om de inhoud van ‘READER’ te bekijken.
Dus denk ik dat het veranderen van de user id niet geheel heeft gewerkt, namelijk als ik mijn account de user id weer op 1000 zet werkt het wel , maar dan kan ik niet bij de
bestanden op mijn NAS. Wat kan ik hier aan doen.

Het aanpassen van de gebruikers accounts heb ik met gebruikers en groepen gedaan en die kun je installeren met  sudo apt-get install gnome-system-toolsIn alle voorgaande ubuntu versies was dit nooit een probleem.

Emil

Offline vanadium

  • Lid
  • Steunpunt: Nee
Is die READER een ext4 geformateerde USB schijf? In dat geval moet je wellicht eenmalig de rechten van /media/READER instellen naar jou account: dat staat nu wellicht nog op gebruiker 1000 (wiens account volgens wat je aangaf nu niet meer actief is).

Offline Emil Sokolowski

  • Lid
  • Steunpunt: Nee
Is die READER een ext4 geformateerde USB schijf? In dat geval moet je wellicht eenmalig de rechten van /media/READER instellen naar jou account: dat staat nu wellicht nog op gebruiker 1000 (wiens account volgens wat je aangaf nu niet meer actief is).

De READER is gewoon fat geformateerd, en dient als voorbeeld. Ik kan helemaal niets openen wat ik Mount. Wat zo vreemd is dat het account van Wendy die ik had aangemaakt ook gewoon op id 1001 begint en die heb ik naar 1027 gebracht en het werkt.

Wat ik nog wel heb lopen denken dat ik de pc heb geinstalleerd als gebruiker 1000 en toen heb veranderd.
Heb net getest door nog een account te maken als "test"en die naar 1026 gezet.
Dan kan ik dus bij mijn NAS en ik kan een device koppelen.
Hier ga ik op voortborduren en kijken of ik mijn gebruikersnaam en directory kan aanpassen.
 

Offline vanadium

  • Lid
  • Steunpunt: Nee
Misschien iets aan de hand met de groepen waartoe je user behoort. De groepen waartoe je account behoort kan je oplijsten met het commando "groups" (of "groups <login>" voor een andere gebruiker. Standaard (in Ubuntun 14.04) behoort een account tot de volgende groepen:
$USER adm cdrom sudo dip plugdev lpadmin sambashare ($USER staat voor de gebruikersnaam (login)). Ik denk dat lidmaatschap voor plugdev bepaalt of je aangekoppelde apparaten kan gebruiken.