Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Links naar locaties op eigen harde schijf werken slechts voor één sessie ?!  (gelezen 1458 keer)

Offline Merel

  • Lid
  • Steunpunt: Nee
In Ubuntu 14.04 wens ik op de Desktop enkele links te maken naar mappen of bestanden welke op een willekeurige windows partitie staat op dezelfde interne harde schijf.

Ik navigeer (via "Files") , naar de locatie van het bronbestand of de map, waarop ik rechtsklik om in contextmenu een verwijzing aan te maken (Make Link). Eens deze link gemaakt, verhuis ik hem naar mijn Ubuntu desktop.

Die werkt dan goed en ik kan het doel (map/bestand) hiermede openen en zonodig opent zich tevens de extensie-gekoppelde toepassing . Het pijltje van de link-icoon duidt aan dat het om een link gaat..

Het probleem is echter dat later bij een nieuwe Ubuntu sessie geen van deze links nog werken.
Deze iconen vertonen een pijltje dat is verschoven naar rechterbovenhoek en er komt een gesloten slotje bij onderaan rechts.

Er komt meteen volgend foutbericht met de uitleg :
This link cannot be used because its target “/media/username/VolmumeNaam/Doelmap/" doesn't exist.

Dat is nogal straf want Ubuntu heeft (op mijn rechtsklik menu) zelf die links aangemaakt.
Ik heb ze gewoon maar verplaatst en ze hebben bovendien eenmalig normaal gewerkt !

Hoe moet ik het anders aaanleggen om een werkende verwijzing aan te maken op het bureaublad ?!
Ik vermoed evenwel een bug, meer dan een gebruikersfout.

Bedankt.
Twee  oude desktops Windows XP + Ubuntu 14.04

Offline vanadium

  • Lid
  • Steunpunt: Nee
Zeker geen bug, want de linux links bestaan al zolang linux bestaat: die stukjes code zijn ondertussen perfect uitgevlooid.

Wellicht wordt je Windows partitie niet automatisch aangekoppeld tijdens de opstart. Als de partitie niet is aangekoppeld, dan is de link gebroken, want de bestemming is niet beschikbaar.

Door op je Windows partitie te klikken in bestandsbeheer, zal de partitie aangekoppeld worden. Vanaf dan zullen de links weer werken.

USB schijven worden automatisch aangekoppeld van zodra je ze inplugt. Partities op interne harde schijven worden echter niet automatisch aangekoppeld, behalve als dit ingesteld wordt in het configuratiebestand /etc/fstab. Het is mogelijk dit bestand zelf aan te passen om daar de Windows partities toe te voegen, zodat die automatisch bij de opstart deel uitmaken van het bestandssysteem (= aangekoppeld zijn).

Offline Merel

  • Lid
  • Steunpunt: Nee
Bedankt vanadium
Ik herinner mij nog mijn eerste ervaring met Ubuntu jaren terug en tevens bij enkele van de volgende versies, bijzonder enthoesiast te zijn geweest omdat Ubuntu onmiddellijk (reeds vanuit een life CD absoluut alle elementen van mijn systeem detecteerde inclusief het thuisnetwerkje (nochtans via Windows netwerk wizard opgezet).

Ik ben wat verrast bij de huidige situatie waarbij de interne schijf wel wordt gezien, maar niet gekoppeld.
Enfin , het kan blijkbaar worden opgelost maar momenteel staat de map welke U aanhaalt leeg. Ik zal mij proberen te documenteren over de nodige code die hierbij nodig is.

Is dit soms eigen aan Ubuntu of werken alle distro's op dezelfde manier ? 
Twee  oude desktops Windows XP + Ubuntu 14.04

Offline Merel

  • Lid
  • Steunpunt: Nee
Edit : De map noemt hier eigenlijk met dezelfde naam maar met een aanvoegsel achteraan :
fstab.d

(Off topic : Ik heb geprobeerd vorigepost te editeren via het icoontje maar dat blijkt geen enkel effect te hebben)
Twee  oude desktops Windows XP + Ubuntu 14.04

Offline vanadium

  • Lid
  • Steunpunt: Nee
Bedankt vanadium
Ik herinner mij nog mijn eerste ervaring met Ubuntu jaren terug en tevens bij enkele van de volgende versies, bijzonder enthoesiast te zijn geweest omdat Ubuntu onmiddellijk (reeds vanuit een life CD absoluut alle elementen van mijn systeem detecteerde inclusief het thuisnetwerkje (nochtans via Windows netwerk wizard opgezet).

Ik ben wat verrast bij de huidige situatie waarbij de interne schijf wel wordt gezien, maar niet gekoppeld.
Enfin , het kan blijkbaar worden opgelost maar momenteel staat de map welke U aanhaalt leeg. Ik zal mij proberen te documenteren over de nodige code die hierbij nodig is.

Is dit soms eigen aan Ubuntu of werken alle distro's op dezelfde manier ?
Dit is hoe unix/linux werkt. "By design" is unix/linux ontworpen voor meerdere gebruikers en veiligheid. Dat houdt in dat niet zomaar alle schijven, partities, enz. zomaar automatisch aangekoppeld worden en beschikbaar zijn voor iedereen. Enkel die partities nodig om het systeem te doen werken, worden standaard aangekoppeld. Een Windows systeempartitie, met een niet-unix bestandssysteem,  hoort daar zeker niet bij. Als de gebruiker die partitie wel aangekoppeld wil zien bij opstart, dan is het aan de systeembeheerder om hiervoor te kiezen en dit zo te configureren.

De klassieke manier om dat te configureren, is /etc/fstab. Het kan ook grafisch met het gereedschap "Disks" (Gnome disks) (ik heb er wel geen ervaring mee). Je kan eens kijken hoe je dit met Disks zou kunnen doen. Anders kan je ook de uitvoer van "sudo blkid" hier posten. Dan kan ik in detail aangeven hoe je je partitie bij opstart kunt laten aankoppelen.

Offline Mikkel

  • Lid
  • Steunpunt: Nee
Edit : De map noemt hier eigenlijk met dezelfde naam maar met een aanvoegsel achteraan :
fstab.d

Merel, etc/fstab is geen map, maar het bestand fstab in de map etc  ;) 

Offline Merel

  • Lid
  • Steunpunt: Nee
Bedankt voor de ontvangen reacties.

Vanadium Ik ga graag in op uw voorstel :
Citaat
"... Anders kan je ook de uitvoer van "sudo blkid" hier posten.
Dan kan ik in detail aangeven hoe je je partitie bij opstart kunt laten aankoppelen."

georges@PC1:~$ sudo blkid
[sudo] password for georges:
/dev/sda1: LABEL="WinXp_Pro" UUID="11734A50A895B551" TYPE="ntfs"
/dev/sda5: LABEL="D3_PROGS" UUID="01CE8AFD84EB86B0" TYPE="ntfs"
/dev/sda6: LABEL="D3_DATA" UUID="01CE8AE0155DA890" TYPE="ntfs"
/dev/sda7: LABEL="NoName" UUID="01CF35FCC5106350" TYPE="ntfs"
/dev/sda8: UUID="4cedecab-ddd8-4f19-ae7b-b02a650abce6" TYPE="ext4"
/dev/sda9: UUID="320f5308-39ee-499d-b81a-eaae232683a1" TYPE="swap"
/dev/sdb1: SEC_TYPE="msdos" LABEL="CF_64 MB" UUID="B8B3-D836" TYPE="vfat"
/dev/sdf1: LABEL="Sharkoon_32" UUID="52A4434AA4432FB1" TYPE="ntfs"
/dev/sdg: SEC_TYPE="msdos" LABEL="JETFLASH" UUID="30EE-556C" TYPE="vfat"
georges@PC1:~$


Graag als voorbeeld een procedure voor de automatische koppeling van partities /dev/sda6 en dev/sda7

Hierbij terloops toch een bedenking. Het kan dan wel zo zijn dat linux geen Windows partities zomaar te grabbel legt.  Maar het is dan ook totaal onlogisch dat men WEL in met een Ubuntu sessie diep kan duiken in een Windows partititie zo diepgaand als men wil en daarin zelfs 'Linux-links' links kan aanmaken.... welke achteraf ongeldig worden. De rechten worden inderdaad goed in het oog gehouden (beetje teveel zelfs). Al bij al toch vriendelijker dan Microsoft die op hun ivoren toren leeft.
Twee  oude desktops Windows XP + Ubuntu 14.04

Offline Merel

  • Lid
  • Steunpunt: Nee
Nog een eigenaardigheid terloops opgemerkt : Ik heb in een ver verleden ooit Windows partities gehad op deze disk , welke door Ubuntu destijds vermoedelijk werden bestempeld als sda2 sda3 sda4. Maar dat is zo lang geleden dat ik niet zo zeker ben van wat ik nu verkondig.

Intussen werden er verschillende versies van Ubuntu geïnstalleerd met telkens  een schoone installatie.
Ik begrijp niet waarom telkens opnieuw bij elke installatie er niets is tussen sda1 en sda5.
Kan dat op een of andere wijze betrekking hebben op 'vergane partities' die ergens toch nog worden gedetecteerd  ?
Kan die terminologie sda tevens op andere hardware duiden dan een disk of partitie ?

Het is al even gek als met Windows stationletters, welke worden uitgedeeld als in een kaartspel, waar men telkens andere kaarten krijgt.
Twee  oude desktops Windows XP + Ubuntu 14.04

Offline vanadium

  • Lid
  • Steunpunt: Nee
Je moet werken als systeembeheerder. Open een terminal.

1) Maak koppelpunten aan, d.w.z., lege folders waarin de partities zullen aangekoppeld worden (tip: kopieer commando en plak in terminal om fouten te vermijden).
sudo mkdir -p /mounts/D3_DATA /mounts/NoName
Het commando "sudo" vraagt je gebruikerspaswoord. Als je het ingeeft zie je niets gebeuren: dat is normaal.

2) Pas het configbestand /etc/fstab aan.
a) maak een reservekopie mocht je een fout maken.
sudo cp /etc/fstab /etc/fstab_old

a) Open /etc/fstab als beheerder met de editor van je keuze (ik neem hier gedit, de standaard editor)
sudo -i gedit /etc/fstab
De editor start met daarin de inhoud van /etc/fstab. Voeg onderaan regels toe voor beide partities.
UUID="01CE8AE0155DA890" /mounts/D3_DATA ntfs nls=utf8, dmask=005,fmask=005,uid=1000 0 0
UUID="01CF35FCC5106350" /mounts/NoName ntfs nls=utf8, dmask=005,fmask=005,uid=1000 0 0
Bewaren en editor afsluiten.

Dat is het. Koppel de partities aan (en controleer of er geen fouten zijn) met het commando
sudo mount -a
Hier mag je geen feedback krijgen. Indien wel, dan zal het een foutmelding zijn. Indien niet, dan zijn je partities aangekoppeld in de twee folders onder /mounts. Zoals het nu geregeld is, heeft de eerste gebruiker die op het systeem (tijdens installatie) werd aangemeld, volle toegang tot de schijf. Moeten meerdere personen toegang hebben, of een andere gebruiker, dan moeten de permissies aangepast worden.

Wil je het allemaal wat gebruiksvriendelijker, dan kan je een symbolische link aanmaken in je homefolder naar die partities:
cd
ln -s /mounts/D3_DATA && ln -s /mounts/NoName
Nu vind je twee "folders" in  je home directory, die je direct naar die partities brengen. Je kan die links verplaatsen als je wil, indien je de partities vanaf een andere plaats wil bereikbaar maken.

Citaat
Ik begrijp niet waarom telkens opnieuw bij elke installatie er niets is tussen sda1 en sda5.
Heeft er hoogstwaarschijnlijk mee te maken dat alles in een extended partition staat. Wellicht heb je een logische partitie sd2. In die partitie staan alle extended partitions. De namen hiervan beginnen met sda5 enz.
Giswerk van mij: om echt je partitionering te zien, moet je hier eens de uitkomst posten van
sudo fdisk -l

Offline Merel

  • Lid
  • Steunpunt: Nee
Hieronder het verloop van de procedure in Terminal.
Editeren van fstab (toevoegen van 2 regels onderaan) was zonder probleem.
Evenwel waren er twee warnings van gedit : "Calling Inhibit failed"

De laatste opdrachtregel lijkt geen links te hebben aangemaakt in Home directory.
Daarom dat ik dit commando herhaalde.

Er zijn nu updates wachtend en dat ga ik eerst uitvoeren. Ik kom alleszins nog terug op deze topic.
Nogmaals dank voor de hulp

georges@PC1:~$ sudo cp /etc/fstab /etc/fstab_old
georges@PC1:~$ sudo -i gedit /etc/fstab

(gedit:3293): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

(gedit:3293): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
sudo mount -a
cd
ln -s /mounts/D3_DATA && ln -s /mounts/NoName
cd
ln -s /mounts/D3_DATA && ln -s /mounts/NoName
Twee  oude desktops Windows XP + Ubuntu 14.04

Offline Merel

  • Lid
  • Steunpunt: Nee
Achtereenvolgens gedaan:
1. De Windows partitie DATA ingedoken en een  willekeurig bestand.jpg geopend. (ok)
2. In die partitie, met Ubuntu opnieuw een link gemaakt van folder DATA
3. Die link gecopieerd naar Desktop. Daar werkte de link ok
4. Alle open toepassingen gesloten (maar Gedit geeft aan dat er nog een process lopend is !
    Dit zou in principe duiden op het laatste commando (2x gemaakt)
5. Updates uitgevoerd (ok)

6. Herstart : Ubuntu scherm (rode bolletjes) met daaronder het foutbericht
 "An error occured while mounting /mounts/D3_DATA
"Press S to skip mounting or M for manual recovery"
7. M

8. Terminalvenster verschijnt direct met 6 regels (waaronder 3 error codes + beschrijvingen)
[15.223115]....
[15.223119]....
[19.680258]....
A maintenance shell wil now be started
 .... nog wat bla bla bla...

9. ENTER   De Terminal maintenance shell start en stopt al vlug op prompt
10. EXIT => Het  booten gaat normaal verder.

11. Nazicht van huidige toestand :

Als verwacht werkt de (logische) klassiek aangemaakte link naar DATA folder niet meer

MAAR ( en nu ben ik volledig uit mjn lood geslagen) de beide eerder aangemaakte folders op locatie  /mounts/ met namen identiek aan de volumenamen van de  2 Windows partities, waren vooraleer te herbooten LEEG (daar ben ik zeker van) , terwijjl nu na die "herboot met hindernissen" ze niet meer leeg staan !!!!

In die folders blijkt Ubuntu een copie te hebben gezet van de inhoud van de Windows partities ! Alle submappen en bestanden worden getoond met het aantal bytes. Het lijkt er op dat ik niet rechtstreeks op de Windows partities terechtkom maar .... op echte spiegelcopies. In het bestandsysteem "Files" of "Nautilus" of hoe zij het nu ook willen noemen, zie ik heel duidelijk dat de beide partitie-inhouden nu onder /mounts/  worden getoond.

Of  die ganse inhouden daadwerkelijk staan gecopieerd gaat mijn pet te boven.
Is het inderdaad zo dat er twee spiegelcopies zijn gemaakt naar de Ubuntu partitie ? Kan toch niet zijn !?

Enfin, daarmee heb ik helaas mijn uiteindelijk doel niet bereikt om enkele werkende links naar mijn bureaublad te krijgen.

De Ubuntu slagzin "for human beings"  krijgt stilaan meer eerder de betekenis "for masochists" .
Twee  oude desktops Windows XP + Ubuntu 14.04

Offline Nero

  • Lid
  • Steunpunt: Ja
Post eens de volgende gegevens:
- Inhoud van /etc/fstab
- Resultaat van mount ; df -h ; lsblk in een terminal

Offline Merel

  • Lid
  • Steunpunt: Nee
Bedankt Nero
Tenzij ik op een verkeerde locatie zoek is er geen  /etc/fstab/ te bespeuren. Wat er wel staat is een folder met dezelfde benaming maar achteraan staat een punt en een d toegevoegd , zoals ik eerder heb gemeld.
Die fstab.d  staat leeg. Ik heb vruchteloos gezocht naar een andere fstab , via zoekfunctie in "Files" launch bar.

Zie screenshot in bijlage


Bij het  booten krijg ik nog meteen 2 meldingen dat er een fout is opgetreden bij het mounten van de gevraagde partitities.


Voor de regelopdracht kreeg ik in Terminal de volgende respons :
Citaat
georges@PC1:~$ mount ; df -h ; lsblk
/dev/sda8 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/cgroup type tmpfs (rw)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
none on /sys/fs/pstore type pstore (rw)
/dev/sda6 on /mounts/D3_DATA type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)
/dev/sda7 on /mounts/NoName type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)
systemd on /sys/fs/cgroup/systemd type cgroup (rw,noexec,nosuid,nodev,none,name=systemd)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=georges)
/dev/sdb on /media/georges/JETFLASH type vfat (rw,nosuid,nodev,uid=1000,gid=1000,shortname=mixed,dmask=0077,utf8=1,showexec,flush,uhelper=udisks2)
/dev/sdg1 on /media/georges/Sharkoon_32 type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)
/dev/sdc1 on /media/georges/CF_64 MB type vfat (rw,nosuid,nodev,uid=1000,gid=1000,shortname=mixed,dmask=0077,utf8=1,showexec,flush,uhelper=udisks2)
Filesystem      Size  Used Avail Use% Mounted on
/dev/sda8        24G  5,4G   17G  25% /
none            4,0K     0  4,0K   0% /sys/fs/cgroup
udev            999M  4,0K  999M   1% /dev
tmpfs           202M  1,3M  201M   1% /run
none            5,0M     0  5,0M   0% /run/lock
none           1008M   30M  979M   3% /run/shm
none            100M   48K  100M   1% /run/user
/dev/sda6       9,9G  2,9G  7,0G  29% /mounts/D3_DATA
/dev/sda7       5,9G  298M  5,6G   5% /mounts/NoName
/dev/sdb        500M   53M  447M  11% /media/georges/JETFLASH
/dev/sdg1        30G   17G   13G  57% /media/georges/Sharkoon_32
/dev/sdc1        61M   61M     0 100% /media/georges/CF_64 MB
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 149,1G  0 disk
├─sda1   8:1    0  72,4G  0 part
├─sda2   8:2    0     1K  0 part
├─sda5   8:5    0  30,3G  0 part
├─sda6   8:6    0   9,8G  0 part /mounts/D3_DATA
├─sda7   8:7    0   5,9G  0 part /mounts/NoName
├─sda8   8:8    0  23,5G  0 part /
└─sda9   8:9    0     2G  0 part [SWAP]
sdb      8:16   1   500M  0 disk /media/georges/JETFLASH
sdc      8:32   1  61,1M  0 disk
└─sdc1   8:33   1    61M  0 part /media/georges/CF_64 MB
sdg      8:96   1  29,5G  0 disk
└─sdg1   8:97   1  29,5G  0 part /media/georges/Sharkoon_32
sr0     11:0    1  1024M  0 rom 
sr1     11:1    1  1024M  0 rom 
georges@PC1:~$
Twee  oude desktops Windows XP + Ubuntu 14.04

Offline Mikkel

  • Lid
  • Steunpunt: Nee
Tenzij ik op een verkeerde locatie zoek is er geen  /etc/fstab/ te bespeuren. Wat er wel staat is een folder met dezelfde benaming maar achteraan staat een punt en een d toegevoegd , zoals ik eerder heb gemeld.

Dan heb je mijn bericht van vijf dagen geleden niet (goed) gelezen:

Edit : De map noemt hier eigenlijk met dezelfde naam maar met een aanvoegsel achteraan :
fstab.d

Merel, etc/fstab is geen map, maar het bestand fstab in de map etc  ;) 

Offline Erik Krom

  • Lid
  • Steunpunt: Nee
Dat in de map /mounts/ nu de inhoude van de twee partities te zien is kan wel kloppen.
Dat is wat dat hele automatisch mounten via fstab inhoud.

De bestanden zijn niet letterlijk gekopieerd maar via die map kom je nu in die partitie.
Als je van daaruit nu je links maakt zou het moeten blijven werken.

Offline vanadium

  • Lid
  • Steunpunt: Nee
MAAR ( en nu ben ik volledig uit mjn lood geslagen) de beide eerder aangemaakte folders op locatie  /mounts/ met namen identiek aan de volumenamen van de  2 Windows partities, waren vooraleer te herbooten LEEG (daar ben ik zeker van) , terwijjl nu na die "herboot met hindernissen" ze niet meer leeg staan !!!!
Dat toont nu net dat het aankoppelen gelukt is. Als je de partities aankoppelt in die folders, dan komt de inhoud daar te voorschijn.
Citaat
Enfin, daarmee heb ik helaas mijn uiteindelijk doel niet bereikt om enkele werkende links naar mijn bureaublad te krijgen.

De Ubuntu slagzin "for human beings"  krijgt stilaan meer eerder de betekenis "for masochists" .
Het mounten was het moeilijkste. Om de links te maken moet je niet eens beheerder zijn. How ctrl+shift ingedrukt en sleep de Windows folder die je ziet in /mounts naar de plek waar je de link wil (of gebruik het commando "ln -s ...").

Denk eraan je Windows partities in goede conditie te houden! Zorg ervoor dat voor je Linux opstart, je Windows helemaal afgesloten is (geen slaapstand, maar volledig afsluiten). Anders kan het voorkomen dat het bestandssysteem door windows niet correct afgesloten wordt: Ubuntu zal het dan niet aankoppelen. Nu en dan je ntfs partities eens in Windows controleren met de schijfcontroletools.

Offline Merel

  • Lid
  • Steunpunt: Nee
@ Mikkel
Sorry maar om heel eerlijk te zijn , ik had de uitleg niet begrepen en met wat ongeloof, trok ik de conclusie dat het om een misvertand moest gaan.

De redenen zijn te begrijpen: zie de screenshot in bijlage
1. ALLE  items onder /etc/  zijn individueel  (in view list) betiteld als zijnde een "Folder"
2. De foutieve benaming toont een zogezegde inhoud met het aantal itemsijn genoemd als "items"  , wat voor een folder normaal zou zijn, maar wat voor een bestand in bytes zou worden verwacht.

Off topic :Een derde reden is dat Nautilus hier onstabiel is. De inhoud van het venster verwijnt regelmatig voor een deel afhankelijk van de muis-positie. Daarenboven komen er folder-icoontjes te voorschijn of vallen ze weer weg op willekeurige wijze. Soms is gans het venster leeg of amper leesbaar.  Terwijl anders het surfen met Chromium of met Firefox helemaal geen videofouten vertoont, en nog veel minder met Windows. Men zal me zeker toch niet vertellen dat Nautilus ("Files" in 14.04) een onoverkomelijk zware grafische toepassing is ?

Opmerking. Er bestaan nog méér bestanden met de extensie .d zoals het screenshot laat zien.
Twee  oude desktops Windows XP + Ubuntu 14.04

Offline Merel

  • Lid
  • Steunpunt: Nee
@vanadium
Bedankt voor je geduld en hulp.

Vooraleer te gaan slepen :

- Ik zal daarmee hopelijk toch slechts 'link's maken naar mijn werkblad  ?

- Ik hoop toch dat het niet volledige  "echte inhouds-copieën"  zijn die worden overgebracht van Windows partities naar een Linux partitie, maar dat het ware als een soort virtuele transparante werk-copies zijn, welke in de achtergrond alle veranderde bestanden terug stuurt  naar de Windows ter synchronisatie  ?
De exacte werking blijft me een raadsel. Wanneer gaan we nu eens eindelijk allemaal dezelfde formattering gebruiken ! >:(
Twee  oude desktops Windows XP + Ubuntu 14.04

Offline vanadium

  • Lid
  • Steunpunt: Nee
Slepen, maar wel degelijk tegelijk Ctrl-Shift ingedrukt houden. Als je de muisknop loslaat, wordt dan een link gemaakt.

Linux kent geen aparte "schijven" zoals Windows. In die zin is het gebruiksvriendelijker: alles heeft eenduidig en op dezelfde manier een plaats binnen het bestandssysteem. Dat bestandsysteem begint helemaal bovenaan. De bovenste folder noemt "root" en is eenvoudig "/". Onder die folder bevinden zich alle mogelijke systeem en gebruikersfolders.

Binnen die folder heb je ondermeer de home folder. In die home folder (/home) heb je op zijn beurt alle thuisfolders van alle gebruikers op het systeem. Is er een gebruiker "merel", dan is de thuisfolder van die gebruiker /home/merel, t.t.z., de folder "merel" in de "home" folder in de root folder "/".

Zoals je gemerkt hebt, is er ook een "etc" folder in de root. Dat is een folder speciaal bedoeld voor systeembrede configuratiebestanden. Het bestandje "fstab" staat in die folder, en dient om te configureren welke partities waar in het bestandssysteem moeten toegevoegd worden.

Jij hebt nu twee partities toegevoegd in folders onder een "mounts" folder, die je zelf hebt aangemaakt onder de root folder (/mounts). In die mounts folder heb je de folders D3_DATA en NoName aangemaakt (volledige verwijzingen: /mounts/D3_DATA  en /mounts/NoName, ttz. "D3_DATA" in "mounts" onder "/"). Die namen kies je zelf: ik heb gewoon de namen van de twee partities hiervoor genomen.

In eerste instantie zijn  /mounts/D3_DATA  en /mounts/NoName gewone folders binnen je bestandssysteem. Door nu de andere partitie daaraan te koppelen, wordt alle inhoud ervan toegankelijk vanuit die folders. In windows zou je een D: en een E: schijf zien verschijnen, in Linux koppel je die aan binnen de bestandstructuur, waar je dat zelf wil.

Om nu gemakkelijk vanuit de home directory van jezelf of ook van andere gebruikers naar die partities te kunnen, maak je een symbolische link. Die gedraagt zich als een gewone folder (of als een gewoon bestand als het een symbolische link naar een bestand is).

Citaat
Ik hoop toch dat het niet volledige  "echte inhouds-copieën"  zijn die worden overgebracht van Windows partities naar een Linux partitie, maar dat het ware als een soort virtuele transparante werk-copies zijn, welke in de achtergrond alle veranderde bestanden terug stuurt  naar de Windows ter synchronisatie  ?
Zo ingewikkeld is het niet. Synchronisatie komt er niet aan te pas. Als een partitie aangekoppeld is, dan betekent dat gewoon dat de partitie zelf integraal deel uitmaakt van het bestandssysteem. Je werkt rechtstreeks met de data op die partitie. Je gaat naar de partitie via het pad (/mounts/D3_DATA) of via een symbolische link. Als gebruiker merk je niet eens dat je op een andere schijf aan het werken bent. Daarin is linux gebruiksvriendelijker en eenvoudiger dan Windows.

Offline Merel

  • Lid
  • Steunpunt: Nee
Sorry voor het iets langer uitblijven van reactie, terwijl anderzijds hulp steeds zo snel wordt aangereikt.
De links naar de beide Windows partities zijn aangemaakt en blijken nu e blijven werken na het herbooten.

Hoewel het mounten tijdens het booten van Ubuntu al meteen onmiddellijk een foutmelding geeft, (met optie keuzen voor Skip of Manual) blijkt dat bij optie 'S'   , de beide partities toch  kunnen worden benaderd  via hun nieuwe link op de  desktop.

Ik ga er van uit  da t het mounten dan toch  goed verloopt, zij het ietsje later in het bootproces.
Ik zal nogmaals proberen te zien wat er gebeurt via optie Manual maar zal daar zeker niet veel tijd en energie meer insteken.

Allen nogmaals bedankt voor  jullie inzet. Tenzij er wat nieuws opduikt meen ik dat deze topicvraag een efficiënte oplossing heeft gekregen.
Twee  oude desktops Windows XP + Ubuntu 14.04