Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: resolutieprobleem  (gelezen 2563 keer)

Ralf

  • Gast
resolutieprobleem
« Gepost op: 2007/03/19, 21:17:59 »
He,

Ik draai al een tijdje ubuntu op m'n desktop en nu ben ik het ook op mijn laptop aan het installeren. Installatie is goed verlopen en ik heb m'n draadloze netwerkkaart ook aan de praat gekregen na enig zoekwerk. Wel heb ik nog een probleem met m'n resolutie. Deze kan ik alleen op 800 x 600 of 640 x 480 zetten.

Ik heb het forum al goed doorzocht maar ik heb het helaas nog niet op kunnen lossen.

lspci|grep VGA geeft het volgende: 0000:00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 01)

verder heb ik gconf -editer even bekeken. Bij desktop/gnome/screen/default/0 heb ik bij de resolutie 1024 x 786 ingevuld.

Mijn xorg.conf bestand in /etc/X11/ ziet er nu als volgt uit:

-----------------------------------------------------------------------------
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
   FontPath   "/usr/share/X11/fonts/misc"
   FontPath   "/usr/share/X11/fonts/cyrillic"
   FontPath   "/usr/share/X11/fonts/100dpi/:unscaled"
   FontPath   "/usr/share/X11/fonts/75dpi/:unscaled"
   FontPath   "/usr/share/X11/fonts/Type1"
   FontPath   "/usr/share/X11/fonts/100dpi"
   FontPath   "/usr/share/X11/fonts/75dpi"
   # path to defoma fonts
   FontPath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
   Load   "bitmap"
   Load   "ddc"
   Load   "dri"
   Load   "extmod"
   Load   "freetype"
   Load   "glx"
   Load   "int10"
   Load   "type1"
   Load   "vbe"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc104"
   Option      "XkbLayout"   "us"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"      "/dev/input/mice"
   Option      "Protocol"      "ExplorerPS/2"
   Option      "ZAxisMapping"      "4 5"
   Option      "Emulate3Buttons"   "true"
EndSection

Section "InputDevice"
   Identifier   "Synaptics Touchpad"
   Driver      "synaptics"
   Option      "SendCoreEvents"   "true"
   Option      "Device"      "/dev/psaux"
   Option      "Protocol"      "auto-dev"
   Option      "HorizScrollDelta"   "0"
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "stylus"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "stylus"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "eraser"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "eraser"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "cursor"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "cursor"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "Device"
   Identifier   "Intel Corporation 82852/855GM Integrated Graphics Device"
   Driver      "i810"
   BusID      "PCI:0:2:0"
EndSection

Section "Monitor"
   Identifier   "Generic Monitor"
   Option      "DPMS"
   HorizSync   28-51
   VertRefresh   43-60
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "Intel Corporation 82852/855GM Integrated Graphics Device"
   Monitor      "Generic Monitor"
   DefaultDepth   24
   SubSection "Display"
      Depth      1
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      4
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      8
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      15
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      16
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      24
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"
   InputDevice     "stylus" "SendCoreEvents"
   InputDevice     "cursor" "SendCoreEvents"
   InputDevice     "eraser" "SendCoreEvents"
   InputDevice   "Synaptics Touchpad"
EndSection

Section "DRI"
   Mode   0666
EndSection
-----------------------------------------------------------------------------

Het lijkt er dus op dat dit allemaal goed ingesteld is. Ik heb trouwens ook al geprobeerd om mijn xserver te herconfigureren, gewoon overal enter doorgeklikt zoals ik ergens op dit forum heb gelezen maar ook dit heeft nog niet geholpen. Zijn er nog meer dingen die ik nog anders moet instellen? Dit lijkt me een leuke uitdaging voor de die-hard forum bezoekers!

Offline Samuel Rave

  • Lid
    • http://www.familie-rave.de/
  • Steunpunt: Nee
resolutieprobleem
« Reactie #1 Gepost op: 2007/03/19, 21:24:12 »
Vraagje, je hebt wel telkens na het wijzigen van je xorg Ctrl-Alt-Backspace gedaan?

Ralf

  • Gast
resolutieprobleem
« Reactie #2 Gepost op: 2007/03/19, 21:46:46 »
nog niet, bedoel je ctrl-alt-backspace na reconfigure x-server of na aanpassen xorg.conf? Ik heb zojuist na het aanpassen van xorg.conf crt-alt-backspace gedaan maar niet met het gewenste resultaat.

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
resolutieprobleem
« Reactie #3 Gepost op: 2007/03/19, 22:56:47 »
De file xorg.conf wordt alleen ingelezen bij het opstarten van de grafische schil.
Met Control-Alt-Backspace wordt deze opnieuw gestart.

Misschien overbodig, maar hier ben ik een keer flink op gestruikeld ;)
Ron
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een dwarsligger.

Offline Samuel Rave

  • Lid
    • http://www.familie-rave.de/
  • Steunpunt: Nee
resolutieprobleem
« Reactie #4 Gepost op: 2007/03/19, 23:19:50 »
Het eigenhandig aanpassen van je xorg.conf en het aanpassen van xorg met het commando:
sudo dpkg-reconfigure xserver-xorg
dat houdt allemaal hetzelfde in, het wijzigd je xorg configuratie...

Ralf

  • Gast
resolutieprobleem
« Reactie #5 Gepost op: 2007/03/20, 07:45:41 »
Ik heb net geprobeerd om m'n x-server te reconfiguren en heb daarna opnieuw opgestart. Tijdens de configuratie heb ik alleen voor de resolutie 1024 gekozen. Deze geeft hij ook netjes weer in de xorg.conf file nu maar ik kan nog steeds niets voor deze resolutie kiezen bij systeem>>voorkeueren>>schermresolutie. Daar staan alleen 800x600 en 640 x 480. Vreemd toch?

Offline Gandyman

  • Lid
  • Steunpunt: Nee
resolutieprobleem
« Reactie #6 Gepost op: 2007/03/20, 11:29:03 »
Linux is vrij makkelijk, maar er kan soms ergens iets zitten waardoor jouw keuze of voorkeur niet gehonoreerd word.
Er kan soms ergens een boertje dwars zitten, moet je maar denken :P

In dat geval is het een kwestie van keihard aangeven wat je wilt en niet hem meer de keuze laten.

Neem bijv. je xorg file waar de keuze mogelijkheden in staan:
Citaat
Monitor        "Generic Monitor"
    DefaultDepth    24
    SubSection "Display"
        Depth        1
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        4
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        8
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        15
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        16
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        24
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
EndSection
Hier staan de keuzes "800x600" en  "640x480" bij.
Goed die wil je niet blijkbaar dus wis je dit gewoon.

Wat dan overblijft is "1024x768" waardoor je beeld voortaan op deze resolutie zal staan.

Ditzelfde geld voor de Depth.
Er is keuze tussen 1 - 4 - 8 - 16 - 24 ????
Welke wil je gebruiken en welke niet ??

Je snapt het al, wat je niet wilt (of ooit zult) gebruiken wis je gewoon uit je xorg.

Uiteindelijk zal er dus alleen maar staan.
Citaat
SubSection "Display"
        Depth        24
        Modes        "1024x768"
    EndSubSection
Gewoon onthouden dat alles in Linux in tekst file's staat en dus ook handmatig aan te passen is naar je eigen wensen.

Nadeel is dat je moet weten waar je het moet zoeken en wat je op welke manier moet aanpassen.

SCCS

:D
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Ralf

  • Gast
resolutieprobleem
« Reactie #7 Gepost op: 2007/03/20, 12:34:05 »
He,

Na het herconfigureren van m'n xervser stond alleen nog maar de resolutie 1024 x 768 in de xorg.conf file maar toch blijft hij alleen de opties 800 x 600 en 640 x 480 weergeven. Er moet dus nog ergens anders een boertje dwars zitten:)

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
resolutieprobleem
« Reactie #8 Gepost op: 2007/03/20, 13:36:05 »
Doe eens dit:
Systeem - Beheer - Synaptic pakketbeheer
zoekterm: 915resolution
aanvinken:
915resolution
druk op knop Toepassen

Daarna herstart. Kun je de gewenste resolutie nu wel instellen?

Groet, Pjotr.

Ralf

  • Gast
resolutieprobleem
« Reactie #9 Gepost op: 2007/03/20, 16:54:39 »
ook dat heb ik al geprobeerd...

zonder resultaat helaas

Offline Gandyman

  • Lid
  • Steunpunt: Nee
resolutieprobleem
« Reactie #10 Gepost op: 2007/03/20, 22:12:45 »
Citaat
Na het herconfigureren van m'n xervser stond alleen nog maar de resolutie 1024 x 768 in de xorg.conf file maar toch blijft hij alleen de opties 800 x 600 en 640 x 480 weergeven
Dat moet hij lekker weten dat die optie's er nog staan ????
Maar de resolutie's 800 x 600 en 640 x 480 kan hij nu niet meer uitvoeren want die staan niet in de Xorg file.

En voorzover ik weet leest hij alleen die uit en niet een file die nog ergens anders staat.
Dus hij moet die hoge resolutie uitvoeren.
en geloof je me niet ??
Geef je xorg file dan maar eens een andere naam.

Als je dan nog beeld hebt zit je in de verkeerde file te mieren, of je Ubuntu is een eigen leven gaan leiden. :P

en natuurlijk ?
Vermits je vga kaart en monitor dit aankunnen, en vermits je de juiste drivers erin hebt zitten.

SCCS

:D
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Ralf

  • Gast
resolutieprobleem
« Reactie #11 Gepost op: 2007/03/21, 09:19:41 »
ik heb een test gedaan:
- de xorg.conf gerenamed naar xorg1.conf
- opnieuw opgestart
- de xserver kon iet meer geladen worden
- heb daarna weer terug hernoemd naar xorg.conf
- na weer een herstart had ik weer beeld

Hij gebruikt dus wel het bestand xorg.conf maar de gebruikte resolutie haalt hij ergens anders vandaan, maar waar? Ik heb in windows op dezelfde laptop wel in 1024 bij 768 gewerkt dus hij moet dit aankunnen

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
resolutieprobleem
« Reactie #12 Gepost op: 2007/03/21, 10:07:37 »
Ik denk te weten wat er fout loopt.
Je hebt de foute driver voor je videokaart geselecteerd.

Ik had net hetzelde probleem steeds een 1024x768 scherm in plaats van mijn vertrouwde 1280x1024 resolutie.
Niets werkte nog om het probleem te fixen:
gconf-editor
sudo dpkg-reconfigure -phigh xserver-xorg
sudo gedit /etc/X11/xorg.conf
aanpassen doet niets :(

Ik heb er zelfs een herinstallatie voor moeten uitvoeren ...
Tot ik plots zag dat de "vesa" driver gekozen was in plaats van de "nv" standaard driver voor nVidia kaarten.
Aangepast en ik heb terug 1280x1024 scherm.
Of met andere woorden, hier moet iets anders staan bij driver:
Citaat van: Ralf
Section "Device"
    Identifier    "Intel Corporation 82852/855GM Integrated Graphics Device"
    Driver        "i810"
    BusID        "PCI:0:2:0"
EndSection
Ik weet niet welke driver geschikt is voor je intel kaart misschien iemand anders?
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
resolutieprobleem
« Reactie #13 Gepost op: 2007/03/21, 10:17:45 »
Vreemde is dat wanneer ik op 't net rondsurf de i810 driver meestal gebruikt wordt voor je Intelkaart ...
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Ralf

  • Gast
resolutieprobleem
« Reactie #14 Gepost op: 2007/03/22, 21:25:25 »
ik ben weer een stapje verder, ik heb het volgende gedaan:

sudo /etc/init.d/gdm stop (om x server te stoppen)
sudo 915resolution 50 1024 768 (om vBIOS te "hacken")
sudo /etc/init.d/gdm start (om X server weer te starten)

Wanneer ik nu weer inlog staat m'n resolutie heel even (nog geen seconde) op de resolutie die ik wil (1024 bij 768). daarna schiet hij weer terug naar 800 bij 600 en kan ik deze en 640 x 480 kiezen bij systeem >> voorkeuren >> schermresolutie

Iemand die dit herkent en/of weet wat er nu mis gaat?