Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Ubuntu 12.04 LTS start na inloggen niet meer verder op. Systeem vastgelopen  (gelezen 461 keer)

Offline wowo

  • Lid
  • Steunpunt: Nee
Ik was bezig met de instellingen van de nieuwe versie van de internetbrowser 29 van Firefox.

Toen ik bij "Bewerken > Voorkeuren > Geavanceerd" op de knop "Firefox de standaardbrowser maken" liep mijn systeem geheel vast.
Toen ik opnieuw ging opstarten kreeg ik wel het inlogscherm maar na het invullen van het wachtwoord bleef de boel hangen,

Hoe nu verder ?
Het is helaas mijn hoofdsysteem ......
Gek genoeg werkt de boel wel met inloggen in de gast-sessie.
« Laatst bewerkt op: 2014/05/01, 23:40:18 door wowo »
Desktop Ubuntu 16.04 LTS

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Misschien een gevolg van PPA's (of de instellings-restanten daarvan uit vorige Ubuntuversies)? Je krijgt dan een Frankenstein-systeem....
https://sites.google.com/site/computertip/fatalevergissingen

Offline wowo

  • Lid
  • Steunpunt: Nee
Zou kunnen maar het probleem ontstond gelijk na het instellen van firefox 29 als standaard browser.
Zoals gezegd het opstarten van de gastsessie lukt wel.
Ik heb een ssd heb en een de vaste schijf een aparte home partitie.

In de recovery mode heb ik al fsck gedaan maar niets gevonden.

Iemand nog ideeën om de boel te kunnen starten ?
 
Desktop Ubuntu 16.04 LTS

Offline wowo

  • Lid
  • Steunpunt: Nee
Volgens mij is er iets met de home partitie (op mij vaste schijf) gebeurd waarop hij blijft hangen.

Wanneer ik namelijk in de recoverymode met root bevoegdheid ga kijken naar de inhoud van /home zie ik daar niets staan !

Hoe komt het dat mijn home account (silencio1) helemaal niet meer zichtbaar is ?
Desktop Ubuntu 16.04 LTS

Offline wowo

  • Lid
  • Steunpunt: Nee
Oeps na het mount commando: mount /home zag ik wel de inhoud.

Ideeën ?
Desktop Ubuntu 16.04 LTS

Offline Erik Krom

  • Lid
  • Steunpunt: Nee
Je zou kunnen kijken wat er gebeurd als je de instellingen verwijderd.
Dit doe je door in de home map alle mappen en bestanden te verwijderen of te verplaatsen die beginnen met een punt.
Door het verplaatsen (bijv naar een map "configuratie-old") kan je de configuratie weer terug zetten en systematisch uitzoeken waar het mis gaat.

Probeer een in terminal mode in je account in te loggen.
In terminal mode kom je door op [ctrl]+[alt]+[F1] te drukken als het systeem aan staat.
Lukt het dan wel om in te loggen of loop het dan ook vast. Zo ja, met welke foutmeldingen?

Offline daniel

  • Lid
  • Steunpunt: Nee
Als tijdelijke /definetieve oplossing kun je ook vanuit de herstelmodus als root inloggen en een nieuwe username aanmaken en vervolgens daarna in etc/group je gebruikersnaam achter sudo plaatsen voor bevoegdheid.
Daarna je computer opnieuw opstarten met nieuwe gebruiker en alles daarna toe kopieeren.
adduser gebruikersnaam

Of proberen vanuit root firefox volledig te verwijderen.
sudo apt-get autoremove firefox

Offline wowo

  • Lid
  • Steunpunt: Nee
Probeer een in terminal mode in je account in te loggen.
In terminal mode kom je door op [ctrl]+[alt]+[F1] te drukken als het systeem aan staat.
Lukt het dan wel om in te loggen of loop het dan ook vast. Zo ja, met welke foutmeldingen?
Ik kan inloggen in de commandline maar als ik met startx opstart krijg ik de volgende meldingen:
Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
Please consult the X.Org Foundation support
Desktop Ubuntu 16.04 LTS

Offline wowo

  • Lid
  • Steunpunt: Nee
Of proberen vanuit root firefox volledig te verwijderen.
sudo apt-get autoremove firefox
Ik heb de map .firefox verwijderd en het commando sudo apt-get autoremove firefox uitgevoerd.
Helaas nog geen succes.
De andere mogelijkheid die je aandraagt lijkt mij toch nogal bewerkelijk. Dan kan ik beter de boel weer helemaal opnieuw gaan installeren maar dan met Ubuntu 14.04 ipv 12.04. Ik heb de home map zojuist al gekopieerd.
Desktop Ubuntu 16.04 LTS

Offline wowo

  • Lid
  • Steunpunt: Nee
Ik kan inloggen in de commandline maar als ik met startx opstart krijg ik de volgende meldingen:
Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
Please consult the X.Org Foundation support
Als ik .XO-lock wil verwijderen (rm  .X0-lock) krijg ik de melding:
rm: normaal bestand '.X0-lock' (schrijfbeveiligd) verwijderen ?
Daarop heb ik met y geantwoord.
Vervolgens kreeg ik:
rm: kan '.X0-lock' niet verwijderen: Bewerking niet toegestaan
Desktop Ubuntu 16.04 LTS

Offline jolo

  • Lid
  • Steunpunt: Nee
Wellicht zou je eerst nog even je /var/log/Xorg.0.log checken. Met name de errors. Bijvoorbeeld: cat /var/log/Xorg.0.log | grep EE [Enter] zodat je die output hier kunt posten.
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline vanadium

  • Lid
  • Steunpunt: Nee
Als je met de gastaccount wel kan inloggen, dan lijkt het mij duidelijk dat er een probleem is met je eigen gebruikersinstellingen. Volgens mij kan dit veroorzaakt geweest zijn door het hard resetten, wat het beschadigen van het bestandssysteem kan met zich meebrengen. Je zal in elk geval je home partitie moeten controleren met fsck vooraleer verder te gaan.

Wat daniel zegt, is dan inderdaad een remedie: een nieuwe account aanmaken (met root bevoegdheden). Selectief kan je dan indien nodig zaken verplaatsen vanuit je oude profielfolder naar de nieuwe.

Als je je oude accountnaam en userid verder wil gebruiken, dan kan je via een recovery prompt je oude account verwijderen, je nieuwe account hernoemen naar je oude account en de userid van die account instellen op 1000.

Herinstalleren is ook een optie. Vraagt wat minder technisch werk onder de motorkap, en zal niet zoveel langer duren (zeker al als je niet zeer vertrouwd bent met het werk onder de motorkap).


Offline wowo

  • Lid
  • Steunpunt: Nee
Wellicht zou je eerst nog even je /var/log/Xorg.0.log checken. Met name de errors. Bijvoorbeeld: cat /var/log/Xorg.0.log | grep EE [Enter] zodat je die output hier kunt posten.
Uitkomst: Warning (EE) error (NI) not implemented en nog wat over loading extension MIT-screen-saver
Desktop Ubuntu 16.04 LTS

Offline wowo

  • Lid
  • Steunpunt: Nee
Heb het systeem opnieuw geïnstalleerd.
Dit duurde slechts 15 minuten.
Het nawerk duurt natuurlijk wel langer. Ik ben nu wel van plan om direct een scriptje te maken zodat dat de volgende keer ook wat gemakkelijker gaat.
Desktop Ubuntu 16.04 LTS