Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: eID-software probleem na update 14.04  (gelezen 2036 keer)

Offline Patrick Renard

  • Lid
  • Steunpunt: Nee
eID-software probleem na update 14.04
« Gepost op: 2014/04/29, 06:54:28 »
Hoi iedereen, ik heb een Dell Latitude D630 met eID lezer.
voor de update werkte deze perfect, na de update start eID-software wel op maar wanneer ik mijn paspoort insteek krijg ik steeds de melding dat hij deze niet kan lezen en er verschijnt een rood kruisje en probeert het steeds opnieuw ik heb er een log tekst bijgevoegd.

 
[PCSCEidController] Clearing Data for security reasons, due to unexpected problem.
sun.security.smartcardio.PCSCException: SCARD_E_NOT_TRANSACTED
sun.security.smartcardio.ChannelImpl.doTransmit(ChannelImpl.java:219)
sun.security.smartcardio.ChannelImpl.transmit(ChannelImpl.java:90)
be.fedict.eid.applet.sc.PcscEid.transmit(PcscEid.java:1531)
be.fedict.eid.applet.sc.PcscEid.selectFile(PcscEid.java:550)
be.fedict.eid.applet.sc.PcscEid.readFile(PcscEid.java:255)
be.fedict.eidviewer.lib.PCSCEid.readFile(PCSCEid.java:82)
be.fedict.eidviewer.lib.PCSCEid.getFile(PCSCEid.java:336)
be.fedict.eidviewer.lib.PCSCEid.getIdentity(PCSCEid.java:95)
be.fedict.eidviewer.lib.PCSCEidController.run(PCSCEidController.java:378)
java.lang.Thread.run(Thread.java:744)
[PCSCEidController] state state_idle activity reading_identity action none
[CertificatesPanel] Updating..
[CertificatesPanel] Clearing Certificate Data..
[CardPanel] Updating..
[CardPanel] Clear Card Data And Not Loading
[IdentityPanel] Update..
[IdentityPanel] Clearing all data because source is not available
[PCSCEidController] closing card access
[PCSCEidController] starting reader sequence
[PCSCEidController] starting card sequence
[BelgianEidViewer] Scanning card terminal: O2 Micro Oz776 00 00
[PCSCEidController] waiting for eid card..
[PCSCEidController] state state_noeidpresent activity reading_identity action none
[CertificatesPanel] Updating..
[CertificatesPanel] Clearing Certificate Data..
[CardPanel] Updating..
[CardPanel] Clear Card Data And Not Loading
[IdentityPanel] Update..
[IdentityPanel] Clearing all data because source is not available
[BelgianEidViewer] Scanning card terminal: O2 Micro Oz776 00 00

Wie kan mij helpen
M.V.G. Patrick

Offline den boete

  • Lid
  • Steunpunt: Nee
Re: eID-software probleem na update 14.04
« Reactie #1 Gepost op: 2014/05/02, 19:19:29 »
Hallo Patrick,

Enige tijd terug heeft het ook nogal wat voeten in de aarde gehad om eID werkende te krijgen.
Teneinde raad stelde ik de vraag aan de IT-mensen van de overheid zelf via een contactformulier op volgende site :
http://eid.belgium.be/nl/contact/contactform.jsp.
Die mensen hebben me na enig over- en weergemail op het juiste pad gezet.
Ze zijn daar echt vakkundig, vriendelijk en behulpzaam.

Hieronder staat beschreven hoe ik de zaak ondertussen op meerdere pc's in orde kreeg :

Surf naar : http://eid.belgium.be/nl/je_eid_gebruiken/de_eid-middleware_installeren/linux/
en kies de link die past bij jouw systeem. (in mijn geval Ubuntu(64)/Debian(64).
Download de eID-software en de eID-viewer en open ze met 'Softwarecenter'.
Voor installatie van de kaartleze type ACR38U (verdeeld door de overheid). Start 'Synaptic', zoekterm 'acr38'.
Installeer : libacr38u, libacr38ucontrol0 en libacr38ucontrol-dev
Plug nu de kaartlezer in, of herstart indien deze vast is ingebouwd.
Ga naar de 'Dash' en type 'eid', je kan dan het programma van de kaartlezer starten. Steek je identiteitskaart in de lezer, en check of ze gezien wordt.
Mocht Firefox draaien, herstart die dan, er is namelijk een en ander geïnstalleerd dat bij een start van Firefox wordt opgenomen.
Wanneer je nu naar de site https://eservices.minfin.fgov.be/taxonweb/app/citizen/public/taxbox/home.do gaat, zou je moeten kunnen aanloggen met je identiteitskaart.
Wanneer dat niet lukt, ga dan verder met onderstaande :
In Firefox : Bewerken-Voorkeuren-Geavanceerd-Encryptie-Beveiligingsapparaten : kijken of module 'Belgium eID PKCS#11' aanwezig is -> niet aanwezig.
Zoeken in pc naar bestand 'libbeidpkcs11.so', dit bestand is zeker nodig !
Gevonden in de map /usr/lib.
Daarna in Firefox : Bewerken-Voorkeuren-Geavanceerd-Encryptie-Beveiligingsapparaten-Laden-Nieuwe PKCS #11-module. Ik gaf de module de naam 'Belgium eID PKCS #11 Module' en navigeerde naar /usr/lib/libbeidpkcs11.so.
Nu zie ik de module 'Belgium eID PKCS#11'zitten in Firefox.
Aanloggen bij http://ccff02.minfin.fgov.be/taxonweb/app/citizen/public/taxbox/home.do was nu geen probleem : kaart in de kaartlezer, pincode indrukken en de zaak was in orde.

Hopelijk raak je nu verder,

Grtz,
Den Boete
Don't limit your challenges, challenge your limits.

Offline super7707

  • Lid
Re: eID-software probleem na update 14.04
« Reactie #2 Gepost op: 2014/06/12, 13:08:51 »
Dag Patrick,

jij hebt dezelfde smartcard reader zoals ik (oz776) en deze wordt aangesproken door libccid (de libacr38* pakketen zijn voor andere kaartlezers).

libccid 1.4.15 was incompatibel met deze kaartlezer, dus jij moet downgraden (1.4.12) of upgraden (1.4.17).

beschreven is het probleem en de oplossing hier:
https://bugs.launchpad.net/ubuntu/+source/ccid/+bug/1311273

ik heb gedowngraded omdat gisteren nog geen 1.4.17 beschikbaar was, maar het blijkt dat 1.4.17 het probleem al oplost.

succes!