Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Verkeerd Gramps pakket verwijderen  (gelezen 288 keer)

Verkeerd Gramps pakket verwijderen
« Gepost op: 2014/04/16, 22:05:24 »
Ik heb een verkeerd Gramps programma geinstalleerd, het werkt niet, en ik kan het niet verwijderen via het Ubuntu Software Center
Het programma zou via de terminal gestart moeten worden, en als ik dat doe krijg ik de volgende meldingen:

2014-04-11 11:27:09.210: ERROR: grampsapp.py: line 114: Unhandled exception
Traceback (most recent call last):
  File "/usr/bin/gramps", line 3, in <module>
    app.main()
  File "/usr/lib/python2.7/dist-packages/gramps/grampsapp.py", line 443, in main
    errors = run()
  File "/usr/lib/python2.7/dist-packages/gramps/grampsapp.py", line 429, in run
    from .gui.grampsgui import startgtkloop
ImportError: No module named gui.grampsgui

Hoe krijg ik dit spul verwijderd
Kan ik bijv de hierboven genoemde gramps-bestanden en gramps-mappen bijv deleten zonder problemen?

Het installeren van het gramps pakket van Ubuntu software Center loopt af met een foutmelding



Offline Erik Krom

  • Lid
  • Steunpunt: Nee
Re: Verkeerd Gramps pakket verwijderen
« Reactie #1 Gepost op: 2014/04/17, 08:16:43 »
Heb je Gramps geïnstalleerd via het software center of op een andere manier?
Hetziet er naar uit dat een onderdeel ontbreekt.

Wat is de foutmelding van het Softwarecenter als je het probeert te verwijderen?
Mijn kristallen bol is vandaag wat wazig.  ;)

Re: Verkeerd Gramps pakket verwijderen
« Reactie #2 Gepost op: 2014/04/17, 10:17:05 »
Het software center ziet gramps helemaal niet zitten.
terwijl er wel een icon op mijn bureaublad staat
En ik denk dat ik het dus geinstalleerd heb op "die andere manier" maar ik weet het niet meer exact.

Ik heb geprobeerd het Gramps pakket van het Softwarecenter te installeren, maar dat zegt iets over een bestand dat hij niet kan verwijderen.
en stopt dan.

Offline Erik Krom

  • Lid
  • Steunpunt: Nee
Re: Verkeerd Gramps pakket verwijderen
« Reactie #3 Gepost op: 2014/04/17, 17:53:49 »
Wordt er ook gemeld waar en welk bestand er niet kan worden verwijderd?

Re: Verkeerd Gramps pakket verwijderen
« Reactie #4 Gepost op: 2014/04/17, 22:21:47 »
Ik heb de details van de error output van de installatie van het Ubuntu Softwarecentrum pakket opgevangen

installArchives() failed: (Reading database ...
(Reading database ... 5%
........ etc
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 306352 files and directories currently installed.)
Unpacking gramps (from .../gramps_3.3.1-1_all.deb) ...
dpkg: error processing /var/cache/apt/archives/gramps_3.3.1-1_all.deb (--unpack):
 trying to overwrite '/usr/share/mime/packages/gramps.xml', which is also in package python-gramps-webapp 4.0.3
No apport report written because MaxReports is reached already
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Processing triggers for shared-mime-info ...
Processing triggers for menu ...
Errors were encountered while processing:
 /var/cache/apt/archives/gramps_3.3.1-1_all.deb
Error in function:
SystemError: E:Sub-process /usr/bin/dpkg returned an error code (1)
---------------------------------------------------------

Ik hoop dat dit je iets zegt?

Ik zie in ieder geval zoiets als
                trying to overwrite '/usr/share/mime/packages/gramps.xml', which is also in package python-gramps-webapp 4.0.3
en dat is van het foute pakket
Maar zeggen die andere meldingen misschien ook nog iets??


Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Verkeerd Gramps pakket verwijderen
« Reactie #5 Gepost op: 2014/04/17, 22:45:59 »
sudo dpkg -i --force-all /var/cache/apt/archives/gramps_3.3.1-1_all.deb

Offline Erik Krom

  • Lid
  • Steunpunt: Nee
Re: Verkeerd Gramps pakket verwijderen
« Reactie #6 Gepost op: 2014/04/18, 07:54:11 »
En zie daar de package dat de problemen veroorzaakt.
...
... package python-gramps-webapp 4.0.3
...

Kan je dat pakket wel vinden in het software center of synaptic?
Zo ja, kan je het dan verwijderen?

Tuurlijk kan het ook met een terminal opdracht:
sudo apt-get remove python-gramps-webapp

Re: Verkeerd Gramps pakket verwijderen
« Reactie #7 Gepost op: 2014/04/18, 14:00:42 »
Ik heb allebei de terminal opdrachten maar uitgevoerd
Ze hebben allebei het een en ander opgeruimd zo te zien.

En vervolgens via het software centrum de Gramps geinstalleerd en dat werkt nu zo te zien
Bedankt voor de hulp

Peter