Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: probleem met mounten  (gelezen 136 keer)

Offline Seppe

  • Lid
probleem met mounten
« Gepost op: 2014/04/08, 09:51:13 »
Ik volg een tutorial om een kioskpc te maken.
Daarin staat dat ik via fstab een partitie read only moet mounten.

mijn fstab ziet er zo uit:
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda6 during installation
UUID=50ff72e3-7192-4727-83a3-d99aa4eb4933 /kiosk-ro               jfs     defaults,ro 0     2 
# /boot was on /dev/sda1 during installation
UUID=67d7771d-28c0-4e04-a09c-4ca73a19377f /boot           jfs     defaults        0       1
# swap was on /dev/sda5 during installation
UUID=a2ca00f6-e3d2-450b-9b22-7daf909c21bc none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0

tijdens het booten zegt hij dat er een probleem is om /kiosk-ro te mounten
als ik opgestart ben en sudo mount -a ingeef krijg ik de foutmelding " volgens 'mtab' is /dev/sda6 aangekoppeld op /
"

Hebben jullie een idee wat er fout kan zijn of hoe ik dat kan uitzoeken?

Alvast bedankt

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: probleem met mounten
« Reactie #1 Gepost op: 2014/04/15, 14:30:48 »
Tot mijn verwondering zie ik geen enkele lijn voor je systeempartitie ("/") in je /etc/fstab. Het verwondert me dat je systeem met deze /etc/fstab opstart.

Uit wat je beschrijft zou lijken dat de partitie die je op /kiosk-ro probeert te koppelen, al aangekoppeld is als systeempartitie. In de tutorial zie je dat er twee partities zijn, een systeempartitie aangekoppeld op / en de user-template aangekoppeld op /kiosk-ro. Jij blijkt een aparte /boot te hebben, wet perfect kan, maar zonder systeempartitie ("/") kan zeker niet.