Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: geen rechten voor NAS  (gelezen 491 keer)

Offline molly w

  • Lid
geen rechten voor NAS
« Gepost op: 2014/04/02, 18:00:43 »
Ik loop er tegenaan dat ik geen rechten heb op de bestanden die op mijn NAS staan. Ze zijn alle read only.
Deze week ben ik bezig Linux Mint 13LTS te installeren op mijn hoofd pc als vervanger van XP (dat staat er nog naast, maar niet voor internet na 8 april).
Het is me gelukt om alles shares op de NAS te mounten via fstab, maar nu blijkt dat ik geen wijzigingen in bestanden kan aanbrengen: ze zijn allemaal read only. Volgens mij is dat te regelen in de regel in fstab, maar weet niet goed wat. Natuurlijk blijf ik wat proberen, maar als iemand tips heeft ...
De shares op de NAS zijn toegankelijk voor "gast". Met XP kon ik er doen wat ik wilde. Daar ligt de sleutel voor oplossen van het probleem dan ook niet.
Mijn fstab ziet er zó uit:
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda2 during installation
UUID=39ec62f0-8c49-49e7-83de-ad8a34c90cb9 /               ext4    errors=remount-ro 0       1
/dev/sda5       none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
//192.168.1.2/media /media/nas_media cifs username=guest,password=,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
//192.168.1.2/documenten /media/nas_documenten cifs username=guest,password=,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
//192.168.1.2/oblimon /media/nas_oblimon cifs username=guest,password=,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
# /dev/sdb5: UUID=8C88657D88656724
UUID=8C88657D88656724 /media/pczolder_data       ntfs    username=guest,password=,rw,uid=1000,utf8,umask=000,gid=1000 0       1
# /dev/sdb6: UUID=8BBFF89C887876EE
UUID=8BBFF89C887876EE /media/pczolder_oblimon       ntfs    rw,uid=1000,utf8,umask=000,gid=1000 0       1

Op de bestanden op pczolder heb ik wel rechten, dus dat is OK.
De optie username=guest,password= zorgt ervoor dat de betreffende station automatisch mounten. Laat je ze weg, dan mounten ze niet; dat moet je dan met de hand doen (mount -a). Misschien moet ik de waarden van file_mode en dir_mode op 000 zetten (net zoals de umask in de regels van pczolder) en moet ik gid=1000 (mijn groeps-ID) toevoegen.

[Mod edit: Even zo vrij geweest om je FSTAB in codetags te zetten.]
« Laatst bewerkt op: 2014/04/02, 20:25:50 door TopGear »

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: geen rechten voor NAS
« Reactie #1 Gepost op: 2014/04/02, 20:23:27 »
Citaat
Mounting unprotected (guest) network folders

First, let's create the mount directory. You will need a separate directory for each mount.

sudo mkdir /media/windowsshare

Then edit your /etc/fstab file (with root privileges) to add this line:

//servername/sharename  /media/windowsshare  cifs  guest,uid=1000,iocharset=utf8  0  0

Where

    guest indicates you don't need a password to access the share,

    uid=1000 makes the Linux user specified by the id the owner of the mounted share, allowing them to rename files,

    iocharset=utf8 allows access to files with names in non-English languages. This doesn't work with shares of devices like the Buffalo Tera Station, or Windows machines that export their shares using ISO8895-15.

    If there is any space in the server path, you need to replace it by \040, for example //servername/My\040Documents

After you add the entry to /etc/fstab type:

sudo mount -a

This will (re)mount all entries listed in /etc/fstab.

Probeer dit eens,
//servername/sharename  /media/windowsshare  cifs  guest,uid=1000,iocharset=utf8  0  0

Ook eerst proberen, zonder dat de gedeelde map in je fstab staat, of je dan alles kunt wijzigen, als je via nautilus naar je gedeelde  map gaat. Dan pas je fstab aanpassen.
« Laatst bewerkt op: 2014/04/02, 20:29:56 door jan11000 »

Offline molly w

  • Lid
Re: geen rechten voor NAS
« Reactie #2 Gepost op: 2014/04/03, 10:16:20 »
Dank voor de tips. Ik heb een en ander geprobeerd want jouw suggestie werkte niet helemaal. Uiteindelijk is het zó geworden:
//192.168.1.2/documenten /media/nas_documenten cifs username=guest,password=,iocharset=utf8,uid=1000 0 0De codes username=guest,password= moesten er in blijven staan, anders verdwenen de icoontjes van deze stations van het bureaublad, wat betekent dat ze niet zijn gekoppeld bij het herstarten van het systeem. Alleen 'guest' als optie opnemen bleek niet voldoende.

Overigens heb ik direct in fstab gewerkt - had wel een backup gemaakt - want dat is toch de omgeving waarin ie het uiteindelijk moet doen.
Maar nu werkt het.
fstab ziet er nu zó uit:
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda2 during installation
UUID=39ec62f0-8c49-49e7-83de-ad8a34c90cb9 /               ext4    errors=remount-ro 0       1
/dev/sda5       none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
//192.168.1.2/media /media/nas_media cifs username=guest,password=,iocharset=utf8,uid=1000 0 0
//192.168.1.2/documenten /media/nas_documenten cifs username=guest,password=,iocharset=utf8,uid=1000 0 0
//192.168.1.2/oblimon /media/nas_oblimon cifs username=guest,password=,iocharset=utf8,umask=000,uid=1000 0 0
# /dev/sdb5: UUID=8C88657D88656724
UUID=8C88657D88656724 /media/pczolder_data       ntfs    guest,rw,uid=1000,iocharset=utf8,umask=000,gid=1000 0       1
# /dev/sdb6: UUID=8BBFF89C887876EE
UUID=8BBFF89C887876EE /media/pczolder_oblimon       ntfs    guest,rw,uid=1000,iocharset=utf8,umask=000,gid=1000 0       1