Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: NAS servernaam????  (gelezen 4197 keer)

Offline molly w

  • Lid
NAS servernaam????
« Gepost op: 2014/03/24, 13:04:34 »
Ik wil mijn NAS automatisch mounten in mijn Linuxsysteem, maar het lukt niet. Ik kan de juiste servernaam niet vinden. Als ik het commando sudo mount -t cifs //NAS/media /media/nas_media -o iocharset=utf8,file_mode=0777,dir_mode=0777 ingeef, levert dat melding mount error: could not resolve address for NAS: Unknown error op.
Als ik in de router het IP-adres opzoek en dat gebruik dan krijg ik Unable to find suitable address.
.
De NAS is echter wél te zien in map [netwerkservers] op mijn bureaublad, maar daar vind ik geen servernaam. In Gigolo ziet de NAS ook en levert keurig de shares van de NAS, maar ik kan niet vinden hoe de NAS in Gigolo bekend staat.
Het commando smbclient -L 192.168.1.10 -U% levert als servernaam NAS, maar zoals gezegd: dat werkt niet. Wie weet een uitweg??

Offline molly w

  • Lid
Re: NAS servernaam????
« Reactie #1 Gepost op: 2014/03/24, 14:26:44 »
Gigolo uitleg: http://steunpunt-almere.nl/artikelen/gigolo-netwerkbrowser/

Je NAS heeft een eigen IP (dat zul je wel weten) en dat IP adres weet je omdat Gigolo hem ziet.
Wat wil je vinden in Gigolo....hoe de NAS bekend staat? Wat bedoel je daarmee?

Ik wilde weten over Gigolo nog een andere servernaam gebruikt dan NAS of 192.168.1.12.
Als is commando smbclient -L 192.168.1.12 -U
ingeef, krijg ik Connection to 192.168.1.12 failed (Error NT_STATUS_CONNECTION_REFUSED)

Als vervolgens de gebruikersnaam en het wachtwoord waarmee ik toegang krijg tot de NAS om te beheren, toevoeg aan de opdrachtregel voor mounten
sudo mount -t cifs //192.168.1.12/media /media/nas_media username=[user],password=[pw] -o iocharset=utf8,file_mode=0777,dir_mode=0777, krijg ik een heleboel uitleg, maar geen verbinding. Omdat noch NAS noch het IP-adres werken, vraag ik me dus af of er nog meer servernamen kunnen zijn. Maar zou  niet weten welke? Het lijkt me ook zo onwaarschijnlijk. Overigens: de shares op de NAS staan open voor gasten. Er wordt geen inloggegevens gevraagd bij lezen of schrijven.

Offline molly w

  • Lid
Re: NAS servernaam????
« Reactie #2 Gepost op: 2014/03/25, 11:22:58 »
Dus Gigolo ziet hem ook niet, althans, je kan hem in Gigolo ook niet zetten aangezien het ip adres niet goed is.

Dan moet je in het netwerk kijken, dus in het modem van je provider of je eigen router en daar het ip adres vandaan halen.

Gigolo ziet hem wél, maar het IP-adres dat ik in de router vind, geeft nul op het request. Daarom wil ik van Gigolo weten welke servernaam of IP-adres Gigolo gebruikt. Want Gigolo schijnt het dus wel het goede te gebruiken. Hoe kom ik daarachter?

Offline molly w

  • Lid
Re: NAS servernaam????
« Reactie #3 Gepost op: 2014/03/25, 15:17:12 »
Eh.....in Gigolo heb je het toch echt ook lf in moeten vullen! Dus sorry als ik het nog niet helemaal begrijp.

In Gigolo kan je klikken op Pas de Bladwijzers aan...en daar kan je kijken wat je hebt ingevuld. Dus klik op je NAS en klik dan op Bewerken.
Bij server staat dan het ip adres...

Ik kan me voorstellen dat je het niet begrijpt. Voor het instellen van Gigolo heb ik gewerkt volgens de aanwijzingen van "Computertip: Gigolo: netwerkschijven (NAS) gebruiken" (https://sites.google.com/site/computertip/reserve-7). Dat ging allemaal automatisch, ik heb daar geen IP-adressen of zo hoeven op te geven.
Kijk ik nu bij Gigolo zoals jij aangeeft, dan vindt ik als servernaam voor de NAS: nas. - kleine letters dus.

Maar het maakt allemaal niks uit, zoals blijkt uit wat ik in de Terminal al heb geprobeerd en wat dat opleverde:
  • $ smbclient -L NAS -U
    Enter [mijn] password:
    Domain=[mijn naam] OS=[Unix] Server=[Samba 3.5.21]

       Sharename       Type      Comment
       ---------       ----      -------
       IPC$            IPC       IPC Service (NAS)
       oblimon         Disk      data PCZolder D
       media           Disk      Media Server Share
       documenten      Disk      documenten PCZolder F
    Domain=[mijn werkgroep] OS=[Unix] Server=[Samba 3.5.21]

       Server               Comment
       ---------            -------
       NAS                  NAS
       PCZOLDER             PC Zolder

       Workgroup            Master
       ---------            -------
       mijn werkgroep           PCZOLDER
  • $ sudo mount -t cifs //NAS/media/ /media/nas_media -o iocharset=utf8,file_mode=0777,dir_mode=0777
    mount error: could not resolve address for NAS: Unknown error
  • $ sudo mount -t cifs //nas/media/ /media/nas_media -o iocharset=utf8,file_mode=0777,dir_mode=0777
    [sudo] password for [mijn naam]:
    mount error: could not resolve address for nas: Unknown error
En met het IP-adres of de naam die de router opgeeft
  • $ smbclient -L 192.168.1.12 -U
    Enter[mijn] password:
    Connection to 192.168.1.12 failed (Error NT_STATUS_HOST_UNREACHABLE)
  • $ sudo mount cifs //android_900af637534e1e83/media  /media/nas_media -o iocharset=utf8,file_mode=0777,dir_mode=0777
    Gebruik:  mount                 : aangekoppelde bestandssystemen tonen
              mount -l              : idem, inclusief volumenlabels
              mount -h              : deze hulptekst tonen
              mount -V              : programmaversie tonen

    Tot zover het deel dat informatie weergeeft.  Nu het aankoppelen.
    De algemene vorm is:  'mount [-t bestandssysteemsoort] iets ergens'.
    Details die in /etc/fstab staan kunnen worden weggelaten.
              mount -a [-t|-O]      : alles in /etc/fstab aankoppelen
              mount apparaat        : apparaat aankoppelen op de bekende plaats
              mount map             : bekend apparaat hier aankoppelen
              mount -t soort apparaat map : volledige mount-opdracht
    Merk op dat men niet echt een apparaat aankoppelt, maar het bestandssysteem
    (van de gegeven soort) dat zich op dat apparaat bevindt.

    Men kan ook een reeds zichtbare mappenboom ergens anders aankoppelen:
              mount --bind oudemap nieuwemap
    of een subboom verplaatsen:
              mount --move oudemap nieuwemap
    Men kan van een aankoppeling de soort veranderen, als 'map' erin voorkomt:
           mount --make-shared map
           mount --make-slave map
           mount --make-private map
           mount --make-unbindable map
    Men kan van alle aankoppelingen in een subboom de soort veranderen,
    als 'map' erin voorkomt:
           mount --make-rshared map
           mount --make-rslave map
           mount --make-rprivate map
           mount --make-runbindable map

    Een apparaat kan worden opgegeven via de naam, zeg /dev/hda1 of /dev/cdrom,
    of via het label, met -L label, of via de UUID, met -U UUID.
    Andere opties zijn: [-nfFrsvw] [-o opties] [-p wachtwoordbestandsdescriptor].
    Voor meer informatie, zie man mount(8).
  • $ sudo mount cifs //192.168.1.12/media /media/nas_media username=guest -o iocharset=utf8,file_mode=0777,dir_mode=0777
    Gebruik:  mount                 : aangekoppelde bestandssystemen tonen
              mount -l              : idem, inclusief volumenlabels
              mount -h              : deze hulptekst tonen
              mount -V              : programmaversie tonen

    Tot zover het deel dat informatie weergeeft.  Nu het aankoppelen.
    De algemene vorm is:  'mount [-t bestandssysteemsoort] iets ergens'.
    Details die in /etc/fstab staan kunnen worden weggelaten.
              mount -a [-t|-O]      : alles in /etc/fstab aankoppelen
              mount apparaat        : apparaat aankoppelen op de bekende plaats
              mount map             : bekend apparaat hier aankoppelen
              mount -t soort apparaat map : volledige mount-opdracht
    Merk op dat men niet echt een apparaat aankoppelt, maar het bestandssysteem
    (van de gegeven soort) dat zich op dat apparaat bevindt.

    Men kan ook een reeds zichtbare mappenboom ergens anders aankoppelen:
              mount --bind oudemap nieuwemap
    of een subboom verplaatsen:
              mount --move oudemap nieuwemap
    Men kan van een aankoppeling de soort veranderen, als 'map' erin voorkomt:
           mount --make-shared map
           mount --make-slave map
           mount --make-private map
           mount --make-unbindable map
    Men kan van alle aankoppelingen in een subboom de soort veranderen,
    als 'map' erin voorkomt:
           mount --make-rshared map
           mount --make-rslave map
           mount --make-rprivate map
           mount --make-runbindable map

    Een apparaat kan worden opgegeven via de naam, zeg /dev/hda1 of /dev/cdrom,
    of via het label, met -L label, of via de UUID, met -U UUID.
    Andere opties zijn: [-nfFrsvw] [-o opties] [-p wachtwoordbestandsdescriptor].
    Voor meer informatie, zie man mount(8).

Snap je dat ik het ook niet meer weet.
« Laatst bewerkt op: 2014/03/25, 15:19:55 door molly w »

Offline molly w

  • Lid
Re: NAS servernaam????
« Reactie #4 Gepost op: 2014/03/25, 15:28:37 »
Ter aanvulling en om te laten zien dat het probleem ligt tussen Linux (Samba) en de NAS, de twee partities op PCZOlder (win XP) worden wel gevonden. Dat werkt. Het is dus niet een probleem van Samba op zich.

Offline markba

  • Lid
    • http://markbaaijens.nl/
  • Steunpunt: Ja
Re: NAS servernaam????
« Reactie #5 Gepost op: 2014/03/25, 16:22:18 »
Heb je al 'Netwerk doorbladeren' geprobeerd? Want daarmee zou een server (als deze actief en zichtbaar is natuurlijk) altijd getoond moeten worden...

Offline molly w

  • Lid
Re: NAS servernaam????
« Reactie #6 Gepost op: 2014/03/25, 17:16:07 »
http://steunpunt-almere.nl/artikelen/gigolo-netwerkbrowser/

mijn handleiding geeft toch echt aan dat je de server in moet vullen!! Anders vind hij hem niet.

Dan moet er toch iets niet in orde zijn ingevuld, naar mijn mening.

Als ik die handleiding goed lees, kan ik niet vinden waar ik bij de installatie of bij eerste start van Gigolo met hand servernamen moet invullen. Ik kan in de rechterkolom, tab 'netwerk' kiezen uit (reeds) beschikbare servers/netwerklocaties. De rest gaat vanzelf.

Offline molly w

  • Lid
Re: NAS servernaam????
« Reactie #7 Gepost op: 2014/03/25, 17:33:59 »
Heb je al 'Netwerk doorbladeren' geprobeerd? Want daarmee zou een server (als deze actief en zichtbaar is natuurlijk) altijd getoond moeten worden...

De NAS is reeds zichtbaar. In de map [netwerkservers] op mijn bureaublad staan alle actieve netwerklocaties getoond, ook de NAS. Het is dus niet zo dat er überhaupt geen verbinding gemaakt kan worden, het lukt me alleen niet om in de Terminal met het commando 'mount -t' een verbinding te maken en zo te bepalen hoe de NAS straks in 'fstab' vermeld moet worden. (De reden waarom ik dit wil, heb ik eerder al uiteengezet).

Terug naar de map [netwerkservers].
Ik open de NAS en vind daar de shares die op de NAS staan. ('Media' is daar één van). Met de rechtermuisknop klik ik op 'eigenschappen' van 'media'. Als locatie wordt genoemd: "smb: //nas/".
De servernaam van de NAS is dus toch echt NAS of nas, zou je denken. Maar waarom dan toch telkens "mount error: could not resolve address for NAS: Unknown error" of dat verhaal over al die opties???

Offline molly w

  • Lid
Re: NAS servernaam????
« Reactie #8 Gepost op: 2014/03/25, 17:38:48 »
Dan lees je niet goed:



Klik met rechts op wat jij wilt delen in je netwerk, en klik daarna op Maak een bladwijzer.

Wanneer je er een bladwijzer van gemaakt hebt, selecteer dan Automatisch verbinding maken.

Voorbeeld zoals het eruit gaat zien als je alle gegevens die nodig zijn, hebt ingevuld. Op de plaats van de zwarte puntjes komt uiteraard je eigen ip adres van je NAS.



Je hebt gelijk, ik<las er overheen. Maar ik zal je het verhaal geven dat ik gevolgd heb en waarin geen sprake is van invullen. Geen wonder dat we elkaar niet snapten.

Offline molly w

  • Lid
Re: NAS servernaam????
« Reactie #9 Gepost op: 2014/03/25, 17:39:10 »
1.4. Nu start u Gigolo, via Menuknop - Systeem - Gigolo

Werkbalk Gigolo: Bewerken - Voorkeuren - tabblad Netwerkkaart

Vink aan:
- Start geminimaliseerd in het meldvak
- Toon zijbalk

Haal het vinkje weg bij:
- Toon foutmeldingen voor auto-verbinden

Het wordt dus zoals op onderstaande schermafdruk (klik erop om hem te vergroten):



Klik nu op het tabblad Werkbalk - Stijl: zet die op Beide
Zie onderstaande schermafdruk (Klik erop om hem te vergroten):



Klik op Sluiten om de Voorkeuren te verlaten.


1.5. Klik vervolgens op het tabblad Netwerk (verticale tekst) links in beeld. Nu klapt het beschikbare netwerk open, met daarin de netwerkschijf.

Rechtsklik met de muis op de schijf en kies Maak een bladwijzer. Zie onderstaand voorbeeld (klik op de afbeelding om hem te vergroten):



Nu duikt het venstertje "Bewerk bladwijzer" op.
Zet daarin een vinkje bij: Automatisch verbinden. Zie onderstaande schermafdruk (klik erop om hem te vergroten):



Gigolo is nu ingesteld om automatisch te verbinden met de netwerkschijf, en zal binnen 60 seconden vanzelf verbinding maken. Gewoon even afwachten dus!

????????Waar blijven de plaatjes???????????
« Laatst bewerkt op: 2014/03/25, 17:41:06 door molly w »

Offline molly w

  • Lid
Re: NAS servernaam????
« Reactie #10 Gepost op: 2014/03/25, 18:00:29 »
Ben nog wat aan het googlen geweest.
Op site http://www.linuxquestions.org/questions/blog/ted_chou12-538462/cifs-not-able-to-mount-by-hostname-only-by-ip-solved-34948/ lees ik de suggestie om in het bestand [/etc/hosts] een regel toe te voegen met "192.168.1.101   NAS".
Nu staat daar:
127.0.0.1   localhost
127.0.1.1   toshiba

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters


Ik wil dat nog gaan proberen maar niet nu. Geen tijd.

Offline molly w

  • Lid
Re: NAS servernaam????
« Reactie #11 Gepost op: 2014/03/26, 15:46:07 »
Waar blijven de plaatjes?? Moet je niet aan ons vragen maar aan degene van de site waar je het hebt afgehaald. En die is niet zo van de plaatjes. ;) heb ik weleens eerder gemerkt.

Daarom maak ik er wel werk van om het met plaatjes uit te leggen, dan is het makkelijker te begrijpen.  ;)

Maar dan nog hoor, zijn er mensen die bepaalde dingen niet snappen terwijl het wordt voor gekauwd met plaatjes. Die hou je altijd.

Ik had verwacht dat met copy - paste ook de afbeeldingen zouden worden geplakt. Niet dus. later bedacht me daik ze misschien apart zou moeten invoegen met de knop [voeg afbeelding toe]. Maar dat probeer ik nu niet, want ik ben eruit!

Na een heleboel gesurf en geprobeer en kijken op de NAS naar de toegangsrechten zag ik met findsmb dat de NAS als IP-adres had 192.168.1.2 en niet 192.168.1.12 zoals in de router staat. In eerste instantie hielp me dat niet verder. totdat ik in de opdrachtregel
mount -t cifs //192.168.1.2/media /media/nas_media -o username=guest enz enz [username=guest] weghaalde. Toen deed ie het!

Vervolgens heb ik alle shares van de NAS in fstab vermeld, zodat ze voortaan  automatisch zouden mounten. Helaas gebeurd dat niet, zodat ik met mount -a dat alsnog moet doen. Is wel 5x wachtwoord ingeven. Pff. Heb ik iets niet helemaal goed gedaan??
In fstab staan ze nu zó - ik geef er maar één, de syntaxis van de andere is hetzelfde - :
//192.168.1.2/media /media/nas_media cifs iocharset=utf8,file_mode=0777,dirmode=0777   0   0
(met een return op eind van de regel voor een nieuwe lege regel)
« Laatst bewerkt op: 2014/03/26, 15:48:53 door molly w »

Offline maasnet

  • Lid
    • m-vd-hoeven
  • Steunpunt: Ja
Re: NAS servernaam????
« Reactie #12 Gepost op: 2014/03/26, 16:18:22 »
//192.168.1.12/movies /media/Movies cifs username=playon,password=hierwachtwoord,rw,noperm,iocharset=utf8,dir_mode=0777,file_mode=0777 0 0
Je ziet wel wat een ander heeft, maar je ziet niet wat hij mist.

OS: Ubuntu Gnome 18.04/Xubuntu 18.04; Windows 10 (dualboot) RPI: Ubuntu Mate; Asus 1005PE: Linux Lite 3.8
***Steunpunt***  voor andere steunpunten: https://kaart.ubuntu-nl.org/

Offline molly w

  • Lid
Re: NAS servernaam????
« Reactie #13 Gepost op: 2014/03/26, 17:55:03 »
Op de site https://wiki.ubuntu.com/MountWindowsSharesPermanently vond ik ooit een oplossing voor het probleem van niet automatisch mounten. Ik citeer:

Unprotected network folder won't automount

I've had a situation where an unprotected network folder wouldn't automount during bootup, but after manually entering "sudo mount -a" was mounted correctly. I solved this by replacing the "guest" option by "username=guest,password=". If anyone has an explanation for this, please leave a comment.

//servername/sharename  /media/windowsshare  smbfs  username=guest,password=,uid=1000,iocharset=utf8,codepage=unicode,unicode  0  0

Toen ik de tekst [username=guest,password=] aan de opdrachtregel in fstab had toegevoegd, lukt het wel.
Nu was ik dat even vergeten en had die woorden verwijderd nadat ik de regels voor de NAS-shares had toegevoegd.
Tijdens het wandelen met de hond - zo zie je hoe afstand nemen verfrissend en probleem oplossend werken kan - schoot me dat weer te binnen.
Uit wat experimenteren bleek dat die woorden aan alle opdrachtregels toegevoegd moesten worden. Vreemd dat dit bij de opdracht 'mount -t' deze oorzaak van het probleem was, nu is het de oplossing.
Het IP-adres moet - in mijn geval - echt 192.168.1.2 zijn en niet wat de router opgeeft (192.168.1.12).

Fstab ziet er dus nu zó uit:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda3 during installation
UUID=1dfa9793-1efe-483f-98de-125a9f8e034d /               ext4    errors=remount-ro 0       1
# /mnt/data was on /dev/sda5 during installation
UUID=4772-7471  /mnt/data       vfat    rw,uid=1000,utf8,umask=000,gid=1000 0       1
# /mnt/windows was on /dev/sda1 during installation
UUID=966CB74C6CB725C1 /mnt/windows    ntfs    rw,uid=1000,umask=000,gid=1000 0       0
# swap was on /dev/sda4 during installation
UUID=3778685b-bf68-4886-b71a-cee3c12a75a3 none            swap    sw              0       0
/dev/fd0        /media/floppy0  vfat    rw,users,noauto,exec,utf8 0       0
//192.168.1.10/D /media/pczolder_D cifs username=guest,password=,iocharset=utf8,file_mode=0777,dir_mode=0777 0      0
//192.168.1.10/F /media/pczolder_F cifs username=guest,password=,iocharset=utf8,file_mode=0777,dir_mode=0777 0      0
//192.168.1.2/media /media/nas_media cifs username=guest,password=,iocharset=utf8,file_mode=0777,dir_mode=0777   0   0
//192.168.1.2/documenten /media/nas_documenten cifs username=guest,password=,iocharset=utf8,file_mode=0777,dir_mode=0777   0   0
//192.168.1.2/oblimon /media/nas_oblimon cifs username=guest,password=,iocharset=utf8,file_mode=0777,dir_mode=0777   0   0


Alle locaties zijn nu ook beschikbaar in het [open bestand]-menu van bijv. Firefox. Zie bijlage

Offline molly w

  • Lid
Re: NAS servernaam????
« Reactie #14 Gepost op: 2014/03/28, 11:04:22 »
Citaat
Alle locaties zijn nu ook beschikbaar in het [open bestand]-menu van bijv. Firefox. Zie bijlage
ik neem aan dat je Nautilus gedoeld.
[/qoute]
Nee, ik bedoel écht het dialoogvenster van open-bestand in bijv. Firefox of GoogleChrome
In Nautilus waren ook de stations te zien die Gigolo koppelde, maar die waren in dat openingsvenster van Firefox niet beschikbaar.
GglCr keek in /media/ bijv. nas_media maar als dat station niet via fstab gekoppeld was, was de betreffende map leeg.
Dit nu is opgelost door de netwerkstation in fstab te zetten.Gigolo is daarmee waarschijnlijk overbodig geworden.
tenzij een updat van Firefox of GglCr het anders gaat organiseren dan tot nu toe. - zoals in de windowsversie kan.

Citaat
Mijn NAS staat daar ook in (hoewel ik Nemo gebruik) en dat alles gewoon met Gigolo. Mijn NAS heeft 6 aparte mappen die je allemaal ziet.
Elke keer bij opstarten van de pc worden die automatisch gemount met Gigolo.

Maar fijn dat het je nu gelukt is.

Offline molly w

  • Lid
Re: NAS servernaam????
« Reactie #15 Gepost op: 2014/03/28, 13:58:08 »
Voortaan even kijken waar je je antwoord zet, het is nu erg onduidelijk. Ik zie alleen een quote en verder niets.

Maar je schrijft dus dit erbij:

Citaat
Nee, ik bedoel écht het dialoogvenster van open-bestand in bijv. Firefox of GoogleChrome
In Nautilus waren ook de stations te zien die Gigolo koppelde, maar die waren in dat openingsvenster van Firefox niet beschikbaar.
GglCr keek in /media/ bijv. nas_media maar als dat station niet via fstab gekoppeld was, was de betreffende map leeg.
Dit nu is opgelost door de netwerkstation in fstab te zetten.Gigolo is daarmee waarschijnlijk overbodig geworden.
tenzij een updat van Firefox of GglCr het anders gaat organiseren dan tot nu toe. - zoals in de windowsversie kan.

Wil je dit nader uitleggen? "Nee, ik bedoel écht het dialoogvenster van open-bestand in bijv. Firefox of GoogleChrome"
want ik snap dit even niet?

Ik hoop dat ik het met woorden kan uitleggen.
Ik heb Firefox opgestart en wil een html-bestand openen dat op het externe station nas/documenten staat. Ik klik aan bestand --> open. Ik krijg een dialoogvenster met in de rechterkolom een rij locaties/stations. Daarin staan de locaties en de stations die óf in het eigen systeem voorkomen (HDD of partities op de laptop waarop Linux draait)  óf die in fstab staan opgenomen.
Nu is het zo, dat zolang het externe station nas/documenten niet in fstab staat (of, zo ja, niet automatisch wordt gemount), het niet voorkomt in de rechterkolom van het dialoogvenster van Firefox.
Het koppelpunt van nas/documenten heb ik gemaakt in /etc/media/nas_documenten. Ik kan in het dialoogvenster daar naartoe gaan, maar zolang nas/documenten niet is gemount, is /etc/media/nas_documenten leeg. Dus dat werkt niet.

Nu heb ik het dus zo gemaakt, dat nas/documenten in fstab staat en automatisch gemount wordt. Nu staat het station nas/documenten wél in de rechterkolom genoemd en kan ik daarnaar toegaan om mijn bestand te openen. Ik zou het ook via /etc/media/nas_documenten kunnen doen - dat is nu niet leeg meer - dat werkt ook.
De bijgevoegde foto die ik er laatst bij gedaan had, laat het rijtje in de rechterkolom van het dialoogvenster "openen" zien.

Hetzelfde verhaal geldt ook als ik een bepaalde internetpagina wil opslaan.

Voor GoogleChrome geldt hetzelfde, alleen zoekt GglCr van meet af aan in etc/media.

Ik hoop dat het nu helderder is. Anders probeer ik het uit te leggen met plaatjes. ;)
Tussen haakjes: afbeeldingen kan ik in dit bericht plakken??? De knop 'afbeeldingen invoegen' voegt de tags in. Daartussen zou ik een pad moeten typen, maar hoe vind ik het pad naar een afbeeldingen in - zeg eens - Documenten in mijn persoonlijke map?

Offline molly w

  • Lid
Re: NAS servernaam????
« Reactie #16 Gepost op: 2014/03/29, 11:03:12 »
Citaat
Ik heb Firefox opgestart en wil een html-bestand openen dat op het externe station nas/documenten staat. Ik klik aan bestand --> open. Ik krijg een dialoogvenster met in de rechterkolom een rij locaties/stations. Daarin staan de locaties en de stations die óf in het eigen systeem voorkomen .

dat is in feite gewoon je nautilus, nbemo of thunar. Je verkenner dus.

Bij mij staan dan mijn nas mappen ook daarin, zoals ik al schreef. ;)

Hmmm. Bij mij was dat in het begin niet zo. Hangt dat er vanaf hoe je bij de installatie en het instellen van het netwerk de dingen regelt? Ik heb namelijk niet zelf Linux geïnstalleerd op de oude toshiba, waarop ik met Linux heb kunnen stoeien zonder op mijn hoofdpc de boel te verzieken. Ik zat erbij en keek er naar - naar de installatie dus - en dan ontgaat je veel. Nu ik de komende week op die hoofdpc Linux wil installeren (naast XP, dat wel) met oog op "D-day" 8 april, is het handig dat te weten.

Offline molly w

  • Lid
Re: NAS servernaam????
« Reactie #17 Gepost op: 2014/04/01, 17:04:21 »
Nee, heb gewoon mijn eigen handleiding gevolgd (uiteraard). En dan komen ze gewoon in de verkenner.

OK Ik laat het hierbij. Op mijn hoofdpc probeer ik het mounten op basis van fstab en laat gigolo nog even weg. Per slot van rekening wil ik niet teveel icoontjes op mijn bureaublad.