Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Moho systeemeisen, huh?  (gelezen 1300 keer)

Rasheed

  • Gast
Moho systeemeisen, huh?
« Gepost op: 2006/02/25, 14:47:45 »
Ik zou graag Moho willen installeren op mijn laptopje. Er staat al Ubuntu 5.10 op en Moho is specifiek getest voor Ubuntu door Lost Marble. Alleen de systeemeisen, daar snap ik niks van:

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Moho systeemeisen, huh?
« Reactie #1 Gepost op: 2006/02/25, 21:22:33 »
Als ik zo de moho pagina lees hoef je niks extras te installeren, gtk+ en glibc staan erop en zijn gecompileerd met een (waarschijnlijk) compatibele versie van gcc.

Rasheed

  • Gast
Moho systeemeisen, huh?
« Reactie #2 Gepost op: 2006/02/25, 21:59:40 »
Was ik nog vergeten, KDE was ook nodig. Kun je dat naast de Gnome Desktop installeren?

Ren

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Moho systeemeisen, huh?
« Reactie #3 Gepost op: 2006/02/25, 22:17:30 »
Ja, maar als je dat gaat downloaden, downoad dan een kubuntu installatie cd. Steek die in de cd speler, klik het bericht "Heym dit is een Ubuntu CD, upgraden?" weg en gebruik apt-cd add om de cdrom bekend te maken. Je kunt daarna het kubuntu-desktop pakket installeren.

Rasheed

  • Gast
Moho systeemeisen, huh?
« Reactie #4 Gepost op: 2006/02/25, 22:36:38 »
Bedankt, dat zal ik morgen proberen. Het is nu al te laat om die Kubuntu CD te downloaden (duurt enige uren op 100 KB/s).

Ren

Rasheed

  • Gast
Moho systeemeisen, huh?
« Reactie #5 Gepost op: 2006/02/26, 10:58:16 »
Ik kreeg net een antwoord terug op het Moho forum dat iemand met succes Moho gebruikt op Fedora Core 4 onder Gnome. Dus KDE is blijkbaar niet nodig.

Echter, als ik Moho installeer in mijn home directory (~/moho/) en ik draai het shell script moho, krijg ik een cryptische foutmelding:
rene@ubuntu:~$ moho/moho
/home/rene/moho/moho.donotrunme: error while loading shared libraries: libstdc++.so.5 cannot open shared object file: No such file or directory
Moho is geschreven in C++, dus dat verklaar wellicht libstdc++.so.5, maar ik heb geen idee hoe ik dit moet oplossen.

Het shell script is als volgt:
#!/bin/sh

# If you have purchased a copy of Moho, fill in the registration code below.
export MOHO_REGISTRATION=

# Modify the following path to point to a font folder. The default setting points
# to some included fonts in Red Hat 8. You can point to any folder of TrueType or
# Type1 fonts. A big collection of freely-downloadable fonts that work well for
# animation can be found here:
# http://www.chank.com/freefonts.php
export MOHO_FONTS=/usr/X11R6/lib/X11/fonts/Type1

if echo $(dirname $0) | grep '^/.*' > /dev/null; then
MOHO_DIR=$(dirname $0)
else
MOHO_DIR=$(pwd)/$(dirname $0)
fi
MOHO_LOCATION=$MOHO_DIR/moho.donotrunme
export MOHO_LOCATION

export LC_ALL=C
export LANG=C
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$MOHO_DIR

if [ -e "$MOHO_LOCATION" ]; then
$MOHO_LOCATION $*
else
echo "Please edit the startup script before running Moho."
fi
En de Linux Notes van de Lost Marble website vermeld dat:
Citaat
To install Moho on your Linux system, all you should need to do is to uncompress the package and place it wherever you like on your system. To launch Moho, run the script called 'moho' included in the download. If you run into problems, you may need to make small adjustments to that startup script.
Kleine aanpassingen, klinkt goed, maar ik weet niet eens wat deze foutmelding inhoudt :/

Ren

Offline kennywest

  • Lid
    • http://kennywest.blogspot.com
  • Steunpunt: Nee
Moho systeemeisen, huh?
« Reactie #6 Gepost op: 2006/02/26, 11:07:40 »
Je hebt nog een aantal libs nodig. Ik heb:
kenneth@pavane:~$ dpkg -l | grep libstd
ii  libstdc++5                            3.3.6-8ubuntu1                       The GNU Standard C++ Library v3
ii  libstdc++5-3.3-dev                    3.3.6-8ubuntu1                       The GNU Standard C++ Library v3 (development
ii  libstdc++6                            4.0.1-4ubuntu9                       The GNU Standard C++ Library v3
ii  libstdc++6-4.0-dev                    4.0.1-4ubuntu9                       The GNU Standard C++ Library v3 (development
kenneth@pavane:~$

Dus apt-get install libstdc++5 zou soelaas moeten brengen.

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Moho systeemeisen, huh?
« Reactie #7 Gepost op: 2006/02/26, 11:44:07 »
apt-get install libstdc++5 zou het moeten doen.

Rasheed

  • Gast
Moho systeemeisen, huh?
« Reactie #8 Gepost op: 2006/02/26, 12:56:01 »
sudo apt-get install libstdc++5

Maar goed, nu is het gelukt. Hartstikke bedankt!

Hier zijn wat foto's van het scherm:




Ren