Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Twee versies van Java? En andere Javavragen.  (gelezen 891 keer)

Offline Bert Ernste

  • Lid
    • Bert Ernste - Utrecht | São Paulo
  • Steunpunt: Nee
Twee versies van Java? En andere Javavragen.
« Gepost op: 2014/03/11, 23:47:58 »
Ik heb ooit via de pakketten van Duinsoft Oracle Java geïnstalleerd op mijn netboek met Ubuntu 12.04. Toen ik Gimp 2.8 installeerde meende ik uit een ooghoek te zien dat die ook Java OpenJDK installeerde.

Kan dat kloppen?
Ik heb geprobeerd het te checken via Synaptic en Software Center, maar kom er niet uit. Ik zie wel dat ik inderdaad OpenJDK Java 6 Runtime, IcedTea Java Pluging en IcedTea Java Web Start heb, het Duinsoft pakket zie ik niet terug, misschien door verkeerd zoeken. Of kan dat door Open JDK verwijderd zijn?

Als beide Javaversies op mijn netbook staan, kunnen die twee Java’s naast elkaar kwaad?

Is een update naar OpenJDK Java 7 Runtime aan te bevelen? Ik neem aan van wel. Moet ik dan eerst 6 verwijderen of gaat dat automatisch?

(Ik weet: Java heeft veiligheidsrisicos’s, maar er zijn buitenlandse banken, die er hun veiligheidsmodule mee laten werken.)
« Laatst bewerkt op: 2014/03/12, 00:04:22 door Bert Ernste »
Bert Ernste (Xubuntu 16.04)
Web | Blog | Diaspora

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Twee versies van Java? En andere Javavragen.
« Reactie #1 Gepost op: 2014/03/12, 08:23:13 »
Kijk hier eens voor Java met uitleg: https://sites.google.com/site/computertip/java en http://wiki.ubuntu-nl.org/community/JavaRuntime

Wat betreft de Duinsoft geïnstalleerde versie van Java, hoe is deze geinstalleerd, met een tar. ?
In der Beschränkung zeigt sich der Meister.

Offline Bert Ernste

  • Lid
    • Bert Ernste - Utrecht | São Paulo
  • Steunpunt: Nee
Re: Twee versies van Java? En andere Javavragen.
« Reactie #2 Gepost op: 2014/03/12, 12:04:44 »
Dank voor de antwoorden.

Citaat
Normaliter hoef je dat pakket van Duisnsoft niet te installeren, je hebt aan de "normale" Java genoeg. Dus de Java OpenJDK.

Ik heb het  Duinsoftpakket hoogstwaarschijnlijk wel nodig. Dat was ook de reden dat ik hem installeerde (door het toevoegen van de repository).

Klopt het dat Gimp 2.8 Open JDK installeert?

Blijft mijn vraag of de twee elkaar bijten en of verwijderen van Open JDK -indien nodig- het functioneren van Gimp nadelig beïnvloedt.
Bert Ernste (Xubuntu 16.04)
Web | Blog | Diaspora

Offline Cheap Applications

  • Lid
  • Steunpunt: Nee
Re: Twee versies van Java? En andere Javavragen.
« Reactie #3 Gepost op: 2014/03/12, 12:13:05 »
Ze bijten niet, het is te vergelijken met een dualboot systeem, je kiest het een of het ander, maar ze vechten verder niet met elkaar.

Toch vraag ik me af, waar denk je Oracle Java voor nodig te hebben? Ik gebruik dagelijks Java en kan me niet meer voorstellen waarom OpenJDK iets niet zou kunnen en Oracle Java wel.
Desktop:
Processor: Intel® Core™2 Quad CPU Q8300 @ 2.50GHz × 4, Geheugen: 3.9Gb, GPU: nVidia 220GT OS: Windows 7 64 bit / Ubuntu 12.04 64 bit
Notebook:
Processor: Intel® Core™ i7-4700MQ, Geheugen: 8Gb, GPU: nVidia GTX765m (met Optimus) OS: Windows 8 64 bit / Elementary OS Luna 64 bit

Offline Bert Ernste

  • Lid
    • Bert Ernste - Utrecht | São Paulo
  • Steunpunt: Nee
Re: Twee versies van Java? En andere Javavragen.
« Reactie #4 Gepost op: 2014/03/12, 12:38:34 »
OK, ik laat de boel voorlopig maar zo staan.

(Volgens fora heb ik het Duinsoftpakket nodig vanwege de veiligheidsmodule van een buitenlandse bank, waar ik een rekening heb. De laatste keer functioneerde hij overigens niet. Elke update geeft problemen. Dat blijft een nadeel van een ‘minderheids-OS’.)
Bert Ernste (Xubuntu 16.04)
Web | Blog | Diaspora