Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [Afgehandeld] blokjes in beeld  (gelezen 1781 keer)

Offline Old man

  • Lid
  • Steunpunt: Nee
[Afgehandeld] blokjes in beeld
« Gepost op: 2014/03/07, 15:09:28 »
Zo af en toe zie ik op mijn notebook blokjes in beeld:

Heeft iemand enig idee waar dit vandaan komt?
Mijn Acer heeft een NVIDIA GeForce GT 710M videokaart
En nu zie ik ik dat er bij de installatie kennelijk iets anders is verondersteld (zie foto)
Moet ik nu naar een andere driver toe?

Mod-edit: Tekst iets minder schreeuwerig gemaakt.
« Laatst bewerkt op: 2014/03/08, 14:56:35 door Old man »
Linux Mint 17.3 met Cinnamon 64 bits -> VirtualBox -> Windows 10 op  Acer Aspire V3 771G.

Offline Old man

  • Lid
  • Steunpunt: Nee
Re: blokjes in beeld
« Reactie #1 Gepost op: 2014/03/07, 15:28:18 »
Dank voor je reactie Femke.
Ja ik had het Stuurprogrammabeheer ook al aangeklikt, maar dan krijg dit plaatje waar ik niets mee kan; de knoppen werken niet.

Linux Mint 17.3 met Cinnamon 64 bits -> VirtualBox -> Windows 10 op  Acer Aspire V3 771G.

Offline Old man

  • Lid
  • Steunpunt: Nee
Re: blokjes in beeld
« Reactie #2 Gepost op: 2014/03/07, 16:41:54 »
Nee, dat betekent dat er geen stuurprogramma's zijn voor je kaart.

Even kijken...je hebt een grafische kaart en je dacht een Nvidia maar dat is het dus niet, begrijp ik.
Het is een Intel en daar zijn dus geen stuurprogramma's voor in jouw geval.

Nee, zo is het niet.
Niet dat ik DENK dat het een nvidia is: het staat op de de notebook: links een sticker Nvidia Geforce 710Mmet daarnaast nog een stickertje NVIDIA Optimus (great battery life, great performance) en rechts deze sticker:
Linux Mint 17.3 met Cinnamon 64 bits -> VirtualBox -> Windows 10 op  Acer Aspire V3 771G.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: blokjes in beeld
« Reactie #3 Gepost op: 2014/03/07, 16:53:45 »
Optimus.... Dat is dus een dubbele videokaart, eentje van Intel en eentje van Nvidia.

Dat los je op met Bumblebee:
https://wiki.ubuntu.com/Bumblebee

Offline Old man

  • Lid
  • Steunpunt: Nee
Re: blokjes in beeld
« Reactie #4 Gepost op: 2014/03/07, 18:46:04 »
Bumblebee uitgevoerd en het lijkt een verbetering. De eerder getoonde internet-pagina geeft nu geen blokjes meer.
Wat wel blijft -maar dat kan ook aan het programma zelf liggen-  is een blokkenpatroon in Google-Earth
Bijvoorbeeld hier in een plaatje van Klein-Curacao (met rechtsonder piepklein de catamaran die daar dagelijks vanuit Curacao naar toe gaat:

Waar de diepzee begint verschijnt een blokkenpatroon.
Linux Mint 17.3 met Cinnamon 64 bits -> VirtualBox -> Windows 10 op  Acer Aspire V3 771G.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: blokjes in beeld
« Reactie #5 Gepost op: 2014/03/07, 18:53:14 »
De bedoeling van Optimus is, dat je standaard het energiezuinige Intel-kaartje gebruikt, en alleen "op afroep" de betere Nvidia-kaart (die meer stroom verbruikt).

De vraag is dus: heb je Google Earth wel gestart met de Nvidia, dus als volgt:
Citaat
Usage

To run your application with the discrete NVIDIA card run in the terminal:

    $ optirun [options] <application> [application-parameters]

Example:

    $ optirun firefox

For a list of options for optirun run:

    $ optirun --help

Normally you do not use optirun for your window manager, installations or other non graphic heavy demanding programs. The optirun command is mainly used for graphic demanding programs or for games.
(Bron: wiki voor Bumblebee)

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: blokjes in beeld
« Reactie #6 Gepost op: 2014/03/07, 20:29:15 »
En je kunt dat ook aan de starter toevoegen als je Alacarte installeert. Dan kun je bij commando 'google-earth' vervangen door 'optirun google-earth'. Dan hoef je niet constant de terminal open te hebben.

Offline niekn

  • Lid
    • omega-xis
  • Steunpunt: Nee
Re: blokjes in beeld
« Reactie #7 Gepost op: 2014/03/07, 20:43:21 »
Er zit ook nog verschil in hoe je de frames van je nvidia naar je Intel stuurt.

Optirun <applicatie> gebruikt virtualgl en een netwerk-brug om de beelden door te geven.

Optirun -b primus <applicatie> plaatst de frames van de nvidia in een framebuffer in t ram geheugen (sneller)

Wat je ook kunt doen is nvidia's eigen optimus support gebruiken, maar die staat nog in de kinderschoenen.
Installeer daarvoor het pakket "prime" (staat in de repo van Ubuntu 13.10, voor 14.04 weet ik t niet)
Wat dit doet Is alles op je nvidia berekenen en de intel-kaart word alleen gebruikt als doorgeefluik.
Deze methode raad ik ten strengste af!! Je nvidia staat dan ten alle tijden aan, trekt je accu leeg en ik heb zelfs verhalen gehoord over oververhitte laptops.... Mijn advies: FF wachten totdat nvidia Dat heeft gerepareerd...

Offline Old man

  • Lid
  • Steunpunt: Nee
Re: blokjes in beeld
« Reactie #8 Gepost op: 2014/03/07, 21:42:44 »
Ik probeer dit, maar waarschijnlijk doe ik iets fout
In de GoogleEarth-starter (waarmee Google-Earth wel start) zie ik het volledige pad. Dat is  /opt/google/earth/free/google-earth %f
Ga ik nu in Terminal en toets in: optirun /opt/google/earth/free/google-earth %f
(zowel met als zonder de parameter %f), dan knippert de cursor even en dat is alles.
Breek ik het proces na verloop van tijd af dan zie ik dit:
Citaat
[10816.688135] [WARN]Could not read data! Error: Bad file descriptor
[10816.688142] [ERROR]Failed to retrieve LibraryPath setting.
Wat doe ik fout?

P.S. Hetzelfde gebeurt bij mij ook met het voorbeeld
optirun firefox
« Laatst bewerkt op: 2014/03/07, 21:47:35 door Old man »
Linux Mint 17.3 met Cinnamon 64 bits -> VirtualBox -> Windows 10 op  Acer Aspire V3 771G.

Offline Old man

  • Lid
  • Steunpunt: Nee
Re: blokjes in beeld
« Reactie #9 Gepost op: 2014/03/08, 10:00:23 »
Hoewel ik het eigenlijk allemaal niet zo belangrijk vindt, kan ik moeilijk verdragen dat het niet werkt. Daarom als een laatste poging dit, de Bumblebee instructies volgend:

Verwijderen
Twee instructies:
    sudo apt-get install ppa-purge

    sudo ppa-purge ppa:bumblebee/stable

Mijn OS is Linuxmint 16 Cinnamon. Daarover staat in de specs
Citaat
Linux Mint 16 features Cinnamon 2.0, MDM 1.4, a Linux kernel 3.11 and an Ubuntu 13.10 package base.

Dit wetend gebruik ik uit Bumblebee aanvullend de code voor Ubuntu 13.10:
sudo apt-get install bumblebee bumblebee-nvidia primus linux-headers-generic
, met dit als resultaat:
Citaat
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
bumblebee is reeds de nieuwste versie.
bumblebee-nvidia is reeds de nieuwste versie.
linux-headers-generic is reeds de nieuwste versie.
primus is reeds de nieuwste versie.
0 pakketten opgewaardeerd, 0 pakketten nieuw geïnstalleerd, 0 te verwijderen en 0 niet opgewaardeerd.

Start ik nu firefox met optirun, dan werkt dat
Google Earth echter geeft een boodschap (zie bijlage) en de volgende reeks meldingen, die mij boven de pet gaan:
Citaat
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
[0308/095235:ERROR:net_util.cc(2195)] Not implemented reached in bool net::HaveOnlyLoopbackAddresses()
[0308/095235:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0308/095235:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0308/095235:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0308/095235:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0308/095235:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0308/095235:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0308/095235:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0308/095235:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0308/095235:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0308/095235:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0308/095235:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0308/095235:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0308/095235:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0308/095235:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0308/095235:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0308/095235:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
Xlib:  extension "NV-GLX" missing on display ":0".
[0308/095242:WARNING:backend_impl.cc(1875)] Destroying invalid entry.
[0308/095242:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0308/095242:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0308/095242:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0308/095242:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
Google Earth has caught signal 11.



We apologize for the inconvenience, but Google Earth has crashed.
 This is a bug in the program, and should never happen under normal
 circumstances. A bug report and debugging data have been written
 to this text file:

    /home/bart/.googleearth/crashlogs/crashlog-531ada5a.txt

Please include this file if you submit a bug report to Google.



Linux Mint 17.3 met Cinnamon 64 bits -> VirtualBox -> Windows 10 op  Acer Aspire V3 771G.

Offline Old man

  • Lid
  • Steunpunt: Nee
Re: blokjes in beeld
« Reactie #10 Gepost op: 2014/03/08, 14:55:35 »
Citaat
  /home/bart/.googleearth/crashlogs/crashlog-531ada5a.txt

Kijk dus eens naar die file en kijk dan eens wat er staat aangegeven in de log.

ps. moet je Google earth dan niet met die andere kaart starten? Dus met de betere Nvidia-kaart
Die vertelt dit:
Citaat
Major Version 7
Minor Version 1
Build Number 0001
Build Date Apr 19 2013
Build Time 19:21:42
OS Type 3
OS Major Version 3
OS Minor Version 11
OS Build Version 0
OS Patch Version 0
Crash Signal 11
Crash Time 1394268762
Up Time 7,3026

Stacktrace from glibc:
./libgoogleearth_free.so(+0x1e826b)[0xf733626b]
./libgoogleearth_free.so(+0x1e84a1)[0xf73364a1]
[0xf7703400]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0x61)[0xf6825761]
./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x1db)[0xf6825b9b]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+0x170)[0xf68256d0]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0x61)[0xf6825761]
./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x1db)[0xf6825b9b]
./libQtGui.so.4(_ZN7QWidget10showNormalEv+0x5c)[0xf68128ac]
./libgoogleearth_free.so(_ZN10MainWindow18readScreensizeInfoEv+0xd66)[0xf730a996]
./libgoogleearth_free.so(_ZN5earth6client11Application12SetupMainWinENS0_3Kvw7ProductEb+0x334)[0xf73d14a4]
./libgoogleearth_free.so(_ZN5earth6client11Application3runEv+0x745)[0xf73d84b5]
./libgoogleearth_free.so(+0x1e7b54)[0xf7335b54]
./libgoogleearth_free.so(earthmain+0x2ec)[0xf7335e6c]
./googleearth-bin[0x804882b]
/lib/i386-linux-gnu/libc.so.6(__libc_start_main+0xf5)[0xf74e8905]

Maar ik laat het hier bij. Dan zou ik alleen voor Google Earth in mijn notebook moeten gaan sleutelen. Als ik dan zo nodig Google Earth moet zien dan pak ik wel even mijn oude desktop.
Maar evenzogoed, bedankt voor de tip.

Bart
Linux Mint 17.3 met Cinnamon 64 bits -> VirtualBox -> Windows 10 op  Acer Aspire V3 771G.