Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: vastlopers door hardware versnelling grafische kaart  (gelezen 2109 keer)

Offline XPijtoptant

  • Lid
  • Steunpunt: Nee
vastlopers door hardware versnelling grafische kaart
« Gepost op: 2014/03/06, 19:52:28 »
Na het installeren van Ubuntu 12.04 LST op mijn desktop PC had ik voortdurend last van (ogenschijnlijke) vastlopers, voornamelijk in Firefox bij scrollen van pagina's.
Op internet gezocht naar de oorzaak, vond ik veel vergelijkbare klachten, maar geen oplossing die bij mij werkt. Uiteindelijk heb ik die min of meer toevallig gevonden. In firefox kan je het scrollen op verschillende manieren instellen in het menu Voorkeuren/tabblad Geavanceerd-Algemeen. Ik heb daar alles uitgevinkt en nu heb ik (tot nu toe) geen vastlopers meer.

En nu de vraag:
Het is waarschijnlijk de hardwareversnelling van de grafische kaart die problemen geeft. Aangezien ik soms ook bij andere programma's hetzelfde probleem heb, vroeg ik mij af of je dit ergens voor de hele PC kan uitschakelen.

In Windows XP (sorry) had ik hardwareversnelling wel aanstaan en gaf dat nooit problemen.

Nog wat relevante bijzonderheden over mijn PC:
Systeemnaam   PENTIUMII
Systeemfabrikant    System manufacturer
Systeemmodel   System Product Name
Systeemtype   Op x86 gebaseerde pc
Processor   x86 Family 6 Model 15 Stepping 6 GenuineIntel ~2401 Mhz
BIOS-versie/datum   American Megatrends Inc. 1202, 27-3-2007
SMBIOS-versie   2.4
Totaal fysiek geheugen   2.048,00 MB

Grafische kaart:
Naam   ASUS X1650 Series
Adaptertype   ATI Radeon Graphics Processor (0x7291), compatibel met ATI Technologies Inc.
Beschrijving   ASUS X1650 Series
RAM-geheugen   256,00 MB (268.435.456 bytes)
PC eigenschappen:
Moederbord: Epox 8K9A
Processor: AMD Athlon 2600
Grafische kaart Gallium 0.4 on ATI RV350

Offline IHC1000

  • Lid
  • Steunpunt: Nee
Re: vastlopers door hardware versnelling grafische kaart
« Reactie #1 Gepost op: 2014/03/06, 20:33:56 »
Dat is wel een oud beestje hoor.

Ik zou xubuntu of lubuntu proberen i.v.m. de hardware specifikaties.

Xubuntu lijkt wel wat op XP ook.

Offline Erik Krom

  • Lid
  • Steunpunt: Nee
Re: vastlopers door hardware versnelling grafische kaart
« Reactie #2 Gepost op: 2014/03/07, 08:11:09 »
Van de processor weet ik niet zeker maar verder lijkt mij dat Ubuntu er prima op moeten kunnen draaien.

De problemen hardware versnelling kunnen aan de grafische drivers liggen.
Vooral ATI schijnt daar wat gevoeliger voor te zijn.
Ik heb zelf verder geen ervaringen met ATI, maar misschien kan iemand anders er verder mee helpen.

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: vastlopers door hardware versnelling grafische kaart
« Reactie #3 Gepost op: 2014/03/07, 14:56:34 »
Wellicht dat Xubuntu/Lubuntu soepeler draait op de oude pc van de TS, zou dat niet de reden van vastlopers moeten zijn. En zeker niet met 2 GB werkgeheugen.

Ikzelf heb ook nog een X1650Pro in één van mijn oude pc's. Waarin Xubuntu Firefox Voorkeuren/tabblad Geavanceerd > Algemeen de optie "Hardwareversnelling gebruiken wanneer beschikbaar" de default instelling is. Dat zou prima moeten voldoen, zolang deze gebruik maakt van de open bron radeon drivers. Dit is te controleren via commando
sudo lshw -c video Of eventueel in het /var/log/Xorg.0.log
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline XPijtoptant

  • Lid
  • Steunpunt: Nee
Re: vastlopers door hardware versnelling grafische kaart
« Reactie #4 Gepost op: 2014/03/07, 22:04:54 »
Het lijkt mij ook onwaarschijnlijk dat het met xubuntu of lubuntu beter zal gaan, want voor zover ik heb kunnen nagaan, onderscheiden die zich alleen van ubuntu door de eenvoudiger GUI.
Ik heb ook geen klagen over de snelheid van ubuntu op mijn PC, ook al is het een oud beestje.

lshw levert geen bruikbare informatie over de drivers, maar in de log kom ik een paar vreemde dingen tegen m.b.t. het niet laden van sommige modules.

Citaat

[    20.508] (II) LoadModule: "fglrx"
[    20.513] (WW) Warning, couldn't open module fglrx
[    20.513] (II) UnloadModule: "fglrx"
[    20.513] (II) Unloading fglrx
[    20.513] (EE) Failed to load module "fglrx" (module does not exist, 0)
[    20.513] (II) LoadModule: "ati"
[    20.513] (II) Loading /usr/lib/xorg/modules/drivers/ati_drv.so
[    20.521] (II) Module ati: vendor="X.Org Foundation"
[    20.521]    compiled for 1.14.5, module version = 7.2.0
[    20.521]    Module class: X.Org Video Driver
[    20.521]    ABI class: X.Org Video Driver, version 14.1
[    20.521] (II) LoadModule: "radeon"
[    20.521] (II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
[    20.538] (II) Module radeon: vendor="X.Org Foundation"
[    20.538]    compiled for 1.14.5, module version = 7.2.0
[    20.538]    Module class: X.Org Video Driver
[    20.538]    ABI class: X.Org Video Driver, version 14.1
[    20.538] (II) LoadModule: "vesa"
[    20.539] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    20.544] (II) Module vesa: vendor="X.Org Foundation"
[    20.544]    compiled for 1.14.5, module version = 2.3.2
[    20.544]    Module class: X.Org Video Driver
[    20.544]    ABI class: X.Org Video Driver, version 14.1
[    20.544] (II) LoadModule: "modesetting"
[    20.544] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    20.551] (II) Module modesetting: vendor="X.Org Foundation"
[    20.551]    compiled for 1.14.5, module version = 0.8.0
[    20.551]    Module class: X.Org Video Driver
[    20.551]    ABI class: X.Org Video Driver, version 14.1
[    20.551] (II) LoadModule: "fbdev"
[    20.551] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    20.560] (II) Module fbdev: vendor="X.Org Foundation"
[    20.560]    compiled for 1.14.5, module version = 0.4.3
[    20.560]    Module class: X.Org Video Driver
[    20.560]    ABI class: X.Org Video Driver, version 14.1
[    20.560] (==) Matched fglrx as autoconfigured driver 0
[    20.560] (==) Matched ati as autoconfigured driver 1
[    20.560] (==) Matched fglrx as autoconfigured driver 2
[    20.560] (==) Matched ati as autoconfigured driver 3
[    20.560] (==) Matched vesa as autoconfigured driver 4
[    20.560] (==) Matched modesetting as autoconfigured driver 5
[    20.560] (==) Matched fbdev as autoconfigured driver 6
[    20.560] (==) Assigned the driver to the xf86ConfigLayout
[    20.560] (II) LoadModule: "fglrx"
[    20.561] (WW) Warning, couldn't open module fglrx
[    20.561] (II) UnloadModule: "fglrx"
[    20.561] (II) Unloading fglrx
[    20.561] (EE) Failed to load module "fglrx" (module does not exist, 0)
[    20.561] (II) LoadModule: "ati"
[    20.561] (II) Loading /usr/lib/xorg/modules/drivers/ati_drv.so
[    20.561] (II) Module ati: vendor="X.Org Foundation"
[    20.561]    compiled for 1.14.5, module version = 7.2.0
[    20.561]    Module class: X.Org Video Driver
[    20.561]    ABI class: X.Org Video Driver, version 14.1
[    20.561] (II) LoadModule: "vesa"
[    20.561] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    20.561] (II) Module vesa: vendor="X.Org Foundation"
[    20.561]    compiled for 1.14.5, module version = 2.3.2
[    20.561]    Module class: X.Org Video Driver
[    20.561]    ABI class: X.Org Video Driver, version 14.1
[    20.561] (II) UnloadModule: "vesa"
[    20.561] (II) Unloading vesa
[    20.562] (II) Failed to load module "vesa" (already loaded, 0)
[    20.562] (II) LoadModule: "modesetting"
[    20.562] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    20.562] (II) Module modesetting: vendor="X.Org Foundation"
[    20.562]    compiled for 1.14.5, module version = 0.8.0
[    20.562]    Module class: X.Org Video Driver
[    20.562]    ABI class: X.Org Video Driver, version 14.1
[    20.562] (II) UnloadModule: "modesetting"
[    20.562] (II) Unloading modesetting
[    20.562] (II) Failed to load module "modesetting" (already loaded, 0)
[    20.562] (II) LoadModule: "fbdev"
[    20.562] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    20.562] (II) Module fbdev: vendor="X.Org Foundation"
[    20.562]    compiled for 1.14.5, module version = 0.4.3
[    20.562]    Module class: X.Org Video Driver
[    20.562]    ABI class: X.Org Video Driver, version 14.1
[    20.562] (II) UnloadModule: "fbdev"
[    20.562] (II) Unloading fbdev
[    20.562] (II) Failed to load module "fbdev" (already loaded, 0)
[    20.562] (II) RADEON: Driver for ATI Radeon chipsets:


Daarna volgt een hele lijst met ondersteunde videokaarten, waaronder de X1650.
Vervolgens geen foutmeldingen meer.

Ik kan hier zelf verder niet veel mee, omdat ik nog niet zo veel weet van Linux/Ubuntu.
Ik weet alleen dat ik geen extra drivers heb gedownload, dus de kaart doet het met wat bij de oorspronkelijke installatie is meegekomen (vorige week gedownload) en de updates daarna.

Blijft nog steeds de vraag of ik ergens centraal de hardwareversnelling uit kan schakelen. Alhoewel het na het instellen in Firefox nog maar 1 keer weer fout is gegaan.

PC eigenschappen:
Moederbord: Epox 8K9A
Processor: AMD Athlon 2600
Grafische kaart Gallium 0.4 on ATI RV350

Offline Paul Matthijsse

  • Lid
  • Steunpunt: Nee
Re: vastlopers door hardware versnelling grafische kaart
« Reactie #5 Gepost op: 2014/03/07, 22:22:04 »
Hallo, het lijkt er op dat je een probleem met de grafische afdeling hebt. Je log zegt dat de module fglrx niet aanwezig is. Kijk eens wat er gebeurt als je die installeert (bv. via Synaptic als je dat hebt, anders Softwarecenter, anders apt-get in een terminal). ATI en Linux gaan niet altijd prettig samen, met Nvidia heb je meer kans op een probleemloze samenwerking, als ik alle forumberichten goed begrepen heb.
https://allesgimpofbijna.wordpress.com - GIMP en omstreken
https://paulsphotopalace.wordpress.com (Engelstalig) - Raw, RawTherapee, G'MIC, GIMP...

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: vastlopers door hardware versnelling grafische kaart
« Reactie #6 Gepost op: 2014/03/08, 09:21:10 »
Voor de ASUS X1650 Series is het probleem niet op te lossen met fglrx drivers. Want die worden niet geleverd door ATI/AMD voor Ubuntu 12.04. De nieuwste fglrx drivers voor een ASUS X1650 is Revision Number 9.3. Ik weet uit ervaring met mijn eigen X1650Pro dat deze te installeren is, tot en met Ubuntu 10.04. Voor Ubuntu 12.04 zijn er geen fglrx drivers te installeren, die een X1650 ondersteunen.

De beste drivers die voor een X1650 kunt draaien, is de open bron radeon driver.

Of deze goed draait, kan gecontroleerd worden met het volgende commando
dmesg | grep radeon Dit is als voorbeeld deze output op de pc met die X1650Pro

[   11.623320] [drm] radeon defaulting to kernel modesetting.
[   11.623334] [drm] radeon kernel modesetting enabled.
[   11.623633] radeon 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[   11.664496] radeon 0000:01:00.0: putting AGP V2 device into 4x mode
[   11.664519] radeon 0000:01:00.0: GTT: 128M 0xF0000000 - 0xF7FFFFFF
[   11.664546] radeon 0000:01:00.0: VRAM: 256M 0x0000000000000000 - 0x000000000FFFFFFF (256M used)
[   11.675255] [drm] radeon: 256M of VRAM memory ready
[   11.675264] [drm] radeon: 128M of GTT memory ready.
[   11.703130] [drm] radeon: 1 quad pipes, 2 z pipes initialized.
[   11.745513] radeon 0000:01:00.0: WB disabled
[   11.745645] [drm] radeon: irq initialized.
[   14.196731] [drm] radeon: ring at 0x00000000F0001000
[   14.197490] [drm] radeon: ib pool ready.
[   14.564631] fbcon: radeondrmfb (fb0) is primary device
[   14.668302] fb0: radeondrmfb frame buffer device
[   14.668409] [drm] Initialized radeon 2.12.0 20080528 for 0000:01:00.0 on minor 0

Het uitschakelen van hardwareversnelling/hardware acceleration voor de radeon driver zou kunnen, via het /etc/X11/xorg.conf bestand, zoals te lezen is in de manpages van radeon. Ik heb het dus over deze option
Citaat
Option "NoAccel" "boolean"
              Enables or disables all hardware acceleration.
              The default is to enable hardware acceleration.


Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline XPijtoptant

  • Lid
  • Steunpunt: Nee
Re: vastlopers door hardware versnelling grafische kaart
« Reactie #7 Gepost op: 2014/03/08, 20:06:38 »
@jolo:
Ik had gisteravond ook al even gekeken naar nieuwere fglrx drivers maar kwam er achter dat dat niet de oplossing is.
Die open bron Radeon driver geeft hoop. Bij de ondersteunde kaarten staat mijn type RV560 Radeon X1650 XT bij de ondersteunde kaarten.
Ik ga daarmee aan de slag. Ik zie dat ik eerst de oude drivers moet de-installeren.  Zo te zien, kan dat niet met één muisklik. Lijkt wel terug naar MS-DOS ;-)

Bedankt alvast. Ik laat nog wel weten of het gelukt is.

 

PC eigenschappen:
Moederbord: Epox 8K9A
Processor: AMD Athlon 2600
Grafische kaart Gallium 0.4 on ATI RV350

Offline DeBaas

  • Lid
  • Steunpunt: Ja
Re: vastlopers door hardware versnelling grafische kaart
« Reactie #8 Gepost op: 2014/03/08, 21:47:42 »
Citaat
20.561] (EE) Failed to load module "fglrx" (module does not exist, 0)
Kaart is van omstreeks oktober 2006

Je hebt, indien aanwezig, oudere fglrx drivers nodig, compleet met bijbehorende X11 ondersteuning

Deze zitten standaard niet meer in de repo en is waarschijnlijk niet compatibel met de huidige kernel.
Dat wordt behelpen met een van de aanwezige legacy en opensource drivers.
Zorg dat alle sporen van fglrx en amdcccle worden verwijderd.

Mogelijk zet de installatie van xserver-xorg-video-radeon je op het goede spoor.
Ik beantwoord GEEN hulpvragen via PB en/of MAIL

Offline XPijtoptant

  • Lid
  • Steunpunt: Nee
Re: vastlopers door hardware versnelling grafische kaart
« Reactie #9 Gepost op: 2014/03/28, 22:06:24 »
Het is even stil geweest in dit topic, maar ik denk dat ik de oorzaak nu heb gevonden.

De open bron Radeon driver kreeg ik niet geïnstalleerd. Na downloaden en uitpakken van de files is het mij niet duidelijk, hoe ik de driver moet installeren. Uiteindelijk heb ik dan toch maar Windows 7 gekocht, ook omdat ik erg gehecht ben aan Paintshop (heb zelf veel macro's er voor gemaakt) en onder Linux geen vergelijkbaar pakket kon vinden.
Nu heb ik in Windows 7 ook beeldschermstoringen, alleen kan het besturingssysteem de storing af en toe opvangen en de PC herstellen.
Vandaag even terug gegaan naar Windows XP en daar nu ook uitvallen van de beeldschermen. Dus vermoedelijk is mijn  grafische kaart kapot aan het gaan. Iets anders kan het niet zijn, want de PC heeft de op dat moment lopende back-up gewoon afgemaakt.

Wel toevallig dat het samenviel met het installeren van Ubuntu. Tenzij Ubuntu de oorzaak is van het defect. Maar dat lijkt mij onwaarschijnlijk.

Mijn ervaringen met Ubuntu zijn echter niet vergeefs. Op een oude laptop (IBM T46) en een andere, nog oudere PC met een AMD Athlon 2600, draait Ubuntu zonder problemen. Spaart toch de aanschaf van 2 Windows licenties uit.

« Laatst bewerkt op: 2014/03/28, 22:09:03 door XPijtoptant »
PC eigenschappen:
Moederbord: Epox 8K9A
Processor: AMD Athlon 2600
Grafische kaart Gallium 0.4 on ATI RV350

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: vastlopers door hardware versnelling grafische kaart
« Reactie #10 Gepost op: 2014/03/29, 15:34:26 »
De open bron Radeon driver hoef je niet te installeren. Want die wordt al meegeleverd op de Ubuntu installatie dvd. Het gedeelte van je geposte /var/log/Xorg.0.log geeft de indruk, dat je open bron Radeon driver al draait. Ofschoon er dan ook in je sudo lshw -c video output, de tekst driver=radeon behoort te staan.

Één van de Paintshop alternatieven is Gimp.

Het is inderdaad nier erg waarschijnlijk, dat de videokaart door Ubuntu is beschadigd. Draait de ventilator van die ASUS X1650 Series nog wel? Wordt/werd deze wellicht te warm? Werkt de pc dan nog wel goed, met een andere vergelijkbare videokaart? Of als je moederbord dat heeft, een onboard videokaart.

Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline midas

  • Lid
  • Steunpunt: Nee
Re: vastlopers door hardware versnelling grafische kaart
« Reactie #11 Gepost op: 2014/03/30, 11:25:06 »
Ik draai ook met een oudere ATI-kaart die niet meer ondersteund wordt met een fgrlx-driver. In het algemeen gaat het met de opensource-driver erg goed alleen wordt de laptop soms wat warmer bij afspelen (volbeeld) van Youtube en je kunt bijvoorbeeld GoogleEarth niet draaien. Ik heb ook de ervaring dat je hardware-versnelling het best in browser en LibreOffice kunt uitschakelen.

Ook desktop-effecten zoveel mogelijk uitschakelen scheelt in jouw geval veel. Of kies een versie zoals Lubuntu, Xubuntu, of Mint met Mate zou een goede vervanger zijn. Deze versies kennen niet of nauwelijks desktop-effecten.
Ubuntu 16.04 Mate (64-bits)

Offline DeBaas

  • Lid
  • Steunpunt: Ja
Re: vastlopers door hardware versnelling grafische kaart
« Reactie #12 Gepost op: 2014/03/30, 11:32:40 »
In dit topic is het probleem met oudere ATI (fglrx legacy), met verwijzingen hoe te gebruiken onder 12.04 ZONDER . (punt) versie, beschreven.

http://ubuntuforums.org/showthread.php?t=2181190

Andere distro's hebben dat op hun eigen min of meer elegante wijze opgelost.
« Laatst bewerkt op: 2014/03/30, 11:40:21 door DeBaas »
Ik beantwoord GEEN hulpvragen via PB en/of MAIL

Offline DeBaas

  • Lid
  • Steunpunt: Ja
Re: vastlopers door hardware versnelling grafische kaart
« Reactie #13 Gepost op: 2014/03/30, 11:35:05 »
Sorry dubbel
« Laatst bewerkt op: 2014/03/30, 11:38:34 door DeBaas »
Ik beantwoord GEEN hulpvragen via PB en/of MAIL

Offline DeBaas

  • Lid
  • Steunpunt: Ja
Re: vastlopers door hardware versnelling grafische kaart
« Reactie #14 Gepost op: 2014/03/30, 11:37:23 »
Sorry dubbel
Ik beantwoord GEEN hulpvragen via PB en/of MAIL