Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: stecnyl 3.x installeren  (gelezen 472 keer)

Offline thelowlander

  • Lid
    • Mijn blog
  • Steunpunt: Nee
stecnyl 3.x installeren
« Gepost op: 2014/03/03, 16:39:20 »
Hey, poos geleden alweer.
Ik probeer momenteel Stencyl te "installeren"
http://www.stencyl.com/

Van installeren is niet echt sprake omdat je het gewoon download, uitpakt en vanuit een mapje runt.... Althans, zo zou het moeten zijn.
Als ik dat doe is er een bestandje dat Stencyl heet, en als ik dat probeer te openen wordt het met gedit geopend. Er staat het volgende in:
Citaat
#!/bin/bash

./runtimes/jre-linux/bin/java -Xms64m -Xmx1024m -Djava.library.path=./lib -Djava.library.path=./lib -Dswing.defaultlaf=javax.swing.plaf.metal.MetalLookAndFeel -jar ./sw.jar

Als ik het probeer te openen door het in de terminal te slepen krijg ik de volgende foutmelding:
Citaat
line 3: ./runtimes/jre-linux/bin/java: No such file or directory

Schijnbaar heeft het te maken met de versie van java, en ik heb nu verschillende java pakketten geinstalleerd via synaptic, maar dat helpt niet.

Heeft iemand een idee hoe ik Stencyl 3.x aan de praat kan krijgen?

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: stecnyl 3.x installeren
« Reactie #1 Gepost op: 2014/03/03, 19:15:32 »
Dat opstartscript is niet zo slim om eerst naar de goede map te gaan waar al zijn bestanden staan.
Het script slepen naar een terminal zal dus voor problemen zorgen. Dit heeft niets te maken met de versie van Java.

Hoe je dit programma wél kan starten:
Open een terminalvenster en ga met cd pad/naar/stencyl eerst naar de juiste map.
Hierna voer je ./Stencyl uit.

Als alternatief kan je ook het Stencyl bestandje even bewerken.
Voeg dit toe op de 2e regel:
cd "$(dirname "$0")"

Hierna kan je hem wel naar een terminal slepen.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: stecnyl 3.x installeren
« Reactie #2 Gepost op: 2014/03/03, 20:43:43 »
Ik heb Stencyl ook geinstalleerd en de zelfde fout. Op internet deze oplossing gevonden:
Here, try this:
sudo apt-get install -y libxtst6:i386 libXext6:i386 libxi6:i386 libncurses5:i386 libxt6:i386 libxpm4:i386 libxmu6:i386 libxp6:i386
Deze heb ik toegepast en Stencyl werkt

en dit antwoord stond eronder:
Don't go and start installing a bunch of 32bit packages. Uninstall wakfu from the Software Center. Then download the new 64bit updater from here.

That should solve your problem. Heb ik niet geprobeerd.

Van http://www.wakfu.com/en/forum/36-technical-issues/138311-ubuntu-13-10-game-does-not-launch


In der Beschränkung zeigt sich der Meister.

Offline thelowlander

  • Lid
    • Mijn blog
  • Steunpunt: Nee
Re: stecnyl 3.x installeren
« Reactie #3 Gepost op: 2014/03/05, 14:14:22 »
Helaas Johan, allebei de methodes geprobeerd, maar geen resultaat.
Er gebeurd gewoon niks, de terminal gaat gewoon een lijn verder en ik kan weer vrolijk verdertypen in mijn terminal alsof ik nooit een opdracht gegeven had.
Citaat
lowlander@lowlander-K46CM:~$ '/home/lowlander/stencyl/Stencyl'
lowlander@lowlander-K46CM:~$

Ik heb ergens een oplossing gevonden dat je het script moest veranderen in:
Citaat
#!/bin/bash

java -Xms64m -Xmx1024m -Djava.library.path=./lib -jar ./sw.jar
Maar dat helpt ook niet. Dan krijg ik de volgende foutmelding:
Citaat
Error: Unable to access jarfile ./sw.jar

Ook heb ik jouw oplossing geprobeerd Gijsbert, hoewel dat niet eens over stencyl gaat maar over een of ander spel. Ook geen resultaat.

openjdk-7-jre en andere openjdk-7-jre-blahblah bestanden zijn geinstalleerd. Java-package (de officiele van oracle) is echter ook geinstalleerd.
Kan ik Java op een of andere manier resetten? zou dat verschil kunnen maken?

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: stecnyl 3.x installeren
« Reactie #4 Gepost op: 2014/03/05, 14:38:13 »
Probeer eens de twee ingrepen die hier beschreven zijn: http://www.ducky-pond.com/posts/2013/Aug/install-stencyl-on-ubuntu/ Vooral het installeren van ia32-libs is wellicht nodig om het programma in eerste instantie aan de gang te krijgen. De tweede ingreep is enkel vereist om te kunnen updaten.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: stecnyl 3.x installeren
« Reactie #5 Gepost op: 2014/03/05, 21:35:47 »
In 13.10 zit ia32 niet meer, dat is te vervangen door:
sudo apt-get install -y libxtst6:i386 libXext6:i386 libxi6:i386 libncurses5:i386 libxt6:i386 libxpm4:i386 libxmu6:i386 libxp6:i386

@ thelowlander, ik ben op deze link gekomen via een andere link. Na installatie hiervan en de computer opnieuw op te starten lukte het wel om Stencyl te starten. Navigeer met de terminal naar de map waar je stencyl hebt uitgepakt en type in de terminal:
./Stencyl en geef een ENTER. Let op de punt voor de / het is een hoofdletter S en zorg dat het bestand uitvoerbaar is.
Dan moet het lukken. Het bestandje verwijst nl. naar mappen binnen Stencyl.
#!/bin/bash

./runtimes/jre-linux/bin/java -Xms64m -Xmx1024m -Djava.library.path=./lib -Djava.library.path=./lib -Dswing.defaultlaf=javax.swing.plaf.metal.MetalLookAndFeel -jar ./sw.jar

En zo ziet het eruit:

« Laatst bewerkt op: 2014/03/05, 21:41:48 door Gijsbert »
In der Beschränkung zeigt sich der Meister.

Offline thelowlander

  • Lid
    • Mijn blog
  • Steunpunt: Nee
Re: stecnyl 3.x installeren
« Reactie #6 Gepost op: 2014/03/08, 02:41:00 »
Helaas, werkt nog altijd niet. Ik zit op 13.04 en ben eigenlijk niet van plan om naar 13.10 te gaan. Ik heb dat eerder gedaan met 9.04-9.10, en 10.04-10.10 zwaar gecrashed en bestanden kwijt, dus om een of andere reden blijf ik meestal vd .10 versies af. Binnenkort is 14.04 LTS uit, en dan doe ik gewoon een complete schone herinstall.

als ik de suggestie van Gijsbert probeer:
Citaat
sudo apt-get install -y libxtst6:i386 libXext6:i386 libxi6:i386 libncurses5:i386 libxt6:i386 libxpm4:i386 libxmu6:i386 libxp6:i386
dan wordt alles geinstalleerd behalve libxmu6
Citaat
After this operation, 300 kB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  libxmu6
E: There are problems and -y was used without --force-yes

Vanadium, helaas. ia32libs werkt ook niet:
Citaat
lowlander@lowlander-K46CM:~$ sudo apt-get install ia32-libs
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ia32-libs : Depends: ia32-libs-multiarch
E: Unable to correct problems, you have held broken packages.

ik heb ook geprobeerd om de multiarch te installeren, omdat ia32libs daarop depend
Citaat
lowlander@lowlander-K46CM:~$ sudo apt-get install ia32-libs-multiarch
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ia32-libs-multiarch:i386 : Depends: libqt4-qt3support:i386 but it is not going to be installed
                            Depends: libqt4-scripttools:i386 but it is not going to be installed
                            Depends: libqt4-svg:i386 but it is not going to be installed
                            Depends: libqt4-test:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
lowlander@lowlander-K46CM:~$

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: stecnyl 3.x installeren
« Reactie #7 Gepost op: 2014/03/08, 08:47:54 »
@thelowlander, de laatste regel geeft deze foutmelding E: Unable to correct problems, you have held broken packages.
Open een terminal en kopieer en plak deze regel in de terminal:
sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade

en geef een ENTER, ww intypen en geef een ENTER.
Helpt dit niet, zet dan eventuele backports in de softwarebronnen uit en herhaal het commando.
Gevolgd door deze commando's:
sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade
In der Beschränkung zeigt sich der Meister.