Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: slocate broken  (gelezen 2261 keer)

Offline bwog

  • Lid
  • Steunpunt: Nee
slocate broken
« Gepost op: 2007/03/16, 18:57:00 »
Ik probeer te upgraden van 6.06 naar 6.10 met
gksu "update-manager -c". De upgrade-manager wilde niet upgraden want ik moest eerst een ubuntu-desktop installeren, bijna 800 packages, 1.5 GB!

1 van die packages, slocate, is stuk of kan niet geinstalleerd worden.

Synaptic:

E: /var/cache/apt/archives/slocate_3.0.beta.r3-1ubuntu0.1_i386.deb: subprocess pre-installation script returned error exit status 2

Dit verhinderd de upgrade.

Offline Kiwinote

  • Lid
    • Launchpad
  • Steunpunt: Nee
slocate broken
« Reactie #1 Gepost op: 2007/03/16, 19:03:36 »
Schone installatie kan wonderen doen.

Offline bwog

  • Lid
  • Steunpunt: Nee
slocate broken
« Reactie #2 Gepost op: 2007/03/16, 19:14:30 »
Opnieuw installeren lijkt me een nogal drastische methode als er slechts 1 pakketje stuk is.

Guus

  • Gast
slocate broken
« Reactie #3 Gepost op: 2007/03/16, 19:36:56 »
ik ben het eens met Kiwinote

een schone installatie is vaker stabliere dan een upgrade

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
slocate broken
« Reactie #4 Gepost op: 2007/03/16, 19:38:25 »
Weet je zeker dat je van Dapper naar Edgy aan het upgraden bent?
Citaat
/var/cache/apt/archives/slocate_3.0.beta.r3-1ubuntu0.1_i386.deb
Ik zie hier een beta-pakketje staan, die volgens mij helemaal niet in Edgy zit :o

Plaats eerst de oude sources.list van Dapper eens terug.
Doe daarna apt-get update
Als je dan ubuntu-desktop installeert, zou je wel de goede versies binnen moeten krijgen.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
slocate broken
« Reactie #5 Gepost op: 2007/03/16, 19:38:56 »
Citaat van: Guus
ik ben het eens met Kiwinote

een schone installatie is vaker stabieler dan een upgrade
........ bij elk besturingssysteem onder de zon!

Offline bwog

  • Lid
  • Steunpunt: Nee
slocate broken
« Reactie #6 Gepost op: 2007/03/16, 19:40:09 »
A new slocate vulnerability update is available for Ubuntu:

http://www.linuxcompatible.org/USN-425-1_slocate_vulnerability_s82096.html

The problem can be corrected by upgrading your system to the
following package versions:

Ubuntu 6.06 LTS:
slocate 3.0.beta.r3-1ubuntu0.1

Ubuntu 6.10:
slocate 3.1-1ubuntu0.1

In general, a standard system upgrade is sufficient to effect the
necessary changes.

Dat lukt nu juist niet, maar ik zoek nog verder.

Offline bwog

  • Lid
  • Steunpunt: Nee
slocate broken
« Reactie #7 Gepost op: 2007/03/16, 19:44:40 »
@Johanvd: Ik probeer van 6.06 naar 6.10 te upgraden, niet vanuit dapper. Voordat ik kan upgraden moet slocate gefixt worden.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
slocate broken
« Reactie #8 Gepost op: 2007/03/16, 20:19:16 »
6.06 IS Dapper
6.10 is Edgy.

Offline bwog

  • Lid
  • Steunpunt: Nee
slocate broken
« Reactie #9 Gepost op: 2007/03/16, 20:37:21 »
@Johanvd: klopt, ik heb Ubuntu 6.06 LTS - the Dapper Drake.

De oplossing van de bug is van 22-02-07, dus je zou verwachten dat het nieuwe pakketje al in de repositories zit. Bijzonder aan mijn situatie is wel dat ik ongeveer 9 maanden niet met ubuntu gewerkt heb en dus ook niet ge-update. Zou niet mogen uitmaken, maar ja.

Ik heb nog geen manier gevonden om slocate te fixen.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
slocate broken
« Reactie #10 Gepost op: 2007/03/16, 20:44:13 »
Als ik jou was, zou ik gewoon bij 6.06 blijven, en over een maandje overstappen op Feisty. Beter nog, over twee maanden, als de eerste reeks updates van Feisty is uitgebracht.

En dan met een schone installatie, met formatteren en al. Opwaarderen is op zijn best vuil (er blijft altijd een hoop troep achter) en op zijn slechtst veroorzaakt het storingen. Bij elk denkbaar besturingssysteem.

Kortom: sla Edgy gewoon over.....

Offline bwog

  • Lid
  • Steunpunt: Nee
slocate broken
« Reactie #11 Gepost op: 2007/03/16, 22:00:36 »
Mischien kan iemand wat met de output van sudo apt-get install -f :

Reading package lists... Done
Building dependency tree... Done
Correcting dependencies... Done
The following extra packages will be installed:
  slocate
The following NEW packages will be installed:
  slocate
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
Need to get 0B/30.4kB of archives.
After unpacking 156kB of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 65006 files and directories currently installed.)
Unpacking slocate (from .../slocate_3.0.beta.r3-1ubuntu0.1_i386.deb) ...
Removing `diversion of /etc/cron.daily/find to /etc/cron.daily/find.notslocate b y slocate'
dpkg-divert: rename involves overwriting `/etc/cron.daily/find' with
  different file `/etc/cron.daily/find.notslocate', not allowed
dpkg: error processing /var/cache/apt/archives/slocate_3.0.beta.r3-1ubuntu0.1_i3 86.deb (--unpack):
 subprocess pre-installation script returned error exit status 2
Errors were encountered while processing:
 /var/cache/apt/archives/slocate_3.0.beta.r3-1ubuntu0.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Offline kel_p

  • Lid
    • www.labordusjes.nl
  • Steunpunt: Nee
slocate broken
« Reactie #12 Gepost op: 2007/03/16, 22:06:50 »
Probeer dit 's

sudo rm /etc/cron.daily/find
sudo dpkg-divert --rename --remove /etc/cron.daily/find
Hardware: Asus P5QC, Intel Core 2 Quad Q8200, 4Gb DDR3, 3x1Tb HD, GeForce 9500 GT
Powered by: Arch(64)

http://ubuntuforums.org/member.php?u=44758
http://www.labordusjes.nl

Offline bwog

  • Lid
  • Steunpunt: Nee
slocate broken
« Reactie #13 Gepost op: 2007/03/16, 22:35:18 »
Bedankt kel_p, dat werkte goed.

Ik heb a.d.h. van jouw post zelfs een paar oude posts gevonden met precies hetzelfde probleem, die ik via zoeken op slocate nog niet tegengekomen was.

Wellicht zijn niet alle problemen voorbij: omdat hplip niet geconfigureerd is, kan ubuntu-desktop ook niet geconfigureerd worden. Maar dat probleem moet tot morgen wachten.

Ik vind herinstallatie overigens echt het allerlaatste redmiddel, ook al was ik dan een stuk sneller klaar geweest.

Offline kel_p

  • Lid
    • www.labordusjes.nl
  • Steunpunt: Nee
slocate broken
« Reactie #14 Gepost op: 2007/03/16, 22:46:28 »
Maar ja, nu hebt je daadwerkelijk iets geleert toch? ;-)
Hardware: Asus P5QC, Intel Core 2 Quad Q8200, 4Gb DDR3, 3x1Tb HD, GeForce 9500 GT
Powered by: Arch(64)

http://ubuntuforums.org/member.php?u=44758
http://www.labordusjes.nl

Offline bwog

  • Lid
  • Steunpunt: Nee
slocate broken
« Reactie #15 Gepost op: 2007/03/16, 22:57:01 »
Inderdaad, dat is wat ik bedoel.

Overigens was ik in dit specifieke geval vooral blij dat er een werkende oplossing was, maar dat had je waarschijnlijk wel door :-)