Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Partitie 'data' (Data on Toshiba) is niet toegankelijk vanuit het netwerk  (gelezen 1430 keer)

Offline molly w

  • Lid
Data on Toshiba is vanuit netwerk niet toegankelijk: "mogelijk geen rechten".
Bestanden kopiëren of verplaatsen vanuit netwerk naar deze locatie is niet mogelijk.
Ter info: het netwerk bestaat naast de Toshiba waarop Linux Mint 13 LTS Mate 32 bit staat, uit een pc (winXP), een NAS en een laptop met Win7.
De eigenaar van Data on Toshiba is 'root' en de groep is 'plugdev', althans volgens File System --> mnt.
Toegang en rechten en groep wijzigen zijn niet mogelijk, want root is de eigenaar. Hoe word ik eigenaar??

Offline Anco

  • Lid
  • Steunpunt: Nee
Door nautilus als root te draaien kan je makkelijk de eigenaar wisselen. (dit kan natuurlijk ook via terminal maar daar weet wat minder van af).  Om nautilus als root te starten typ je gewoon  "sudo nautilus" in terminal.
Linux user #485563


Offline molly w

  • Lid
Door nautilus als root te draaien kan je makkelijk de eigenaar wisselen. (dit kan natuurlijk ook via terminal maar daar weet wat minder van af).  Om nautilus als root te starten typ je gewoon  "sudo nautilus" in terminal.

Helaas, het lukt niet. In Terminla type ik 'sudo nautilus', wachtwoord invullen en dan komt nautilus. Maar ik kan noch de eigenaar noch groep noch bestandstoegangen wijzigen. Is niet toegestaan.
Misschien lukt het via het Grubmenu met rootrechten aan de slag te gaan.

Offline molly w

  • Lid
Door nautilus als root te draaien kan je makkelijk de eigenaar wisselen. (dit kan natuurlijk ook via terminal maar daar weet wat minder van af).  Om nautilus als root te starten typ je gewoon  "sudo nautilus" in terminal.

Helaas, het lukt niet. In Terminla type ik 'sudo nautilus', wachtwoord invullen en dan komt nautilus. Maar ik kan noch de eigenaar noch groep noch bestandstoegangen wijzigen. Is niet toegestaan.
Misschien lukt het via het Grubmenu met rootrechten aan de slag te gaan.

Van een ander forum kreeg ik de tip het commando 'su' te gebruiken in plaats van 'sudo'. Maar ook dit werkt niet.

Offline molly w

  • Lid
Het probleem met de partitie Data is nog niet opgelost. Is wel belangrijk omdat straks als XP vogelvrij is, ik Linux op mijn hoofdpc wil gebruiken. Daarin zit een 2e hard schijf met alle data, en die wil ik benaderbaar houden vanaf een laptop met windows 7.
Daarom deze uitdaging om op mijn proeflaptop partitie Data benaderbaar te krijgen vanuit een windowssysteem.
Het is nu zo: als ik de laptop opstart met Windows, is Data toegankelijk voor een ander windowssysteem. Als ik de laptop opstart met Linux, wordt de toegang tot Data vanuit een windowssyteem geweigerd.
De eigenschappen van mnt/data zeggen dat root eigenaar is. Dat krijg ik maar niet veranderd, ook in Terminal met sudo chown enz. lukt niet: deze bewerking wordt niet toegestaan. Googelend kwam ik terecht op http://forum.nedlinux.nl/viewtopic.php?id=25446. Daarin wedr als oorzaak geopperd dat het feit dat een partitie in FAT32 is ingedeeld, wel eens de oorzaak kon zijn. Data is inderdaad FAT32. (Gparted noemt het vfat).
Zou het helpen als ik de indeling verander in NTFS? (want Data moet natuurlijk wel leesbaar blijven voor Windows. Alle partities en schijven van mijn hoofdpc zijn in NTFS)
En hoe doe ik dat? Of is een Linux format beter? En is dat leesbaar voor Windows?

Offline molly w

  • Lid
Ik wilde al vragen wat de extensie was van Data, maar nu lees ik dat het FT32 is.
Beter is om het NTFS te zetten, dan kan het ook door Linux gelezen worden.Let wel: ext4 is voor Linux, maar kan niet door Windows gelezen worden.

Mijn Linuxmap 'documenten' kan heel goed door windows geopend worden; de bestanden zijn door XP te lezen. Dus dat begrijp ik niet helemaal.

Citaat
NTFS is voor Windows, maar kan ook door Linux gelezen worden.
FAT32 is trouwens niet handig indien je zaken hebt die groter dan 4 GB. zijn. Zoals films of zo, dat gaat niet werken.

Ik heb intussen gekeken of ik de rechten van de partitie Windows (heb ik naast Linux staan) kon wijzigen. Dat is een NTSF-partitie. Noppes! Ik open nautilus als administrator (in ik doe sudo nautilus), ik kies uit het lijstje eigenaar van de map Windows (mnt/windows) mijn naam, maar zo gauw ik naar een volgend veld ga, springt eigenaar weer terug naar root. Het is om hopeloos ervan te worden.
De partitie data omzetten van FAT32 naar NTSF biedt dus geen oplossing.

Offline molly w

  • Lid
Ik wilde al vragen wat de extensie was van Data, maar nu lees ik dat het FT32 is.
Beter is om het NTFS te zetten, dan kan het ook door Linux gelezen worden.Let wel: ext4 is voor Linux, maar kan niet door Windows gelezen worden.

Mijn Linuxmap 'documenten' kan heel goed door windows geopend worden; de bestanden zijn door XP te lezen. Dus dat begrijp ik niet helemaal.

Citaat
NTFS is voor Windows, maar kan ook door Linux gelezen worden.
FAT32 is trouwens niet handig indien je zaken hebt die groter dan 4 GB. zijn. Zoals films of zo, dat gaat niet werken.

Ik heb intussen gekeken of ik de rechten van de partitie Windows (heb ik naast Linux staan) kon wijzigen. Dat is een NTSF-partitie. Noppes! Ik open nautilus als administrator (in ik doe sudo nautilus), ik kies uit het lijstje eigenaar van de map Windows (mnt/windows) mijn naam, maar zo gauw ik naar een volgend veld ga, springt eigenaar weer terug naar root. Het is om hopeloos ervan te worden.
De partitie data omzetten van FAT32 naar NTSF biedt dus geen oplossing.

Mag ik vragen welke extensie je Linux heeft? (want ik lees het volgende: Alle partities en schijven van mijn hoofdpc zijn in NTFS ......Ter info: het netwerk bestaat naast de Toshiba waarop Linux Mint 13 LTS Mate 32 bit staat, uit een pc (winXP), een NAS en een laptop met Win7.)

Mijn vraag is nu eigenlijk: Op de Data Toshiba staat dus Mint, (dat is dus de externe hd?) en dan heb je een pc met daarop XP, een laptop met Win 7 en een NAS.
Welke extensie heeft dan die Linux Mint op die Toshiba?

en het is NTFS. ;)

Het netwerk bestaat uit:
1) PC met twee HDD
HD 0 met partitie C:\ (windowsXP) en partitie D:\ (data)
HD 1 met F:\ (mijn documenten)

2) laptop Toshiba met één HD
partitie sda1 (windows) NTFS
partitie sda3 (?linux) EXT4
partitie sda2 extended
partitie sda5 (data) FAT32

3) NAS

4)laptop met één HD
partitie C:\ windows7
partitie D:\ data

Probleem is dus dat partitie sda5 (data) FAT32 noch partitie sda1 (windows) NTFSop Toshiba niet door PC gelezen kan worden: Toegang geweigerd. Root is eigenaar en verhindert elke vorm van wijziging van toegangsrechten. Ook niet als ik mezelf root maak door 'sudo -s'.

Intussen bedacht ik me dat de oplossing wel eens kon liggen in het bestand fstab. Ik heb dus wijzigingen aangebracht en nu ziet fstab er zó uit:
# /mnt/data was on /dev/sda5 during installation
UUID=4772-7471  /mnt/data       vfat    rw,users,utf8,umask=000,gid=user 0       1
# /mnt/windows was on /dev/sda1 during installation
UUID=966CB74C6CB725C1 /mnt/windows    ntfs    rw,users,umask=000,gid=user 0       0

Na opstarten bleek dit inderdaad effect te hebben, want nu liep de opstart vast. Na nog een keer opstarten, kreeg ik melding van een probleem bij mnt/windows en daarna bij mnt/data. Intypen van 'S' liet het starten verder gaan. (ik werk dus nu vanaf Linux)
Echter: bij openen van mnt/data bleef het scherm leeg: een lege map dus. Van mnt/windows werd aangegeven dat de map leeg was. Maar openen van data vanaf het bureaublad ([user]/bureaublad/data liet wél bestanden zien: deze map was wél gevuld. Raar!
Wat ook opviel dat openen van data of van windows (toshiba) vanuit de PC ditmaal geen melding van 'Toegang geweigerd' opleverde. Maar er waren geen bestanden te zien.
De oplossing ligt dus misschien inderdaad in fstab.
Helaas was ik dom geweest geen backup te maken van de originele fstab, zodat het nu nog steeds niet goed gaat bij het aankoppelen van data en windows. Wat is er fout in de betreffende regels van fstab??
Ter info: in mtab komen beide partities nu niet voor.

« Laatst bewerkt op: 2014/03/13, 17:17:49 door molly w »

Offline Mikkel

  • Lid
  • Steunpunt: Nee
Ik heb dus wijzigingen aangebracht en nu ziet fstab er zó uit:
# /mnt/data was on /dev/sda5 during installation
UUID=4772-7471  /mnt/data       vfat    rw,users,utf8,umask=000,gid=user 0       1
# /mnt/windows was on /dev/sda1 during installation
UUID=966CB74C6CB725C1 /mnt/windows    ntfs    rw,users,umask=000,gid=user 0       0

Dit kan nooit de complete inhoud van fstab zijn, dus post die eens helemaal.
Als voorbeeld, dit is de fstab van mijn pc:
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda5 during installation
UUID=2f8c48df-2cc4-4d85-8400-7c21dba2a60a /               ext4    errors=remount-ro 0       1
# /home was on /dev/sda8 during installation
UUID=024abcb8-bf92-4e93-8f34-8ba49e08f765 /home           ext4    defaults        0       2
# swap was on /dev/sda9 during installation
UUID=dab2adb8-48a6-47a5-bdd2-9ad5151bfd2c none            swap    sw              0       0
# /dev/sda1
UUID=2083A9A6201DFCEC  /media/sda1  ntfs  defaults,uid=1000,utf8,fmask=0177,dmask=0077  0  0
# /dev/sda2
UUID=768A88CC736C1809  /media/sda2  ntfs  defaults,uid=1000,utf8,fmask=0177,dmask=0077  0  0
# /dev/sda6
UUID=0C11EBF04B4CD2FA  /media/sda6  ntfs  defaults,uid=1000,utf8,fmask=0177,dmask=0077  0  0
# /dev/sda7
UUID=02DF164E353D27D7  /media/sda7  ntfs  defaults,uid=1000,utf8,fmask=0177,dmask=0077  0  0
# /dev/sdb1
UUID=08D5F5A924EBD3A9  /media/sdb1  ntfs  defaults,uid=1000,utf8,fmask=0177,dmask=0077  0  0



De UUID van jouw /dev/sda5 heeft een veel te korte cijfercombinatie, dus die klopt niet.
Met het commando sudo blkid in een terminal krijg je een overzicht van de UUID's van alle partities.

Offline koos4401

  • Lid
  • Steunpunt: Nee
Citaat
UUID=4772-7471
UUID van 2*4 tekens zijn i.h.a USBsticks (of fout natuurlijk), dacht ik
Op 27-okt-2009 om 08.20 GMT geregistreerd als gebruiker nr.: 498523

Offline molly w

  • Lid
Re: Partitie 'data' (Data on Toshiba) is niet toegankelijk vanuit het netwerk
« Reactie #10 Gepost op: 2014/03/14, 10:21:10 »
Begrip ik het zo goed dat je vanaf de PC met Windows de laptop wilt bereiken en dat sda1 en sda5 niet te bereiken zijn? De partitie met Linux dus wel?
[/qoute]
Ja, de Linuxpartitie is bereikbaar.
In Windows Verkenner (op PC) zie ik de volgende stations van Toshiba:
- data (is nu toegankelijk, maar leeg. was eerder ontoegankelijk) dit is de sda5
- Documents: ik kan alle bestanden inzien en bewerken. Dit is de Linux partitie
- floppy: is leeg (zie andere topic hierover op dit forum en op Belgisch Linux Mint Forum). Dit is fd0
- windows (is nu toegankelijk, maar leeg. was eerder ontoegankelijk) Dit is de sda1

Citaat
Je kan het met Gigolo proberen aangezien ze allemaal volgens jou in het netwerk zitten en dus hebben ze allemaal een eigen adres.
Pjotr opperde dit ook al.

Kijk, ik heb al mijn pc's hier in het netwerk, maar ik kan vanaf mijn pc boven niet in de pc beneden, met Gigolo werkt dat wel.
Ook mijn laptop kan ik niet bereiken maar wel met Gigolo. En zo ook met mijn NAS.

Jouw situatie is bijna hetzelde als dat van mij, ware het niet dat mijn laptop Linux en Windows bevat en mijn 2 desktops Mint.

Ik heb ook Gigolo onder Linux geïnstalleerd. Daarmee kon ik vanuit Linux de netwerkstations bereikbaar maken. Mij is echter niet duidelijk hoe Gigolo de sda1 en sda5 bereikbaar kan maken vanuit de windowsPC

Offline molly w

  • Lid
Re: Partitie 'data' (Data on Toshiba) is niet toegankelijk vanuit het netwerk
« Reactie #11 Gepost op: 2014/03/14, 10:31:35 »
Ik heb dus wijzigingen aangebracht en nu ziet fstab er zó uit:
# /mnt/data was on /dev/sda5 during installation
UUID=4772-7471  /mnt/data       vfat    rw,users,utf8,umask=000,gid=user 0       1
# /mnt/windows was on /dev/sda1 during installation
UUID=966CB74C6CB725C1 /mnt/windows    ntfs    rw,users,umask=000,gid=user 0       0

Dit kan nooit de complete inhoud van fstab zijn, dus post die eens helemaal.
Als voorbeeld, dit is de fstab van mijn pc:
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda5 during installation
UUID=2f8c48df-2cc4-4d85-8400-7c21dba2a60a /               ext4    errors=remount-ro 0       1
# /home was on /dev/sda8 during installation
UUID=024abcb8-bf92-4e93-8f34-8ba49e08f765 /home           ext4    defaults        0       2
# swap was on /dev/sda9 during installation
UUID=dab2adb8-48a6-47a5-bdd2-9ad5151bfd2c none            swap    sw              0       0
# /dev/sda1
UUID=2083A9A6201DFCEC  /media/sda1  ntfs  defaults,uid=1000,utf8,fmask=0177,dmask=0077  0  0
# /dev/sda2
UUID=768A88CC736C1809  /media/sda2  ntfs  defaults,uid=1000,utf8,fmask=0177,dmask=0077  0  0
# /dev/sda6
UUID=0C11EBF04B4CD2FA  /media/sda6  ntfs  defaults,uid=1000,utf8,fmask=0177,dmask=0077  0  0
# /dev/sda7
UUID=02DF164E353D27D7  /media/sda7  ntfs  defaults,uid=1000,utf8,fmask=0177,dmask=0077  0  0
# /dev/sdb1
UUID=08D5F5A924EBD3A9  /media/sdb1  ntfs  defaults,uid=1000,utf8,fmask=0177,dmask=0077  0  0



De UUID van jouw /dev/sda5 heeft een veel te korte cijfercombinatie, dus die klopt niet.
Met het commando sudo blkid in een terminal krijg je een overzicht van de UUID's van alle partities.

Ik had slechts de betreffende regels van fstab gekopieerd. Hier het complete fstab:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda3 during installation
UUID=1dfa9793-1efe-483f-98de-125a9f8e034d /               ext4    errors=remount-ro 0       1
# /mnt/data was on /dev/sda5 during installation
UUID=4772-7471  /mnt/data       vfat    rw,users,utf8,umask=000,gid=user 0       1
# /mnt/windows was on /dev/sda1 during installation
UUID=966CB74C6CB725C1 /mnt/windows    ntfs    rw,users,umask=000,gid=user 0       0
# swap was on /dev/sda4 during installation
UUID=3778685b-bf68-4886-b71a-cee3c12a75a3 none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0

Code 'sudo  blkid' levert de volgende UUID 's op:
/dev/sda1: UUID="966CB74C6CB725C1" TYPE="ntfs"
/dev/sda3: UUID="1dfa9793-1efe-483f-98de-125a9f8e034d" TYPE="ext4"
/dev/sda4: UUID="3778685b-bf68-4886-b71a-cee3c12a75a3" TYPE="swap"
/dev/sda5: LABEL="data" UUID="4772-7471" TYPE="vfat"

Die van sd5 zou volgens jou te kort zijn, maar het lijkt dus echt wel te kloppen.
Trouwens ook sda1 levert een mount-probleem op bij opstart.
Als het systeem (voor de 2e keer) opstart, vliegt kort een melding voorbij waarin ik iets zie over 'onbekend' en 'GID=user'. Ik wou dat ik dat even kon stilzetten, zodat ik deze melding kon bestuderen. Levert misschien de sleutel van het huidige start-probleem.


Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Partitie 'data' (Data on Toshiba) is niet toegankelijk vanuit het netwerk
« Reactie #12 Gepost op: 2014/03/14, 13:30:45 »
Heb je effectief een groep met de naam "user" op je systeem? In de optie "gid=" moet je een bestaande groepnaam (of het overeenstemmende groepsnummer) invullen.

Offline molly w

  • Lid
Re: Partitie 'data' (Data on Toshiba) is niet toegankelijk vanuit het netwerk
« Reactie #13 Gepost op: 2014/03/14, 14:02:56 »
Heb je effectief een groep met de naam "user" op je systeem? In de optie "gid=" moet je een bestaande groepnaam (of het overeenstemmende groepsnummer) invullen.
Opgelost! De tip over de waarde van "gid" bood de oplossing. Linux start nu weer gewoon op EN de partities sda1 en sda5 zijn ook vanaf de windowsXP PC te lezen. Geen gezeur meer van "toegang geweigerd". Ik heb het nummer van mijn groep ingevuld, dat was de oplossing, naast umask = 000. (er stond eerst umask=007)
Dank dank