Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Grub niet tonen...[OPGELOST]  (gelezen 618 keer)

Offline swaenie

  • Lid
  • Steunpunt: Nee
Grub niet tonen...[OPGELOST]
« Gepost op: 2014/02/15, 13:02:57 »
Ik lees 'Op een enkelvoudig opstartbare computer is het Grubmenu immers standaard onzichtbaar.'
Op mijn PC staat alleen Linux Mint. 
Na gksudo leafpad /etc/default/grub heb ik onderstaande instellingen gemaakt:
Citaat
GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
Toch wordt de grub getoond. Hoe voorkom ik dat?
« Laatst bewerkt op: 2014/03/14, 16:57:17 door swaenie »

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Grub niet tonen...
« Reactie #1 Gepost op: 2014/02/15, 13:37:24 »
Geen idee! Maar ik heb wel de vraag....als de grub maar heel kort te zien is, wat is dan het probleem? Je wint er hooguit 2 seconden door als het al kan wat jij wilt.


Als GRUB_HIDDEN_TIMEOUT op 0 staat zoals in Swaenie's post dan is er geen timeout en blijft Grub dus in beeld totdat jij iets selecteert.

@swaenie: GRUB_HIDDEN_TIMEOUT_QUIET en GRUB_HIDDEN_TIMEOUT moet je een # voor zetten en dan sudo update-grub doen.

Offline swaenie

  • Lid
  • Steunpunt: Nee
Re: Grub niet tonen...
« Reactie #2 Gepost op: 2014/02/15, 19:07:49 »
@Vistaus: bedankt voor je reactie. Echter na wijziging,  sudo update-grub en reboot wordt de grub nog steeds getoond.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Grub niet tonen...
« Reactie #3 Gepost op: 2014/02/15, 20:08:48 »
Post eens de inhoud van /etc/default/grub ?

Offline swaenie

  • Lid
  • Steunpunt: Nee
Re: Grub niet tonen...
« Reactie #4 Gepost op: 2014/02/16, 10:52:48 »
@Vistaus: Excuses voor de late reactie...
Citaat
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
#GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: Grub niet tonen...
« Reactie #5 Gepost op: 2014/02/16, 15:59:27 »
Ik heb hier nog wat kunnen uitproberen op de PC 2007 uit mijn onderschrift. Origineel zijn dit de bovenste 4 GRUB regels. Dit zowel met een Ubuntu dual boot Windows en ook met Ubuntu als enige besturingssysteem. Check eventueel de GRUB manual. 
GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10

Bij mij wordt met Ubuntu als enige besturingssysteem, het GRUB menu niet getoond. Tenminste als sudo update-grub alleen één Ubuntu versie toont. Ofwel onder die regel
Found memtest86+ image: /boot/memtest86+.bin
 
zou geen besturingssysteem moeten zijn vermeldt.
Hoofd PC januari 2018 HP Compaq Elite 8300 SFF Windows 10 & Xubuntu 18.04.1
PC 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Xubuntu 18.04 & testversie Xubuntu 19.04  
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM

Offline swaenie

  • Lid
  • Steunpunt: Nee
Re: Grub niet tonen...
« Reactie #6 Gepost op: 2014/02/16, 17:04:16 »
Hij zegt:
Citaat
Found memtest86+ image: /boot/memtest86+.bin
Found Ubuntu 12.04.3 LTS (12.04) on /dev/sda1
Ubuntu 12.04 heb ik echter vervangen door Linux Mint. Blijkbaar heb ik daarbij iets fout gedaan.

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: Grub niet tonen...
« Reactie #7 Gepost op: 2014/02/16, 17:27:35 »
Dan is Linux Mint niet over Ubuntu 12.04 geïnstalleerd, maar ernaast. Zag je dus ook in het GRUB menu zowel Linux Mint en Ubuntu 12.04?
Hoofd PC januari 2018 HP Compaq Elite 8300 SFF Windows 10 & Xubuntu 18.04.1
PC 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Xubuntu 18.04 & testversie Xubuntu 19.04  
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM

Offline swaenie

  • Lid
  • Steunpunt: Nee
Re: Grub niet tonen...
« Reactie #8 Gepost op: 2014/02/17, 11:36:20 »
@jolo: Bedankt. Ik ben een beetje dom geweest ;-)

Ik heb de grub nooit bekeken. Niet erg handig. Op mijn grub staan:
Linux Mint + recovery
Ubuntu met Linux 3.2.0-58 + recovery (werkt)
Ubuntu met Linux 3.2.0-57 + recovery (werkt)
Ubuntu met Linux 3.2.0-52 + recovery (hiermee kom ik in de root)

Ik begrijp dat daarom mijn grub werd vermeld.
Nu ik XUbuntu toch heb, laat ik 'm maar staan. Hoe krijg ik  de laatste 2 verwijderd?