Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [Opgelost] Updatebeheer gaat niet goed (12.04 64 bits)  (gelezen 1596 keer)

Offline aartje

  • Lid
  • Steunpunt: Nee
[Opgelost] Updatebeheer gaat niet goed (12.04 64 bits)
« Gepost op: 2014/02/03, 09:56:59 »
Vanmorgen startte ik update beheer op (met de hand) op mijn
12.04 Ubuntu 64bit systeem. Ik kreeg een popupvenster met
de melding:
====
Niet alle updates kunnen worden geïnstalleerd
Voer een gedeeltelijke upgrade uit om zoveel mogelijke updates te installeren.

Dit kan veroorzaakt worden door:
* Een vorige upgrade die niet werd voltooid
* Problemen met de geïnstallerde software
*Onofficiële softwarepaketten die niet ondersteund worden door Ubuntu
*Gewoonlijke wijzigingen in een pre-uitgave van Ubuntu
===
Ik kan dan kiezen voor "Gedeeltelijke opwaardering" en "Sluiten"
Ik heb gekozen voor het eerste en toen ging het fout, er werden 105 paketten ge-update,
vernieuwd zowel als weggehaald.
Ik zag dat daar paketten bij waren die ik wel nodig had (ia32libs en een hoop andere libs, xscreensaver)
Het uitvoeren van Google-earth deed het bv niet meer (missende libraries), de screensaver
was  er niet meer...

Ik heb met Clonezilla een backup van mijn root-device teruggezet (27 december 2013) en toen deed
het het weer. Daarna weer "Update" met de hand gestart en weer dezelfde mededeling,
dus maar even niet uitgevoerd. Volgens mij is er iets niet helemaal kosher met het update-systeem
« Laatst bewerkt op: 2014/02/03, 19:37:31 door aartje »

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Updatebeheer gaat niet goed (12.04 64 bits)
« Reactie #1 Gepost op: 2014/02/03, 10:00:54 »
Open eens een terminal en voer dit commando uit:
sudo apt-get dist-upgrade
Nadat je je wachtwoord ingevuld hebt krijg je een hele lijst van wat hij allemaal gaat doen.
Voordat je hier toestemming voor geeft plaats aub de hele lijst hier. Voer "n" in om de update af te breken.

Offline aartje

  • Lid
  • Steunpunt: Nee
Re: Updatebeheer gaat niet goed (12.04 64 bits)
« Reactie #2 Gepost op: 2014/02/03, 15:42:05 »
Open eens een terminal en voer dit commando uit:
sudo apt-get dist-upgrade
Nadat je je wachtwoord ingevuld hebt krijg je een hele lijst van wat hij allemaal gaat doen.
Voordat je hier toestemming voor geeft plaats aub de hele lijst hier. Voer "n" in om de update af te breken.
Bedankt Johan voor je aandacht.
Ik heb met Clonezilla het root-device gerestored van een backup gemaakt op 27 december 2013.
Mijn systeem is altijd geheel upt-to-date. Ik had via Systeem->Beheer-> Updatebeheer weer geprobeerd te updaten
en kreeg weer dezelfde melding, dus heb ik dat afgebroken.

Daarna gedaan wat je vroeg (met "script" ervoor)
De output is als volgt:
sudo apt-get dist-upgrade
Pakketlijsten worden ingelezen... 0%Pakketlijsten worden ingelezen... 100%Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd... 0%Boom van vereisten wordt opgebouwd... 0%Boom van vereisten wordt opgebouwd... 50%Boom van vereisten wordt opgebouwd... 50%Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... 0%De status informatie wordt gelezen... 0%De status informatie wordt gelezen... Klaar
Opwaardering wordt doorgerekend... Klaar
De volgende pakketten zullen VERWIJDERD worden:
  libgraphite2-2.0.0
De volgende NIEUWE pakketten zullen geïnstalleerd worden:
  libboost-date-time1.54.0 libgraphite2-3
  libreoffice-avmedia-backend-gstreamer libreoffice-base-drivers
  libreoffice-sdbc-firebird libreoffice-sdbc-hsqldb linux-headers-3.2.0-58
  linux-headers-3.2.0-58-generic linux-image-3.2.0-58-generic
De volgende pakketten zullen opgewaardeerd worden:
  adobe-flash-properties-gtk adobe-flashplugin base-files bc bind9-host
  browser-plugin-libreoffice chromium-browser chromium-browser-l10n
  chromium-codecs-ffmpeg-extra consolekit dc dmsetup dnsutils duplicity
  fonts-opensymbol gir1.2-appindicator3-0.1 gir1.2-gtk-3.0 hplip hplip-data
  iproute language-pack-en language-pack-en-base language-pack-gnome-en
  language-pack-gnome-en-base language-pack-gnome-nl
  language-pack-gnome-nl-base language-pack-kde-en language-pack-kde-en-base
  language-pack-kde-nl language-pack-kde-nl-base language-pack-nl
  language-pack-nl-base libappindicator1 libappindicator3-1 libbind9-80
  libcdt4 libck-connector0 libdevmapper-event1.02.1 libdevmapper1.02.1
  libdns81 libdrm-intel1 libdrm-intel1:i386 libdrm-nouveau1a
  libdrm-nouveau1a:i386 libdrm-radeon1 libdrm-radeon1:i386 libdrm2
  libdrm2:i386 libexttextcat-2.0-0 libexttextcat-data libgail-3-0
  libgl1-mesa-dri libgl1-mesa-dri:i386 libgl1-mesa-glx libgl1-mesa-glx:i386
  libglapi-mesa libglapi-mesa:i386 libglu1-mesa libglu1-mesa:i386 libgraph4
  libgtk-3-0 libgtk-3-bin libgtk-3-common libgvc5 libhpmud0 libicu48 libisc83
  libisccc80 libisccfg82 liblvm2app2.2 liblwres80 libmysqlclient18:i386
  libnautilus-extension1a libnspr4 libnspr4:i386 libnspr4-0d libnss3
  libnss3:i386 libnss3-1d libpam-ck-connector libpathplan4 libpixman-1-0
  libpixman-1-0:i386 libqt4-dbus libqt4-dbus:i386 libqt4-declarative
  libqt4-declarative:i386 libqt4-designer libqt4-designer:i386 libqt4-help
  libqt4-network libqt4-network:i386 libqt4-opengl libqt4-opengl:i386
  libqt4-qt3support libqt4-qt3support:i386 libqt4-script libqt4-script:i386
  libqt4-scripttools libqt4-scripttools:i386 libqt4-sql libqt4-sql:i386
  libqt4-sql-mysql:i386 libqt4-sql-sqlite libqt4-svg libqt4-svg:i386
  libqt4-test libqt4-test:i386 libqt4-xml libqt4-xml:i386 libqt4-xmlpatterns
  libqt4-xmlpatterns:i386 libqtcore4 libqtcore4:i386 libqtgui4 libqtgui4:i386
  libraptor2-0 librasqal3 librdf0 libreoffice-base libreoffice-base-core
  libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw
  libreoffice-emailmerge libreoffice-gnome libreoffice-gtk
  libreoffice-help-en-gb libreoffice-help-nl libreoffice-impress
  libreoffice-java-common libreoffice-l10n-en-gb libreoffice-l10n-nl
  libreoffice-math libreoffice-pdfimport libreoffice-style-human
  libreoffice-style-tango libreoffice-writer libsane-hpaio libssl1.0.0
  libssl1.0.0:i386 libunity-2d-private0 libunity-core-5.0-5 libwpg-0.2-2
  libxatracker1 libxfixes3 libxfixes3:i386 libxfont1 libxi6 libxi6:i386
  linux-generic linux-headers-generic linux-image-generic linux-libc-dev
  mysql-common nautilus nautilus-data notify-osd notify-osd-icons openssl
  printer-driver-hpcups printer-driver-hpijs printer-driver-postscript-hp
  python-appindicator python-software-properties python-uno qdbus
  software-properties-common software-properties-gtk unity unity-2d
  unity-2d-common unity-2d-panel unity-2d-shell unity-2d-spread unity-common
  unity-services uno-libs3 ure
180 pakketten opgewaardeerd, 9 pakketten nieuw geïnstalleerd, 1 te verwijderen en 0 niet opgewaardeerd.
Er moeten 268 MB aan archieven opgehaald worden.
Door deze operatie zal er 227 MB extra schijfruimte gebruikt worden.
Wilt u doorgaan [J/n]? n
Afbreken.
[code]



« Laatst bewerkt op: 2014/02/03, 16:57:03 door aartje »

Offline aartje

  • Lid
  • Steunpunt: Nee
Re: Updatebeheer gaat niet goed (12.04 64 bits)
« Reactie #3 Gepost op: 2014/02/03, 15:53:34 »
Eigenlijk de enige software die niet bij de reguliere paketten van 12.04 zit en die
ik heb ge-installeerd is Libreoffice4.1.4.2 dmv de source op
http://ppa.launchpad.net/libreoffice/ppa/ubuntu precise main

Maar ik kan me niet voorstellen dat dat er niets mee te maken heeft.

Offline aartje

  • Lid
  • Steunpunt: Nee
Re: Updatebeheer gaat niet goed (12.04 64 bits)
« Reactie #4 Gepost op: 2014/02/03, 16:09:43 »
Aartje....een tip:
voor lange lappen tekst zoals in een eerdere bericht van je, zet het even in code.
Die vind je naast de quote in de teksteditor als je je bericht gaat schrijven.

Verder heb ik dit een keer gehad met Xubuntu. Ook ik deed de eerste optie "gedeeltelijke opwaardering" , heb het laten gaan en daarna kwam alles weer goed.
Want daarna kwam er toch weer een update die alles normaal maakte. (hoewel ik niet had gezien dat er dingen niet werkte hoor, alles deed het bij mij nog waar ik mee werkte)

ps. waarom breek je hem af?
Hoi Femke,

Je hebt gelijk over die tekst, ik kan het zelfs misschien beter als bijlage geven. Sorry, een beetje luiheid van mezelf :-[

Ik zal de update nog een keer doen, herstarten en kijken of ik het door nog een update kan herstellen.
Met Clonezilla kan ik desnoods weer terug naar de status van 27 december.

Ik brak hem af omdat Johan dat voorstelde.

Offline aartje

  • Lid
  • Steunpunt: Nee
Re: Updatebeheer gaat niet goed (12.04 64 bits)
« Reactie #5 Gepost op: 2014/02/03, 16:51:02 »
Ik kreeg op een gegeven moment een melding dat er heeeel veel werd weggehaald.
Zie oa wat sceendumps als bijlages

Offline aartje

  • Lid
  • Steunpunt: Nee
Re: Updatebeheer gaat niet goed (12.04 64 bits)
« Reactie #6 Gepost op: 2014/02/03, 16:55:33 »
en nog wat bijlages. Dat lijkt me niet gezond. Herstarten en nog een keer een update maakte niets uit
Ik ga toch maar terug naar de backup van 27 december. Of misschien heeft iemand een tip.

Offline aartje

  • Lid
  • Steunpunt: Nee
Re: Updatebeheer gaat niet goed (12.04 64 bits)
« Reactie #7 Gepost op: 2014/02/03, 17:21:12 »
Met handmatig bedoel ik dat ik soms met de hand Beheer->Updatebeheer opstart.
Normaal wordt dat door een cronjob één keer per twee dagen gedaan (dacht ik...)

Het gaat dus zowel fout met een update tov 27 december als met een update
van (hoogstens?) twee dagen terug. Er verdwijnen wel heeel veel libraries. Het verwondert
me dat er nog niet meer meldingen van zijn, ik heb geen hardware-problemen en/of
software-problemen buiten dit. Dat teruggaan naar die backup heb ik al twee keer gedaan.
(Lang leve Clonezilla)
« Laatst bewerkt op: 2014/02/03, 17:23:02 door aartje »

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Updatebeheer gaat niet goed (12.04 64 bits)
« Reactie #8 Gepost op: 2014/02/03, 18:46:18 »
Ik kreeg op een gegeven moment een melding dat er heeeel veel werd weggehaald.
Zie oa wat sceendumps als bijlages

Dat is gek, als je via de terminal wil updaten wil hij maar 1 pakket verwijderen en dat is op zich niet het probleem.
Als je nu de updater opent wil hij dan weer je halve systeem weghalen?

Offline aartje

  • Lid
  • Steunpunt: Nee
Re: Updatebeheer gaat niet goed (12.04 64 bits)
« Reactie #9 Gepost op: 2014/02/03, 19:07:33 »
Ik kreeg op een gegeven moment een melding dat er heeeel veel werd weggehaald.
Zie oa wat sceendumps als bijlages

Dat is gek, als je via de terminal wil updaten wil hij maar 1 pakket verwijderen en dat is op zich niet het probleem.
Als je nu de updater opent wil hij dan weer je halve systeem weghalen?
Ik heb het systeem al twee keer gerestored van een backup van 27 dec. jl
Na allebei de keren wil hij al die zaken weghalen (Systeemgereedschap->Beheer->Updatebeheer)
De tweede keer heb ik het maar afgebroken voor hij al die zaken weghaalde. Wat me opvalt
is dat dat vnl i386 zaken zijn (aan de naam te zien).
En verder cups-pdf hoort toch ook niet weggegooid te worden.(?)

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Updatebeheer gaat niet goed (12.04 64 bits)
« Reactie #10 Gepost op: 2014/02/03, 19:18:59 »
Je kan in ieder geval wel via de terminal updaten:
sudo apt-get dist-upgrade
Dan verwijdert hij niet meteen je halve systeem.

Wat je hierna even moet doen is het installeren van het pakket ia32-libs:
sudo apt-get install ia32-libs

Als het goed is zou het nu weer goed moeten gaan. Je zal wel goed op moeten letten bij de volgende keer dat er updates binnengehaald worden of hij niet weer een hoop pakketten wil verwijderen. Dat moet je dan dus niet doen ;)

Offline aartje

  • Lid
  • Steunpunt: Nee
Re: Updatebeheer gaat niet goed (12.04 64 bits)
« Reactie #11 Gepost op: 2014/02/03, 19:21:59 »
Ik heb maar eens gekozen voor  "sluiten" ipv "Gedeeltelijk opwaarderen"
bij het venster :

====
Niet alle updates kunnen worden geïnstalleerd
Voer een gedeeltelijke upgrade uit om zoveel mogelijke updates te installeren.

Dit kan veroorzaakt worden door:
* Een vorige upgrade die niet werd voltooid
* Problemen met de geïnstallerde software
*Onofficiële softwarepaketten die niet ondersteund worden door Ubuntu
*Gewoonlijke wijzigingen in een pre-uitgave van Ubuntu

===

Nu lijkt het wel goed te gaan, alleen komt hij na een reboot en weer controleren
op updates weer met dat scherm en een paar updates die niet zijn aangevinkt,
nl. een nieuwe kernel en libreoffice

Offline aartje

  • Lid
  • Steunpunt: Nee
Re: Updatebeheer gaat niet goed (12.04 64 bits)
« Reactie #12 Gepost op: 2014/02/03, 19:37:02 »
Dat "Gedeeltelijk opwaarderen" moet ik dus gewoon niet meer doen, maar
wel "Sluiten"
Ik heb nog een keer "sudo apt-get dist-upgrade" gedaan en nu wordt ook de
nieuwe kernel en libreoffice ge-installeerd. Rebooten gaf weer een systeem zonder
problemen.

Hartelijk dank Johan en Femke  voor het helpen oplossen !!!