Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Opstartproblemen (VGA)  (gelezen 774 keer)

Anaesthetix

  • Gast
Opstartproblemen (VGA)
« Gepost op: 2007/03/15, 18:50:48 »
Goedenavond allemaal,

Na een weekje Windows Vista op dualboot gedraaid te hebben, ben ik (zoals te raden) niet bepaald tevreden.
Dus ik dacht, laat ik de ruimte beter besteden door er een Linux distributie op te draaien! :)
Na een ietwat rommelige installatie (Installatie via LiveCD werkte niet..), hoopte ik vandaag eindelijk een volledig werkende Ubuntu zien te verschijnen. Helaas vond Ubuntu dat niet zo'n goed idee.. :(
Na het bootscherm verschijnt er een scala aan blokjes en kleuren, terwijl het geluid wél werkt.
Ik gok erop dat er een conflict is met mijn videokaart, of de aansturende software.
Het exacte probleem heb ik nog nergens kunnen terugvinden, noch de eventuele oplossing. Het kan natuurlijk ook zijn dat ik niet goed ben in zoeken, maar neem me dat alstublieft niet kwalijk.

Ik heb wel ongeveer een idee van hoe ik het zou kunnen 'fixen'. Helaas ben ik niet zo bedreven met Terminal/BASH..

Is iemand in staat om mij te helpen, zodat ik aan de slag mag gaan met de grafische interface van Ubuntu? :)



Bij voorbaat heel erg bedankt! :D



Relevante hardware:

AMD Athlon64 3200+
NVidia Geforce 6800 GS
ASUS A8N SLI-Deluxe mobo
(Mocht het helpen om andere hardware te vermelden, geef dit even aan.)


P.S.  Ik denk dat een logfile makkelijker zou zijn om het te localiseren. Zou iemand me kunnen aangeven hoe, wat en waar?

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Opstartproblemen (VGA)
« Reactie #1 Gepost op: 2007/03/15, 19:14:27 »
Probeer eens het volgende:

voorzover je die niet hebt geselecteerd, pak de generieke i386 versie van Ubuntu 6.10:
ftp://ftp.tudelft.nl/pub/Linux/releases.ubuntu.com/edgy/ubuntu-6.10-desktop-i386.iso

Had je die al, probeer dan eens een versiewissel: Ubuntu 6.06.1 (LTS-versie), eveneens in generieke i386-editie:
ftp://ftpserv.tudelft.nl/pub/Linux/releases.ubuntu.com/6.06/ubuntu-6.06.1-desktop-i386.iso

Helpt geen van deze ingrepen, overweeg dan eens om een maand te wachten: op 20 april komt de nieuwste versie uit, 7.04 (Feisty Fawn), die de nieuwste hardware-herkenning aan boord zal hebben.

In elk geval: brand je CD op zeer lage snelheid (8 x of zo), en laat je brandprogramma het bakproduct controleren. Brandfouten gebeuren gauw en zijn fataal voor de volgepropte installatie-CD van Ubuntu.

Helpt dit?

Groet, Pjotr.

Anaesthetix

  • Gast
Opstartproblemen (VGA)
« Reactie #2 Gepost op: 2007/03/16, 01:11:00 »
Na een tijdje wat geprutst te hebben met "sudo dpkg-reconfigure xserver-xorg" , ben ik erachter gekomen dat het inderdaad aan de aansturende software lag. Ik heb het voor de zekerheid eens geprobeerd in te stellen op VESA en plotsklaps draaide Ubuntu fatsoenlijk.

Momenteel probeer ik mijn Nvidia acceleratie een beetje aan de gang te krijgen, maar gelukkig helpt Synaptic me al stukken verder! :)

Pjotr, bedankt voor je hulp, ik heb uiteindelijk toch gekozen voor de i386 versie. Naar mijn idee is er over het algemeen betere ondersteuning voor deze versie. Helaas werd mijn videokaart niet meteen herkend..

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Opstartproblemen (VGA)
« Reactie #3 Gepost op: 2007/03/16, 07:56:38 »
Graag gedaan!

De nvidia fabrieksdriver installeer je als volgt:

Synaptic starten.
zoekterm: nvidia
aanvinken:
- nvidia-glx

Druk op knop Toepassen

Daarna in terminal:
sudo dpkg-reconfigure xserver-xorg

In de vragenriedel als driver "nvidia" selecteren i.p.v. de huidige "nv"
verder geen eigen keuzes maken, dat geeft beste resultaat (foutje in progje).

daarna: herstarten.

Als het gelukt is, zie je tijdens de herstart kort een schermpje in beeld komen met het nvidia-logo.

Groet, Pjotr.

Anaesthetix

  • Gast
Opstartproblemen (VGA)
« Reactie #4 Gepost op: 2007/03/16, 08:07:48 »
Bedankt, het is gelukt. Is er ook een soort configuratiepanel, zoals bij de ForceWare in Windows het geval is? Ik zou het fijn vinden om de videokaart op deze manier te tweaken, maar vooralsnog is het me niet gelukt om iets dergelijks te vinden..

madberry

  • Gast
Opstartproblemen (VGA)
« Reactie #5 Gepost op: 2007/03/16, 08:29:04 »
Citaat van: Anaesthetix
Bedankt, het is gelukt. Is er ook een soort configuratiepanel, zoals bij de ForceWare.....
sudo nvidia-glx-config enablegeen idee hoe het verder werkt want ik gebruik het niet :D

probeer ook Envy eens om de nieuwste drivers gemakkelijk te instaleren.

Envy linkje


greetzzzz,
[mad]Berry

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Opstartproblemen (VGA)
« Reactie #6 Gepost op: 2007/03/16, 14:25:35 »
Systeem - Voorkeuren - Schermresolutie

Voor verdergaande bijstellingen:
Installeer in Synaptic:
- nvidia-settings

Daarna in terminal:
nvidia-settings  (of sudo nvidia-settings, dat weet ik niet meer)

Nog verdergaand:
Het nVidia stuurprogramma denkt het beter te weten en houdt geen rekening met bepaalde xorg instellingen. Die betweterige instellingen staan in EDID.

Ik kreeg de gewenste instelling pas na het gedeeltelijk uitschakelen van EDID, en wel door het toevoegen van de volgende regel in xorg.conf:
Option      "UseEdidFreqs" "FALSE"

De sectie in xorg.conf wordt dan als volgt:
-----------------
Section "Device"
        Identifier      "NVIDIA Corporation [naam van je videokaart]"
        Driver          "nvidia"
        BusID           "PCI:1:0:0"
        Option      "UseEdidFreqs" "FALSE"
--------------------------

Bewerken: Terminal:
sudo gedit /etc/X11/xorg.conf

Bron: http://download.nvidia.com/XFree86/Linux-x86/1.0-8774/README/appendix-d.html

Groet, Pjotr.