Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Launcher  (gelezen 192 keer)

Offline Luuk073

  • Lid
  • Steunpunt: Nee
Launcher
« Gepost op: 2014/02/02, 15:48:06 »
Hallo,

Ik heb snel een klein bestandje geschreven dat minecraft op zou moeten starten.
Het commando werkt wel in een terminal maar niet als ik het op het bureaublad gebruik, dan krijg ik deze melding:
Citaat
Er is een fout opgetreden bij het starten van de toepassing.
Details: Uitvoeren van dochterproces ‘cd’ is mislukt (Bestand of map bestaat niet)
Dit is de code die ik gebruik:
[Desktop Entry]
Encoding=UTF-8
Name=Minecraft
GenericName=Game
Comment=Start Minecraft
Type=Application
Exec=cd ~ && cd /home/luuk/Downloads/ && java -jar Minecraft.jar
Icon=/home/luuk/Documenten/Pictogrammmen/minecraft.jpg
Categories=0
Het bestandje heeft volgens mij de goede extensie (.desktop) en staat ook op het bureaublad.
Wat doe ik hier fout?

Offline HarzG

  • Lid
  • Steunpunt: Nee
Re: Launcher
« Reactie #1 Gepost op: 2014/02/02, 16:08:00 »
Hoewel een andere plaats voor een applicatie zou kiezen ..., misschien kan het ook helemaal zonder cd...
[Desktop Entry]
Encoding=UTF-8
Name=Minecraft
GenericName=Game
Comment=Start Minecraft
Type=Application
Exec=java -jar /home/luuk/Downloads/Minecraft.jar
Icon=/home/luuk/Documenten/Pictogrammmen/minecraft.jpg
Categories=0
Xubuntu 16.04; siduction-15.1.0 Xfce

Offline Luuk073

  • Lid
  • Steunpunt: Nee
Re: Launcher
« Reactie #2 Gepost op: 2014/02/02, 16:11:53 »
Werkt, bedankt voor de snelle reactie!

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Launcher
« Reactie #3 Gepost op: 2014/02/02, 20:18:48 »
Het lag wellicht aan het ~ symbool: wellicht wordt dat in een launcher niet herkend als een speciaal teken dat wordt vervangen door je home directory. Een manier om die problemen niet te hebben, is eenvoudig in je launcher een script aanroepen waarin alles wordt geregeld.

Offline Luuk073

  • Lid
  • Steunpunt: Nee
Re: Launcher
« Reactie #4 Gepost op: 2014/02/02, 20:29:40 »
Ik had het eerder al geprobeert zonder ~, dit leek niet te werken. Ik ben nog niet de beste programmeur en heb me nog niet verdiept in scripts