Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Ddosbot linux?  (gelezen 3578 keer)

Offline BorisM

  • Lid
    • http://www.brandeveen-motoriek.com
  • Steunpunt: Nee
Ddosbot linux?
« Gepost op: 2014/01/29, 11:32:27 »
Dit kwam ik vanochtend tegen. Kan men dan toch linux binnendringen?


http://bit.ly/1hMahaP
Alles komt goed, je weet echter nooit wanneer..

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Ddosbot linux?
« Reactie #1 Gepost op: 2014/01/29, 11:42:02 »
Citaat
als daarop Java is geïnstalleerd.

Offline Joris Donders

  • Lid
  • Steunpunt: Nee
Re: Ddosbot linux?
« Reactie #2 Gepost op: 2014/01/29, 11:45:30 »
Citaat
Anders dan alleen de browser-plugin om binnen te komen, maakt dit virus gebruik van de hele runtime. De malware is volledig geschreven in Java, waardoor het platformonafhankelijk kan draaien.

Vandaar dat ik als steunpunt NOOIT installaties aflever met een Java erop geïnstalleerd; sterker, ik raad het mensen compleet af om Java dan alsnog te installeren , tenzij ze daar gegronde redenen voor hebben.
Java is gewoon in zijn geheel té gevaarlijk om op je systeem te hebben.

Natuurlijk is deze melding weer iets van een Antivirusbedrijf (Kapersky) en een korrel zout lijkt me hier ook aangewezen.
Gubuntu 17.04 wegens verdwijnen Unity binnenkort

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Ddosbot linux?
« Reactie #3 Gepost op: 2014/01/29, 11:55:25 »
Kan men dan toch linux binnendringen?

Tuurlijk kan dat. Niets is 100% veilig. Maar in dit geval, zoals Pjotr en Joris al aangeven, gaat het om een runtime via Java. Het is dat ik Java nodig heb, anders had ik het al gedeïnstalleerd...

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Ddosbot linux?
« Reactie #4 Gepost op: 2014/01/29, 11:57:10 »
Via Java is er van alles mogelijk...
Maar zoals je hier en hier kan zien is het lek in Ubuntu in juli al gedicht.

Overigens vragen Firefox en Chrome (en andere browsers misschien ook wel) standaard om toestemming voordat ze Java toestaan.  Als je onverwacht zo'n vraag krijgt is dat altijd verdacht.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Ddosbot linux?
« Reactie #5 Gepost op: 2014/01/29, 12:41:02 »
Storm in een glas water dus. Tja, het lijkt weer de zoveelste Kaspersky-publiciteitsstunt te zijn....

Offline DeBaas

  • Lid
  • Steunpunt: Ja
Re: Ddosbot linux?
« Reactie #6 Gepost op: 2014/01/29, 12:53:23 »
launchd of in init.d

En wie geeft dan root toestemming om daar iets in neer te zetten ?

Het gevaar zit weer tussen toetsenbord en stoel.
Ik beantwoord GEEN hulpvragen via PB en/of MAIL

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Ddosbot linux?
« Reactie #7 Gepost op: 2014/01/29, 13:43:08 »
Maar zoals je hier en hier kan zien is het lek in Ubuntu in juli al gedicht.

Ehm, nee. Het gat is gedicht in Ubuntu's OPENJDK. Maar niet iedere Linux-gebruiker gebruikt OpenJDK, velen gebruiken ook Oracle Java waar het gat nog steeds in zit.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Ddosbot linux?
« Reactie #8 Gepost op: 2014/01/29, 13:53:03 »
Als je zelf dingen van buiten de repository's installeert dan ben je daar ook zelf verantwoordelijk voor. Het pakket dat vanuit Ubuntu komt is gedicht.

Voor discussies over of een pakket dat je "van buiten haalt" ook een lek in Ubuntu zelf kan veroorzaken kan je beter een nieuw topic openen.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Ddosbot linux?
« Reactie #9 Gepost op: 2014/01/29, 13:56:22 »
Als je zelf dingen van buiten de repository's installeert dan ben je daar ook zelf verantwoordelijk voor. Het pakket dat vanuit Ubuntu komt is gedicht.

Voor discussies over of een pakket dat je "van buiten haalt" ook een lek in Ubuntu zelf kan veroorzaken kan je beter een nieuw topic openen.

Waarom een nieuw topic? De TS heeft het over LINUX. Ik zie niet dat ie specificeert het over OpenJDK en/of Ubuntu te hebben.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Ddosbot linux?
« Reactie #10 Gepost op: 2014/01/29, 14:17:43 »
Zo moeilijk is het toch niet? Het gat zit in Java. En het pakket dat Java bevat dat door Ubuntu geleverd wordt is opgelapt. Dus het lek in Ubuntu zelf is dicht.

Als jij discussies aan wil gaan of een lek in een pakket dat van derden afkomstig is ook betekent dat er een lek in Ubuntu zit, dan is dat hier niet de bedoeling. We gaan ook niet bij MS klagen als er een lek zit in Java. Dat is het probleem van Oracle en niet van MS.

Maar zoals je hier en hier kan zien is het lek in Ubuntu in juli al gedicht.

Ehm, nee. Het gat is gedicht in Ubuntu's OPENJDK. Maar niet iedere Linux-gebruiker gebruikt OpenJDK, velen gebruiken ook Oracle Java waar het gat nog steeds in zit.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Ddosbot linux?
« Reactie #11 Gepost op: 2014/01/29, 14:32:39 »
Oké, maar zou je dan de topictitel en de tekst van de startpost willen aanpassen? Want Linux is niet alleen Ubuntu en de TS vraagt of Linux binnen te dringen is, niet of Ubuntu binnen te dringen is...
« Laatst bewerkt op: 2014/01/29, 14:49:34 door Vistaus »

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Ddosbot linux?
« Reactie #12 Gepost op: 2014/01/29, 15:16:18 »
Zoals al eerder gezegd: het is alleen Java.
Linux is zo kwetsbaar als het zwakste stukje code dat aangevallen wordt. Hoevaak zie je dit soort topics als er weer eens een update is voor Firefox, Chrome, de Flashplugin of andere onderdelen?

Offline testcees

  • Documentatieteam
    • testcees
    • www.testcees.nl
  • Steunpunt: Nee
Re: Ddosbot linux?
« Reactie #13 Gepost op: 2014/01/29, 15:57:51 »
Het gevaar zit weer tussen toetsenbord en stoel.
Vervelend voor je. ;)
Kan (in een volgende versie) ~/.bashrc worden gebruikt? Daar zijn geen rootrechten voor nodig.
Via Java is er van alles mogelijk...
Maar zoals je hier en hier kan zien is het lek in Ubuntu in juli al gedicht.
Ook Oracle heeft dit lek (juni 2013) gedicht. Alleen up-to-date versies gebruiken dus.
De nieuwswaarde van dit bericht zie ik niet als waarschuwing ‘dat je kan worden geïnfecteerd’ maar inderdaad dat ook als je Linux gebruikt ‘er van alles mogelijk is’. :evil:
As of this date, few viruses have actually been discovered for Linux, and the ones that have been discovered aren't worth losing sleep over. This will undoubtedly change with time.
Klik links bovenin op Documentatie

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Ddosbot linux?
« Reactie #14 Gepost op: 2014/01/29, 16:12:50 »
Nee, alleen als je Ubuntu gebruikt, niet Linux. Zie Johans post.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Ddosbot linux?
« Reactie #15 Gepost op: 2014/01/29, 16:19:09 »
Als je toch per se wil mierenneuken: Linux is alleen de kernel. En zonder alles wat daar verder bij hoort kan je verder niks.
Wil je daarom stoppen Vistaus? Dit begint behoorlijk vervelend te worden.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Ddosbot linux?
« Reactie #16 Gepost op: 2014/01/29, 20:19:27 »
Ik was keurig ontopic over Java i.c.m. Linux aan het praten en ineens zeg jij dat dit over Ubuntu gaat en dat ik voor Oracle Java en/of Linux een apart topic moet openen... Ik mag dan wel vervelend zijn maar jij hebt het wel een beetje verwarrend gemaakt want waarom zou ik een apart topic moeten openen over iets wat in dit topic wordt besproken? Dat snap ik niet helemaal en ik wacht nog steeds op je uitleg waar ik hierboven al om vroeg... Of wil iemand anders het me uitleggen die snapt wat Johan bedoeld? Want ik snap niet waarom Oracle Java op LINUX offtopic is...
« Laatst bewerkt op: 2014/01/29, 20:34:27 door Vistaus »

Offline asphyxia

  • Forumteam
  • Steunpunt: Nee
Re: Ddosbot linux?
« Reactie #17 Gepost op: 2014/01/29, 21:00:44 »
Alles wordt eigenlijk al samengevat in de fipo en de eerste reactie. Java is niet hetzelfde als OpenJDK.

Wellicht ook aardig de reacties op Webwereld bij dit artikel te lezen, zowaar een bekende reaguurder erbij  ;)
Als de werkelijkheid er niet was, zou de wereld er heel anders uitzien. [Theo Maassen]
Alles is te kraken, niets is veilig, zorg dus voor zoveel mogelijk niets. [Ramana]
It's always darkest before the dawn. [Florence Welch]

Offline niekn

  • Lid
    • omega-xis
  • Steunpunt: Nee
Re: Ddosbot linux?
« Reactie #18 Gepost op: 2014/01/30, 11:06:33 »
De bot dringt systemen trouwens ook gewoon binnen via een gat in de browser-plugin Java dat meer dan een half jaar geleden is gepatcht.
gewoon Updates installeren dus....

Offline BorisM

  • Lid
    • http://www.brandeveen-motoriek.com
  • Steunpunt: Nee
Re: Ddosbot linux?
« Reactie #19 Gepost op: 2014/02/01, 15:31:16 »
Alles wordt eigenlijk al samengevat in de fipo en de eerste reactie. Java is niet hetzelfde als OpenJDK.

Wellicht ook aardig de reacties op Webwereld bij dit artikel te lezen, zowaar een bekende reaguurder erbij  ;)


vertel vertel ik haal hem er niet uit....
Alles komt goed, je weet echter nooit wanneer..

Offline Tom

  • Lid
    • Wanda´s Blog Linux Xubuntu. ♥
  • Steunpunt: Nee
Re: Ddosbot linux?
« Reactie #20 Gepost op: 2014/02/01, 17:32:33 »
1 x Xuby 14.04.5 Lts 64 bits.1 x 16.04.5 Lts. 2 x Xuby 18.04.1 Lts 64 bits. ♥
https://sites.google.com/site/wandabloglinuxxubuntu/pc-s-installeren-configureren.

Offline testcees

  • Documentatieteam
    • testcees
    • www.testcees.nl
  • Steunpunt: Nee
Re: Ddosbot linux?
« Reactie #21 Gepost op: 2014/02/05, 17:01:19 »
Via Java is er van alles mogelijk...
Of met Flash...
Zoals vandaag gemeld door www.waarschuwingsdienst.nl, hoewel de melding met betrekking tot Linux een fout versienummer bevat:
Linux
Maak je gebruik van Flash Player met een versie 11.2.202.336 of lager dan kun je deze updaten via http://get.adobe.com/flashplayer/.
Volgens de omschrijving bovenaan de pagina is voor Linux alleen versie 11.2.202.335 en lager kwetsbaar.
Flash heb ik via Ubuntu softwarecentrum geïnstalleerd (Ubuntu-restricted-extras) en heb na een softwareupdate nu de (nieuwste) versie 11.2.202.336 (Ubuntu 13.10).
Klik links bovenin op Documentatie

Offline asphyxia

  • Forumteam
  • Steunpunt: Nee
Re: Ddosbot linux?
« Reactie #22 Gepost op: 2014/02/05, 19:52:39 »
En wat Flash betreft, waarom loopt Linux toch altijd zo achter met die versies? Ik zie op de site http://www.adobe.com/software/flash/about/
dat Windows 12.0.0.44 heeft en wij met Linux zitten op 11.2.202.336
Waarom is dat en hoe komt dat?

(maar dit is offtopci waarschijnlijk, want de topic gaat over java  ;) ;) )


☑ Er zijn 7.797.708 meer Windows-exploits gevonden
☑ Men is voor Windows gaan tellen vanaf nieuwjaar 2012, en bij Linux vanaf februari 2011 v.w.b. het aantal benodigde patches
☑ Iets anders...

Nogmaals eens blijkt weer hoe noodzakelijk het is dagelijks de updates bij te houden.

OT: Java is de meest gebruikte exploit tegenwoordig (ook al in een ander draadje), de browser-plugin uitschakelen doet al veel. 
Als de werkelijkheid er niet was, zou de wereld er heel anders uitzien. [Theo Maassen]
Alles is te kraken, niets is veilig, zorg dus voor zoveel mogelijk niets. [Ramana]
It's always darkest before the dawn. [Florence Welch]

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Ddosbot linux?
« Reactie #23 Gepost op: 2014/02/05, 20:32:53 »
http://webwereld.nl/beveiliging/57783-alarm-over-kritiek-java-lek-op-windows--mac-en-linux       < Google je vriendje !.  :)

 :o :o artikel van 28 aug. 2012 !!

En wat Flash betreft, waarom loopt Linux toch altijd zo achter met die versies? Ik zie op de site http://www.adobe.com/software/flash/about/
dat Windows 12.0.0.44 heeft en wij met Linux zitten op 11.2.202.336
Waarom is dat en hoe komt dat?

(maar dit is offtopci waarschijnlijk, want de topic gaat over java  ;) ;) )

Dat komt omdat Flash voor Linux alleen nog maar beveiligingsupdates krijgt tot 2015 (of 2016), daarna is het voorbij. Alleen Chrome (en via een trucje Chromium) voor Linux krijgt de nieuwste Flash-versie van Google zelf.

@testcees: Ja, vandaag kreeg ik een update van Flash voor Linux. Jammer genoeg hebben ze de update niet goed getest want embedded Flash doet het niet meer en ik hoorde her en der al dat ik niet de enige met het probleem was... Hoeft niet persé bij iedereen te zijn maar kennelijk op sommige configuraties dus wel.