Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [opgelost] Geen verbinding naar buiten  (gelezen 420 keer)

[opgelost] Geen verbinding naar buiten
« Gepost op: 2014/01/07, 14:17:42 »
Hallo Iedereen,

Na enkele dagen zoeken kom ik er toch niet helemaal uit. Ik heb een server draaien (virtueel) waarmee ik verbinding kan maken op het interne netwerk. Maar extern kan ik mijn server niet bereiken. Ook updaten lijkt niet mogelijk. Wat ik voorheen deed was de virtuele machine opnieuw installeren. Echter, om dat iedere keer te moeten doen loop ik het risico data te verliezen (ja, ik heb een backup) en het kost me gewoon te veel tijd.

Als eerste heb ik mijn instellingen na gekeken voor het netwerk. Deze lijken gewoon in orde:

eth0      Link encap:Ethernet  HWaddr 08:00:27:42:d5:7e 
          inet addr:192.168.*.*  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::a00:27ff:fe42:d57e/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:479 errors:0 dropped:0 overruns:0 frame:0
          TX packets:129 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:35675 (35.6 KB)  TX bytes:15855 (15.8 KB)


Om er zeker van te zijn dat het werkt heb ik mijn instellingen nagekeken in /etc/network/interfaces

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet dhcp
#address 192.168.*.*
#netmask 255.255.255.0
#network 192.168.0.0
#broadcast 192.168.0.255
#gateway 192.168.0.1
#dns-nameservers 8.8.8.8 8.8.4.4

Oke, goed dhcp lijkt niet het antwoord dus dan proberen we static. Dit had ook geen effect, dan maar in de router kijken en daar was ook alles in orde. Na het lezen van diverse artikelen en wiki's kwam ik er nog niet uit en blijf ik zitten met het feit dat ik niet kan updaten en ik kan mijn server niet gebruiken.

Nu is de vraag of ik iets over het hoofd ziet of dat ik iets mis. Zou iemand mij kunnen helpen?
« Laatst bewerkt op: 2014/01/08, 18:54:22 door theancientone »

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: [server 12.04.3] Geen verbinding naar buiten
« Reactie #1 Gepost op: 2014/01/07, 16:13:25 »
Wat voor een server heb je draaien? Elke server heeft nl. zijn eigen instellingen.
Kijk eens op de wiki hoe je deze moet instellen. http://wiki.ubuntu-nl.org/NetwerkenEnServers
In der Beschränkung zeigt sich der Meister.

Re: [server 12.04.3] Geen verbinding naar buiten
« Reactie #2 Gepost op: 2014/01/07, 17:00:32 »
uhm, ik draai een webserver met php voor een installatie van owncloud. Het enige extra dat ik er op draai is ssh. op deze manier heb ik er ook toegang toe.

ik zal ook je link na kijken (ik ben nu niet bij de machine).

Re: [server 12.04.3] Geen verbinding naar buiten
« Reactie #3 Gepost op: 2014/01/08, 09:15:03 »
Ik heb de link bekeken en is erg handig alleen ik kon niet veel terug vinden over het oplossen van het probleem. Ik heb het idee dat dit echt te maken heeft met Ubuntu zelf en niet met de webserver aangezien ik niet kan updaten.

Re: [server 12.04.3] Geen verbinding naar buiten
« Reactie #4 Gepost op: 2014/01/08, 09:47:42 »
Oke, na wat verder zoeken lijkt het er op dat misschien een probleem is aangezien ik deze meldingen nooit eerder gezien heb. Deze meldingen komen van syslog:

Jan  8 09:37:18 user-owncloud6 kernel: [    9.308543] type=1400 audit(1389170238.680:8): apparmor="STATUS" operation="profile_replace" name="/sbin/dhclient" pid=688 comm="apparmor_parser"
Jan  8 09:37:18 user-owncloud6 kernel: [    9.308965] type=1400 audit(1389170238.680:9): apparmor="STATUS" operation="profile_replace" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=688 comm="apparmor_parser"

Wat ik ook vreemd vind maar misschien heeft het met het bovenstaande te maken is dat als ik "networking" herstart dat hij dan zegt "unkown instance":

user@user-owncloud6:~$ sudo service networking restart
stop: Unknown instance:
networking stop/waiting

« Laatst bewerkt op: 2014/01/08, 10:04:01 door theancientone »

Re: [server 12.04.3] Geen verbinding naar buiten
« Reactie #5 Gepost op: 2014/01/08, 18:53:53 »
Hoe ik het voor elkaar heb gekregen weet ik niet. De instellingen van de router staan echt goed maar toch even een reset geprobeerd en wonder boven wonder werkt het gewoon weer.

Ik heb niet eens een dns functie in de router, nou ja geen beheerbare dns.

Mag ik jullie danken voor het lezen en hulp voor het oplossen van dit probleem!