Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Fout: BrokenCount >0  (gelezen 701 keer)

Offline Da Freeze

  • Lid
  • Steunpunt: Nee
Fout: BrokenCount >0
« Gepost op: 2013/12/23, 00:01:00 »
Ik krijg een foutmelding in bestand linux-headers-3.2.0-56 in Ubuntu 12.04
Deze fout heb ik al sinds deze update ergens begin november(?) uitkwam, maar die heb ik vooralsnog genegeerd. Nu blijk ik helemaal geen updates meer te krijgen omdat ik niets nieuws kan installeren als linux-headers-3.2.0-56 niet juist wordt geïnstalleerd.

Dit is de foutmelding in het "verboden in te rijden" icoontje rechts bovenin.
Er is een fout opgetreden. Start pakketbeheer uit het snelmenu of via apt-get in een terminal om te zien wat er mis is. De foutmelding was: Fout: broken count >0. Dit betekent meestal dat softwarepaketten op uw computer afhankelijk zijn van paketten die nog (niet) geïnstalleerd zijn.

Nu vond ik op het web al vele mogelijke oplossingen waaronder
sudo apt-get install -f
Ik krijg vervolgens dit:[i]martijn@Martijn:~$ sudo apt-get install -f
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
Vereisten worden gecorrigeerd... Klaar
De volgende pakketten zijn automatisch geïnstalleerd en zijn niet langer nodig:
  liblaunchpad-integration1 libcogl9 libclutter-gst-1.0-0
  linux-headers-3.2.0-29 libclutter-gtk-1.0-0 libcogl-common
  linux-headers-3.2.0-29-generic-pae compiz-plugins-main python-compizconfig
  libclutter-1.0-0 python-central libcogl-pango0 libclutter-1.0-common
  libgtkspell0
U kunt deze verwijderen via 'apt-get autoremove'.
De volgende extra pakketten zullen geïnstalleerd worden:
  linux-headers-3.2.0-56
De volgende NIEUWE pakketten zullen geïnstalleerd worden:
  linux-headers-3.2.0-56
0 pakketten opgewaardeerd, 1 pakketten nieuw geïnstalleerd, 0 te verwijderen en 108 niet opgewaardeerd.
3 pakketten niet volledig geïnstalleerd of verwijderd.
Er moeten 0 B/11,7 MB aan archieven opgehaald worden.
Door deze operatie zal er 56,3 MB extra schijfruimte gebruikt worden.
Wilt u doorgaan [J/n]? [/i]

[i](Database inlezen ... 756772 files and directories currently installed.)
Uitpakken van linux-headers-3.2.0-56 (uit .../linux-headers-3.2.0-56_3.2.0-56.86_all.deb) ...
dpkg: fout bij afhandelen van /var/cache/apt/archives/linux-headers-3.2.0-56_3.2.0-56.86_all.deb (--unpack):
 unable to create `/usr/src/linux-headers-3.2.0-56/arch/sh/include/asm/processor.h.dpkg-new' (while processing `./usr/src/linux-headers-3.2.0-56/arch/sh/include/asm/processor.h'): Geen ruimte meer over op apparaat
Er is geen apport-verslag weggeschreven omdat de foutmelding een fout is over een volle schijf.
               dpkg-deb: error: subprocess paste was killed by signal (Gebroken pijp)
Fouten gevonden tijdens behandelen van:
 /var/cache/apt/archives/linux-headers-3.2.0-56_3.2.0-56.86_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
martijn@Martijn:~$ ^C
martijn@Martijn:~$ sudo apt-get install -f
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
Vereisten worden gecorrigeerd... Klaar
De volgende pakketten zijn automatisch geïnstalleerd en zijn niet langer nodig:
  liblaunchpad-integration1 libcogl9 libclutter-gst-1.0-0
  linux-headers-3.2.0-29 libclutter-gtk-1.0-0 libcogl-common
  linux-headers-3.2.0-29-generic-pae compiz-plugins-main python-compizconfig
  libclutter-1.0-0 python-central libcogl-pango0 libclutter-1.0-common
  libgtkspell0
U kunt deze verwijderen via 'apt-get autoremove'.
De volgende extra pakketten zullen geïnstalleerd worden:
  linux-headers-3.2.0-56
De volgende NIEUWE pakketten zullen geïnstalleerd worden:
  linux-headers-3.2.0-56
0 pakketten opgewaardeerd, 1 pakketten nieuw geïnstalleerd, 0 te verwijderen en 108 niet opgewaardeerd.
3 pakketten niet volledig geïnstalleerd of verwijderd.
Er moeten 0 B/11,7 MB aan archieven opgehaald worden.
Door deze operatie zal er 56,3 MB extra schijfruimte gebruikt worden.
Wilt u doorgaan [J/n]? j
(Database inlezen ... 756772 files and directories currently installed.)
Uitpakken van linux-headers-3.2.0-56 (uit .../linux-headers-3.2.0-56_3.2.0-56.86_all.deb) ...
dpkg: fout bij afhandelen van /var/cache/apt/archives/linux-headers-3.2.0-56_3.2.0-56.86_all.deb (--unpack):
 unable to create `/usr/src/linux-headers-3.2.0-56/arch/sh/include/asm/device.h.dpkg-new' (while processing `./usr/src/linux-headers-3.2.0-56/arch/sh/include/asm/device.h'): Geen ruimte meer over op apparaat
Er is geen apport-verslag weggeschreven omdat het maximum aantal verslagen (MaxReports) al is bereikt
                     dpkg-deb: error: subprocess paste was killed by signal (Gebroken pijp)
Fouten gevonden tijdens behandelen van:
 /var/cache/apt/archives/linux-headers-3.2.0-56_3.2.0-56.86_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
martijn@Martijn:~$
[/i]

In de uitdraai vind ik deze tekst: Geen ruimte meer over op apparaat

Ik heb e.e.a. opgeschoond en heb 1,8 GB beschikbaar op mijn root. Ik geloof dan ook niet dat ruimtegebrek het probleem is voor de installatie.

Toch lijkt versie 56 wel geïnstalleerd:
martijn@Martijn:~$ uname -a
Linux Martijn 3.2.0-56-generic-pae #86-Ubuntu SMP Wed Oct 23 17:51:27 UTC 2013 i686 athlon i386 GNU/Linux


Hoe kom ik van deze fout af en vervolgens de laatste updates weer installeren?


« Laatst bewerkt op: 2013/12/24, 13:19:20 door Ron »

Offline joop905

  • Lid
  • Steunpunt: Nee
Re: Fout: BrokenCount >0
« Reactie #1 Gepost op: 2013/12/23, 04:18:39 »
Wat is exacte uitkomst van

(Terminal)
sudo df -h  laat de uitkomst eens zien

kijk eens of je nog meer kan opruimen

(Terminal)
sudo apt-get autoremove && sudo apt-get clean all && sudo apt-get autoclean all

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Fout: BrokenCount >0
« Reactie #2 Gepost op: 2013/12/23, 07:14:25 »
En voor als je het nog niet weet, indien je te weinig ruimte op partities hebt, dan vertraagt linux.
Dus houd meer plaats vrij. En 2 GB is te weinig.
En als je bedenkt dat als je bijv met grote files werkt, en en software maakt een temp file aan in je root, dan heb je al een probleem.
« Laatst bewerkt op: 2013/12/23, 07:16:22 door jan11000 »

Offline Da Freeze

  • Lid
  • Steunpunt: Nee
Re: Fout: BrokenCount >0
« Reactie #3 Gepost op: 2013/12/24, 10:37:07 »
Alvast bedankt voor het meedenken jongens!
 
Joop905, dit zie ik:
/dev/sda10          13G      10G  1,6G  87% /
udev               873M     4,0K  873M   1% /dev
tmpfs              352M     908K  351M   1% /run
none               5,0M        0  5,0M   0% /run/lock
none               880M     812K  879M   1% /run/shm
/dev/sda9          106G      80G   27G  76% /media/MP3 & FILMS
martijn@Martijn:~$


Ik kan al 2 jaar probleemloos updaten met minder dan 1 GB, vandaar dat ik het vreemd vind dat ie nu een melding geeft over te weinig ruimte.

sudo apt-get autoremove && sudo apt-get clean all && sudo apt-get autoclean all

Dit commando had ik al geprobeerd, ik win geen extra ruimte meer. Dit is het resultaat van het commando:
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
U kunt 'apt-get -f install' uitvoeren om dit op te lossen.
De volgende pakketten hebben niet-voldane vereisten:
 linux-headers-3.2.0-56-generic-pae : Vereisten: linux-headers-3.2.0-56 maar het is niet geïnstalleerd
E: Er zijn vereisten waaraan niet voldaan is. Probeer -f te gebruiken.


jan11000:
Zijn er bij jou temp-files bekend die ik probleemloos zou kunnen verwijderen?


Offline joop905

  • Lid
  • Steunpunt: Nee
Re: Fout: BrokenCount >0
« Reactie #4 Gepost op: 2013/12/24, 11:15:08 »
 Maak Ubuntu schoon
https://sites.google.com/site/computertip/schoon

En dit had je ook al gedaan sudo apt-get -f install
die schijf of partitie is wel vol 87% / (kan je die niet uitbreiden)



Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Fout: BrokenCount >0
« Reactie #5 Gepost op: 2013/12/24, 11:34:55 »
1.8 G vrij is nog steeds heel wat op een systeempartitie. Anderzijds is een verbruik van 10GB voor een systeempartitie heel veel, tenzij je er ook je /home op hebt.

Probeer eens de "gebroken" kernelpakketten te purgen: aangezien niet goed geïnstalleerd, zal je wellicht niet met die kernel aan het werken zijn. Verwijder bovendien alle oudere kernels: dit zal mogelijk enkele gigabyte vrije ruimte opleveren. Daarba kan je eens terug proberen updaten.

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Fout: BrokenCount >0
« Reactie #6 Gepost op: 2013/12/24, 12:37:06 »
Indien je bleachbit nog kunt installeren, daar kun je temp file(en nadere) verwijderen.
Let wel op dat je niet alles aanvinkt, want dan wordt er teveel weggehaald.

Offline Da Freeze

  • Lid
  • Steunpunt: Nee
Re: Fout: BrokenCount >0
« Reactie #7 Gepost op: 2013/12/24, 14:22:07 »
Maak Ubuntu schoon
https://sites.google.com/site/computertip/schoon

En dit had je ook al gedaan sudo apt-get -f install
die schijf of partitie is wel vol 87% / (kan je die niet uitbreiden)

Het eerste waar ik hier tegenaan loop is dat ik Synaptic niet kan installeren, omdat ik de melding krijg dat ik eerst linux-headers-3.2.0-56-generic-pae moet verwijderen. Maar ik krijg deze kernel niet verwijderd?? Kan ik wellicht nog herstarten naar een oudere kernel?
Bleachbit krijg ik ook niet geïnstalleerd om dezelfde reden.

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Fout: BrokenCount >0
« Reactie #8 Gepost op: 2013/12/24, 14:33:15 »
Om welke kernel draai je nu? Het zou mij verwonderen als het de niet goed geïnstalleerde kernel is.
uname -a

Als je inderdaad draait op die kernel die niet correct geïnstalleerd is (hoe kan dat?), start dan op met een eerdere kernel.

Probeer kernels te verwijderen via de terminal:
sudo apt-get purge linux-<tab>
Druk op de tab toets waar <tab> staat. Je ziet een aantal paketten, waronder linux-headersxxx, linux-imagexxx en linux-extraxxxx. De xxx staat voor de versienummers. Verwijder die pakketten met versienummers van kernels die je niet aan het gebruiken bent.

Offline Da Freeze

  • Lid
  • Steunpunt: Nee
Re: Fout: BrokenCount >0
« Reactie #9 Gepost op: 2013/12/24, 19:22:14 »
Om welke kernel draai je nu? Het zou mij verwonderen als het de niet goed geïnstalleerde kernel is.
uname -a

martijn@Martijn:~$ uname -a
Linux Martijn 3.2.0-56-generic-pae #86-Ubuntu SMP Wed Oct 23 17:51:27 UTC 2013 i686 athlon i386 GNU/Linux

Hij lijkt er wel op te draaien. Ik ga eens kijken of ik kan opstarten vanuit 3.2.0-55.

Hoe kan ik relatief snel oudere kernels verwijderen via de terminal? Als ik
sudo apt-get purge linux-<tab>toepas, worden alle kernels gedetecteerd tot 3.2.0-29....
Eén voor één verwijderen is wel errug veel werk.  =D

Offline Da Freeze

  • Lid
  • Steunpunt: Nee
Re: Fout: BrokenCount >0
« Reactie #10 Gepost op: 2014/01/19, 11:06:51 »
Ik heb het opgelost! Ik denk dat de factor "tijd" er in dit geval een cruciale rol in heeft gespeeld.

Ik kreeg telkens updateproblemen tijdens versie 3.2.0.56, maar ik denk niet dat de kernel de veroorzaker was van deze problemen. Hoe dan ook, omdat de melding van een fout in de kernel kwam, heb ik Updatebeheer->Softwarebronnen->Ubuntu Software alleen Multiverse, Universe en Restricted aangevinkt. Main (door Canonical geleverde software) heb ik heel bewust uit gelaten.

Het resultaat was dat enkele software werd geüpdate en de foutmelding was verdwenen. Nu, 3 weken later heb ik bij Ubuntu Software Main aangevinkt en de overige onderdelen uit. Vandaag kwam de melding dat er 191 onderdelen moesten worden geïnstalleerd, waaronder kernel 3.2.0.58. Deze heb ik geïnstalleerd en alles loopt probleemloos zonder foutmeldingen.

Toch ben ik blij dat Ubuntu een goed zelf herstellend vermogen heeft waar ik soms weinig van begrijp. In ieder geval bedankt voor jullie hulp!