Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Heb je drivers nodig voor een printer?  (gelezen 2509 keer)

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Heb je drivers nodig voor een printer?
« Gepost op: 2013/12/21, 08:35:17 »
Hallo,


ik ga binnenkort een printer kopen. Het is jaren geleden dat ik nog een printer gebruikt heb bij Linux. Daarom wil ik graag weten: moet je zoals vroeger nog drivers gaan zoeken van dat type printer? Of herkent de laptop de printer als je die met de USB-kabel aan de laptop hangt?

Ik hoop dat iemand mij kan helpen. Alvast heel vriendelijk bedankt.

Groetjes,

Els

Offline aartje

  • Lid
  • Steunpunt: Nee
Re: Heb je drivers nodig voor een printer?
« Reactie #1 Gepost op: 2013/12/21, 10:21:03 »
Kijk eens naar de volgende site, daar staan de recommended printers op
aangegeven:

https://help.ubuntu.com/community/Printers

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Heb je drivers nodig voor een printer?
« Reactie #2 Gepost op: 2013/12/21, 10:22:39 »
Tip: koop een HP of een Samsung. Minste kans op problemen met stuurprogramma's.

Offline aartje

  • Lid
  • Steunpunt: Nee
Re: Heb je drivers nodig voor een printer?
« Reactie #3 Gepost op: 2013/12/21, 10:26:32 »
Of een Brother, zij supporten Linux-drivers zelf uitgebreid, zie:
http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Heb je drivers nodig voor een printer?
« Reactie #4 Gepost op: 2013/12/21, 11:53:46 »
HP heeft ook mijn voorkeur. Ze hebben voor elke van hun printers een driver incl. broncode. Vaak werken HP-printers zelfs out-of-the-box op Ubuntu, soms volstaat HPLIP installeren al. En in het ergste geval kun je dus altijd de nieuwste HPLIP met de nieuwste drivers gemakkelijk installeren.


Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Re: Heb je drivers nodig voor een printer?
« Reactie #6 Gepost op: 2013/12/22, 11:47:02 »
Bedankt iedereen voor alle uitleg en websites, daar ben ik heel blij mee. Ik heb het bekeken van die links die jullie gaven en dat zal wel lukken zo.  Heel erg bedankt voor de hulp.

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Re: Heb je drivers nodig voor een printer?
« Reactie #7 Gepost op: 2014/01/10, 20:25:21 »
Zou iemand mij alstublieft willen helpen? Ik ben aan 't proberen geweest de printer te installeren en het lukt niet. Kan iemand mij een beetje stap voor stap zeggen wat ik moet doen? Ik heb dit gekregen in de terminal:

els@els-Satellite-L300:~$ sudo hp-setup
[sudo] password for els:

HP Linux Imaging and Printing System (ver. 3.12.2)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

warning: Qt/PyQt 4 initialization failed.
error: hp-setup requires GUI support (try running with --qt3). Also, try using interactive (-i) mode.
els@els-Satellite-L300:~$ sudo apt-get install sane libsane sane-utils xsane
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
libsane is reeds de nieuwste versie.
sane-utils is reeds de nieuwste versie.
De volgende pakketten zijn automatisch geïnstalleerd en zijn niet langer nodig:
  kde-l10n-nl language-pack-kde-nl linux-headers-3.2.0-29
  linux-headers-3.2.0-29-generic-pae language-pack-kde-nl-base amarok-help-nl
U kunt deze verwijderen via 'apt-get autoremove'.
De volgende extra pakketten zullen geïnstalleerd worden:
  gimp gimp-data libbabl-0.0-0 libgegl-0.0-0 libgimp2.0
  libjavascriptcoregtk-1.0-0 libwebkitgtk-1.0-0 libwebkitgtk-1.0-common
  xsane-common
Voorgestelde pakketten:
  gimp-help-en gimp-help gimp-data-extras hylafax-client mgetty-fax gv gocr
De volgende NIEUWE pakketten zullen geïnstalleerd worden:
  gimp gimp-data libbabl-0.0-0 libgegl-0.0-0 libgimp2.0
  libjavascriptcoregtk-1.0-0 libwebkitgtk-1.0-0 libwebkitgtk-1.0-common sane
  xsane xsane-common
0 pakketten opgewaardeerd, 11 pakketten nieuw geïnstalleerd, 0 te verwijderen en 0 niet opgewaardeerd.
Er moeten 19,5 MB aan archieven opgehaald worden.
Door deze operatie zal er 60,6 MB extra schijfruimte gebruikt worden.
Wilt u doorgaan [J/n]?
Ophalen:1 http://be.archive.ubuntu.com/ubuntu/ precise-updates/main libgimp2.0 i386 2.6.12-1ubuntu1.3 [616 kB]
Ophalen:2 http://be.archive.ubuntu.com/ubuntu/ precise-updates/main gimp-data all 2.6.12-1ubuntu1.3 [1983 kB]
Ophalen:3 http://be.archive.ubuntu.com/ubuntu/ precise/main libbabl-0.0-0 i386 0.0.22-1.1 [78,3 kB]
Ophalen:4 http://be.archive.ubuntu.com/ubuntu/ precise/main libgegl-0.0-0 i386 0.0.22-2ubuntu3 [350 kB]
Ophalen:5 http://be.archive.ubuntu.com/ubuntu/ precise-updates/main libjavascriptcoregtk-1.0-0 i386 1.8.3-0ubuntu0.12.04.1 [1427 kB]
Ophalen:6 http://be.archive.ubuntu.com/ubuntu/ precise-updates/main libwebkitgtk-1.0-common all 1.8.3-0ubuntu0.12.04.1 [756 kB]
Ophalen:7 http://be.archive.ubuntu.com/ubuntu/ precise-updates/main libwebkitgtk-1.0-0 i386 1.8.3-0ubuntu0.12.04.1 [7315 kB]
Ophalen:8 http://be.archive.ubuntu.com/ubuntu/ precise-updates/main gimp i386 2.6.12-1ubuntu1.3 [4755 kB]
Ophalen:9 http://be.archive.ubuntu.com/ubuntu/ precise/universe sane i386 1.0.14-9 [111 kB]
Ophalen:10 http://be.archive.ubuntu.com/ubuntu/ precise/universe xsane-common all 0.998-3ubuntu2 [1815 kB]
Ophalen:11 http://be.archive.ubuntu.com/ubuntu/ precise/universe xsane i386 0.998-3ubuntu2 [271 kB]
19,5 MB opgehaald in 19s (985 kB/s)                                           
Selecting previously unselected package libgimp2.0.
(Database inlezen ... 260586 files and directories currently installed.)
Uitpakken van libgimp2.0 (uit .../libgimp2.0_2.6.12-1ubuntu1.3_i386.deb) ...
Selecting previously unselected package gimp-data.
Uitpakken van gimp-data (uit .../gimp-data_2.6.12-1ubuntu1.3_all.deb) ...
Selecting previously unselected package libbabl-0.0-0.
Uitpakken van libbabl-0.0-0 (uit .../libbabl-0.0-0_0.0.22-1.1_i386.deb) ...
Selecting previously unselected package libgegl-0.0-0.
Uitpakken van libgegl-0.0-0 (uit .../libgegl-0.0-0_0.0.22-2ubuntu3_i386.deb) ...
Selecting previously unselected package libjavascriptcoregtk-1.0-0.
Uitpakken van libjavascriptcoregtk-1.0-0 (uit .../libjavascriptcoregtk-1.0-0_1.8.3-0ubuntu0.12.04.1_i386.deb) ...
Selecting previously unselected package libwebkitgtk-1.0-common.
Uitpakken van libwebkitgtk-1.0-common (uit .../libwebkitgtk-1.0-common_1.8.3-0ubuntu0.12.04.1_all.deb) ...
Selecting previously unselected package libwebkitgtk-1.0-0.
Uitpakken van libwebkitgtk-1.0-0 (uit .../libwebkitgtk-1.0-0_1.8.3-0ubuntu0.12.04.1_i386.deb) ...
Selecting previously unselected package gimp.
Uitpakken van gimp (uit .../gimp_2.6.12-1ubuntu1.3_i386.deb) ...
Selecting previously unselected package sane.
Uitpakken van sane (uit .../sane_1.0.14-9_i386.deb) ...
Selecting previously unselected package xsane-common.
Uitpakken van xsane-common (uit .../xsane-common_0.998-3ubuntu2_all.deb) ...
Selecting previously unselected package xsane.
Uitpakken van xsane (uit .../xsane_0.998-3ubuntu2_i386.deb) ...
Processing triggers for man-db ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for doc-base ...
Processing 1 added doc-base file...
Instellen van libgimp2.0 (2.6.12-1ubuntu1.3) ...
Instellen van gimp-data (2.6.12-1ubuntu1.3) ...
Instellen van libbabl-0.0-0 (0.0.22-1.1) ...
Instellen van libgegl-0.0-0 (0.0.22-2ubuntu3) ...
Instellen van libjavascriptcoregtk-1.0-0 (1.8.3-0ubuntu0.12.04.1) ...
Instellen van libwebkitgtk-1.0-common (1.8.3-0ubuntu0.12.04.1) ...
Instellen van libwebkitgtk-1.0-0 (1.8.3-0ubuntu0.12.04.1) ...
Instellen van gimp (2.6.12-1ubuntu1.3) ...
Instellen van sane (1.0.14-9) ...
Instellen van xsane-common (0.998-3ubuntu2) ...
Instellen van xsane (0.998-3ubuntu2) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
els@els-Satellite-L300:~$  gksudo hp-setup

HP Linux Imaging and Printing System (ver. 3.12.2)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

els@els-Satellite-L300:~$ sudo hp-check -r

HP Linux Imaging and Printing System (ver. 3.12.2)
Dependency/Version Check Utility ver. 14.3

Copyright (c) 2011-14 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the HPLIP supplied tarball   
(.tar.gz or .run) to determine if the proper dependencies are installed to successfully compile HPLIP.   
2. Run-time check mode (-r or --run): Use this mode to determine if a distro supplied package (.deb, .rpm,
etc) or an already built HPLIP supplied tarball has the proper dependencies installed to successfully run.
3. Both compile- and run-time check mode (-b or --both) (Default): This mode will check both of the above
cases (both compile- and run-time dependencies).                                                         

Saving output in log file: hp-check.log

Initializing. Please wait...
 
---------------
| SYSTEM INFO |
---------------

Basic system information:
Linux els-Satellite-L300 3.2.0-58-generic-pae #88-Ubuntu SMP Tue Dec 3 18:00:02 UTC 2013 i686 i686 i386 GNU/Linux

Distribution:
ubuntu 12.04

Checking Python version...
OK, version 2.7.3 installed

Checking PyQt 4.x version...
error: NOT FOUND OR FAILED TO LOAD!

Checking for CUPS...
Status: scheduler is running
warning: Version: (cups-config) Not available. Unable to determine installed version of CUPS.)
error_log is set to level: warn

Checking for dbus/python-dbus...
dbus daemon is running.
python-dbus version: 1.0.0


------------------------
| RUNTIME DEPENDENCIES |
------------------------


Checking for dependency: CUPS - Common Unix Printing System...
OK, found.

Checking for dependency: CUPS DDK - CUPS driver development kit...
warning: NOT FOUND! This is an OPTIONAL/RUNTIME ONLY dependency. Some HPLIP functionality may not function properly.

Checking for dependency: GhostScript - PostScript and PDF language interpreter and previewer...
OK, found.

Checking for dependency: PIL - Python Imaging Library (required for commandline scanning with hp-scan)...
OK, found.

Checking for dependency: PolicyKit - Administrative policy framework...
OK, found.

Checking for dependency: PyQt 4 DBus - DBus Support for PyQt4...
error: NOT FOUND! This is a REQUIRED/RUNTIME ONLY dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: Python DBus - Python bindings for DBus...
OK, found.

Checking for dependency: Python libnotify - Python bindings for the libnotify Desktop notifications...
OK, found.

Checking for dependency: Python XML libraries...
OK, found.

Checking for dependency: Python 2.3 or greater - Required for fax functionality...
OK, found.

Checking for dependency: Reportlab - PDF library for Python...
OK, found.

Checking for dependency: SANE - Scanning library...
OK, found.

Checking for dependency: scanimage - Shell scanning program...
OK, found.

Checking for dependency: xsane - Graphical scanner frontend for SANE...
OK, found.


----------------------
| HPLIP INSTALLATION |
----------------------


Currently installed HPLIP version...
HPLIP 3.12.2 currently installed in '/usr/share/hplip'.

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf.  Generated from hplip.conf.in by configure.

[hplip]
version=3.12.2

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/hplip/HP
ppdbase=/usr/share/ppd/hplip
doc=/usr/share/doc/hplip-doc/HTML
icon=no
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv

# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
pp-build=yes
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=yes
foomatic-drv-install=yes
foomatic-ppd-install=yes
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.12.2
restricted-build=no
ui-toolkit=qt4
qt3=no
qt4=yes
policy-kit=yes
hpijs-only-build=no
lite-build=no
udev-acl-rules=yes
hpcups-only-build=no
hpijs-only-build=no


Current contents of '/var/lib/hp/hplip.state' file:
# hplip.state - HPLIP runtime persistent variables.

[plugin]
installed=0
eula=0



Current contents of '~/.hplip/hplip.conf' file:
[last_used]
device_uri = hp:/par/DESKJET_3820?device=/dev/parport0



--------------------------
| DISCOVERED USB DEVICES |
--------------------------

No devices found.

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

 
Deskjet-3520-series
-------------------
Type: Unknown
Device URI: usb://HP/Deskjet%203520%20series?serial=CN38U1C05Y05SY&interface=1
PPD: /etc/cups/ppd/Deskjet-3520-series.ppd
PPD Description: HP Deskjet 3500, hpcups 3.12.2
Printer Rendering completedkjet-3520-series is idle.  enabled since vr 10 jan 2014 20:15:48 CET
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend to function in HPLIP.


----------------------
| SANE CONFIGURATION |
----------------------

'hpaio' in '/etc/sane.d/dll.conf'...
'hpaio' in '/etc/sane.d/dll.d/hplip'...
OK, found. SANE backend 'hpaio' is properly set up.

Checking output of 'scanimage -L'...
 
No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).


---------------------
| PYTHON EXTENSIONS |
---------------------

Checking 'cupsext' CUPS extension...
OK, found.

Checking 'pcardext' Photocard extension...
OK, found.

Checking 'hpmudext' I/O extension...
OK, found.

Checking 'scanext' SANE scanning extension...
OK, found.


 
-----------------
| USB I/O SETUP |
-----------------

Checking for permissions of USB attached printers...

HP Device 0xb011 at 002:004:
    Device URI: hp:/usb/Deskjet_3520_series?serial=CN38U1C05Y05SY
error: Unsupported model: Deskjet_3520_series

---------------
| USER GROUPS |
---------------

root

error: User needs to be member of group 'lp' to enable print, scan & fax.
error: User needs to be member of group 'lpadmin' to manage printers.

-----------
| SUMMARY |
-----------

error: 4 errors and/or warnings.

Please refer to the installation instructions at:
http://hplip.sourceforge.net/install/index.html


Ik heb geen enkel idee hoe ik die printer aan de praat kan krijgen in Ubunut. Ik heb Ubuntu 12.04. Ik heb de all-in-one printer gekocht HP Deskjet 3520 (printen, scannen, kopiëren).
« Laatst bewerkt op: 2014/01/10, 20:30:23 door Els Stevens »

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Heb je drivers nodig voor een printer?
« Reactie #8 Gepost op: 2014/01/10, 20:27:51 »
Systeeminstellingen --> Printers

Probeert het eerst daar eens om hem toe te voegen voordat je hplip erbij gaat halen.

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Re: Heb je drivers nodig voor een printer?
« Reactie #9 Gepost op: 2014/01/10, 20:32:41 »
Hij staat daar bij, de printer. Maar als ik de testpagina wil afdrukken gebeurt er niets, dan zegt hij testpagina afdrukken en eventjes later afdrukken voltooid, maar er is niks gebeurd. Er staat geen locatie bij de printer.

Op het schermke van de printer staat "Geen computer gevonden. Zorg ervoor dat de printersoftware is geïnstalleerd op uw computer en dat scannnen naar computer is ingeschakeld via de printersoftware". Ik wou een scan maken maar dat blijft heel de tijd op het scherm staan en er gebeurt niks.
« Laatst bewerkt op: 2014/01/10, 20:35:56 door Els Stevens »

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Heb je drivers nodig voor een printer?
« Reactie #10 Gepost op: 2014/01/10, 20:35:46 »
Via USB of WiFi?

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Re: Heb je drivers nodig voor een printer?
« Reactie #11 Gepost op: 2014/01/10, 20:36:33 »
Ik wil hem via USB laten werken.

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Re: Heb je drivers nodig voor een printer?
« Reactie #12 Gepost op: 2014/01/10, 20:38:59 »
Ik heb daarnet updates gehad, zou het kunnen dat ik eens de laptop moet afsluiten en terug moet opzetten? Dat er misschien iets van printerupdates is geïnstalleerd ondertussen?

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Heb je drivers nodig voor een printer?
« Reactie #13 Gepost op: 2014/01/10, 21:21:07 »
Ik heb daarnet updates gehad, zou het kunnen dat ik eens de laptop moet afsluiten en terug moet opzetten? Dat er misschien iets van printerupdates is geïnstalleerd ondertussen?

Kan geen kwaad om te proberen inderdaad.

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Re: Heb je drivers nodig voor een printer?
« Reactie #14 Gepost op: 2014/01/10, 21:56:32 »
Ik heb hem juist een kopie kunnen laten maken maar scannen wil nog niet werken. De printer zegt nog altijd "Geen computer gevonden. Zorg ervoor dat de printersoftware is geïnstalleerd op uw computer en dat scannnen naar computer is ingeschakeld via de printersoftware".  Ik heb geen flauw idee hoe ik dat moet doen, welke stappen ik daarvoor moet volgen.
Ik heb ondertussen de laptop afgesloten en terug opgestart omdat ik updates had.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Heb je drivers nodig voor een printer?
« Reactie #15 Gepost op: 2014/01/10, 22:10:44 »
Probeer je te scannen met het standaardprogramma (Simple Scan)? Zo ja, dan zou ik een ander programma adviseren zoals bijv. XSane of GIMP want Simple Scan heb ik zelf ook de ervaring mee dat ie mijn scanner (all-in-one HP) nooit vindt...

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Re: Heb je drivers nodig voor een printer?
« Reactie #16 Gepost op: 2014/01/10, 22:16:44 »
Alledrie de programma 's die u zegt staan geïnstalleerd als ik in het softwarecentrum kijk. Ik had gewoon op het scherm van de printer voor "Scannen" gekozen en hij wil het niet doen.
Ik weet daar niks van, van die instellingen, ik heb geen idee hoe je kan aanduiden met welk programma hij moet scannen.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Heb je drivers nodig voor een printer?
« Reactie #17 Gepost op: 2014/01/10, 22:27:43 »
Je kunt gewoon XSane of GIMP opstarten via de Dash (Ubuntu-logo linksbovenin) :)

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Re: Heb je drivers nodig voor een printer?
« Reactie #18 Gepost op: 2014/01/10, 22:32:00 »
Goed dat u er bent want dat wist ik nog niet eens, ik had daar nog nooit op gelet en nog nooit die dingen gebruikt. Ik ga het dadelijk proberen, eerst eens proberen een documentje te printen.

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Re: Heb je drivers nodig voor een printer?
« Reactie #19 Gepost op: 2014/01/10, 22:41:53 »
Met Gimp kan ik totaal niet overweg, ik heb geen enkel idee hoe dat werkt. Ik heb een document liggen om te scannen naar de computer en ik krijg te zien dat er geen scanners gevonden zijn. Ik heb absoluut geen idee hoe ik die scanner aan de praat kan krijgen.

Ik heb geprobeerd een tekst af te printen en dat wil ook maar niet lukken. Xsane vindt geen apparaten, geen apparaten aanwezig stond er.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Heb je drivers nodig voor een printer?
« Reactie #20 Gepost op: 2014/01/10, 22:45:51 »
Hmm, volgens http://www.openprinting.org/printer/HP/HP-DeskJet_3520 zou het gewoon moeten werken (met evt. HPLIP)... Probeer HPLIP nog eens? (of sudo hp-setup, dat start dezelfde wizard)

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Re: Heb je drivers nodig voor een printer?
« Reactie #21 Gepost op: 2014/01/10, 22:50:38 »
Dan krijg ik dit te zien:

els@els-Satellite-L300:~$ sudo hp-setup
[sudo] password for els:

HP Linux Imaging and Printing System (ver. 3.12.2)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

warning: Qt/PyQt 4 initialization failed.
error: hp-setup requires GUI support (try running with --qt3). Also, try using interactive (-i) mode.
els@els-Satellite-L300:~$

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Heb je drivers nodig voor een printer?
« Reactie #22 Gepost op: 2014/01/10, 22:53:17 »
Hmm, pyqt4 ontbreekt...

sudo apt-get install python-qt4

En daarna nog eens sudo hp-setup?

Offline Els Stevens

  • Lid
  • Steunpunt: Nee
Re: Heb je drivers nodig voor een printer?
« Reactie #23 Gepost op: 2014/01/10, 22:59:05 »
Nu gaat er eindelijk iets meer gebeuren maar nu zegt hij als ik USB aanduid No devices found, terwijl de printer op staat en de usb insteekt.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Heb je drivers nodig voor een printer?
« Reactie #24 Gepost op: 2014/01/10, 23:00:12 »
Heb je de printer direct in de PC zitten, zonder USB-hubje? Zo ja, probeer dan eens een andere poort en laat hp-setup opnieuw zoeken naar printers.