Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Foutmelding na schone installatie  (gelezen 319 keer)

Offline martijn1985

  • Lid
  • Steunpunt: Nee
Foutmelding na schone installatie
« Gepost op: 2013/11/20, 19:29:53 »
Het probleem
Van de ene op de andere dag wil ubuntu 13.04 niet meer opstarten. Ik kan me niet herinneren dat ik iets abnormaals heb gedaan, dus ik vermoed dat er een of andere update is geïnstalleerd. Ik krijg de melding 'gave up waiting for root device' (vergelijkbaar met deze), en ik val terug op een initramfs prompt.

Wat heb ik al gedaan?
  • grub opnieuw geinstalleerd met Boot-repair
  • Ubuntu 13.10 geinstalleerd
  • harde schijf opnieuw gepartitioneerd (wilde ik sowieso al doen om andere redenen)
  • Ubuntu 13.04 opnieuw geinstalleerd
  • GSMartControl uitgevoerd om de staat van de harde schijf te inspecteren, dit lijkt niet het probleem. Geen recente fouten en zonder problemen door de short self-test
  • in initramfs 'exit' ingevoerd om te zien of hij doorstart

Relevante Output
test@martijn-GA-MA78GM-S2H:~$ sudo blkid
[sudo] password for test:
/dev/sda1: UUID="393cbbd0-d164-4ecb-8b83-b8a960e0ded2" SEC_TYPE="ext2" TYPE="ext3"
/dev/sda2: UUID="0cdf674b-cc94-46c7-adae-6bec64c35a75" TYPE="swap"
/dev/sda3: LABEL="Homeschijf" UUID="f748b552-1d66-42f3-bb84-d1fd347b9ee7" TYPE="ext3"
/dev/sda4: UUID="c250e77b-3204-489f-8c4d-93e04fde5d54" TYPE="
13.04 staat op /dev/sda1 en wil dus niet opstarten. Ik werk nu vanaf /dev/sda4 waar 12.04 op staat, deze doet het zonder problemen.

Boot-repair log: klik (gemaakt vanaf een live-USB, dus vandaar een /dev/sdb, er zit normaal maar 1 harde schijf in)

Mijn vraag
Hoe krijg ik 13.04 weer opgestart?

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Foutmelding na schone installatie
« Reactie #1 Gepost op: 2013/11/20, 20:07:55 »
Mijn vraag
Hoe krijg ik 13.04 weer opgestart?
Mijn tegenvraag: waarom wil je ├╝berhaupt nog 13.04? Die is over twee maanden al zo dood als een pier (krijgt dan geen veiligheidsupdates meer)...

En waarom EXT3 in plaats van de veel betere EXT4?
« Laatst bewerkt op: 2013/11/20, 20:16:11 door Pjotr »

Offline martijn1985

  • Lid
  • Steunpunt: Nee
Re: Foutmelding na schone installatie
« Reactie #2 Gepost op: 2013/11/20, 22:03:21 »
Ik had 13.10 geinstalleerd, maar die startte ook niet op. Ik had ergens gelezen dat dat zou kunnen komen door bugs met UEFI, dus daarom ben ik in eerste instantie teruggegaan naar 13.04, maar die startte dus ook niet op. Ik wil nu eerst eens kijken of ik ervoor kan zorgen dat dat in elk geval weer werkt voordat ik ga upgraden, want een schone installatie lost tot nu toe in elk geval niets op. Het is niet zo dat ik per se weer naar 13.04 toe wil, maar dat is wel wat er nu op staat en waarvan ik weet dat het in principe ook zou moeten werken.

Offline Paul Matthijsse

  • Lid
  • Steunpunt: Nee
Re: Foutmelding na schone installatie
« Reactie #3 Gepost op: 2013/11/20, 22:52:31 »
Kan je niet direct helpen maar vraag me wel een paar dingen af:
- waarom gebruik je ext3 ipv. ext4?
- dat sec_type=ext2 heb ik nooit eerder gezien: is dat vanwege een versleutelde harde schijf misschien?
- waarom heeft je sda4 geen type=-aanduiding?
https://allesgimpofbijna.wordpress.com - GIMP en omstreken
https://paulsphotopalace.wordpress.com (Engelstalig) - Raw, RawTherapee, G'MIC, GIMP...

Offline martijn1985

  • Lid
  • Steunpunt: Nee
Re: Foutmelding na schone installatie
« Reactie #4 Gepost op: 2013/11/20, 23:16:56 »
Ik heb ooit op die schijven op ext3 gezet en had er verder niet erg lang over nagedacht. Blijkbaar kun je schijven omzetten van ext3 naar ext4 zonder te formatteren, dus dat heb ik gedaan. Dat sec_type=ext2 schijnt te betekenen dat je een ext3 schijf ook als ext2 kunt mounten als ext3 om de een of andere reden niet kan (secondary type, niet secure), maar dat is nu ook weg, zie code. Sda3 zet ik nog wel een keer over, dat is alleen data en krijg ik nu ontmount.

test@martijn-GA-MA78GM-S2H:~$ sudo blkid
/dev/sda1: UUID="393cbbd0-d164-4ecb-8b83-b8a960e0ded2" TYPE="ext4"
/dev/sda2: UUID="0cdf674b-cc94-46c7-adae-6bec64c35a75" TYPE="swap"
/dev/sda3: LABEL="Homeschijf" UUID="f748b552-1d66-42f3-bb84-d1fd347b9ee7" TYPE="ext3"
/dev/sda4: UUID="c250e77b-3204-489f-8c4d-93e04fde5d54" TYPE="ext4"

Offline Paul Matthijsse

  • Lid
  • Steunpunt: Nee
Re: Foutmelding na schone installatie
« Reactie #5 Gepost op: 2013/11/20, 23:25:12 »
Groot voordeel van sda4 tov. 3 is dat de automatische schijf check veel en veel korter is, seconden versus minuten. Voor de rest vrees ik dat ik je - zoals ik eerder al aangaf - niet verder kan helpen.
https://allesgimpofbijna.wordpress.com - GIMP en omstreken
https://paulsphotopalace.wordpress.com (Engelstalig) - Raw, RawTherapee, G'MIC, GIMP...