Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Probleem bij installeren (dependencies)  (gelezen 1035 keer)

Offline Carharttguy

  • Lid
  • Steunpunt: Nee
Probleem bij installeren (dependencies)
« Gepost op: 2013/11/10, 17:42:50 »
Hello

Ik probeer een oudere versie van RealStudio te installeren, en krijg deze error:

dpkg: dependency problems prevent configuration of realstudio2012r2.1:
 realstudio2012r2.1 is afhankelijk van libc6 (>= 2.3).
 realstudio2012r2.1 is afhankelijk van libexpat1 (>= 1.95.8).
 realstudio2012r2.1 is afhankelijk van libglib2.0-0 (>= 2.2.0).
 realstudio2012r2.1 is afhankelijk van libgtk2.0-0 (>= 2.2.0).

Volgens mij voldoe ik precies aan alle voorwaarden, want ik heb toch een hogere versie? Wel nog rekening mee te houden dat RealStudio 32bit is, en ik een 64bit systeem heb.

Weet iemand een oplossing van mijn probleem?

Hartelijk bedankt!

Offline joop905

  • Lid
  • Steunpunt: Nee
Re: Probleem bij installeren (dependencies)
« Reactie #1 Gepost op: 2013/11/10, 17:57:47 »
Als je een 32 bit programma wilt installeren op een 64bit pc

sudo apt-get install ia32-libs
deze moet even met de hand installeren
libc6
libexpat1
libglib2.0-0
libgtk2.0-0

Offline Carharttguy

  • Lid
  • Steunpunt: Nee
Re: Probleem bij installeren (dependencies)
« Reactie #2 Gepost op: 2013/11/10, 18:08:06 »
Ik heb die ia32-libs proberen installeren:

Citaat
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
Pakket ia32-libs is niet beschikbaar, hoewel er naar verwezen wordt door
een ander pakket. Mogelijk betekent dit dat het pakket ontbreekt,
verouderd is, of enkel beschikbaar is van een andere bron
Echter, de volgende pakketten vervangen dit:
  lib32z1 lib32ncurses5 lib32bz2-1.0

E: Pakket 'ia32-libs' heeft geen kandidaat voor installatie

Bij het installeren van libc6 krijg ik:

Citaat
akketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
libc6 is reeds de nieuwste versie.
U wilt waarschijnlijk 'apt-get -f install' uitvoeren om volgende op te lossen:
De volgende pakketten hebben niet-voldane vereisten:
 realstudio2012r2.1:i386 : Vereisten: libc6:i386 (>= 2.3) maar het zal niet geïnstalleerd worden
                           Vereisten: libexpat1:i386 (>= 1.95.8) maar het zal niet geïnstalleerd worden
                           Vereisten: libglib2.0-0:i386 (>= 2.2.0) maar het zal niet geïnstalleerd worden
                           Vereisten: libgtk2.0-0:i386 (>= 2.2.0) maar het zal niet geïnstalleerd worden
                           Aanbevelingen: libgtkhtml3.8-15:i386 (>= 3.12.1) maar het is niet installeerbaar
E: Er zijn niet-voldane vereisten. U kunt best 'apt-get -f install' uitvoeren zonder pakketten op te geven, (of u kunt zelf een oplossing specificeren).

Die apt-get -f install lijkt ook niet te werken, want als ik dat deb bestand meegeef, vind hij het gelijk niet.
Bij libexpat1, libglib2.0-0 en libgtk2.0-0 hetzelfde verhaaltje jammer genoeg.

Voor mensen die op 13.10 zitten, dit is het bestand in kwestie dat ik probeer te installeren. Het is geen freeware, maar het is niet illegaal om dit bestand te delen, installeren zonder key kan, maar gebruiken zonder key mag duidelijk niet. https://www.dropbox.com/s/tws7jzmd7fc6e35/RealStudio2012r21.deb


Offline Cheap Applications

  • Lid
  • Steunpunt: Nee
Re: Probleem bij installeren (dependencies)
« Reactie #3 Gepost op: 2013/11/10, 18:31:15 »
Backports uitvinken en vervolgens:
sudo apt-get updateLukt het dan wel?
Desktop:
Processor: Intel® Core™2 Quad CPU Q8300 @ 2.50GHz × 4, Geheugen: 3.9Gb, GPU: nVidia 220GT OS: Windows 7 64 bit / Ubuntu 12.04 64 bit
Notebook:
Processor: Intel® Core™ i7-4700MQ, Geheugen: 8Gb, GPU: nVidia GTX765m (met Optimus) OS: Windows 8 64 bit / Elementary OS Luna 64 bit

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Probleem bij installeren (dependencies)
« Reactie #4 Gepost op: 2013/11/10, 20:01:34 »
sudo apt-get -f install

En dan, om een 32-bit-pakket te installeren, doe: sudo dpkg -i --force-architecture RealStudio2012r21.deb