Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Problemen na dualboot installatie: geen grubmenu  (gelezen 667 keer)

Offline Elvje

  • Lid
  • Steunpunt: Nee
Problemen na dualboot installatie: geen grubmenu
« Gepost op: 2013/11/06, 18:45:36 »
Hallo,

Ik heb vandaag mijn nieuwe laptop, een Medion E6227 ontvangen.
Helaas een windows 8 laptop, dus ik probeerde Ubuntu er naast te installeren. Ik heb hiervoor keurig de tips van de computertipsite gevolgd.
Secure boot uitgeschakeld en windows boot manager onderaan in de lijst gezet.

Tijdens de installatie herkende Ubuntu Windows niet, dus m gparted heb ik de partities gemaakt en vervolgens Ubuntu geïnstalleerd.

Nu, na het installeren en dus bij het gewoon opstarten, verschijnt er heel kort een aantal keer de error: efidisk read error, een aantal keer onder elkaar.
Vervolgens een paar schermpje van ubuntu, zwart, zwart zwart en dan start Ubuntu op. Niets geen grub of een keuzemenu.
Windows bestaat nog wel, wanneer ik tijdens het opstarten F10 druk, kan ik voor windows boot manager kiezen en dan werkt Windows 8 nog.

Wie kan mij helpen om mijn laptop op een normale manier te laten functioneren?

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Problemen na dualboot installatie: geen grubmenu
« Reactie #1 Gepost op: 2013/11/06, 19:03:27 »
Windows bestaat nog wel, wanneer ik tijdens het opstarten F10 druk, kan ik voor windows boot manager kiezen en dan werkt Windows 8 nog.
Het probleem is dus gelukkig meer cosmetisch dan praktisch.... Grub herkent Windows 8 niet, en start daarom direct Ubuntu op. Maar via de F10-toets kun je toch nog Windows 8 opstarten, wanneer je dat wil. Dus praktisch is er niet veel aan de hand.  :)

Een oplossing om in dit geval Grub Windows 8 te laten herkennen zie ik niet 1-2-3: dat zal "vanzelf" goed moeten komen door een nieuwere of gerepareerde Grubversie, denk ik.

Welke Ubuntuversie is het trouwens? Op mijn Windows 8-proefbak had ik namelijk hetzelfde verschijnsel als jij, met Ubuntu 12.04.3 LTS. In Ubuntu 13.10 daarentegen, herkent Grub Windows 8 wel degelijk op mijn proefbak, en zet-ie 'm dus ook netjes in het Grubmenu.

Mocht het bij jou ook om 12.04 LTS gaan, dan zou ik dat overigens geen reden vinden om over te stappen naar de gewone tussenversie 13.10: een LTS-versie is immers altijd beter dan een tussenversie, en het probleem is in de praktijk nauwelijks hinderlijk.
« Laatst bewerkt op: 2013/11/06, 19:13:18 door Pjotr »

Offline Elvje

  • Lid
  • Steunpunt: Nee
Re: Problemen na dualboot installatie: geen grubmenu
« Reactie #2 Gepost op: 2013/11/06, 20:52:38 »
Alvast bedankt voor de reactie!

Ik gebruik inderdaad nog 12.04 LTS, met de reden dat het een LTS is.
Het was inderdaad wel een opluchting dat Windows nog wel bestond  :)

Ubuntu is inderdaad mijn hoofd-besturingsprogramma, dus dat is nog een gelukje. Als ik de Windows Bootmanager omhoog schuif in de boot options, start hij wel (enkel) op in Windows. Ik weet nu in wat ik zou kunnen doen mocht het hinderlijk gaan worden.

Kunnen die foutmeldingen nog kwaad?  Die verdwijnen overigens als Windows Bootmanager onderaan staat. Of is dat ook te wijten aan de Grub? (Ik hou niet zo van foutmeldingen).

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Problemen na dualboot installatie: geen grubmenu
« Reactie #3 Gepost op: 2013/11/06, 22:59:43 »
Kunnen die foutmeldingen nog kwaad?  Die verdwijnen overigens als Windows Bootmanager onderaan staat. Of is dat ook te wijten aan de Grub? (Ik hou niet zo van foutmeldingen).
Linux is altijd erg eerlijk met foutmeldingen, ook als ze volkomen onschuldig zijn en geen enkel probleem opleveren. Deze foutmelding is naar alle waarschijnlijkheid zo'n onschuldig probleem.  :)