Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: OPGELOST Ubuntu niet op kunnen starten in combinatie met windows 8  (gelezen 1274 keer)

Offline daido

  • Lid
  • Steunpunt: Nee
Ik heb een asus vivo S300ca en ik heb er ubuntu 13.10 op gezet. Ik heb naar Pjotr tips gekeken.
Als  eerste stap heb ik dit http://support.asus.com/FAQ/Detail.aspx?SLanguage=en&no=8AEDC590-B808-710B-1877-4E94E38B8FD9&p=3&m=S300CA gedaan. (de acer beschrijving is niet te gebruiken op de asus)
Vervolgens bij het opstarten krijg ik gewoon windows 8 en geen grub menu.
Launch en Launch PXE OpRom staan ingeschakeld.
https://sites.google.com/site/computertip/windows#TOC-Zet-Windows-Boot-Manager-onderaan-in-de-opstartvolgorde
Zoals Pjotr beschrijft staat windows bootmanager ingeschakeld.
Op mijn bios staat
-Windows Bootmanager
-Atheros Boot agent
-Disabled
Wat te doen?
MAAR GEEN HDD
Dus ik kan de bootoptie niet veranderen.
« Laatst bewerkt op: 2013/11/04, 12:51:41 door daido »

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Ubuntu niet op kunnen starten in combinatie met windows 8
« Reactie #1 Gepost op: 2013/11/01, 15:18:30 »
Heb je Secure Boot nog steeds uit staan en launch CSM nog steeds ingeschakeld (zoals moest om ├╝berhaupt te kunnen installeren)?

En waar staat die "disabled" voor?

Tot slot: draait-ie al op de nieuwste BIOS (UEFI)?
http://support.asus.com/download.aspx?SLanguage=en&p=3&s=38&m=S300CA&os=&hashedid=A3KUR073OVSlf1ze

Zo niet, gooi dan alsnog de nieuwste versie erop (305) en kijk dan eens opnieuw in de instellingen.
« Laatst bewerkt op: 2013/11/01, 15:39:47 door Pjotr »

Offline daido

  • Lid
  • Steunpunt: Nee
Re: Ubuntu niet op kunnen starten in combinatie met windows 8
« Reactie #2 Gepost op: 2013/11/01, 15:56:20 »
Heb je Secure Boot uitgezet en launch CSM ingeschakeld, zoals ook op die pagina van Asus staat?

En waar staat die "disabled" voor?

Tot slot: draait-ie al op de nieuwste BIOS (UEFI)?
http://support.asus.com/download.aspx?SLanguage=en&p=3&s=38&m=S300CA&os=&hashedid=A3KUR073OVSlf1ze

Zo niet, gooi dan alsnog de nieuwste versie erop (305) en kijk dan eens opnieuw in de instellingen.
Secure Boot staat uit en Launch csm aan.
Enabled staat alleen onder om -Windows Bootmanager en Atheros Boot agent ui te schakelen.
Er staat trouwens ook add boot option. Als ik dat aanklik krijg ik SELECT FILESYSTEM. Dan kan ik invoeren:
PCI(1F!2)Devicpath (type 3, subtype 12 (Part 1, Sig03059cfo-2a7a-43bd-88b6-112418ad1baa)
Ik heb de windows bootmanager en atheros boot disabled en geprobeerd  add boot option met bovenstaande filesysteem in te schakelen. als ik dan probeer op te starten kom ik weer in het biossysteem.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Ubuntu niet op kunnen starten in combinatie met windows 8
« Reactie #3 Gepost op: 2013/11/01, 18:35:11 »
En hoe zit 't met de BIOS-versie (zie mijn eerdere bericht)?

Offline daido

  • Lid
  • Steunpunt: Nee
Re: Ubuntu niet op kunnen starten in combinatie met windows 8
« Reactie #4 Gepost op: 2013/11/01, 21:27:26 »
Er  is een nieuwere Bios-versie, maar ik ben eerst  gaan klooien met "add boot option". Dat was geen goed idee, omdat nu een aantal instellingen van de bios gewist zijn.
Ik moet even kijken hoe ik de nieuwe versie moet flashen met windows 8.1.
Krijg ik  met een de nieuwere  bios-versie de gewiste instellingen terug?
Wat een gedoe met die uefi, dat is niet bevordelijk voor beginners om ubuntu te installeren.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Ubuntu niet op kunnen starten in combinatie met windows 8
« Reactie #5 Gepost op: 2013/11/01, 21:39:57 »
BIOS/UEFI kun je altijd terugzetten op de standaardwaarden. Is altijd een optie, ergens in de instellingen.

Offline daido

  • Lid
  • Steunpunt: Nee
Re: Ubuntu niet op kunnen starten in combinatie met windows 8
« Reactie #6 Gepost op: 2013/11/01, 22:53:10 »
Bedankt voor de antwoorden!
Ik ga van de week even verder stoeien, want het moeten lukken met 13.10 (http://www.linlap.com/asus_vivobook_s300ca).

Offline daido

  • Lid
  • Steunpunt: Nee
Re: Ubuntu niet op kunnen starten in combinatie met windows 8
« Reactie #7 Gepost op: 2013/11/04, 11:29:40 »
Ik heb de nieuwste bios geinstalleerd en ubuntu er opnieuw op gezet.
Verder Secure BootControl op Disabled gezet.
Launch CSM en Launch PXE OoROM staan op enabled.
Van een usbstick start hij meteen op.

Bij opstarten komt alleen windows 8.1 te voorschijn.

Bij BOOT OPTION #1 staat alleen de WINDOWS BOOTMANAGER (die kan je uitschakelen) Ook geprobeerd maar dan start niks op.

Als extra optie staat: ADD NEW BOOT OPTION:   Staat  in een zijschermpje: ADD A NEW EFI BOOT OPTION TO THE BOOTORDER
#Add boot option (daar kan je een naam invullen).
#Select Filesystem  PCI(1F!2)Devicpath (type 3, subtype 12 (Part 1, Sig03059cfo-2a7a-43bd-88b6-112418ad1baa) Dit is te veranderen.
#Path for bootoption (moet je zelf een path invoeren)
#Create

Hoe nu verder?
« Laatst bewerkt op: 2013/11/04, 11:36:03 door daido »

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Ubuntu niet op kunnen starten in combinatie met windows 8
« Reactie #8 Gepost op: 2013/11/04, 12:05:08 »
Lastig probleem.... het lijkt erop, alsof Ubuntu bij de installatie een "gewone" Grub voor BIOS installeert en niet de vereiste Grub-EFI.

Probeer eens het volgende:
- zet Launch CSM op disabled
- probeer weer op te starten vanaf 't USB-staafje. Lukt dat? Zo ja, herinstalleer Ubuntu dan nog een keer, en kijk daarna de Boot priority (Boot options) nog eens na. Indien Ubuntu er dan wel bij staat, is 't opgelost....

Offline daido

  • Lid
  • Steunpunt: Nee
Re: Ubuntu niet op kunnen starten in combinatie met windows 8
« Reactie #9 Gepost op: 2013/11/04, 12:49:33 »
Lastig probleem.... het lijkt erop, alsof Ubuntu bij de installatie een "gewone" Grub voor BIOS installeert en niet de vereiste Grub-EFI.

Probeer eens het volgende:
- zet Launch CSM op disabled
- probeer weer op te starten vanaf 't USB-staafje. Lukt dat? Zo ja, herinstalleer Ubuntu dan nog een keer, en kijk daarna de Boot priority (Boot options) nog eens na. Indien Ubuntu er dan wel bij staat, is 't opgelost....
Geweldig, Ubuntu start zonder bios te veranderen meteen op. Met het grub-menu kan ik ook voor Windows kiezen en dat werkt ook.
Bedankt, ik ben heel blij!
Dus bij deze laptop hoef je eigenlijk alleen de secure boot in de bios uit te schakelen en voor de rest gaat hetzelde als bij een gewone installatie?
« Laatst bewerkt op: 2013/11/04, 12:56:14 door daido »