Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Xubuntu loopt vast/boot niet meer  (gelezen 1609 keer)

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Xubuntu loopt vast/boot niet meer
« Gepost op: 2013/09/10, 16:04:31 »
OS = Xubuntu 12.04 LTS 

Mijn ASUS laptop start van het ene op het andere niet meer op. In eerste instantie bleef hij voortdurend hangen in het Xubuntu opstartscherm.

Heb eerst een eerdere kernelversie proberen te gebruiken. Geen resultaat.

Heb toen via de live cd punt 2 van Pjotr's Computertip-site uitgeprobeerd : https://sites.google.com/site/computertip/grub

Kreeg de volgende output :

xubuntu@xubuntu:~$  sudo grub-install /dev/sda --root-directory=/mnt
/usr/sbin/grub-setup: warn: This GPT partition label has no BIOS Boot Partition; embedding won't be possible!.
/usr/sbin/grub-setup: warn: Embedding is not possible.  GRUB can only be installed in this setup by using blocklists.  However, blocklists are UNRELIABLE and their use is discouraged..
/usr/sbin/grub-setup: error: will not proceed with blocklists.

Na een reboot krijg ik de volgende melding in een zwart scherm te zien :

error : invalid arch independent ELF magic
grub rescue>

Hierna moet ik blijkbaar iets invullen, maar ik heb geen idee wat? Ik heb sowieso geen idee wat hier nou is misgegaan ???

Kortom : hellup!

Een boek doet het altijd...

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Xubuntu loopt vast/boot niet meer
« Reactie #1 Gepost op: 2013/09/10, 16:17:03 »
Edit:
Ik zie net iets staan over ELF in je errors. Dat is natuurlijk iets anders. Dat maakt denk ik wel een verschil. Heb daar geen ervaring mee. Dus je zal even moeten wachten op iemand die daar wel iets over weet.

Edit2:
Op de site van Pjotr dit gevonden (onder nr 3 word deze ELF-error vermeld):
https://sites.google.com/site/computertip/fouten

Kijk eerst eens vanop de live cd of je nog je bestanden kan zien en openen.
Daarna kan je eventueel de HD testen via Dash/(applicatie-icoon)/Schijven (of tik gewoon in de Dash zoekbalk: schijven

Grub2 herstellen via live cd en deze wiki:
http://wiki.ubuntu-nl.org/community/Grub2/Grub2Herstel
Neem er je tijd voor en neem eerst eens alle aanwijzingen door voor je wat doet.
Als je nu nog error krijgt post die dan even hier.

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: Xubuntu loopt vast/boot niet meer
« Reactie #2 Gepost op: 2013/09/10, 16:56:02 »
Heb net hetgeen Pjotr vermeldt bij foutmeldingen nr 3 doorgenomen en nogmaals zijn instructies uitgevoerd, waarbij Xubuntu bij mij - na de Gparted check- op sda2 blijkt te staan. Dit heb ik aangepast in het betreffende commando, echter ik krijg weer precies dezelfde output als zoals ik eerder heb vermeld.

Wie weet de oplossing?
Een boek doet het altijd...

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: Xubuntu loopt vast/boot niet meer
« Reactie #3 Gepost op: 2013/09/10, 17:09:53 »
Nog even aanvullend : ik heb enkel Xubuntu op m'n laptop staan. Geen Windows dus.
Het gaat om de volgende laptop:  ASUS R500VD-SX013H

Hopelijk weet iemand de oplossing. Alvast bedankt!
Een boek doet het altijd...

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Xubuntu loopt vast/boot niet meer
« Reactie #4 Gepost op: 2013/09/10, 17:26:40 »
Voer dit commando eens uit, dat vertelt wat meer over de partities op je schijf:
sudo parted /dev/sda unit s print

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: Xubuntu loopt vast/boot niet meer
« Reactie #5 Gepost op: 2013/09/10, 17:50:52 »
Dit is de output van dat commando :

xubuntu@xubuntu:~$ sudo parted /dev/sda unit s print
Model: ATA Hitachi HTS54505 (scsi)
Disk /dev/sda: 976773168s
Sector size (logical/physical): 512B/4096B
Partition Table: gpt

Number  Start       End         Size        File system     Name  Flags
1      2048s       194559s     192512s     fat32                 boot
2      194560s     968615935s  968421376s  ext4
3      968615936s  976771071s  8155136s    linux-swap(v1)

Mij zegt het niet zoveel :o

Een boek doet het altijd...

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: Xubuntu loopt vast/boot niet meer
« Reactie #6 Gepost op: 2013/09/10, 17:53:40 »
In bijlage hetgeen Gparted laat zien.
Een boek doet het altijd...

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Xubuntu loopt vast/boot niet meer
« Reactie #7 Gepost op: 2013/09/10, 18:06:22 »
Het probleem is dat je schijf/ssd ingedeeld is met GPT partitie-indeling, en niet in de ouderwetse MBR indeling.
Dat is verder prima, alleen heeft het wat andere eisen.

In dit geval is de opstartvlag verkeerd. Dit kan je zo oplossen:
sudo parted /dev/sda set 1 bios_grub on
Hierna kan je de herstelprocedure die je eerder al geprobeerd hebt opnieuw doen.

Wat wel vreemd is dat de eerste partite als fat32 geformatteerd is, maar dat zou niet uit mogen maken. Waarschijnlijk is dit een overblijfsel van de Windows installatie die er ooit opgestaan heeft.

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: Xubuntu loopt vast/boot niet meer
« Reactie #8 Gepost op: 2013/09/10, 19:29:19 »
Commando uitgevoerd en Pjotr's stappen ook weer (kreeg dit keer de melding dat er geen errors waren gevonden en de installatie was gelukt!). Na reboot verschijnt nu echter het bios (American Megatrends  version 404 GOP version 3.0.12.1012 EC version 204E120001)  in beeld met bij de bootsequence #1 de melding :

 'Ubuntu (Drive not present)'

Ene probleem is opgelost en het volgende dient zich alweer aan >:(

Weet je hier ook nog een oplossing voor? We komen langzaamaan dichterbij de oplossing ;)

(Overigens klopt het dat er ooit Windows op heeft gestaan. Vandaar die FAT32 partitie. Ik kocht het ding met Windows en heb die er toen direct afgegooid om vervolgens Xubuntu te installeren)
 
 
Een boek doet het altijd...

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Xubuntu loopt vast/boot niet meer
« Reactie #9 Gepost op: 2013/09/11, 08:06:46 »
Heb je in de BIOS de opstartinstellingen gecontroleerd?

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: Xubuntu loopt vast/boot niet meer
« Reactie #10 Gepost op: 2013/09/11, 09:41:40 »
Uiteraard...voordat ik het commando sudo parted /dev/sda set 1 bios_grub on uitvoerde herkende het bios m'n harde schijf gewoon. Nu dus niet meer. Ik hoop niet dat ik straks Xubuntu volledig opnieuw moet installeren.
Wat nu dus?
Een boek doet het altijd...

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Xubuntu loopt vast/boot niet meer
« Reactie #11 Gepost op: 2013/09/11, 09:52:59 »
Wacht even, herkent je BIOS de schijf nu helemaal niet meer? Dus in het overzicht van alle schijven in je computer komt de schijf helemaal niet meer voor?
Of is het alleen de opstartschijf die je even opnieuw moet instellen? Dat lijkt me een stuk waarschijnlijker.

Weet je trouwens ook wel zeker dat het de BIOS is die die fout geeft en niet GRUB?

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: Xubuntu loopt vast/boot niet meer
« Reactie #12 Gepost op: 2013/09/11, 16:04:09 »
Wanneer ik de laptop start, dan verschijnt direct het bios in beeld op het tabblad 'main'. Wanneer ik onder de tab 'boot' kijk, dan staat daar slechts 1 boot option. Letterlijk staat er :

Boot Option #1      Ubuntu (drive not present)

Het bios geeft enerzijds aan dat het Ubuntu herkent(?), maar anderzijds dat de schijf niet aanwezig is(?). Beetje tegenstrijdig, me dunkt. Voordat ik het door jou genoemde commando had gebruikt, gaf het bios nog aan dat het een schijf herkende. Er stond iets van Hitachi.

Je schrijft 'Of is het alleen de opstartschijf die je even opnieuw moet instellen?'. Ik hoop het wel...Alleen van 'even' is geen sprake. Zelfs Pjotr's website biedt nu geen uitkomst.

(Nog even aanvullend :Het rare is dat er wanneer ik de live cd in de dvd-brander doe en de laptop boot, dat dan pas de boot option voor de cd in het bios verschijnt. Heb ik ook nog nooit eerder meegemaakt. Standaard staan er in de biossen die ik ken een aantal boot options vermeld, waaronder die voor dvd. Onder de tab 'save & exit' staat oa de optie 'launch EFI shell from filesystem device'. Geen idee of je hier nog iets mee kan??)

Deze laptop is m'n werklaptop en ik wil ḿ graag zo snel weer aan de praat hebben.

Meer info dan boven heb ik niet en ik weet er ook te weinig van om het ding weer aan de gang te krijgen. Ik snap niet wat er nou mis is gegaan. Baal er wel behoorlijk van.

Alvast bedankt voor je hulp Johan...
Een boek doet het altijd...

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: Xubuntu loopt vast/boot niet meer
« Reactie #13 Gepost op: 2013/09/11, 16:28:20 »
Ik ontdekte nog het volgende. Heb de laptop met de live cd opgestart en gparted ook gestart en daaruit blijkt dat er na jouw commando het eea is veranderd. Zie de bijlage.

Bij partitie sda1 staat nu een uitroepteken en filesystem unknown. Bij flags staat bios_grub. Bij mijn weten is dit die ouwe windows-partitie waar ik niets meer mee doe. Kan ik die niet gewoon verwijderen? Zou dat de oorzaak van het probleem kunnen zijn? Zou ik dan vervolgens Pjotr's stappen weer moeten uitvoeren (dit keer zal de ext4 partitie dan wel sda1 zijn??) om grub goed in te stellen waarna de laptop mogelijk weer gewoon opstart. Ik heb in het verleden ook al eens problemen gehad met grub bij deze laptop staat me bij.

Ik hoor het wel....
Een boek doet het altijd...

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Xubuntu loopt vast/boot niet meer
« Reactie #14 Gepost op: 2013/09/11, 16:38:17 »
Bij partitie sda1 staat nu een uitroepteken en filesystem unknown. Bij flags staat bios_grub. Bij mijn weten is dit die ouwe windows-partitie waar ik niets meer mee doe. Kan ik die niet gewoon verwijderen? Zou dat de oorzaak van het probleem kunnen zijn?
Dat zou inderdaad kunnen. Bovendien kan het totaal geen kwaad om die partitie weg te duvelen.

Het beste is om 'm niet te vernietigen maar te herformatteren, bijvboorbeeld in ext4. Zodoende hou je de partitienummering in stand (zou eigenlijk niet nodig moeten zijn, maar voor alle zekerheid toch aan te raden). Verplaats gelijk de opstartvlag (boot flag) even naar de rootpartitie van Xubuntu.

Beter om Johans aanwijzingen te volgen.... :)
« Laatst bewerkt op: 2013/09/11, 17:36:24 door Pjotr »

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Xubuntu loopt vast/boot niet meer
« Reactie #15 Gepost op: 2013/09/11, 16:48:25 »
Het belangrijkste bij een GPT schijfindeling is dat de eerste partitie de bios_grub vlag heeft. Die partitie hoeft niet zo groot te zijn (2 MB is al genoeg) en mag verder leeg zijn er hoeft dus geen bestandssysteem op die partitie te staan.
Het bootloadergedeelte van GRUB moet je op die partitie installeren. De overige bestanden van GRUB en Ubuntu zelf kunnen op de andere partities staan.

Ik heb even de handleiding opgezocht: in de Appendix vanaf A-4 staan de instellingen voor je BIOS beschreven, incl. het instellen van de boot schijf.
http://www.manualowl.com/m/Asus/R500VD/Manual/262175

Hier een voorbeeld van mijn SSD:
$ sudo gdisk -l /dev/sda
GPT fdisk (gdisk) version 0.8.1

Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present

Found valid GPT with protective MBR; using GPT.
Disk /dev/sda: 500118192 sectors, 238.5 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): 47D9845C-49B8-4160-ABEE-5DCB088E35A9
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 500118158
Partitions will be aligned on 2048-sector boundaries
Total free space is 206814 sectors (101.0 MiB)

Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048            6143   2.0 MiB     EF02  BIOS boot partition
   2            6144       499913358   238.4 GiB   8300  Linux filesystem
(gdisk is standaard niet geïnstalleerd in Ubuntu)

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: Xubuntu loopt vast/boot niet meer
« Reactie #16 Gepost op: 2013/09/11, 19:12:02 »
Ik heb geprobeerd om hetgeen staat in de manual over de bios instellingen te volgen, maar bij stap 2 kan ik al niet verder, want ik moet een device selecteren, maar er is geen device! ('Drive not present' wordt bij mij aangegeven, zoals ik reeds aangaf).

Ik zal eerlijk zijn. Ik snap er eigenlijk geen hout van. Dit gaat mij ver boven de pet. Ik wil alle inspanning leveren waartoe ik in staat ben, maar het is voor mij complete abacadabra. Het enige wat ik wil is dat die laptop gewoon weer opstart en dat dit soort ellende in de toekomst niet meer voorkomt als het even kan. Wanneer ik zelf nou een eikel ben geweest en iets verkeerd heb gedaan, heb ik daar vrede mee en installeer ik de hele toko gewoon opnieuw. Maar het is erg frustrerend wanneer je niets fout doet en het ding is met geen mogelijkheid meer aan de praat te krijgen. I love linux, maar nu even niet...

Ik kom er dus niet uit. Mijn vraag is of het mogelijk is om mij simpel, stapgewijs uiteen te zetten wat ik moet doen? Ik weet niets omtrent flags, GPT, MBR, Gdisk etc.  ;) Is als Chinees voor me.

(Excusez wanneer ik ietwat geirriteerd overkom, maar ... dat ben ik inmiddels ook om eerlijk te zijn. Is niet naar jullie gericht hoor. Lang geleden trouwens dat ik dat ik-smijt-die-laptop-nu-van-tien-hoog-naar-beneden-gevoel had =D. In m'n Windows-tijd liep ik daar regelmatig tegenaan....)
Een boek doet het altijd...

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Xubuntu loopt vast/boot niet meer
« Reactie #17 Gepost op: 2013/09/11, 19:17:36 »
@Johan: waar ik aan zit te denken: misschien is 't beter om dat hele GPT-gedoe teniet te doen? Bijvoorbeeld door in het UEFI de harde schijf op Legacy of IDE te zetten, de boel compleet te vernietigen met Gparted (alle partities weg) en daarna Xubuntu opnieuw schoon te installeren?

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Xubuntu loopt vast/boot niet meer
« Reactie #18 Gepost op: 2013/09/11, 19:50:38 »
Dat is een oplossing die een grote kans van slagen heeft en waarschijnlijk sneller werkt dan het handmatig oplossen.
Ik weet zeker dat het ook op een 'nette' manier gewoon opgelost kan worden, maar lijkt me ondoenlijk om dat via het forum te doen.
Dus als er een specialist in de buurt woont en tijd heeft kan je dat proberen, zo niet dan is een nieuwe installatie het makkelijkst en snelst.

Wat nu het belangrijkste is dat je je data veilig stelt. Zorg dat je een externe schijf hebt met genoeg vrije ruimte en kopieer alle data vanuit je home map naar die schijf. Vergeet niet om te controleren of alle verborgen mappen ook meegenomen zijn in de kopie. Het beste is als de externe schijf als ext3 of ext4 geformatteerd is, zo blijven de rechten op je bestanden goed. Dat scheelt weer wanneer je de backup terugzet.

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: Xubuntu loopt vast/boot niet meer
« Reactie #19 Gepost op: 2013/09/12, 16:37:17 »
M'n data is reeds veilig gesteld. Heb altijd voldoende backups achter de hand. Voor dit soort cases dus ...

Een specialist heb ik hier niet bij de hand dus ik ga Xubuntu wel opnieuw installeren, hoewel ik er goed van baal! Ik meen te mogen concluderen dat het het restant van de overgebleven Windows-partitie is, die de zaak naar alle waarschijnlijkheid heeft vernaggeld, aangezien ik bij mijn overige computers - waar nooit die Redmondtroep op heeft gestaan - nimmer tegen dit probleem ben aangelopen. Zelfs vanuit de verste uithoek is Windows blijkbaar nog in staat om ellende te veroorzaken.
Kortom, kill alle Windows-partities grondig met Gparted alvorens je (X)Ubuntu gaat installeren, want het gedrocht zal je mogelijk blijven 'stalken'.

Nog even een kleine check. Wanneer ik de Windows-partities om zeep heb geholpen en Xubuntu opnieuw ga installeren, dan zorgt deze installatie toch voor een correct werkende grub? Hoop ook dat er niets in m'n bios om zeep is geholpen, omdat na het laatste commando de harde schijf niet meer werd herkend.

Johan & Pjotr in elk geval bedankt voor jullie hulp! Ik ga de handel nu maar herinstalleren :(
Een boek doet het altijd...

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Xubuntu loopt vast/boot niet meer
« Reactie #20 Gepost op: 2013/09/12, 16:57:27 »
Voordat je begint: zet eerst in het UEFI de harde schijf van AHCI naar Legacy of IDE.  :)

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: Xubuntu loopt vast/boot niet meer
« Reactie #21 Gepost op: 2013/09/12, 17:37:18 »
Ik had de windows-partitie al verwijderd. M'n bios ziet nu helemaal niets meer van een harde schijf. Dus de harde schijf van AHCI naar Legacy of IDE zetten gaat niet lukken ben ik bang... Is dit problematisch?
Een boek doet het altijd...

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: Xubuntu loopt vast/boot niet meer
« Reactie #22 Gepost op: 2013/09/12, 17:45:30 »
Herstel ... sorry Pjotr ik was te snel. Zat onder de verkeerde tab te kijken ???. Heb via Advanced > SATA Mode selection de harde schijf  nu op IDE gezet.
Een boek doet het altijd...

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Xubuntu loopt vast/boot niet meer
« Reactie #23 Gepost op: 2013/09/12, 18:17:39 »
Persoonlijk zou ik hem wel lekker op AHCI laten staan, dat is de methode die de beste prestaties geeft en het meest compatibel zou moeten zijn.

Voor de opstartopties in de BIOS moet er ergens een schermpje zijn om je schijf te kiezen. Dat hij verdwenen is geloof ik niet, je kijkt waarschijnlijk op de verkeerde plek.
Het enige wat nog wel een oorzaak zou kunnen zijn is dat hij is ingesteld om EFI systemen te booten. Die optie zou je ook uit kunnen zetten (zoek naar iets als Legacy BIOS boot of zo).

Trouwens zie ik nu net dat je gewoon een nieuwe opstartoptie aan kan maken in de BIOS...
Probeer dit dus eerst voordat je je schijf leegveegt.
Zie hier: http://superuser.com/questions/524598/asus-uefi-bios-options-how-to-boot-from-dvd
Met een mooi plaatje waarop staat hoe je een extra bootoptie toe kan voegen.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Xubuntu loopt vast/boot niet meer
« Reactie #24 Gepost op: 2013/09/12, 18:37:01 »
Overigens zat ik er in eerdere berichten naast over de eerste partitie.

Blijkbaar was ik wat verward door de schijf in GPT indeling, maar het echte probleem is de EFI boot.
Zie hier: https://help.ubuntu.com/community/UEFI

De eerste partitie moet dus wel gewoon 200 MB groot zijn (ofzo), FAT32 geformatteerd zijn en de boot vlag hebben.

Het wordt er niet makkelijker op, met al die nieuwe opstartopties die nu door elkaar op de markt zijn en allemaal net iets anders eisen. :|