Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Vodafone + huawei E220  (gelezen 2102 keer)

Offline anomic

  • Lid
Vodafone + huawei E220
« Gepost op: 2013/09/06, 09:37:21 »
Ik heb een Dell D600 met 12.04 draaien, en alles werkt behalve de verbinding via Vodafone mobile broadband. Het modem (Huawei e220) wordt herkend, de wizzard is doorlopen en alles lijkt goed te gaan. In de netwerk manager staat alles okee. Via de netwerk snelkoppeling (taartpunt rechtsboven in de balk) kan ik "mobiel breedband inschakelen" aanzetten, en het modem gaat dan van groen naar blauw knipperen en er verschijnt "vodafone NL UMTS" in beeld. Dat ziet er toch goed uit zou je zeggen. Dan kies ik mijn verbinding (Vodafone  Nonbusiness), en dan gaat het taartpuntje even wapperen, maar dan komt de popup:  modemnetwerk - verbinding verbroken u bent niet verbonden met het internet. Het lijkt dus dat de modem wel goed werkt en zich verbindt met het vodafone UMTS netwerk, maar het verbindingsprofiel niet klopt ofzo waardoor ik niet online kan. Ik heb verschillende settings getest, maar hij verdomd het om online te gaan. Help!

Groetjes,

Mike.

Offline joop905

  • Lid
  • Steunpunt: Nee
Re: Vodafone + huawei E220
« Reactie #1 Gepost op: 2013/09/06, 09:50:34 »
Wat is hier de uitkomst van:
Open je terminal
Sneltoetscombinatie Ctrl + Alt + T
Knip & Plak

sudo iwlist wlan0 scan

Offline anomic

  • Lid
Re: Vodafone + huawei E220
« Reactie #2 Gepost op: 2013/09/06, 12:06:02 »
Hij zegt:

wlan0  Interface doesn't support scanning.

Offline DeBaas

  • Lid
  • Steunpunt: Ja
Re: Vodafone + huawei E220
« Reactie #3 Gepost op: 2013/09/06, 12:12:04 »
DejaVu
Net een gelijksoortig topic voor andere Linuxversie gelezen in het Engels.
Misschien heb je hier iets aan.
« Laatst bewerkt op: 2013/09/06, 12:14:11 door DeBaas »
Ik beantwoord GEEN hulpvragen via PB en/of MAIL

Offline anomic

  • Lid
Re: Vodafone + huawei E220
« Reactie #4 Gepost op: 2013/09/06, 13:00:34 »
Hoi Baas,

Dit gaat over een probleem met usb mode switch, bij mij werkt dat ook gewoon. Het modem wordt idd eerst herkend als usb-storage, maar daarna omgeswitched naar een modem. Dus het modem werkt wel, maar hij wil niet kleppen met internet. In syslog zie ik dat ppp niet wil opkomen:

Sep  6 12:54:00 d600 modem-manager[760]: <info>  (ttyUSB0) opening serial
port...
Sep  6 12:54:00 d600 modem-manager[760]: <info>  Modem
/org/freedesktop/ModemManager/Modems/1: state changed (disabled ->
enabling)
Sep  6 12:54:01 d600 modem-manager[760]: <info>  (ttyUSB0): using text
mode for SMS
Sep  6 12:54:01 d600 modem-manager[760]: <info>  Modem
/org/freedesktop/ModemManager/Modems/1: state changed (enabling ->
enabled)
Sep  6 12:54:01 d600 NetworkManager[783]: <info> WWAN now enabled by
management service
Sep  6 12:54:01 d600 modem-manager[760]: <info>  Modem
/org/freedesktop/ModemManager/Modems/1: state changed (enabled ->
registered)
Sep  6 12:54:19 d600 NetworkManager[783]: <info> Activation (ttyUSB0)
starting connection 'Vodafone 3G'
Sep  6 12:54:19 d600 NetworkManager[783]: <info> (ttyUSB0): device state
change: disconnected -> prepare (reason 'none') [30 40 0]
Sep  6 12:54:19 d600 NetworkManager[783]: <info> Activation (ttyUSB0)
Stage 1 of 5 (Device Prepare) scheduled...
Sep  6 12:54:19 d600 NetworkManager[783]: <info> Activation (ttyUSB0)
Stage 1 of 5 (Device Prepare) started...
Sep  6 12:54:19 d600 NetworkManager[783]: <info> (ttyUSB0): device state
change: prepare -> need-auth (reason 'none') [40 60 0]
Sep  6 12:54:19 d600 NetworkManager[783]: <info> Activation (ttyUSB0)
Stage 1 of 5 (Device Prepare) complete.
Sep  6 12:54:19 d600 NetworkManager[783]: <info> Activation (ttyUSB0)
Stage 1 of 5 (Device Prepare) scheduled...
Sep  6 12:54:19 d600 NetworkManager[783]: <info> Activation (ttyUSB0)
Stage 1 of 5 (Device Prepare) started...
Sep  6 12:54:19 d600 NetworkManager[783]: <info> (ttyUSB0): device state
change: need-auth -> prepare (reason 'none') [60 40 0]
Sep  6 12:54:19 d600 NetworkManager[783]: <info> Activation (ttyUSB0)
Stage 1 of 5 (Device Prepare) complete.
Sep  6 12:54:20 d600 modem-manager[760]: <info>  Modem
/org/freedesktop/ModemManager/Modems/1: state changed (registered ->
connecting)
Sep  6 12:54:20 d600 modem-manager[760]: <info>  Modem
/org/freedesktop/ModemManager/Modems/1: state changed (connecting ->
connected)
Sep  6 12:54:20 d600 NetworkManager[783]: <info> Activation (ttyUSB0)
Stage 2 of 5 (Device Configure) scheduled...
Sep  6 12:54:20 d600 NetworkManager[783]: <info> Activation (ttyUSB0)
Stage 2 of 5 (Device Configure) starting...
Sep  6 12:54:20 d600 NetworkManager[783]: <info> (ttyUSB0): device state
change: prepare -> config (reason 'none') [40 50 0]
Sep  6 12:54:20 d600 NetworkManager[783]: <info> Activation (ttyUSB0)
Stage 2 of 5 (Device Configure) successful.
Sep  6 12:54:20 d600 NetworkManager[783]: <info> Activation (ttyUSB0)
Stage 3 of 5 (IP Configure Start) scheduled.
Sep  6 12:54:20 d600 NetworkManager[783]: <info> Activation (ttyUSB0)
Stage 2 of 5 (Device Configure) complete.
Sep  6 12:54:20 d600 NetworkManager[783]: <info> Activation (ttyUSB0)
Stage 3 of 5 (IP Configure Start) started...
Sep  6 12:54:20 d600 NetworkManager[783]: <info> (ttyUSB0): device state
change: config -> ip-config (reason 'none') [50 70 0]
Sep  6 12:54:20 d600 NetworkManager[783]: <info> starting PPP connection
Sep  6 12:54:20 d600 NetworkManager[783]: <info> pppd started with pid 4974
Sep  6 12:54:20 d600 NetworkManager[783]: <info> Activation (ttyUSB0)
Stage 4 of 5 (IPv6 Configure Timeout) scheduled...
Sep  6 12:54:20 d600 NetworkManager[783]: <info> Activation (ttyUSB0)
Stage 3 of 5 (IP Configure Start) complete.
Sep  6 12:54:20 d600 NetworkManager[783]: <info> Activation (ttyUSB0)
Stage 4 of 5 (IPv6 Configure Timeout) started...
Sep  6 12:54:20 d600 NetworkManager[783]: <info> Activation (ttyUSB0)
Stage 4 of 5 (IPv6 Configure Timeout) complete.
Sep  6 12:54:20 d600 pppd[4974]: Plugin
/usr/lib/pppd/2.4.5/nm-pppd-plugin.so loaded.
Sep  6 12:54:20 d600 pppd[4974]: pppd 2.4.5 started by root, uid 0
Sep  6 12:54:20 d600 NetworkManager[783]:    SCPlugin-Ifupdown: devices
added (path: /sys/devices/virtual/net/ppp0, iface: ppp0)
Sep  6 12:54:20 d600 NetworkManager[783]:    SCPlugin-Ifupdown: device
added (path: /sys/devices/virtual/net/ppp0, iface: ppp0): no ifupdown
configuration found.
Sep  6 12:54:20 d600 pppd[4974]: Using interface ppp0
Sep  6 12:54:20 d600 pppd[4974]: Connect: ppp0 <--> /dev/ttyUSB0
Sep  6 12:54:20 d600 pppd[4974]: CHAP authentication succeeded
Sep  6 12:54:20 d600 pppd[4974]: CHAP authentication succeeded
Sep  6 12:54:21 d600 pppd[4974]: Modem hangup
Sep  6 12:54:21 d600 pppd[4974]: Connection terminated.
Sep  6 12:54:21 d600 NetworkManager[783]: <info> Activation (ttyUSB0)
Stage 4 of 5 (IPv4 Configure Timeout) scheduled...
Sep  6 12:54:21 d600 NetworkManager[783]: <info> Activation (ttyUSB0)
Stage 4 of 5 (IPv4 Configure Timeout) started...
Sep  6 12:54:21 d600 NetworkManager[783]: <info> (ttyUSB0): device state
change: ip-config -> failed (reason 'ip-config-unavailable') [70 120 5]
Sep  6 12:54:21 d600 modem-manager[760]: <info>  (ttyUSB0) closing serial
port...
Sep  6 12:54:21 d600 modem-manager[760]: <info>  (ttyUSB0) serial port closed
Sep  6 12:54:21 d600 modem-manager[760]: <info>  Modem
/org/freedesktop/ModemManager/Modems/1: state changed (connected ->
disconnecting)
Sep  6 12:54:21 d600 modem-manager[760]: <info>  Modem
/org/freedesktop/ModemManager/Modems/1: state changed (disconnecting ->
connected)
Sep  6 12:54:21 d600 NetworkManager[783]: <warn> Activation (ttyUSB0) failed.
Sep  6 12:54:21 d600 NetworkManager[783]: <info> Activation (ttyUSB0)
Stage 4 of 5 (IPv4 Configure Timeout) complete.
Sep  6 12:54:21 d600 NetworkManager[783]: <info> disconnect failed: (32)
The serial port is not open.
Sep  6 12:54:21 d600 NetworkManager[783]: <info> (ttyUSB0): device state
change: failed -> disconnected (reason 'none') [120 30 0]
Sep  6 12:54:21 d600 NetworkManager[783]: <info> (ttyUSB0): deactivating
device (reason 'none') [0]
Sep  6 12:54:21 d600 avahi-daemon[801]: Withdrawing workstation service
for ppp0.
Sep  6 12:54:21 d600 NetworkManager[783]: nm_system_iface_flush_routes:
assertion `ifindex > 0' failed
Sep  6 12:54:21 d600 NetworkManager[783]: nm_system_iface_flush_addresses:
assertion `ifindex > 0' failed
Sep  6 12:54:21 d600 NetworkManager[783]: <info> Policy set 'anomic.net'
(eth1) as default for IPv4 routing and DNS.
Sep  6 12:54:21 d600 NetworkManager[783]: <info> Policy set 'anomic.net'
(eth1) as default for IPv4 routing and DNS.
Sep  6 12:54:21 d600 NetworkManager[783]:    SCPlugin-Ifupdown: devices
removed (path: /sys/devices/virtual/net/ppp0, iface: ppp0)
Sep  6 12:54:22 d600 pppd[4974]: Exit.

Offline DeBaas

  • Lid
  • Steunpunt: Ja
Re: Vodafone + huawei E220
« Reactie #5 Gepost op: 2013/09/06, 17:24:31 »
Moet het modem als ppp ?
In het daar aangehaalde item juist niet.
Kan je helaas wegens ontbreken van gelijksoortige apparatuur niet verder helpen.

Iemand anders die aan de bel wil trekken ? ;)
Ik beantwoord GEEN hulpvragen via PB en/of MAIL

Offline softbart

  • Lid
  • Steunpunt: Nee
Re: Vodafone + huawei E220
« Reactie #6 Gepost op: 2013/09/07, 10:10:23 »
Mogelijk niet de juiste instellingen in de NetworkManager.
Hier als bijlage mijn wanneer ik mijn telefoon aansluit.

groet,

Theo

Offline anomic

  • Lid
Re: Vodafone + huawei E220
« Reactie #7 Gepost op: 2013/09/07, 13:38:35 »
Hoi Theo,

Dank je voor je screenshot. Bij mij is dit hetzelfde, het zijn de standaard instellingen voor Vodafone. Ik snap er echt geen snars van, hij wil gewoon niet verbinden. Onder windows XP doet ie het wel direct, dus het ligt niet aan het modem of het abonnement.

Offline softbart

  • Lid
  • Steunpunt: Nee
Re: Vodafone + huawei E220
« Reactie #8 Gepost op: 2013/09/07, 18:13:10 »
Kijk ook naar de PPP tab.

Volgens Pjotr is daar ook nog verbetering te halen. Met name de inbelsnelheid, daar gaat het denk ik net mis.
zie     https://sites.google.com/site/computertip/huawei

groet,

Theo

Offline DeBaas

  • Lid
  • Steunpunt: Ja
Re: Vodafone + huawei E220
« Reactie #9 Gepost op: 2013/09/07, 23:08:09 »
Ik beantwoord GEEN hulpvragen via PB en/of MAIL

Offline anomic

  • Lid
Re: Vodafone + huawei E220
« Reactie #10 Gepost op: 2013/09/08, 13:39:56 »
Hey, bedankt voor de input. Ik krijg helaas nog steeds geen verbinding, ook niet met de handmatige scripts. Ik word er een beetje moedeloos van inmiddels. Het modem wordt herkend, hij registreert keurig vodafone NL UMTS of vodafone NL GPRS afhankelijk van mijn bereik binnen of buiten, dus tot zo ver gaat het allemaal goed. Ik krijg ook bij het inprikken de vraag om de pincode, dan krijg ik een popup van u bent nu aangemeld bij het GSM netwerk, maar daarna kan ik dus niet verbinden. Ik heb ook nog een andere stick geprobeerd, de huawei E1750. Deze is unlocked en zou dus ook moeten kunnen werken met de sim uit de E220. Ook dit device wordt helemaal herkend en registreert zich bij het vodafone netwerk, maar ook hier wordt geen PPP/IP verbinding tot stand gebracht. Ik voel mijn tranen branden...

Offline anomic

  • Lid
Re: Vodafone + huawei E220
« Reactie #11 Gepost op: 2013/09/09, 09:39:47 »
Ik heb nog een andere laptop (Sony Vaio) geinstalleerd met 12.04, en deze geeft precies hetzelfde resultaat. Ik vermoed dat het abonnement specifieke instellingen vereist in het modem profiel, en dat de standaard APN/user/pass/inbelnummer niet werken. Kan dat? Ik kan in de windows software de inbelgegevens niet terugzien. Iemand nog een hint?

Offline anomic

  • Lid
Re: Vodafone + huawei E220
« Reactie #12 Gepost op: 2013/09/09, 20:09:26 »
JAHAAAAA!!! HIJ DOET HET!!! uhm sorry, maar ik ben blij dat het gefikst is ;-)  In windows zag ik dat ik verbonden was met office.vodafone.nl ipv live.vodafone.com, dus de business variant. Alhoewel ik deze al eerder had geprobeerd pakte 'ie hem toch niet. Nu alle profielen verwijderd en meteen de business variant ingevoerd, dongel er in en FLOEMPIE ... online! Wat een opluchting... en nu definitief DOEI XP.. je was een fijn OS maar nu moet ik je laten gaan ;-)

Bedankt allemaal voor de ondersteuning!

Groetjes,

Mike.

Offline DeBaas

  • Lid
  • Steunpunt: Ja
Re: Vodafone + huawei E220
« Reactie #13 Gepost op: 2013/09/10, 00:09:34 »
party ;)
Ik beantwoord GEEN hulpvragen via PB en/of MAIL