Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [opgelost]Kubutu 12.04 kate werkt niet  (gelezen 465 keer)

Offline MKe

  • Lid
  • Steunpunt: Nee
[opgelost]Kubutu 12.04 kate werkt niet
« Gepost op: 2013/09/05, 10:19:08 »
Hoi,

sinds een paar dagen werkt kate niet meer bij mij. Ik krijg de melding:
Citaat
A KDE text-editor component could not be found.
Please check your KDE installation.
Weet iemand waar ik moet beginnen om dit op te lossen?

Ik heb Kubuntu 12.04-64 met backports aangezet.
« Laatst bewerkt op: 2013/09/06, 11:38:08 door MKe »
Mijn blokkendoos blog: http://mke21.wordpress.com/

Offline Timo

  • Forumteam
    • timo.diedering
  • Steunpunt: Ja
Re: Kubutu 12.04 kate werkt niet
« Reactie #1 Gepost op: 2013/09/05, 17:45:21 »
timo@vosje:~$ apt-cache showpkg kate
Package: kate
Versions:
4:4.11.0-0ubuntu1~ubuntu12.04~ppa1 (/var/lib/apt/lists/ppa.launchpad.net_kubuntu-ppa_backports_ubuntu_dists_precise_main_binary-amd64_Packages) (/var/lib/dpkg/status)
 Description Language:
                 File: /var/lib/apt/lists/ppa.launchpad.net_kubuntu-ppa_backports_ubuntu_dists_precise_main_binary-amd64_Packages
                  MD5: b080306f1c11971681ea19eaf6e8f772

4:4.8.5-0ubuntu0.1 (/var/lib/apt/lists/nl.archive.ubuntu.com_ubuntu_dists_precise-updates_main_binary-amd64_Packages)
 Description Language:
                 File: /var/lib/apt/lists/nl.archive.ubuntu.com_ubuntu_dists_precise_main_binary-amd64_Packages
                  MD5: 16b212a84f4addb3e17b287f9e77a0f1
 Description Language: en
                 File: /var/lib/apt/lists/nl.archive.ubuntu.com_ubuntu_dists_precise_main_i18n_Translation-en
                  MD5: 16b212a84f4addb3e17b287f9e77a0f1

4:4.8.2-0ubuntu2 (/var/lib/apt/lists/nl.archive.ubuntu.com_ubuntu_dists_precise_main_binary-amd64_Packages)
 Description Language:
                 File: /var/lib/apt/lists/nl.archive.ubuntu.com_ubuntu_dists_precise_main_binary-amd64_Packages
                  MD5: 16b212a84f4addb3e17b287f9e77a0f1
 Description Language: en
                 File: /var/lib/apt/lists/nl.archive.ubuntu.com_ubuntu_dists_precise_main_i18n_Translation-en
                  MD5: 16b212a84f4addb3e17b287f9e77a0f1


Reverse Depends:
  kxstudio-desktop-kde4,kate
  libkateinterfaces4:i386,kate 4:4.6.90
  libkateinterfaces4:i386,kate 4:4.6.90
  katepart:i386,kate 4:4.7.0
  katepart:i386,kate 4:4.7.0
  kate:i386,kate
  libkateinterfaces4,kate 4:4.6.90
  libkateinterfaces4,kate 4:4.6.90
  katepart,kate 4:4.7.0
  katepart,kate 4:4.7.0
  kate-data,kate 4:4.10.80
  kate-data,kate 4:4.10.80
  kubuntu-full,kate
  kde-standard,kate 4:4.10.80
  kubuntu-desktop,kate
  kdesdk-scripts,kate
  kdesdk-scripts,kate
  kdesdk,kate
  libkateinterfaces4:i386,kate 4:4.6.90
  libkateinterfaces4:i386,kate 4:4.6.90
  katepart:i386,kate 4:4.7.0
  katepart:i386,kate 4:4.7.0
  kate:i386,kate
  kde-standard,kate 4:4.8.2
  libkateinterfaces4,kate 4:4.6.90
  libkateinterfaces4,kate 4:4.6.90
  kdesdk-scripts,kate
  kdesdk,kate
  katepart,kate 4:4.7.0
  katepart,kate 4:4.7.0
  kate-data,kate 4:4.6.90
  kate-data,kate 4:4.6.90
  libkateinterfaces4:i386,kate 4:4.6.90
  libkateinterfaces4:i386,kate 4:4.6.90
  katepart:i386,kate 4:4.7.0
  katepart:i386,kate 4:4.7.0
  kate:i386,kate
  kde-standard,kate 4:4.8.2
  kate-syntax-go,kate
  ichthux-desktop,kate
  faust,kate
  libkateinterfaces4,kate 4:4.6.90
  libkateinterfaces4,kate 4:4.6.90
  kubuntu-full,kate
  kubuntu-desktop,kate
  kdesdk-scripts,kate
  kdesdk,kate
  katepart,kate 4:4.7.0
  katepart,kate 4:4.7.0
  kate-data,kate 4:4.6.90
  kate-data,kate 4:4.6.90
Dependencies:
4:4.11.0-0ubuntu1~ubuntu12.04~ppa1 - kate-data (2 4:4.11.0-0ubuntu1~ubuntu12.04~ppa1) katepart (5 4:4.11.0-0ubuntu1~ubuntu12.04~ppa1) libc6 (2 2.14) libkateinterfaces4 (5 4:4.11.0-0ubuntu1~ubuntu12.04~ppa1) libkdecore5 (0 (null)) libkdeui5 (0 (null)) libkfile4 (0 (null)) libkio5 (0 (null)) libkparts4 (0 (null)) libktexteditor4 (0 (null)) libplasma3 (0 (null)) libpython2.7 (2 2.7) libqjson0 (2 0.7.1) libqt4-dbus (2 4:4.5.3) libqt4-sql (2 4:4.5.3) libqt4-xml (2 4:4.5.3) libqtcore4 (2 4:4.8.0) libqtgui4 (2 4:4.8.0) libqtwebkit4 (2 2.2~2011week36) libstdc++6 (2 4.1.1) aspell (16 (null)) ispell (16 (null)) hspell (0 (null)) khelpcenter4 (0 (null)) konsole (0 (null)) kate:i386 (0 (null))
4:4.8.5-0ubuntu0.1 - kate-data (2 4:4.8.5-0ubuntu0.1) katepart (5 4:4.8.5-0ubuntu0.1) kde-runtime (0 (null)) libc6 (2 2.14) libkateinterfaces4 (0 (null)) libkdecore5 (2 4:4.8.1) libkdeui5 (2 4:4.8.1) libkfile4 (2 4:4.8.1) libkio5 (2 4:4.8.1) libknewstuff2-4 (2 4:4.8.1) libknewstuff3-4 (2 4:4.8.1) libkparts4 (2 4:4.8.1) libktexteditor4 (2 4:4.8.1) libplasma3 (2 4:4.8.1) libqt4-dbus (2 4:4.5.3) libqt4-qt3support (2 4:4.5.3) libqt4-sql (2 4:4.5.3) libqt4-xml (2 4:4.5.3) libqtcore4 (2 4:4.8.0) libqtgui4 (2 4:4.8.0) libstdc++6 (2 4.1.1) aspell (16 (null)) ispell (16 (null)) hspell (0 (null)) khelpcenter4 (0 (null)) konsole (0 (null)) kate:i386 (0 (null))
4:4.8.2-0ubuntu2 - kate-data (2 4:4.8.2-0ubuntu2) katepart (5 4:4.8.2-0ubuntu2) kde-runtime (0 (null)) libc6 (2 2.14) libkateinterfaces4 (0 (null)) libkdecore5 (2 4:4.8.1) libkdeui5 (2 4:4.8.1) libkfile4 (2 4:4.8.1) libkio5 (2 4:4.8.1) libknewstuff2-4 (2 4:4.8.1) libknewstuff3-4 (2 4:4.8.1) libkparts4 (2 4:4.8.1) libktexteditor4 (2 4:4.8.1) libplasma3 (2 4:4.8.1) libqt4-dbus (2 4:4.5.3) libqt4-qt3support (2 4:4.5.3) libqt4-sql (2 4:4.5.3) libqt4-xml (2 4:4.5.3) libqtcore4 (2 4:4.8.0) libqtgui4 (2 4:4.8.0) libstdc++6 (2 4.1.1) aspell (16 (null)) ispell (16 (null)) hspell (0 (null)) khelpcenter4 (0 (null)) konsole (0 (null)) kate:i386 (0 (null))
Provides:
4:4.11.0-0ubuntu1~ubuntu12.04~ppa1 -
4:4.8.5-0ubuntu0.1 -
4:4.8.2-0ubuntu2 -
Reverse Provides:
timo@vosje:~$

Kijk eens of alle dependencies geïnstalleerd zijn?
Trotse eigenaar van een Nokia N900, een Nokia N9 en een Jolla.

Offline MKe

  • Lid
  • Steunpunt: Nee
Re: Kubutu 12.04 kate werkt niet
« Reactie #2 Gepost op: 2013/09/06, 07:41:48 »
Hoi Timo
Ik snap niet helemaal wat dit commando doet. Maar als ik jouw output vergelijk met die van mij valt me op dat ik de regel : kxstudio-desktop-kde4,kate mis.

Offline Timo

  • Forumteam
    • timo.diedering
  • Steunpunt: Ja
Re: Kubutu 12.04 kate werkt niet
« Reactie #3 Gepost op: 2013/09/06, 08:25:10 »
Het commando geeft aan welke afhankelijkheden kate heeft (onder het kopje 'dependencies'), dus je moet even kijken, of die allemaal geïnstalleerd zijn. Allereerst zou ik even kate-data proberen, als die niet geïnstalleerd is heeft -ie een reden om te mekkeren ;)
Trotse eigenaar van een Nokia N900, een Nokia N9 en een Jolla.

Offline MKe

  • Lid
  • Steunpunt: Nee
Re: Kubutu 12.04 kate werkt niet
« Reactie #4 Gepost op: 2013/09/06, 11:37:51 »
Bedankt, ik heb libktexteditor4 opnieuw geïnstalleerd, omdat die een lagere versie had dan de candidate met apt-cache policy. Daardoor werd er een heleboel geüpgraded en nu doet kate het ineens weer. Geen idee waarom apt-get update dit niet al gedaan had, maar het lijkt voorlopig weer te werken :)

$ apt-cache policy libktexteditor4
libktexteditor4:
  Installed: 4:4.10.5-0ubuntu0.1~ubuntu12.04~ppa1
  Candidate: 4:4.11.0-0ubuntu1~ubuntu12.04~ppa1
  Version table:
     4:4.11.0-0ubuntu1~ubuntu12.04~ppa1 0
        500 http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu/ precise/main amd64 Packages
 *** 4:4.10.5-0ubuntu0.1~ubuntu12.04~ppa1 0
        100 /var/lib/dpkg/status
     4:4.8.5-0ubuntu0.2 0
        500 http://nl.archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu/ precise-security/main amd64 Packages
     4:4.8.2-0ubuntu1 0
        500 http://nl.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages

Dit gedaan:
$ sudo apt-get install libktexteditor4

« Laatst bewerkt op: 2013/09/06, 11:39:39 door MKe »
Mijn blokkendoos blog: http://mke21.wordpress.com/

Offline Timo

  • Forumteam
    • timo.diedering
  • Steunpunt: Ja
Re: [opgelost]Kubutu 12.04 kate werkt niet
« Reactie #5 Gepost op: 2013/09/06, 16:10:03 »
apt-get update doet niet wat de naam zegt: het ververst namelijk alleen de softwarelijsten. Om te updaten moet je apt-get upgrade gebruiken ;)
Trotse eigenaar van een Nokia N900, een Nokia N9 en een Jolla.

Offline MKe

  • Lid
  • Steunpunt: Nee
Re: [opgelost]Kubutu 12.04 kate werkt niet
« Reactie #6 Gepost op: 2013/09/06, 18:38:31 »
Ja duh :) typefoutje, sorry :D

Ik bedoelde dus apt-get upgrade en apt-get dist-upgrade. Deze hebben dus geen upgrade gedaan van deze kde componenten.

Offline Timo

  • Forumteam
    • timo.diedering
  • Steunpunt: Ja
Re: [opgelost]Kubutu 12.04 kate werkt niet
« Reactie #7 Gepost op: 2013/09/06, 21:31:47 »
Ik dacht wel dat je het zou weten, maar ik haalde het toch maar even aan :P

Vreemd. Nou ja, apt heeft wel vaker van dat soort hickups, gelukkig heb je het kunnen oplossen :)
Trotse eigenaar van een Nokia N900, een Nokia N9 en een Jolla.