Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Lazarus 1.0.10 voor Xubuntu 13.04  (gelezen 314 keer)

Offline seghele

  • Lid
  • Steunpunt: Nee
Lazarus 1.0.10 voor Xubuntu 13.04
« Gepost op: 2013/08/21, 18:28:53 »
Heb de 3 bestanden
fpc_2.6.2-0_amd64.deb
fpc-src_2.6.2-0_amd64.deb
lazarus_1.0.10-0_amd64.deb

Tracht eerst het volgende te installeren:
~$ sudo apt-get install libgtk2.0-dev
[sudo] password for seghers:
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
Sommige pakketten konden niet geïnstalleerd worden. Dit kan betekenen dat u
een onmogelijke situatie gevraagd hebt of dat u de 'unstable'-distributie
gebruikt en sommige benodigde pakketten nog vastzitten in 'incoming'.
De volgende informatie helpt u mogelijk verder:
De volgende pakketten hebben niet-voldane vereisten:
 libgtk2.0-dev : Vereisten: libxcursor-dev maar het zal niet geïnstalleerd worden
                 Vereisten: libxfixes-dev (>= 1:3.0.0-3) maar het zal niet geïnstalleerd worden
                 Vereisten: libxcomposite-dev (>= 1:0.2.0-3) maar het zal niet geïnstalleerd worden
                 Vereisten: libxdamage-dev (>= 1:1.0.1-3) maar het zal niet geïnstalleerd worden
E: Kan problemen niet verhelpen, u houdt defecte pakketten vast.

Waar kan ik deze (welke) defecte pakketten vinden?
Hoe op te lossen?

Offline Cheap Applications

  • Lid
  • Steunpunt: Nee
Re: Lazarus 1.0.10 voor Xubuntu 13.04
« Reactie #1 Gepost op: 2013/08/21, 21:16:35 »
Citaat
Sommige pakketten konden niet geïnstalleerd worden. Dit kan betekenen dat u
een onmogelijke situatie gevraagd hebt of dat u de 'unstable'-distributie
gebruikt en sommige benodigde pakketten nog vastzitten in 'incoming'.
Staat de pakketbron unstable aan?
Desktop:
Processor: Intel® Core™2 Quad CPU Q8300 @ 2.50GHz × 4, Geheugen: 3.9Gb, GPU: nVidia 220GT OS: Windows 7 64 bit / Ubuntu 12.04 64 bit
Notebook:
Processor: Intel® Core™ i7-4700MQ, Geheugen: 8Gb, GPU: nVidia GTX765m (met Optimus) OS: Windows 8 64 bit / Elementary OS Luna 64 bit

Offline seghele

  • Lid
  • Steunpunt: Nee
Re: Lazarus 1.0.10 voor Xubuntu 13.04
« Reactie #2 Gepost op: 2013/08/21, 22:51:38 »
Citaat
Staat de pakketbron unstable aan?
Kan het aub duidelijker. Waar/wat bedoelt u?
Ben geen prof in Xubuntu.

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Lazarus 1.0.10 voor Xubuntu 13.04
« Reactie #3 Gepost op: 2013/08/22, 11:24:05 »
Om lazarus te installeren zonder lazarus te worden, gebruik je het softwarecentrum (ook beschikbaar in Xubuntu voor zover ik weet). Anders via de terminal: "sudo apt-get install lazarus". Installeren vanaf deb bestanden die je afzonderlijk download, is al een stuk moeilijker en vereist dat je al een beetje prof bent in Xubuntu.

Moet je echt de laatste versie, probeer dan de afhankelijkheden zoveel mogelijk te installeren via het softwarecentrum (of apt-get), vooraleer je de gedownloade debs installeert.
« Laatst bewerkt op: 2013/08/22, 11:28:02 door vanadium »

Offline seghele

  • Lid
  • Steunpunt: Nee
Re: Lazarus 1.0.10 voor Xubuntu 13.04
« Reactie #4 Gepost op: 2013/08/22, 11:33:30 »
Ik wil wel degelijk de nieuwe Lazarus.
Via Google heb ik de volgende info gevonden om de drie 'deb' bestanden te installeren, namelijk met volgende code:
sudo dpkg -i *.deb

Maar eerst moet het volgende opgelost worden:
sommige benodigde pakketten nog vastzitten in 'incoming'
Hoe los ik dat op?

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Lazarus 1.0.10 voor Xubuntu 13.04
« Reactie #5 Gepost op: 2013/08/22, 12:49:56 »
Post misschien eerst eens de foutmeldingen bij de installatie van de drie lazaruspakketten.

Offline seghele

  • Lid
  • Steunpunt: Nee
Re: Lazarus 1.0.10 voor Xubuntu 13.04
« Reactie #6 Gepost op: 2013/08/22, 20:26:26 »
Heb Xubuntu opnieuw geïnstaleerd
Deze werkt nu ook:
~$ sudo apt-get install libgtk2.0-devDaarna Lazarus 1.0.10 + fpc.
Alles werkt.
Bedankt voor de reacties.
 :)