Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: sdl (sdl-config)  (gelezen 883 keer)

dJnEvS

  • Gast
sdl (sdl-config)
« Gepost op: 2007/03/09, 14:29:07 »
Beste mensen,

Ik probeer het spel daimonin te installeeren
Heb em al eens een keer draaiende gehad
Maar toen had ik mijn linux verkloot (x troep perongelijk verwijdert)
Nu heb ik ubuntu er weer op. maar krijg sdl niet aan de praat
Als ik de .deb uitvoer die ik van packages.debian.com uitvoer
geeftie aan dat een nieuwere versie al is geinstalled.

Mijn foutmelding met ./config van daimonin:
# ./configure
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking whether make sets $(MAKE)... yes
checking for a BSD-compatible install... /usr/bin/install -c
checking for makedepend... /usr/bin/makedepend
checking for cp... /bin/cp
checking for rm... /bin/rm
checking for rmdir... /bin/rmdir
checking for mkdir... /bin/mkdir
checking for sdl-config... ./configure: line 2749: error:: command not found
no
./configure: line 2766: --cflags: command not found
./configure: line 2768: --libs: command not found
checking for stricmp... no
checking for strnicmp... no
checking for strcasecmp... yes
checking for strncasecmp... yes
checking how to run the C preprocessor... gcc -E
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for unistd.h... (cached) yes
checking fcntl.h usability... yes
checking fcntl.h presence... yes
checking for fcntl.h... yes
configure: creating ./config.status
config.status: creating Makefile
config.status: creating ../../src/Makefile
config.status: creating ../../src/include/define.h
config.status: ../../src/include/define.h is unchanged
Hij kan sdl-config dus niet vinden.
Is er mischien een los pakket met sdl-config?

Vriendelijke groeten,
Sven Petersen.

dJnEvS

  • Gast
sdl (sdl-config)
« Reactie #1 Gepost op: 2007/03/09, 16:37:33 »
Zou iemand mij hier bij kunnen helpen?

Offline Kiwinote

  • Lid
    • Launchpad
  • Steunpunt: Nee
sdl (sdl-config)
« Reactie #2 Gepost op: 2007/03/09, 17:06:28 »
Citaat van: dJnEvS
Als ik de .deb uitvoer die ik van packages.debian.com uitvoer
geeftie aan dat een nieuwere versie al is geinstalled.
Dan is die al geinstalleerd. Wat geeft daimonin in de terminal?

dJnEvS

  • Gast
sdl (sdl-config)
« Reactie #3 Gepost op: 2007/03/09, 20:30:53 »
dat staat in mijn post.....

checking for sdl-config... ./configure: line 2749: error:: command not found
no
./configure: line 2766: --cflags: command not found
./configure: line 2768: --libs: command not found
hij kan sld-config niet vinden.
maar ik kan sdl niet (opnieuw) installeeren
omdat hij zegt dat deze al geinstalleerd is.

Offline muksie

  • Lid
  • Steunpunt: Nee
sdl (sdl-config)
« Reactie #4 Gepost op: 2007/03/09, 20:33:25 »
Het je het pakket libsdl1.2-dev ook geinstalleerd? Om programma's die van SDL gebruik maken te kunnen compileren ben je deze ook nog nodig.

dJnEvS

  • Gast
sdl (sdl-config)
« Reactie #5 Gepost op: 2007/03/09, 21:40:10 »
# apt-get install libsdl1.2-dev
Reading package lists... Done
Building dependency tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libsdl1.2-dev: Depends: libsdl1.2debian (= 1.2.9-0.0ubuntu2) but 1.2.10-3ubuntu2 is to be installed
                 Depends: libasound2-dev but it is not going to be installed
                 Depends: libartsc0-dev but it is not going to be installed
E: Broken packages