Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [Opgelost] Lamp localhost/index.php geeft blanke pagina  (gelezen 697 keer)

Offline VandenBossche

  • Lid
  • Steunpunt: Nee
[Opgelost] Lamp localhost/index.php geeft blanke pagina
« Gepost op: 2013/07/18, 12:37:38 »
Ik heb LAMP-server geïnstalleerd op XUbuntu 12.04, evenals PHPMyAdmin.
Als ik in de browser naar 'localhost' surf krijg ik een werkende index.htm pagina.
Ook localhost/phpmyadmin werkt. Bedoeling is dat ik mijn eigen website kan testen.
Maar localhost/index.php werkt niet, geeft een blanke pagina, blanke paginabron, geen meldingen.
Net zo min als mijn eigen website in /var/www. Ik ben gemigreerd van Ubuntu 10.04 waar het wel werkte.
Iemand een idee? Waarschijnlijk een domme fout van mij?
« Laatst bewerkt op: 2013/07/19, 18:09:03 door Ron »

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Lamp localhost/index.php geeft blanke pagina
« Reactie #1 Gepost op: 2013/07/18, 12:40:46 »
Wellicht een fout in index.php, aangezien php blijkbaar wel correct geïnstalleerd is: phpmyadmin werkt immers.

Offline VandenBossche

  • Lid
  • Steunpunt: Nee
Re: Lamp localhost/index.php geeft blanke pagina
« Reactie #2 Gepost op: 2013/07/18, 19:19:35 »
Dat zal het probleem niet zijn. Ik heb verschillende websites online staan met dezelfde php-bestanden. Die bestanden zijn trouwens niet gewijzigd t.o.v. mijn vorige Ubuntu (10.04), toen ze wel werkten.

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: Lamp localhost/index.php geeft blanke pagina
« Reactie #3 Gepost op: 2013/07/18, 21:00:19 »
Misschien een rechten probleem en mag de file niet gelezen worden?
Even met de rechter-muis-toets kijken of iedereen mag lezen.
OpenStandaard evangelist, OpenSource promotor,  OpenData liefhebber.
Xubuntu gebruiker, liefhebber en tester.
In Nederland bekend als een dwarsligger.

Offline VandenBossche

  • Lid
  • Steunpunt: Nee
Re: Lamp localhost/index.php geeft blanke pagina
« Reactie #4 Gepost op: 2013/07/19, 17:45:06 »
Inderdaad een probleem met rechten.
Ik had de rechten van index.php wel nagezien, maar daar zitten includes in van bestanden die niet de juiste rechten hadden.
Met gevolg dat ik niets te zien kreeg.
Ik heb de rechten gewijzigd met chmod -R 644 /var/www.
Bij de eigenschappen van de bestanden stond dan dat de rechten inconsistent waren. Met een knop 'Maprechten corrigeren' verdween het kruisje op het pictogram van de map. Maar ik versta niet wat er niet consistent was.
Ik heb dan nog eens de rechten gewijzigd naar 777.
Overigens zijn er ondertussen de meeste kruisjes op de pictogrammen spontaan verdwenen.

Ik kan mijn websites op localhost in de browser terug bekijken. Moet ik dit topic als [opgelost] aanmerken? Hoe moet ik dat doen?

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: Lamp localhost/index.php geeft blanke pagina
« Reactie #5 Gepost op: 2013/07/19, 18:08:44 »
Moet ik dit topic als [opgelost] aanmerken? Hoe moet ik dat doen?
Door het eerste bericht aan te passen en [Opgelost] aan het onderwerp toe te voegen.
Dat zal ik voor je doen.
OpenStandaard evangelist, OpenSource promotor,  OpenData liefhebber.
Xubuntu gebruiker, liefhebber en tester.
In Nederland bekend als een dwarsligger.