Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Problemen bij installatie 5.10 en 6.04  (gelezen 3296 keer)

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Problemen bij installatie 5.10 en 6.04
« Gepost op: 2006/02/22, 15:46:13 »
Hallo iedereen :)
Ik ben van plan [K]ubuntu 5.10 of 6.04 (flight4) te installeren op mijn laptop,
omdat ik een meer desktop-gerichte/bleeding edge distro dan Debian wil
(wat ik voorheen altijd draaide)
maar toch wil ik de 'power' van Debian blijven voelen :)

Ik heb een Acer Aspire 1694wlmi laptop.
Met Debian heb ik reeds verschillende installaties gedaan
Maar in Ubuntu / Kubuntu lukt het me niet om de installatie juist af te ronden.

Eerst en vooral gebruik ik de volgende bootparameters:

vga=normal noapic pci=noacpi acpi=off

omdat er anders wel een paar problemen optreden :)
(nogal buggy acpi bios enzo)

In Debian moest ik dit in het begin ook doen
(achteraf doe ik dan wel een kernel recompile met DSDT initrd patch etc...)

Maar het eerste (kleine) probleem ligt bij de detectie van de netwerkkaarten.
Ik heb 2 netwerkkaarten:
1 draadloze netwerkkaart (Intel
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline kennywest

  • Lid
    • http://kennywest.blogspot.com
  • Steunpunt: Nee
Problemen bij installatie 5.10 en 6.04
« Reactie #1 Gepost op: 2006/02/22, 16:14:59 »
Slecht gebrande CD?

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Problemen bij installatie 5.10 en 6.04
« Reactie #2 Gepost op: 2006/02/22, 21:50:14 »
Check inderdaad de CD en probeer eerst 5.10 helemaal te installeren om hardwareproblemen te ontdekken/uit te sluiten.

Verget ook niet dat veel fijne debuginfo kan geven.

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Problemen bij installatie 5.10 en 6.04
« Reactie #3 Gepost op: 2006/02/22, 22:09:01 »
Het is me uiteindelijk gelukt om Kubuntu 6.04 te installeren.
Het had niets te maken met de cd.

Eerst en vooral heb ik chkdsk /f uitgevoerd op mijn FAT32-partitie

en daarna kon ik (na lang wachten bij het zoeken van de partities)
Kubuntu 6.04 installeren op een Acer Aspire 1694wlmi met volgende bootparameters:

noapic acpi=off pci=noacpi

(problemen met ACPI, wil ik achteraf nog oplossen!)

Jammer genoeg heb ik nu problemen met internet!
Hoewel mijn ethernetkaart meteen werkte in Debian met de tg3 driver,
doet deze het in Ubuntu/Kubuntu niet !

Mijn draadloos netwerk (ipw2200) krijg ik ook niet aan de praat..

Ik heb ACPI al gedeeltelijk werkend gekregen met andere DSDT in initrd..
batterijstatus kan nog niet gelezen worden, maar ik ben van plan achteraf zelf nog eens opnieuw DSDT te compileren met iasl

Nu wil ik in ieder geval OF de Broadcom Ethernet eXtreme netwerkkaart OF de ipw2200 draadloze netwerkkaart aan de praat krijgen!

Ik denk dat ik dicht bij een werkende ipw2200 zat na de gedeeltelijk werkende ACPI.
Ik zag in dmesg dat firmware niet geladen kon worden.
Ik heb dan meteen de nieuwste ipw2200 en bijhorende firmware van ipw2200.sourceforge.net gedownload.
Maar Ubuntu 6.04 heeft blijkbaar geen hotplug (wel udev) en hierdoor kan ik de *.fw (firmware bestanden) niet kopie
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Problemen bij installatie 5.10 en 6.04
« Reactie #4 Gepost op: 2006/02/22, 22:34:04 »
nee nee nee, geen hotplug doen in dapper!!
Hotplug is obsolete, dat wordt allemaal door udev gedaan tegenwoordig. Die broadcom kaart, ziet die er ongeveer zo uit in lspci:

0000:02:0e.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5705M_2 Gigabit Ethernet (rev 03)

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Problemen bij installatie 5.10 en 6.04
« Reactie #5 Gepost op: 2006/02/22, 22:38:20 »
Ik denk van wel. Alleen van "BCM5705M_2" ben ik niet 100% zeker...
Volgende keer dat ik nog wat probeer op ubuntu zal ik ook meteen de precieze output van lspci|grep Broadcom posten
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Problemen bij installatie 5.10 en 6.04
« Reactie #6 Gepost op: 2006/02/23, 15:37:28 »
Ik heb net even /var/log/syslog bekeken ...
Ik ben vrij zeker dat het problemen met het Bios zijn.
(foutmeldingen zoals: no irq known for... irq #10 disabled...)

Misschien helpt het om eerst te proberen mijn ACPI en dergelijke volledig in orde te brengen,
ik ga me hiermee straks bezighouden :) (ik zit nu op school)

Als jullie nog tips weten? :)

Ik geef het in ieder geval niet op ! :D
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Problemen bij installatie 5.10 en 6.04
« Reactie #7 Gepost op: 2006/02/23, 15:52:22 »
Nog een bootparameter proberen:

pci=routeirq

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Problemen bij installatie 5.10 en 6.04
« Reactie #8 Gepost op: 2006/02/23, 19:09:47 »
Citaat van: Dennis
Nog een bootparameter proberen:

pci=routeirq
dan krijg ik zelfs geen beeld meer :)
vermoedelijk zelfs gewoon een hele "freeze" van het systeem

ik moet voorlopig "pci=noacpi" wel gebruiken
(en "pci=noacpi pci=routeirq" doet ook geen verschil)

Ik heb DSDT.aml gecompileerd met de intel asl compiler
en deze gekopieerd naar "/etc/mkinitrd/DSDT"
daarna heb ik "dpkg-reconfigure linux-image-2.6.15-15-386" aangeroepen,
acpi werkt nog altijd niet perfect (ik kan namelijk batterijstatus niet inlezen)

Ik zie ongeveer zoiets in dmesg:

"Error: Looking up [Z00C] in namespace, AE_NOT_FOUND"
en
"Error: Method execution failed [\\_SB_.BAT1._BST] (Node 0xc1996580), AE_NOT_FOUND"

BAT1 staat overduidelijk voor "batterij 1" :)

...Ik zou zelf wel eens een kernel recompile willen doen,
maar make tools zijn blijkbaar niet ge
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline kennywest

  • Lid
    • http://kennywest.blogspot.com
  • Steunpunt: Nee
Problemen bij installatie 5.10 en 6.04
« Reactie #9 Gepost op: 2006/02/23, 19:28:09 »
Installeer de make tools en make-kpkg en compileer uw eigen kernel. Heb ik ook gedaan ;)

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Problemen bij installatie 5.10 en 6.04
« Reactie #10 Gepost op: 2006/02/23, 19:53:21 »
Ik lees net ergens dat vanaf Breezy je niet naar "/etc/mkinitrd/DSDT" moet kopie
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline kennywest

  • Lid
    • http://kennywest.blogspot.com
  • Steunpunt: Nee
Problemen bij installatie 5.10 en 6.04
« Reactie #11 Gepost op: 2006/02/23, 20:00:12 »
Ik gebruik geen initrd. Die kernel van mij is zo klein dat dat niet nodig is ;)

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Problemen bij installatie 5.10 en 6.04
« Reactie #12 Gepost op: 2006/02/23, 20:41:46 »
Ok
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Problemen bij installatie 5.10 en 6.04
« Reactie #13 Gepost op: 2006/02/23, 22:12:47 »
Alle problemen liggen aan IRQ 10
Hier heb ik niet zoveel verstand van :)
Maar als iemand me ergens naar kan doorverwijzen?!

Ik zal even posten wat ik heb gevonden i.v.m. IRQ 10:

(lspci -v)

0000:00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 04) (prog-if 00 [UHCI])
        Subsystem: Acer Incorporated [ALI]: Unknown device 0066
        Flags: bus master, medium devsel, latency 0, IRQ 10
        I/O ports at 1860 [size=32]

^^ Ik denk 1 van de USB-poorten ? ik heb ze niet allemaal getest, maar misschien zou ik dat eens moeten doen

0000:00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 04)
        Subsystem: Acer Incorporated [ALI]: Unknown device 0066
        Flags: bus master, medium devsel, latency 0, IRQ 10
        I/O ports at 1c00 [size=256]
        I/O ports at 1880 [size=64]
        Memory at b0000800 (32-bit, non-prefetchable) [size=512]
        Memory at b0000400 (32-bit, non-prefetchable) [size=256]

^^ Geluid werkt niet!

0000:01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility X700 (PCIE) (prog-if 00 [VGA])
        Subsystem: Acer Incorporated [ALI]: Unknown device 0066
        Flags: bus master, fast devsel, latency 0, IRQ 10
        Memory at c0000000 (32-bit, prefetchable) [size=256M]
        I/O ports at 3000 [size=256]
        Memory at b0100000 (32-bit, non-prefetchable) [size=64K]
        Expansion ROM at b0120000 [disabled] [size=128K]

^^ ATI grafische kaart, nog niet geconfigureerd

0000:06:08.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5788 Gigabit Ethernet (rev 03)
        Subsystem: Acer Incorporated [ALI]: Unknown device 0066
        Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 10
        Memory at b0200000 (32-bit, non-prefetchable) [size=64K]

^^ Netwerkkaart die met tg3 zou moeten werken, maar deze werkt dus niet

- - - - - - - - - - - - - - - - - - - -

(dmesg)

[4294680.920000] eth1: Tigon3 [partno(BCM95705A50) rev 3003 PHY(5705)] (PCI:33MHz:32-bit) 10/100/1000BaseT Ethernet 00:c0:9f:c8:6d:f8
[4294680.921000] eth1: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[0] Split[0] WireSpeed[0] TSOcap[1]
[4294680.921000] eth1: dma_rwctrl[763f0000]
[4294681.963000] irq 10: nobody cared (try booting with the "irqpoll" option)
[4294681.963000]  [<4013e1f2>] __report_bad_irq+0x22/0x80
[4294681.963000]  [<4013e2e8>] note_interrupt+0x68/0xc0
[4294681.963000]  [<4013dbac>] __do_IRQ+0xbc/0xe0
[4294681.963000]  [<4010597a>] do_IRQ+0x1a/0x30
[4294681.963000]  [<401040ea>] common_interrupt+0x1a/0x20
[4294681.963000]  [<40120e50>] __do_softirq+0x30/0xb0
[4294681.963000]  [<40120f05>] do_softirq+0x35/0x40
[4294681.963000]  [<40120fb5>] irq_exit+0x35/0x40
[4294681.963000]  [<4010597f>] do_IRQ+0x1f/0x30
[4294681.963000]  [<401040ea>] common_interrupt+0x1a/0x20
[4294681.963000] handlers:
[4294681.963000] [<808b9330>] (usb_hcd_irq+0x0/0x60 [usbcore])
[4294681.963000] [<80a14810>] (snd_intel8x0_interrupt+0x0/0x2a0 [snd_intel8x0])
[4294681.963000] Disabling IRQ #10

- - - - - - - - - - - - - - - - - - - -

Enige suggesties ??
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Problemen bij installatie 5.10 en 6.04
« Reactie #14 Gepost op: 2006/02/23, 22:18:53 »
PS: how do I work with firmware files in udev? with hotplug I had to place the *.fw files in /usr/lib/hotplug/firmware or something like that

-- edit --

Oeps, opnieuw in het Nederlands: :D

PS: hoe werk ik met firmware bestanden in udev? met hotplug moest ik gewoon de *.fw bestanden in /usr/lib/hotplug/firmware ofzoiets plaatsen
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Problemen bij installatie 5.10 en 6.04
« Reactie #15 Gepost op: 2006/02/23, 22:36:22 »
Citaat van: profoX
PS: hoe werk ik met firmware bestanden in udev? met hotplug moest ik gewoon de *.fw bestanden in /usr/lib/hotplug/firmware ofzoiets plaatsen
Blader eens door /etc/udev /etc/mod* enzo (draai nu zelf even geen dapper dus kan niet duidelijker zijn).

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Problemen bij installatie 5.10 en 6.04
« Reactie #16 Gepost op: 2006/02/25, 13:19:31 »
gewoon /lib/firmware als ik me niet vergis ?

Maar nog steeds IRQ problemen! ik heb al zowat
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Problemen bij installatie 5.10 en 6.04
« Reactie #17 Gepost op: 2006/02/25, 20:04:02 »
2.6.12 heeft dan weer een ander probleem . . .
Blijkbaar alleen met KDM, Dus ga ik GDM proberen . . .

Error bij 2.6.12-9-386 en KDM is:

Feb 25 20:13:31 axxel kdm: :0[3497]: IO Error in XOpenDisplay
Feb 25 20:13:31 axxel kdm[3474]: X server for display :0 terminated unexpectedly
Feb 25 20:13:31 axxel kdm[3474]: Display :0 cannot be opened
Feb 25 20:13:31 axxel kdm[3474]: Unable to fire up local display :0; disabling.
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Gast

  • Gast
Problemen bij installatie 5.10 en 6.04
« Reactie #18 Gepost op: 2006/03/08, 00:37:31 »
Hoi profoX,

heb zelf ook een nieuwe Aspire 1694wlmi en probeer er ook Ubuntu op te installeren. Onlangs voor het eerst de desktopversie geinstalleerd op m'n PC en werkt erg prettig :). Op m'n nieuwe laptop gaat het minder vlot :(. Heb me al te pletter gezocht. Ben trouwens een niewbie in linux. Al doende leert men maar de laptop weet ik niet zo zeker.

Ivm de IRQ 10 heb ik het volgende teruggevonden. Niet echt een oplossing maar misschien helpt het je verder.

http://ubuntuforums.org/showthread.php?t=124889&highlight=aspire

Hopelijk kan je hier iets mee

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Problemen bij installatie 5.10 en 6.04
« Reactie #19 Gepost op: 2006/03/08, 11:39:13 »
Nee, dat had ik al geprobeerd :)
Ik heb het een tijd geleden voorlopig opgelost door ipw2200 te blacklisten (draadloos netwerk)
Hierdoor kreeg ik geen problemen meer met IRQ10 . . .
Wel raar, want ipw2200 zit zelf op IRQ 11 :)
Zelf gebruik ik meestal kabel internetverbinding op de laptop dus heb ik er nog niet naar gekeken,
maar als je wil, dan zoek ik het wel nog verder uit.

Anyway, als je hulp wilt met het aan de praat te krijgen op je Aspire1694,
dan stuur je me maar een mail :) wesley@debianbox.be of gogogowesley@gmail.com

Bij mij werkt Alles nu perfect, behalve die ipw2200 :) . . .
Ik gebruik btw Kubuntu 6.04 Flight 4 :)
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)