Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [Opgelost] Portal werkt niet op Ubuntu 13.04  (gelezen 1194 keer)

Offline ikbenerniet

  • Lid
  • Steunpunt: Nee
[Opgelost] Portal werkt niet op Ubuntu 13.04
« Gepost op: 2013/05/08, 19:43:38 »
Goeiemiddag,

Ik ben nieuw hier op het forum, en ook met ubuntu/linux. Als dit in de games sectie hoort te staan dan mogen de modjes het wel verplaatsen :)


Een aantal dagen geleden is er een betá versie van Portal in Steam beschikbaar gekomen, deze heb ik zonder problemen kunnen installeren, maar wil vanwege de volgende foutmelding alleen niet afspelen:




nu heb ik wel op internet naar een oplossing zitten te zoeken, maar heb nog niks kunnen vinden. weet iemand hier een oplossing?

nog wat computer info:
http://i.imgur.com/fdImmdK.png

De gebruikte laptop is een oude medion van de aldi :P
Hiervoor stond er Vista op, een aantal jaar geleden heb ik hier wel Portal op kunnen spelen (ook via Steam)
In de foutmelding hierboven staat dat mogelijk de videokaart niet ondersteund wordt, maar aangezien Portal wel op Vista gewerkt heeft, en de hardware hetzelfde is, zou het nog steeds moeten werken?
« Laatst bewerkt op: 2013/05/10, 16:30:43 door ikbenerniet »

Offline erik1984

  • Lid
    • erik1984
  • Steunpunt: Nee
Re: Portal werkt niet op Ubuntu 13.04
« Reactie #1 Gepost op: 2013/05/08, 20:09:36 »
Helaas gaat die vlieger niet zomaar op. Fabrikanten ondersteunen doorgaans Windows beter wat betreft drivers. Het is belangrijk om te weten om welke videokaart het precies gaat. Wellicht helpt het nog om de gesloten drivers te installeren in plaats van de standaard geactiveerde open source drivers in het geval van een ATI/AMD of Nvidia-kaart.


Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Portal werkt niet op Ubuntu 13.04
« Reactie #2 Gepost op: 2013/05/08, 20:27:18 »
Helaas gaat die vlieger niet zomaar op. Fabrikanten ondersteunen doorgaans Windows beter wat betreft drivers. Het is belangrijk om te weten om welke videokaart het precies gaat. Wellicht helpt het nog om de gesloten drivers te installeren in plaats van de standaard geactiveerde open source drivers in het geval van een ATI/AMD of Nvidia-kaart.



Dat en het feit dat Portal voor Linux nog in beta is.

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Portal werkt niet op Ubuntu 13.04
« Reactie #3 Gepost op: 2013/05/08, 22:07:40 »
glxinfo | grep renderer\ string
lspci -nn

Wat geven deze commando's terug?
« Laatst bewerkt op: 2013/05/09, 00:59:46 door Cumulus007 »

Offline ikbenerniet

  • Lid
  • Steunpunt: Nee
Re: Portal werkt niet op Ubuntu 13.04
« Reactie #4 Gepost op: 2013/05/08, 22:47:48 »
Bovenste geeft:
renderer string: opdracht niet gevonden

je bedoelst waarschijndlijk deze? glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: Gallium 0.4 on ATI RS480
    GL_NV_conditional_render, GL_ARB_ES2_compatibility, GL_ARB_debug_output,

ik kan ook nog wel de gehele glxinfo hier plaatsen als het nodig is?

onderste geeft:
00:00.0 Host bridge [0600]: Advanced Micro Devices [AMD] nee ATI RS480/RS482/RS485 Host Bridge [1002:5950] (rev 10)
00:01.0 PCI bridge [0604]: Advanced Micro Devices [AMD] nee ATI RS480 PCI Bridge [1002:5a3f]
00:06.0 PCI bridge [0604]: Advanced Micro Devices [AMD] nee ATI RS480 PCI Bridge [1002:5a38]
00:07.0 PCI bridge [0604]: Advanced Micro Devices [AMD] nee ATI RS480 PCI Bridge [1002:5a39]
00:12.0 IDE interface [0101]: Advanced Micro Devices [AMD] nee ATI IXP SB400 Serial ATA Controller [1002:4379] (rev 80)
00:13.0 USB controller [0c03]: Advanced Micro Devices [AMD] nee ATI IXP SB400 USB Host Controller [1002:4374] (rev 80)
00:13.1 USB controller [0c03]: Advanced Micro Devices [AMD] nee ATI IXP SB400 USB Host Controller [1002:4375] (rev 80)
00:13.2 USB controller [0c03]: Advanced Micro Devices [AMD] nee ATI IXP SB400 USB2 Host Controller [1002:4373] (rev 80)
00:14.0 SMBus [0c05]: Advanced Micro Devices [AMD] nee ATI IXP SB400 SMBus Controller [1002:4372] (rev 83)
00:14.1 IDE interface [0101]: Advanced Micro Devices [AMD] nee ATI IXP SB400 IDE Controller [1002:4376] (rev 80)
00:14.2 Audio device [0403]: Advanced Micro Devices [AMD] nee ATI IXP SB4x0 High Definition Audio Controller [1002:437b] (rev 01)
00:14.3 ISA bridge [0601]: Advanced Micro Devices [AMD] nee ATI IXP SB400 PCI-ISA Bridge [1002:4377] (rev 80)
00:14.4 PCI bridge [0604]: Advanced Micro Devices [AMD] nee ATI IXP SB400 PCI-PCI Bridge [1002:4371] (rev 80)
00:18.0 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration [1022:1100]
00:18.1 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map [1022:1101]
00:18.2 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller [1022:1102]
00:18.3 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control [1022:1103]
01:05.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI RS482M [Mobility Radeon Xpress 200] [1002:5975]
04:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller [10ec:8168] (rev 01)
05:04.0 FireWire (IEEE 1394) [0c00]: O2 Micro, Inc. Firewire (IEEE 1394) [1217:00f7] (rev 02)
05:04.2 SD Host controller [0805]: O2 Micro, Inc. Integrated MMC/SD Controller [1217:7120] (rev 01)
05:04.3 Mass storage controller [0180]: O2 Micro, Inc. Integrated MS/xD Controller [1217:7130] (rev 01)
05:09.0 Network controller [0280]: Ralink corp. RT2561/RT61 rev B 802.11g [1814:0302]

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Portal werkt niet op Ubuntu 13.04
« Reactie #5 Gepost op: 2013/05/09, 01:03:45 »
Dat bedoelde ik inderdaad :)

En wat doet:

glxinfo | grep version\ string

Offline ikbenerniet

  • Lid
  • Steunpunt: Nee
Re: Portal werkt niet op Ubuntu 13.04
« Reactie #6 Gepost op: 2013/05/09, 12:12:01 »
glxinfo | grep version\ string geeft het volgende:

server glx version string: 1.4
client glx version string: 1.4
OpenGL version string: 2.1 Mesa 9.1.1
OpenGL shading language version string: 1.20

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Portal werkt niet op Ubuntu 13.04
« Reactie #7 Gepost op: 2013/05/09, 23:11:15 »
Je GLSL-versie is te laag om Source Engine-gebaseerde games op Linux te draaien. Waarschijnlijk gaat het je Mobility Radeon Xpress 200 ook niet lukken om OpenGL 3/GLSL 1.3 aan te kunnen, welke driver je ook gebruikt, die van AMD (als die al beschikbaar zijn) of de opensource. Ik vrees dat je pech hebt...

Offline ikbenerniet

  • Lid
  • Steunpunt: Nee
Re: Portal werkt niet op Ubuntu 13.04
« Reactie #8 Gepost op: 2013/05/09, 23:17:18 »
Oké, iig bedankt voor de hulp!  :)

dan ga ik hem binnenkort maar weer deïnstalleren.

mijn vraag is hierbij wel beantwoord, dus hier mag wel een slotje op. (als dat hier gebruikelijk is?)

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Portal werkt niet op Ubuntu 13.04
« Reactie #9 Gepost op: 2013/05/10, 00:58:31 »
Een slotje is hier niet gebruikelijk, dit echter wel ;)
http://forum.ubuntu-nl.org/forum/wat-doe-je-als-je-vraag-is-opgelost/