Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: <opgelost> commando last werkt niet zoals het hoort vanaf kernel 3.2.0-40  (gelezen 285 keer)

Offline HarzG

  • Lid
  • Steunpunt: Nee
Op de vraag naar de laatste gebruikersactiviteiten met last kon je vroeger de activiteiten van de familie zien.
De oude manier van reageren onder 10.04 en met 12.04 tot kernel 3.2.0-39 was bijv. zo
~$ last
willy   pts/0        :0.0             Sun Feb  6 23:16 - 23:16  (00:00)   
max    tty8         :2               Sun Feb  6 22:23 - 22:23  (00:00)   
max    tty8         :1               Sun Feb  6 21:59 - 22:22  (00:23)   
willy   tty7         :0               Sun Feb  6 21:39 - down   (01:37)   
reboot   system boot  2.6.32-28-generi Sun Feb  6 21:39 - 23:17  (01:37)   

Tegenwoordig wordt door last bij Ubuntu vanaf kernel 3.2.0-40 niets meer over de activiteiten van de gebruikers meegedeeld, er staat alleen de boottijd en het afsluiten genoteerd.
reboot   system boot  3.2.0-40-generic Wed May  1 21:13 - 22:31  (01:17) Met een Debian systeem bijv. siduction met kernels 3.8.x kan ik met last nog de bekende uitgave zien van de boot&user activiteiten. Het is dus weer een bijzonder Ubuntu-dingetje wat ik niet gedocumenteerd heb gezien/gevonden. Ook met de kernel 3.2.0-41-generic is (X)Ubuntu weinig informatief met last.

Kan iemand met een Ubuntu 3.5.x systeem voor mij nakijken of het met de nieuwere kernel in een terminal met last weer iets meedeelt zoals het hoort?
« Laatst bewerkt op: 2013/05/03, 11:39:11 door HarzG »
Xubuntu 16.04; siduction-15.1.0 Xfce

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: commando last werkt niet zoals het hoort vanaf kernel 3.2.0-40
« Reactie #1 Gepost op: 2013/05/02, 19:06:32 »
Weet je zeker dat dat aan de kernel ligt? Hier werkt het namelijk wel:
johan@desktop:~$ last
johan    pts/3        localhost        Thu May  2 19:04   still logged in   
johan    pts/4        :0               Thu May  2 15:55   still logged in   
reboot   system boot  3.2.0-41-generic Thu May  2 15:55 - 19:05  (03:09)   

wtmp begins Thu May  2 15:52:09 2013
johan@desktop:~$ uname -a
Linux desktop 3.2.0-41-generic #66-Ubuntu SMP Thu Apr 25 03:27:11 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
(De bovenste regel is omdat ik via ssh verbinding maakte met localhost, om te testen).

Offline Tom

  • Lid
    • Wanda´s Blog Linux Xubuntu.
  • Steunpunt: Nee
Re: commando last werkt niet zoals het hoort vanaf kernel 3.2.0-40
« Reactie #2 Gepost op: 2013/05/02, 19:06:33 »
tom@tom-KC863AA-B14-a6320-be:~$ last
tom      pts/0        :0.0             Thu May  2 19:02   still logged in   
reboot   system boot  3.5.0-28-generic Thu May  2 15:00 - 19:02  (04:01)   
reboot   system boot  3.5.0-28-generic Thu May  2 09:12 - 10:38  (01:25)   
reboot   system boot  3.5.0-28-generic Thu May  2 00:30 - 00:33  (00:02)   
tom      pts/1        :0.0             Wed May  1 23:21 - 23:22  (00:01)   
reboot   system boot  3.5.0-27-generic Wed May  1 16:50 - 00:29  (07:39)   

wtmp begins Wed May  1 13:21:11 2013
tom@tom-KC863AA-B14-a6320-be:~$

Is wel Xubuntu 12.10 Kernel 3.5.0-28-44
2 x Xuby 14.04.5 Lts 64 bits stand alone. 2 x Xuby 16.04.3 Lts 64 bits stand alone.
https://sites.google.com/site/wandabloglinuxxubuntu/pc-s-installeren-configureren

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: commando last werkt niet zoals het hoort vanaf kernel 3.2.0-40
« Reactie #3 Gepost op: 2013/05/02, 19:17:42 »
Was het niet zo dat de loginmanager dit soort dingen regelt?
Zie een vergelijkbare bug van lightdm van een tijdje geleden: https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/870297
https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/1027805

Offline HarzG

  • Lid
  • Steunpunt: Nee
Re: commando last werkt niet zoals het hoort vanaf kernel 3.2.0-40
« Reactie #4 Gepost op: 2013/05/03, 11:38:41 »
Mijne heren,

Bedankt voor jullie reacties. Het zat inderdaad niet in de kernel, maar ik kon de lastige oorzaak ervan niet vaststellen.

Eerst heb ik gdm i.p.v. lightdm geprobeerd - daarmee ging het "goed". Last werkte weer zoals het hoort. Maar helaas was  bij 1 gebruiker het Xfce4-profiel beschadigd. 
Nu werd ik een beetje recalcitrant en dacht Xfce te slim af te zijn, dus heb ik de ppa Xfce4.10 geprobeerd (omdat die mooi werkt in Mint en het daar zelfs zonder ppa kan). Het werd er allemaal niet beter op. Uiteindelijk moest ik weer downgraden naar Xfce4.8.
De oplossing was: inloggen met LXDE, Xfce, Thunar e.a. compleet verwijderen, apt-get clean en vervolgens de Xubuntu-desktop opnieuw installeren. Het beschadigde profiel van mij werkt nu spontaan weer als vanouds en last doet dat (edit: volgorde aangepast) wat ik ervan verwacht.
« Laatst bewerkt op: 2013/05/03, 17:27:50 door HarzG »
Xubuntu 16.04; siduction-15.1.0 Xfce