Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: error code (1) tijdens upgrade  (gelezen 1602 keer)

Offline AB

  • Lid
  • Steunpunt: Nee
error code (1) tijdens upgrade
« Gepost op: 2007/03/05, 20:33:52 »
Tijdens het upgraden van m`n server (6.10) via webmin krijg ik de volgende melding(en) en kan ik vervolgens niets meer upgraden. Ik heb heel `t internet al bekeken maar kom er niet uit. Iemand een idee?

----------------------------------------------------------------------------------------------------------------------
Pakketlijsten worden ingelezen...
Boom van vereisten wordt opgebouwd...
Reading state information...
0 pakketten opgewaardeerd, 0 nieuwe pakketten geïnstalleerd, 0 verwijderen en 0 niet opgewaardeerd.
1 pakketten niet volledig geïnstalleerd of verwijderd.
Er moeten 0B aan archieven opgehaald worden.
Na het uitpakken zal er 0B extra schijfruimte gebruikt worden.
Instellen van samba (3.0.22-1ubuntu4.1) ...
debconf: kan de interface niet initialiseren: Dialog
debconf: (TERM is niet gezet; hierdoor is de dialoog-interface onbruikbaar.)
debconf: er wordt teruggevallen op interface: Readline
debconf: kan de interface niet initialiseren: Readline
debconf: (Deze interface vereist een sturende tty.)
debconf: er wordt teruggevallen op interface: Teletype
Couldn't reopen stdin(/dev/tty): No such device or address at /usr/sbin/update-inetd line 29.
dpkg: fout bij afhandelen van samba (--configure):
 subproces post-installation script gaf een foutwaarde 6 terug
Fouten gevonden tijdens behandelen van:
 samba
E: Sub-process /usr/bin/dpkg returned an error code (1)
----------------------------------------------------------------------------------------------------------------------

Thanks!

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
error code (1) tijdens upgrade
« Reactie #1 Gepost op: 2007/03/05, 20:58:36 »
samba eraf en terug erop ;)
Of eerst eens
sudo dpkg -i samba --configure -a

Offline AB

  • Lid
  • Steunpunt: Nee
error code (1) tijdens upgrade
« Reactie #2 Gepost op: 2007/03/05, 21:03:10 »
Dank voor het snelle antwoord!

dpkg -i samba --configure -a geeft:

dpkg: fout bij afhandelen van samba (--install):
 kon archief niet benaderen: No such file or directory
dpkg: fout bij afhandelen van --configure (--install):
 kon archief niet benaderen: No such file or directory
dpkg: fout bij afhandelen van -a (--install):
 kon archief niet benaderen: No such file or directory
Fouten gevonden tijdens behandelen van:
 samba
 --configure
 -a

Wat gebeurt er met m`n instellingen (gedeelde mappen, gebruikers e.d.) als ik samba verwijder en opnieuw installeer?

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
error code (1) tijdens upgrade
« Reactie #3 Gepost op: 2007/03/05, 21:08:20 »
Sorry, moet

sudo dpkg -reconfigure samba zijn of nog sudo dpkg --configure samba

Bij dat gebeurt er niets met je instellingen, bij herinstallatie ook niet, maar kan geen kwaad om de instellingen dan te kopiëren ;)

Offline AB

  • Lid
  • Steunpunt: Nee
error code (1) tijdens upgrade
« Reactie #4 Gepost op: 2007/03/05, 21:16:09 »
Wederom dank,

------------------------------------------------------------------------------------------
> dpkg -reconfigure samba
dpkg: conflicting actions -e (--control) and -r (--remove)

Type dpkg --help voor hulp met installatie en deïnstallatie van pakketten
  • ;

Gebruik 'dselect' of 'aptitude' voor gebruikersvriendelijk pakketbeheer;
Type dpkg -Dhelp voor een lijst van dpkg debugvlaggen;
Type dpkg --force-help voor een lijst met forceer-opties;
Type dpkg-deb --help voor hulp met manipuleren van *.deb bestanden;
Type dpkg --license voor auteursrecht, licentie en ontbreken van garantie (GNU GPL)
  • .


Opties gemarkeerd met
  • produceren een hoop uitvoer - pijp het door `less' of `more' !

> dpkg --configure samba
Instellen van samba (3.0.22-1ubuntu4.1) ...
debconf: kan de interface niet initialiseren: Dialog
debconf: (TERM is niet gezet; hierdoor is de dialoog-interface onbruikbaar.)
debconf: er wordt teruggevallen op interface: Readline
debconf: kan de interface niet initialiseren: Readline
debconf: (Deze interface vereist een sturende tty.)
debconf: er wordt teruggevallen op interface: Teletype
Couldn't reopen stdin(/dev/tty): No such device or address at /usr/sbin/update-inetd line 29.
dpkg: fout bij afhandelen van samba (--configure):
 subproces post-installation script gaf een foutwaarde 6 terug
Fouten gevonden tijdens behandelen van:
 samba
--------------------------------------------------------------------------------------

Dus nu maar apt-get remove samba en dan apt-get install samba?

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
error code (1) tijdens upgrade
« Reactie #5 Gepost op: 2007/03/05, 21:24:57 »
Dat of ik zit er alweer naast :P Doe nog eens sudo dpkg --configure -a om te proberen.
Lees er anders eens man dpkg op na.
(Of gebruik aptitude zoals voorgesteld ipv dpkg)

Als het allemaal niet goed wil lukken:
aptitude remove samba
aptitude update
aptitude install samba

Offline AB

  • Lid
  • Steunpunt: Nee
error code (1) tijdens upgrade
« Reactie #6 Gepost op: 2007/03/05, 21:38:56 »
aptitude remove samba
- gaat goed

aptitude update
- gaat goed

> aptitude install samba -y
Pakketlijsten worden ingelezen...
Boom van vereisten wordt opgebouwd...
Reading state information...
Reading extended state information...
Initializing package states...
Building tag database...
The following NEW packages will be automatically installed:
  libcompress-zlib-perl libconvert-asn1-perl libcrypt-smbhash-perl
  libdigest-md4-perl libdigest-sha1-perl libfont-afm-perl
  libhtml-format-perl libhtml-parser-perl libhtml-tagset-perl
  libhtml-tree-perl libio-socket-ssl-perl libjcode-pm-perl
  libmailtools-perl libnet-ldap-perl libnet-ssleay-perl libtimedate-perl
  libunicode-map-perl libunicode-map8-perl libunicode-maputf8-perl
  libunicode-string-perl liburi-perl libwww-perl smbldap-tools
The following NEW packages will be installed:
  libcompress-zlib-perl libconvert-asn1-perl libcrypt-smbhash-perl
  libdigest-md4-perl libdigest-sha1-perl libfont-afm-perl
  libhtml-format-perl libhtml-parser-perl libhtml-tagset-perl
  libhtml-tree-perl libio-socket-ssl-perl libjcode-pm-perl
  libmailtools-perl libnet-ldap-perl libnet-ssleay-perl libtimedate-perl
  libunicode-map-perl libunicode-map8-perl libunicode-maputf8-perl
  libunicode-string-perl liburi-perl libwww-perl samba smbldap-tools
0 packages upgraded, 24 newly installed, 0 to remove and 0 not upgraded.
Need to get 2701kB/5729kB of archives. After unpacking 17,1MB will be used.
Writing extended state information...
Get:1 http://nl.archive.ubuntu.com edgy/main libcompress-zlib-perl 1.41-1 [51,5kB]
Get:2 http://nl.archive.ubuntu.com edgy/main libconvert-asn1-perl 0.20-1 [40,9kB]
Get:3 http://nl.archive.ubuntu.com edgy/universe libdigest-md4-perl 1.5-1 [19,4kB]
Get:4 http://nl.archive.ubuntu.com edgy/main libdigest-sha1-perl 2.10-1 [23,7kB]
Get:5 http://nl.archive.ubuntu.com edgy/universe libfont-afm-perl 1.19-1 [13,6kB]
Get:6 http://nl.archive.ubuntu.com edgy/main libhtml-tagset-perl 3.10-2 [13,7kB]
Get:7 http://nl.archive.ubuntu.com edgy/main liburi-perl 1.35-2 [87,8kB]
Get:8 http://nl.archive.ubuntu.com edgy/main libhtml-parser-perl 3.54-1 [105kB]
Get:9 http://nl.archive.ubuntu.com edgy/main libhtml-tree-perl 3.19.01-2 [208kB]
Get:10 http://nl.archive.ubuntu.com edgy/universe libhtml-format-perl 2.04-1 [37,9kB]
Get:11 http://nl.archive.ubuntu.com edgy/main libnet-ssleay-perl 1.30-1 [186kB]
Get:12 http://nl.archive.ubuntu.com edgy/main libio-socket-ssl-perl 0.97-2build1 [35,9kB]
Get:13 http://nl.archive.ubuntu.com edgy/universe libjcode-pm-perl 2.03-1 [30,6kB]
Get:14 http://nl.archive.ubuntu.com edgy/main libtimedate-perl 1.1600-5 [32,7kB]
Get:15 http://nl.archive.ubuntu.com edgy/main libmailtools-perl 1.74-0.1 [85,5kB]
Get:16 http://nl.archive.ubuntu.com edgy/main libwww-perl 5.805-1 [361kB]
Get:17 http://nl.archive.ubuntu.com edgy/main libnet-ldap-perl 1:0.33-2 [319kB]
Get:18 http://nl.archive.ubuntu.com edgy/universe libunicode-map-perl 0.112-9 [480kB]
Get:19 http://nl.archive.ubuntu.com edgy/universe libunicode-string-perl 2.09-1 [133kB]
Get:20 http://nl.archive.ubuntu.com edgy/universe libunicode-map8-perl 0.12-2 [78,6kB]
Get:21 http://nl.archive.ubuntu.com edgy/universe libunicode-maputf8-perl 1.11-1 [15,9kB]
Get:22 http://nl.archive.ubuntu.com edgy/universe libcrypt-smbhash-perl 0.12-1 [13,8kB]
Get:23 http://nl.archive.ubuntu.com edgy/universe smbldap-tools 0.9.2-3 [327kB]
Fetched 2701kB in 17s (157kB/s)
Selecteren van voorheen niet geselecteerd pakket libcompress-zlib-perl.
(Database inlezen ... 19191 bestanden en mappen geïnstalleerd.)
Uitpakken van libcompress-zlib-perl (uit .../libcompress-zlib-perl_1.41-1_i386.deb) ...
Selecteren van voorheen niet geselecteerd pakket libconvert-asn1-perl.
Uitpakken van libconvert-asn1-perl (uit .../libconvert-asn1-perl_0.20-1_all.deb) ...
Selecteren van voorheen niet geselecteerd pakket libdigest-md4-perl.
Uitpakken van libdigest-md4-perl (uit .../libdigest-md4-perl_1.5-1_i386.deb) ...
Selecteren van voorheen niet geselecteerd pakket libdigest-sha1-perl.
Uitpakken van libdigest-sha1-perl (uit .../libdigest-sha1-perl_2.10-1_i386.deb) ...
Selecteren van voorheen niet geselecteerd pakket libfont-afm-perl.
Uitpakken van libfont-afm-perl (uit .../libfont-afm-perl_1.19-1_all.deb) ...
Selecteren van voorheen niet geselecteerd pakket libhtml-tagset-perl.
Uitpakken van libhtml-tagset-perl (uit .../libhtml-tagset-perl_3.10-2_all.deb) ...
Selecteren van voorheen niet geselecteerd pakket liburi-perl.
Uitpakken van liburi-perl (uit .../liburi-perl_1.35-2_all.deb) ...
Selecteren van voorheen niet geselecteerd pakket libhtml-parser-perl.
Uitpakken van libhtml-parser-perl (uit .../libhtml-parser-perl_3.54-1_i386.deb) ...
Selecteren van voorheen niet geselecteerd pakket libhtml-tree-perl.
Uitpakken van libhtml-tree-perl (uit .../libhtml-tree-perl_3.19.01-2_all.deb) ...
Selecteren van voorheen niet geselecteerd pakket libhtml-format-perl.
Uitpakken van libhtml-format-perl (uit .../libhtml-format-perl_2.04-1_all.deb) ...
Selecteren van voorheen niet geselecteerd pakket libnet-ssleay-perl.
Uitpakken van libnet-ssleay-perl (uit .../libnet-ssleay-perl_1.30-1_i386.deb) ...
Selecteren van voorheen niet geselecteerd pakket libio-socket-ssl-perl.
Uitpakken van libio-socket-ssl-perl (uit .../libio-socket-ssl-perl_0.97-2build1_all.deb) ...
Selecteren van voorheen niet geselecteerd pakket libjcode-pm-perl.
Uitpakken van libjcode-pm-perl (uit .../libjcode-pm-perl_2.03-1_i386.deb) ...
Selecteren van voorheen niet geselecteerd pakket libtimedate-perl.
Uitpakken van libtimedate-perl (uit .../libtimedate-perl_1.1600-5_all.deb) ...
Selecteren van voorheen niet geselecteerd pakket libmailtools-perl.
Uitpakken van libmailtools-perl (uit .../libmailtools-perl_1.74-0.1_all.deb) ...
Selecteren van voorheen niet geselecteerd pakket libwww-perl.
Uitpakken van libwww-perl (uit .../libwww-perl_5.805-1_all.deb) ...
Selecteren van voorheen niet geselecteerd pakket libnet-ldap-perl.
Uitpakken van libnet-ldap-perl (uit .../libnet-ldap-perl_1%3a0.33-2_all.deb) ...
Selecteren van voorheen niet geselecteerd pakket libunicode-map-perl.
Uitpakken van libunicode-map-perl (uit .../libunicode-map-perl_0.112-9_i386.deb) ...
Selecteren van voorheen niet geselecteerd pakket libunicode-string-perl.
Uitpakken van libunicode-string-perl (uit .../libunicode-string-perl_2.09-1_i386.deb) ...
Selecteren van voorheen niet geselecteerd pakket libunicode-map8-perl.
Uitpakken van libunicode-map8-perl (uit .../libunicode-map8-perl_0.12-2_i386.deb) ...
Selecteren van voorheen niet geselecteerd pakket libunicode-maputf8-perl.
Uitpakken van libunicode-maputf8-perl (uit .../libunicode-maputf8-perl_1.11-1_all.deb) ...
Selecteren van voorheen niet geselecteerd pakket samba.
Uitpakken van samba (uit .../samba_3.0.22-1ubuntu4.1_i386.deb) ...
Selecteren van voorheen niet geselecteerd pakket libcrypt-smbhash-perl.
Uitpakken van libcrypt-smbhash-perl (uit .../libcrypt-smbhash-perl_0.12-1_all.deb) ...
Selecteren van voorheen niet geselecteerd pakket smbldap-tools.
Uitpakken van smbldap-tools (uit .../smbldap-tools_0.9.2-3_all.deb) ...
Instellen van libcompress-zlib-perl (1.41-1) ...
Instellen van libconvert-asn1-perl (0.20-1) ...
Instellen van libdigest-md4-perl (1.5-1) ...
Instellen van libdigest-sha1-perl (2.10-1) ...
Instellen van libfont-afm-perl (1.19-1) ...
Instellen van libhtml-tagset-perl (3.10-2) ...
Instellen van liburi-perl (1.35-2) ...
Instellen van libhtml-parser-perl (3.54-1) ...
Instellen van libhtml-tree-perl (3.19.01-2) ...
Instellen van libhtml-format-perl (2.04-1) ...
Instellen van libnet-ssleay-perl (1.30-1) ...
Instellen van libio-socket-ssl-perl (0.97-2build1) ...
Instellen van libjcode-pm-perl (2.03-1) ...
Instellen van libtimedate-perl (1.1600-5) ...
Instellen van libmailtools-perl (1.74-0.1) ...
Instellen van libwww-perl (5.805-1) ...
Instellen van libnet-ldap-perl (0.33-2) ...
Instellen van libunicode-map-perl (0.112-9) ...
Instellen van libunicode-string-perl (2.09-1) ...
Instellen van libunicode-map8-perl (0.12-2) ...
Instellen van libunicode-maputf8-perl (1.11-1) ...
Instellen van samba (3.0.22-1ubuntu4.1) ...
debconf: kan de interface niet initialiseren: Dialog
debconf: (TERM is niet gezet; hierdoor is de dialoog-interface onbruikbaar.)
debconf: er wordt teruggevallen op interface: Readline
debconf: kan de interface niet initialiseren: Readline
debconf: (Deze interface vereist een sturende tty.)
debconf: er wordt teruggevallen op interface: Teletype
Couldn't reopen stdin(/dev/tty): No such device or address at /usr/sbin/update-inetd line 29.
dpkg: fout bij afhandelen van samba (--configure):
 subproces post-installation script gaf een foutwaarde 6 terug
Instellen van libcrypt-smbhash-perl (0.12-1) ...
Instellen van smbldap-tools (0.9.2-3) ...

Fouten gevonden tijdens behandelen van:
 samba
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
Instellen van samba (3.0.22-1ubuntu4.1) ...
debconf: kan de interface niet initialiseren: Dialog
debconf: (TERM is niet gezet; hierdoor is de dialoog-interface onbruikbaar.)
debconf: er wordt teruggevallen op interface: Readline
debconf: kan de interface niet initialiseren: Readline
debconf: (Deze interface vereist een sturende tty.)
debconf: er wordt teruggevallen op interface: Teletype
Couldn't reopen stdin(/dev/tty): No such device or address at /usr/sbin/update-inetd line 29.
dpkg: fout bij afhandelen van samba (--configure):
 subproces post-installation script gaf een foutwaarde 6 terug
Fouten gevonden tijdens behandelen van:
 samba

--------------------------------

Ik zou `t niet  verwachten na al die meldingen maar samba draait wel weer.
Maar nog steeds die rare error-meldingen...

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
error code (1) tijdens upgrade
« Reactie #7 Gepost op: 2007/03/05, 22:23:17 »
Bizar...
Maar indien je terug kan updaten...

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
error code (1) tijdens upgrade
« Reactie #8 Gepost op: 2007/03/06, 02:24:29 »
Probeer het anders om het via een ssh verbinding te doen in plaats van webmin.
Dit:
ebconf: kan de interface niet initialiseren: Dialog
debconf: (TERM is niet gezet; hierdoor is de dialoog-interface onbruikbaar.)
debconf: er wordt teruggevallen op interface: Readline
debconf: kan de interface niet initialiseren: Readline
debconf: (Deze interface vereist een sturende tty.)
debconf: er wordt teruggevallen op interface: Teletype
Couldn't reopen stdin(/dev/tty): No such device or address at /usr/sbin/update-inetd line 29.
lijkt er op te wijzen dat het installatieproces geen gebruik kan maken van een tty om berichten en dergelijke weer te geven.
Ik denk dat webmin in de weg zit, en dat het via ssh wel zal werken.