Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [opgelost]disk clone gaat niet met UEFI boot  (gelezen 1747 keer)

Offline Jan Willem

  • Lid
  • Steunpunt: Nee
[opgelost]disk clone gaat niet met UEFI boot
« Gepost op: 2013/03/22, 23:08:07 »
Beste mensen

Ik heb een dual boot van W8 en Ubuntu 12.10.
Vanwege de W8 UEFI boot kan ik Clonezilla niet meer draaien.
Ik zoek een programma waar ik een systeem copie kan maken, zodat ik na een mislukt experiment mijn gehele schijf kan terug zetten.
Voorheen deed ik dat met grote tevredenheid met CLONEZILLA maar dat kan nu niet meer omdat de UEFI boot andere dan Microsoft-programma's niet op laat starten.
CLONEZILLA geeft na het gebruikelijke opstartscherm bv de melding “kernel panic- not syncing”

Andere programmaś op live cd's zoals PARTIMAGE of REDObackup worden ook niet meer toegelaten.
Secure boot kan in de bios ook niet uitgeschakeld worden.

Is er al een CLONE  programma dat wel door de UFI boot heen komt?
Zelf heb ik bedacht dat als ik een programma vanuit mijn werkende UBUNTU partitie gebruik
zoals bv PARTCLONE dit wel zou moeten werken.
Allen heb ik geen flauw idee hoe ik PARTCLONE zou moeten gebruiken.
Mijn eerste wankele schreden met de command line heb ik gezet toen ik GRUB moest aan passen aan de UEFI boot.
Moet ik eerst PARTCLONE installeren in UBUNTU? En hoe dan wel?
In zowel Ubuntu softwarecentre als in Synaptic pakket beheer kan ik geen partclone vinden.

Ik heb op mijn HD sda 1 tm 8 en wil de hele schijf in een keer backuppen/clonen

Wat wordt dan mijn commando voor backuppen? 
partclone.ext4 -c -s /dev/sdxx | gzip > naam.img.gz    ? in te voeren in de terminal?

En voor het terugzetten?
zcat naam.img.gz | partclone.ext4 -r -o /dev/sdxx

Heeft partclone ook een grafische interface?

Wie weet er raad?

Groeten Jan Willem

Systeem: Medion Ayoka P5305F,  8M ddr3, 2TB, i5 3350P, 3,1 GHZ, 64 bit, EXT4, UEFI dualboot met Ubuntu 12.10 en W8.
« Laatst bewerkt op: 2013/03/29, 14:26:49 door Jan Willem »

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: disk clone gaat niet met UEFI boot
« Reactie #1 Gepost op: 2013/03/23, 06:11:32 »
Zelf heb ik net bij een mini pc waar secure boot op stond een backup gemaakt.
Ik moest de firmware updaten, want er waren fouten in de firmware, daarna kon ik weer van alle cd's booten, toen ik de secure boot uitgezet had.(er was geen secure boot optie, en alleen red hat linux en windows werkte).
Dus kijk of je in je bios secure boot uit kunt zetten.
Zelf heb ik met parted magic, hier zit clone zilla in om een backup te maken.

Of hd uit de pc halen en een copie maken op een anderen pc.

Parted magic is dacht ik ook ubuntu, je hebt ubuntu op je pc gekregen, misschien krijg je parted magic ook aan de praat via een boot cd, en dan kun je ook clonezilla starten.
« Laatst bewerkt op: 2013/03/23, 06:16:13 door jan11000 »

Offline aartje

  • Lid
  • Steunpunt: Nee
Re: disk clone gaat niet met UEFI boot
« Reactie #2 Gepost op: 2013/03/23, 13:13:21 »
Zo maar een nieuwsgierig vraagje. Hoe heb je Ubuntu ge-installeerd
als je niets anders als Windows kan booten ? Als je de installatie DVD (of USB-stick) van
Ubuntu kan booten, dan zou je toch ook Clonezilla van USB-stick of CD moeten kunnen booten ?
Welke versie van Clonezilla gebruik je ?

Zie dit:

Clonezilla live 2.0.0-37

    This is a bug fixed version.
    The underlying GNU/Linux operating system was upgraded. This release is based on the Debian Sid repository (as of 2012/Nov/08).
    Package mpg123 was added.
    Package syslinux was updated to 4.06.
    Bug fixed: uEFI booting of Quantal-based Clonezilla failed.
   ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

« Laatst bewerkt op: 2013/03/23, 13:29:40 door aartje »

Offline Jan Willem

  • Lid
  • Steunpunt: Nee
Re: disk clone gaat niet met UEFI boot
« Reactie #3 Gepost op: 2013/03/23, 16:35:26 »
Beste Jan 11000
In eerste instantie liet Ubuntu, versie 12.04, zich ook niet installeren,
Voor 12.10 is van microsoft een securitykey verkregen die wel toegang biedt tot de UEFI boot van W8.
Voor zover ik begrepen heb zet Ubuntu een soort  preboot voor de Windowsboot.
.
Eerst heb ik  in W8 schijfruimte vrij gemaakt en daarna met de LIVEcd Ubuntu 12.10 partities aangemaakt en geïnstalleerd.
Dat ging.
Er volgt dan nog wel een vrij ingewikkelde procedure om GRUB te repareren, maar dan werkt het ook weer.

De secureboot laat zich in mijn configuratie van W8 en Medion beslist niet uitzetten, die mogelijkheid is er niet, van microsoft mag ik niet meer op mijn computer zetten wat ik wil.
Linux ten aanval.
PARTEDMAGIC  heb ik ook geprobeerd maar die ontbeert waarschijnlijk ook de register/security key om toegang tot de boot te krijgen. Zelfde voor REDOBACKUP en PARTIMAGE.

De HD er uit halen en copiëren vind ik wel een stunt, wat omslachtig maar wel afdoende denk ik.
PARTEDMAGIC zal ik ook eens proberen , misschien hebben zij al wel de UEFIboot getackled.


Beste Aartje
De regel:  - Bug fixed: uEFI booting of Quantal-based Clonezilla failed. -
is veel belovend.
Ik heb gewoon de laatste versie van Clonezilla, versie 20121217 Quantal, gedownload zonder te kijken naar Ubuntu of Debian based, ik zal Debian based eens proberen .

Groeten Jan Wiilem

Offline Jan Willem

  • Lid
  • Steunpunt: Nee
Re: [opgelost]disk clone gaat niet met UEFI boot
« Reactie #4 Gepost op: 2013/03/29, 14:28:16 »
 Ik heb nu de Clonezilla versie 2.1.1.7 DEBIAN 64bit geprobeerd en die doet het.
Normaal neem ik klakkeloos de versie die bovenaan de downloadlijst staat, er van uit gaande dat de bovenste versie de nieuwste en dus de beste is.
Als je even verder doorklikt zie je ook nog andere opties zoals DEBIAN of UBUNTU based, 32 of 64 bit enzovoort. 
Mijn probleem is opgelost, maar of dat nu is  omdat CLONEZILLA intussen met een nieuwere versie gekomen is, of dat het aan DEBIAN of UBUNTU versie ligt, of aan 32 of 64 bit, ik weet het niet.

Groeten en bedankt Jan Willem