Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [Opgelost] Ubuntu installeert niet met Wubi  (gelezen 370 keer)

Offline Gerard-P

  • Lid
  • Steunpunt: Nee
[Opgelost] Ubuntu installeert niet met Wubi
« Gepost op: 2013/03/14, 20:11:54 »
Hallo,
In mijn Windows XP computer heb ik een disc (80G in twee partities) bijgeplaatst om daarop Ubuntu te installeren. Met Wubi heb ik een poging gedaan, maar het enige dat gelukt is, is dual-boot. In ieder geval kan ik XP nog gebruiken, wat natuurlijk belangrijk is, maar dat is het dan ook, Ubuntu is niet geïnstalleerd. Daarom de volgend vragen:
De tweede disc is een oude Windows XP disc (wel in goede staat), moet die eerst gepartitioneerd en geformatteerd worden?
Welke partities moet ik minimaal aanmaken?
Kan ik daarvoor de Ubuntu installatie CD gebruiken?
Bij voorbaat dank,
Gerard
« Laatst bewerkt op: 2013/03/19, 13:13:34 door Gerard-P »

Offline Timo

  • Forumteam
    • timo.diedering
  • Steunpunt: Ja
Re: Ubuntu installeert niet met Wubi
« Reactie #1 Gepost op: 2013/03/14, 20:33:52 »
Bij voorkeur installeer je niet in Wubi, zeker niet als je dit op een aparte schijf wilt doen.

Start op van de cd die je hebt gebrand en installeer Ubuntu op die manier. De wiki heeft daar een prachtige handleiding voor: http://wiki.ubuntu-nl.org/InstallatieDesktop

Om XP te installeren laat je XP beter zelf zijn partities regelen, sowieso is XP een zinkend schip.

Succes!
Trotse eigenaar van een Nokia N900, een Nokia N9 en een Jolla.

Offline Gerard-P

  • Lid
  • Steunpunt: Nee
Re: Ubuntu installeert niet met Wubi
« Reactie #2 Gepost op: 2013/03/14, 21:25:37 »
Bedankt voor je reactie Timo,
Het is precies dat zinkende schip dat me naar Ubuntu brengt en ik ben niet ven plan om geld uit te geven aan MS.
Ik heb al wat geëxperimenteerd op een oud barrel, maar die was te oud en liep vast.
In een ander topic werd gevraag om fdisk –l te sturen wat mij in deze ook wel zinvol lijkt.
Wat me opvalt, is dat de bijgeplaatste 80G disk /dav/sda is en de XP disk /dev/sdb
Moet ik daarmee op een gegeven moment iets mee doen, b.v. boot volgorde?

ubuntu@ubuntu:~$ sudo fdisk -l

Disk /dev/sda: 80.0 GB, 80000000000 bytes
255 heads, 63 sectors/track, 9726 cylinders, total 156250000 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xc446c446

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *          63    78124094    39062016    7  HPFS/NTFS/exFAT
/dev/sda2        78124095   156264254    39070080    f  W95 Ext'd (LBA)
/dev/sda5        78124158   156248189    39062016    7  HPFS/NTFS/exFAT

Disk /dev/sdb: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders, total 312581808 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xd584d584

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *          63    81915434    40957686    7  HPFS/NTFS/exFAT
/dev/sdb2        81915435   312576704   115330635    f  W95 Ext'd (LBA)
/dev/sdb5        81915498   312576704   115330603+   7  HPFS/NTFS/exFAT


Offline Erik Krom

  • Lid
  • Steunpunt: Nee
Re: Ubuntu installeert niet met Wubi
« Reactie #3 Gepost op: 2013/03/15, 08:01:25 »
Wubi installeert Ubuntu binnen Windows. Gewoonlijk is dat dus op je XP partitie.
Zoals Timo al aangaf kan je beter een dualboot installatie doen.

Dat de 80Gb sda is ipv sdb is niet erg.
Let er bij het installeren wel op dat je de juiste schijf / partitie pakt.

Voor het installeren geld natuurlijk dat je altijd een back-up dient te hebben. Het gaat niet altijd goed.

Een kleine tip. Als je de 160 Gb schijf los haalt weet je zeker dat je de 80 Gb schijf hebt.
Ook heeft de installatie dan geen enkele invloed op je Windows installatie. Het verwijderen van Ubuntu doe je dan simpelweg door de 80Gb schijf uit de computer te halen.
Grub zal bij de installatie de Windows installatie niet herkennen, maar dat kan met een simpel terminal commando makkelijk worden bijgesteld.

Offline Gerard-P

  • Lid
  • Steunpunt: Nee
Re: Ubuntu installeert niet met Wubi
« Reactie #4 Gepost op: 2013/03/16, 22:27:04 »
Bedankt voor je reactie Erik.,
De tip die je gaf heb ik uitgevoerd: XP disk los en de op de 80G disk 12.04 LTS geïnstalleerd.
Liep best voorspoedig, maar na re-boot gaf het scherm een volstrekt onleesbaar beeld. Het leken een paar regels te zijn, boven in het scherm, maar onleesbare karakters.
Alt-F1 t/m F6 gaf verandering in het patroon en bij Alt-F7 weer het eerste patroon!!

Daarna heb k de XP disk weer aangesloten en na inschakelen gekozen voor boot van Ubuntu. Het duurde erg lang voor dat de volgende reactie kwam (ongeveer):

Try (hd 0,0) : NTFS5
Error “prefix” is not set

GNU  GRUB V1.99
grub>

Daarna niets meer

Ik heb d.m.v. een terminal in de Ubuntu demo met fdisk –l nog het volgende opgehaald:

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *        2048    39063551    19530752   83  Linux
/dev/sdb2        39065598   156248063    58591233    5  Extended
/dev/sdb5        39065600    97659349    29296875   83  Linux
/dev/sdb6       146487296   156248063     4880384   82  Linux swap / Solaris
/dev/sdb7        97660928   146479103    24409088    b  W95 FAT32

Partition table entries are not in disk order

De rest is gelijk aan het eerdere fdisk –l resultaat

Graag advies hoe nu verder te gaan.

Later toegevoegd:
Kan ik het opstarten herstellen zoals aangegeven in http://wiki.ubuntu-nl.org/community/Grub2  ?

Met Wubi hebben mijn problemen niets meer van doen. Ga dit topic afsluiten en twee nieuwe starten.

Toch bedankt tot zover



« Laatst bewerkt op: 2013/03/17, 13:05:10 door Gerard-P »