Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Help met apache  (gelezen 463 keer)

Offline gdonkers

  • Lid
Help met apache
« Gepost op: 2013/03/11, 10:20:35 »
Hallo,

Sinds kort hebben we hier een ubuntu server draaien met Wordpress en MySQL erop. Als experiment hebben we dit opgezet maar zitten nu even vast. Normaal draait alles op Windows bij ons, dus weten we nu niet waar we onze oplossing kunnen vinden.

We hebben momenteel de volgende situatie. Via een ip-adres kunnen we van buitenaf onze server benaderen maar de wordpress geeft een blanco pagina terug en phpMyAdmin werkt wel van buiten af. Intern kunnen we alles goed benaderen.

Ik heb het gevoel dat ik het moet zoeken in de instellingen van Wordpress, maar heb geen idee waar ik moet beginnen. Of zit het toch bij Apache?

Kan iemand mij helpen?

Alvast bedankt..

Giedo


Offline joop905

  • Lid
  • Steunpunt: Nee
Re: Help met apache
« Reactie #1 Gepost op: 2013/03/11, 21:12:06 »

Offline Thomas de Graaff

  • Lid
  • Steunpunt: Nee
Re: Help met apache
« Reactie #2 Gepost op: 2013/03/12, 11:14:35 »
Wat versta je precies over van buitenaf, en intern? Het lokale netwerk t.g.o.v. internet? Het je al geprobeerd wat er gebeurd als je een eigen index.html in de wordpress map zet, werkt die wel? Staat display_errors in php.ini aan zodat je eventueel een foutmelding kan krijgen?

Offline raggar

  • Lid
    • fietsen naar Tibet
  • Steunpunt: Ja
Re: Help met apache
« Reactie #3 Gepost op: 2013/03/13, 10:38:25 »
Heb je in Apache instellingen veranderd?

Als het aan apache ligt zou het helpen als je de volgende bestanden meegeeft:
/etc/apache2/sites-enabled/default
En alle andere bestanden in dezelfde map.

Het kan ook zijn dat je op je wordpress bestanden geen leesrechten hebt voor andere dan de eigennaar. Je kunt twee dingen doen. De bestanden wisselen naar de eigenaar www-data:
sudo chown -R www-data:www-data /de/map/van/jouw/wordpress-install
Of leesrechten geven:
sudo chmod +r -R / de/map/van/jouw/wordpress-install

Offline gdonkers

  • Lid
Re: Help met apache
« Reactie #4 Gepost op: 2013/03/13, 11:18:48 »
Bedankt voor jullie reacties! Het is gelukt..

Ik heb een subdomein doorverwezen naar het IP-adres en intern in de DNS dit naar een ander IP-adres verwezen. Blijkbaar vond Wordpress het op IP niet leuk, het is me namelijk niet gelukt om het op IP-adres te regelen maar nu het via een domein werkt gaat alles goed.

Offline joop905

  • Lid
  • Steunpunt: Nee
Re: Help met apache
« Reactie #5 Gepost op: 2013/03/13, 11:32:16 »
Mooi dat het  werkt.

Het topic sluiten doe je door '[opgelost]' in de titel van het topic te zetten.