Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: asus USB-N13 Wireless-N300 connectie problemen (werkt bijna...)  (gelezen 1901 keer)

Offline victorc

  • Lid
Beste ubuntu gebruikers,

Ik ben niet goed bekend met Linux, hopelijk kunnen jullie mij op weg helpen (omdat ondanks veel zoeken op internet, ik niet verder kom).

Om wireless verbinding met mn router te kunnen maken heb ik de asus USB N13 aangeschaft, omdat hierop was vermeld dat het Linux supported is.

Hierbij wat gegevens:
xbmc@XBMC-Client:~$ cat /etc/lsb-release; uname -a
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.10
DISTRIB_CODENAME=quantal
DISTRIB_DESCRIPTION="Ubuntu 12.10 - XBMCbuntu"
Linux XBMC-Client 3.5.0-22-generic #34-Ubuntu SMP Tue Jan 8 21:41:11 UTC 2013 i686 i686 i686 GNU/Linux

lsusb
xbmc@XBMC-Client:~$ lsusb
Bus 001 Device 004: ID 0b05:17ab ASUSTek Computer, Inc. USB-N13 802.11n Network Adapter (rev. B1) [Realtek RTL8192CU]
Bus 002 Device 002: ID 0451:1446 Texas Instruments, Inc. TUSB2040/2070 Hub
Bus 002 Device 003: ID 045e:0040 Microsoft Corp. Wheel Mouse Optical
Bus 004 Device 002: ID 1241:e000 Belkin
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 004: ID 045e:002b Microsoft Corp. Internet Keyboard Pro


iwconfig
xbmc@XBMC-Client:~$ iwconfig
wlan0     IEEE 802.11bgn  ESSID:off/any
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm
          Retry  long limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off

lo        no wireless extensions.

eth0      no wireless extensions.


lsmod | grep rtl
xbmc@XBMC-Client:~$ lsmod | grep rtl
rtl8192cu              66628  0
rtl8192c_common        47076  1 rtl8192cu
rtlwifi                64173  1 rtl8192cu
mac80211              461203  3 rtl8192cu,rtl8192c_common,rtlwifi
cfg80211              175574  2 rtlwifi,mac80211
 
dmesg | grep -e rtl -e wlan
xbmc@XBMC-Client:~$ dmesg | grep -e rtl -e wlan
[   13.627659] rtl8192cu: Chip version 0x11
[   15.060538] rtl8192cu: MAC address: 50:46:5d:af:f8:56
[   15.060546] rtl8192cu: Board Type 0
[   15.060782] rtlwifi: rx_max_size 15360, rx_urb_num 8, in_ep 1
[   15.060915] rtl8192cu: Loading firmware rtlwifi/rtl8192cufw.bin
[   15.066303] usbcore: registered new interface driver rtl8192cu
[   15.331211] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
[   15.333186] rtlwifi: wireless switch is on
[   21.298534] rtl8192cu: MAC auto ON okay!
[   21.331423] rtl8192cu: Tx queue select: 0x05
[   21.700358] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   21.701110] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   23.534356] wlan0: authenticate with 00:23:69:30:02:6b
[   23.549497] wlan0: send auth to 00:23:69:30:02:6b (try 1/3)
[   23.552592] wlan0: authenticated
[   23.568033] wlan0: associate with 00:23:69:30:02:6b (try 1/3)
[   23.570312] wlan0: RX AssocResp from 00:23:69:30:02:6b (capab=0x411 status=0 aid=4)
[   23.570464] wlan0: associated
[   23.570560] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   31.551967] wlan0: deauthenticated from 00:23:69:30:02:6b (Reason: 15)
[   32.401277] wlan0: authenticate with 00:23:69:30:02:6b
[   32.419271] wlan0: send auth to 00:23:69:30:02:6b (try 1/3)
[   32.428478] wlan0: authenticated
[   32.448046] wlan0: associate with 00:23:69:30:02:6b (try 1/3)
[   32.450221] wlan0: RX AssocResp from 00:23:69:30:02:6b (capab=0x411 status=0 aid=4)
[   32.450332] wlan0: associated
[   40.431681] wlan0: deauthenticated from 00:23:69:30:02:6b (Reason: 15)
[   41.265156] wlan0: authenticate with 00:23:69:30:02:6b
[   41.277624] wlan0: send auth to 00:23:69:30:02:6b (try 1/3)
[   41.303079] wlan0: authenticated
[   41.316038] wlan0: associate with 00:23:69:30:02:6b (try 1/3)
[   41.321806] wlan0: RX AssocResp from 00:23:69:30:02:6b (capab=0x411 status=0 aid=4)
[   41.321942] wlan0: associated
[   48.003582] wlan0: deauthenticating from 00:23:69:30:02:6b by local choice (reason=3)


sudo iwlist wlan0 scan
xbmc@XBMC-Client:~$ sudo iwlist wlan0 scan
[sudo] password for xbmc:
wlan0     No scan results

Op dit moment kan ik mn netwerk selecteren en moet ik vervolgens mijn wachtwoord ingeven. Ondanks dat ik 100% zeker ben dat het wachtwoord juist is, kan ik geen verbinding maken.

Als ik de volgende commando invoer, kan ik wel verbinding maken:
sudo modprobe -r rtl8192cu
sudo modprobe rtl8192cu swenc=1

Op internet stond dat ik deze optie permanent kan maken met het volgende commando:
echo "options rtl8192cu swenc=1" | sudo tee /etc/modprobe.d/rtl8192.conf > /dev/null
Echter, na een reboot moet ik nog steeds een wachtwoord invullen (ook al staat dit goed ingevuld). Na het invullen connect hij meestal, maar valt ook af en toe weg.

Hoe kan ik ervoor zorgen dat mn internetverbinding automatisch verbind? En hoe zorg ik ervoor dat deze niet wegvalt?

Bedankt voor jullie hulp!
Groeten,
Victor

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: asus USB-N13 Wireless-N300 connectie problemen (werkt bijna...)
« Reactie #1 Gepost op: 2013/03/10, 21:42:10 »
Welke Ubuntuversie heb je?

Doe sowieso de volgende ingrepen eens:

- installeer de draadloze Backports-modules:
https://sites.google.com/site/computertip/geendraadloosinternet#TOC-Installeer-de-draadloze-Backports-modules
(punt 1.4, linkerkolom)

- schakel het energiebeheer uit voor de draadloze kaart:
https://sites.google.com/site/computertip/geendraadloosinternet#TOC-Schakel-het-energiebeheer-uit-voor-de-draadloze-kaart
(punt 2.1, rechterkolom)
« Laatst bewerkt op: 2013/03/10, 21:46:22 door Pjotr »

Offline victorc

  • Lid
Re: asus USB-N13 Wireless-N300 connectie problemen (werkt bijna...)
« Reactie #2 Gepost op: 2013/03/10, 22:08:36 »
Pjotr,

Ik heb versie 12.10 (xbmcbuntu).

Ik heb de backports module geüpdate volgens de instructies in de link. Nu werkt m'n muis en keyboard niet meer in m'n desktop??

Hoe kan dit en hoe los ik het op? Nooit eerder last gehad van m'n keyboard en muis.

Mvg,
Victor

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: asus USB-N13 Wireless-N300 connectie problemen (werkt bijna...)
« Reactie #3 Gepost op: 2013/03/10, 22:25:45 »
Tja, XMBC is blijkbaar een verhaal apart.... In Ubuntu is het een risicoloze ingreep. Enfin, verwijder die backportsmodules dan maar weer.

Offline victorc

  • Lid
Re: asus USB-N13 Wireless-N300 connectie problemen (werkt bijna...)
« Reactie #4 Gepost op: 2013/03/11, 07:56:49 »
Hoe doe ik dat?

Offline joop905

  • Lid
  • Steunpunt: Nee
Re: asus USB-N13 Wireless-N300 connectie problemen (werkt bijna...)
« Reactie #5 Gepost op: 2013/03/11, 09:39:31 »
Terminalvenster:

sudo apt-get remove linux-backports-modules-cw-3.6-quantal-generic
Druk op Enter. Tik desgevraagd uw wachtwoord in: dat blijft geheel onzichtbaar, u ziet zelfs geen sterretjes, dat hoort zo.
Druk daarna op Enter.

Herstart uw computer.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: asus USB-N13 Wireless-N300 connectie problemen (werkt bijna...)
« Reactie #6 Gepost op: 2013/03/11, 10:34:03 »
Zoals joop905 zegt.

Mocht dat problemen opleveren wegens niet-werkende muis en toetsenbord: start de computer op in de herstelmodus (recovery), kies terminal als root en voer de genoemde opdracht uit zonder sudo.
Dus: apt-get remove linux-backports-modules-cw-3.6-quantal-generic

Offline victorc

  • Lid
Re: asus USB-N13 Wireless-N300 connectie problemen (werkt bijna...)
« Reactie #7 Gepost op: 2013/03/11, 18:58:13 »
En als m'n toetsenbord het ook niet doet in recovery modus?
Opnieuw installeren?

Zo ja, is xbmcbuntu de beste keuze? Het wordt m'n media center, dus moet uiteindelijk automatisch opstarten in xbmc.

Bedankt voor jullie hulp!

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: asus USB-N13 Wireless-N300 connectie problemen (werkt bijna...)
« Reactie #8 Gepost op: 2013/03/11, 19:09:05 »
En als m'n toetsenbord het ook niet doet in recovery modus?
Probeer het eerst eens? En indien niet functionerend: probeer eens een ander toetsenbord. Dus eentje met ouderwetse PS/2-stekker i.p.v. USB-stekker. Draadloos toetsenbord is sowieso minst kansrijk.

Offline victorc

  • Lid
Re: asus USB-N13 Wireless-N300 connectie problemen (werkt bijna...)
« Reactie #9 Gepost op: 2013/03/11, 19:13:13 »
Ik had het geprobeerd, maar het is niet gelukt. M'n post was dus niet zo duidelijk ;)
Het is een USB toetsenbord. Een ps/2 aansluiting zit niet op de pc.

Offline victorc

  • Lid
Re: asus USB-N13 Wireless-N300 connectie problemen (werkt bijna...)
« Reactie #10 Gepost op: 2013/03/18, 21:38:16 »
Ik heb xbmcbuntu opnieuw geïnstalleerd en de backPorts modules geïnstalleerd.
Helaas nog geen verbetering. Ik krijg nu geen verbinding met m'n wireless USB netwerkkaart.

Heeft iemand nog een idee hoe ik dit kan oplossen?