Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: modem verschijnt niet meer in wifi lijst  (gelezen 4048 keer)

Offline jvanandel

  • Lid
modem verschijnt niet meer in wifi lijst
« Gepost op: 2013/03/10, 11:14:28 »
hallo allemaal,
ik ben een beginner wat betreft ubuntu.
gisteren heb ik voor het eerst ooit ubuntu (versie 12.04) geinstalleerd op mijn asus 1015PEM netbook.
Alles werkte als een trein, ook draadloos internet. Ik heb UPC internet
Nu heb ik vanochtend weer de netbook aangezet, en krijg ik geen draadloze verbinding (wel met kabel). Andere apparaten (telefoon, windows laptop) maken wel verbinding.
Ik heb gezocht op dit forum, en zo kwam ik op https://sites.google.com/site/computertip/geendraadloosinternet.  Ik heb daar alle stappen gevolgd, (ook al heb ik geen idee wat ik dan doe...)
Helaas allemaal zonder resultaat.
Ik hoop dat iemand hier kan helpen?
Ik zie wel allerlei modems in de lijst staan, maar niet die van mij.
alvast bedankt!
Jelle
« Laatst bewerkt op: 2013/03/10, 11:26:31 door jvanandel »

Offline joop905

  • Lid
  • Steunpunt: Nee
Re: modem verschijnt niet meer in wifi lijst
« Reactie #1 Gepost op: 2013/03/10, 12:48:52 »
Als je andere in de buurt wel ziet
Kijk eens in de modem 192.168.0.1

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: modem verschijnt niet meer in wifi lijst
« Reactie #2 Gepost op: 2013/03/10, 13:02:45 »
Post hier eens een overzicht van de apparatuur in je computer, op de volgende wijze:
https://sites.google.com/site/computertip/tipsentrucs#TOC-Maak-automatisch-een-handig-overzicht-van-de-apparatuur-in-uw-computer
(punt 18, rechterkolom)

Overigens, voor alle duidelijkheid: je kunt in dit geval beter de term "draadloos netwerk" gebruiken i.p.v. "modem", dat is correcter. :)

Offline jvanandel

  • Lid
Re: modem verschijnt niet meer in wifi lijst
« Reactie #3 Gepost op: 2013/03/11, 10:47:23 »
bedankt voor de reakties tot zover! ik heb het weer opnieuw geinstalleerd, omdat hij eerst wel werkte , helaas zonder resultaat.
Hier zijn de gegevens van de hardware:

Offline jvanandel

  • Lid
Re: modem verschijnt niet meer in wifi lijst
« Reactie #4 Gepost op: 2013/03/11, 10:51:45 »
bedankt voor de reakties tot zover! ik heb het weer opnieuw geinstalleerd, omdat hij eerst wel werkte , helaas zonder resultaat.  Inloggen op het 192.168.0.1  is na zoeken op internet gelukt, wat kan ik daar doen?
Hier zijn de gegevens van de hardware:

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: modem verschijnt niet meer in wifi lijst
« Reactie #5 Gepost op: 2013/03/11, 10:54:06 »
Broadcom-kaartje.... Pak het eens zo aan:
https://sites.google.com/site/computertip/broadcom

Moet lukken zo.  :)

Offline Lagavulin

  • Lid
  • Steunpunt: Nee
Re: modem verschijnt niet meer in wifi lijst
« Reactie #6 Gepost op: 2013/03/11, 21:31:17 »
Ik had hetzelfde probleem.
Ik heb toen via de kabel het kanaal van mijn router veranderd.
In de lage kanalen werd mijn router opeens zichtbaar. :laugh:

Mischien heb je er wat aan.
Succes.

Offline Joris Donders

  • Lid
  • Steunpunt: Nee
Re: modem verschijnt niet meer in wifi lijst
« Reactie #7 Gepost op: 2013/03/12, 13:45:21 »
open eens een terminal en kopieer en plak de volgende spreuk:

rfkill list all
en geef eens de output (terug kopiƫren en plakken hier in je antwoord) van die terminal.
Gubuntu 17.04 wegens verdwijnen Unity binnenkort

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Re: modem verschijnt niet meer in wifi lijst
« Reactie #8 Gepost op: 2013/03/12, 14:56:47 »
Hoogst waarschijnlijk is je modem/router verhuisd naar kanaal 12 of 13 of 14. in ieder geval hoger dan 11.
Ubuntu kan WIFI kanalen boven 11 niet meer zien of gebruiken.
Ik ben daar wel eens mee bezig geweest maar een fatsoenlijke oplossing zit er niet in, tis een soort hardnekkige bug die er al een heel aantal jaren inzit.

Log in op je modem/router en stel het wifi in op kanaal 11 of lager en je probleem is over.

Geef in de terminal In Ubuntu de opdracht iwlist wlan0 channel of iw list kan je zien welke kanalen je draadlose netwerk kaart kan zien.
Je zal zien dat die lijst vaak tot 14 of zelfs 26 gaat, maar in Linux/ Ubuntu kan je niet hoger werken dan 11.
Je zal ook wel zien dat 12, 13, 14 erbij staan maar dat er "passive channel" achter staat.
Bijvoorbeeld :
Citaat
Frequencies:
   * 2412 MHz [1] (15.0 dBm)
   * 2417 MHz [2] (15.0 dBm)
   * 2422 MHz [3] (15.0 dBm)
   * 2427 MHz [4] (15.0 dBm)
   * 2432 MHz [5] (15.0 dBm)
   * 2437 MHz [6] (15.0 dBm)
   * 2442 MHz [7] (15.0 dBm)
   * 2447 MHz [8] (15.0 dBm)
   * 2452 MHz [9] (15.0 dBm)
   * 2457 MHz [10] (15.0 dBm)
   * 2462 MHz [11] (15.0 dBm)
   * 2467 MHz [12] (15.0 dBm) (passive scanning, no IBSS)
   * 2472 MHz [13] (15.0 dBm) (passive scanning, no IBSS)

Andere opdrachten:
iwlist interface freq
iwlist interface ap
iwlist interface scan
iwlist interface rate
iwlist interface key
iwlist interface power
iwlist interface txpower
iwlist interface retry
iwlist --help
iwlist --version   

Wil je zien welke wifi kaart je hebt:
lspci -vv
Voorheen kon je met de opdracht "/etc/modprobe.d/options" vervolgens toevoegen options cfg80211 ieee80211_regdom=EU en opslaan en daarna het proces opnieuw opstarten, echter op dit moment werkt dat ook niet meer.

In Google vind je nog wel het 1 en ander en dit is een leuke startplek:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/268388

Dit persoon heeft al een hele lijst afgewerkt met allerhande mogelijke oplossingen (zonder resultaat):
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/931168
Is echter wel leuk/leerzaam om te lezen.

Wat me irriteerd is dat er tot op heden nog geen mooie oplossing voor is gemaakt, of het via een grafische interface op 1 of andere wijze netjes aan te passen is.
Althans ik heb het nog niet gevonden.........  :o

NOTE en Update :

Nog wat gevonden wat geprobeerd kan worden.
Als de landcode niet gelezen kan worden (in bijv NVRAM) word standaard US gebruikt en in de US mag je geen kanalen gebruiken boven de 11.

Geef de opdracht:
iw reg geten je zal zien dat de uitkomst "00" is

Je kan nadat de driver geladen is de volgende opdracht in de terminal proberen:
sudo iw reg set EU
Je zou daarna bijvoorbeeld hetvolgende kunnen zien in de log:
Apr 30 10:05:22 myhost kernel: [ 3967.072332] cfg80211: Calling CRDA for
country: EU


Je zal waarschijnlijk wel merken dat na een reboot dit weer verdwenen is.

Primair zit het probleem in de driveren hier zit gelijk de moeilijkheid om de juiste te krijgen, want ook met NDiswrapper (niet aan te bevelen) lukt het niet altijd om van dit probleem af te komen.

In 12.10 Quantal beta 1 lijkt het probleem opgelost te zijn, tenminste ? met gebruik van driver brcmsmac driver, wat erg vreemd is dat deze driver ook gebruikt word in 12.04.1.
Ik lees net dat wanneer de kernel 3.5.0_14 van quantal word gebruikt de bug definitief voorbij is, het zat dus duidelijk in de kernel die de landcode uitleest, welliswaar is de firmware voor brcm4313 driver gewijzigd ondanks dat dit niet het hele probleem was.
Meer over deze driver vind je hier https://git.kernel.org/cgit/linux/kernel/git/linville/wireless-testing.git/commit/?id=898d3c3b2462cd439edb575f43b732425693aff0
Ik neem aan dat ook het probleem voor de andere drivers over is.

Als je van testen houd kan je andere kernels installeren GEHEEL op eigen RISICO:
Kernels kan je hier vinden:
installeren van http://packages.ubuntu.com/quantal/i386/linux-image-3.5.0-14-generic, http://packages.ubuntu.com/quantal/i386/kernel/linux-image-extra-3.5.0-14-generic, http://packages.ubuntu.com/quantal/linux-headers-3.5.0-14, en http://packages.ubuntu.com/quantal/i386/linux-headers-3.5.0-14-generic
« Laatst bewerkt op: 2013/03/13, 10:06:56 door Gandyman »
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline jvanandel

  • Lid
Re: modem verschijnt niet meer in wifi lijst
« Reactie #9 Gepost op: 2013/03/12, 21:31:21 »
super dat er nog wat meer mensen mee willen denken! Ik geeft het nog niet op  :D

Modem stond inderdaad op 13/auto...
ik heb de poort van het modem onder tabje 'wireless' op 9 gezet (control channel/current channel) , helaas zonder resultaat.
Verder stond hij inderdaad ook op US; veranderen naar EU lukt niet want: command failed: Operation not permitted (-1)
 
op het command rfkill list all komt de output:
phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: no
Als iemand nog wat weet?

Offline Gandyman

  • Lid
  • Steunpunt: Nee
Re: modem verschijnt niet meer in wifi lijst
« Reactie #10 Gepost op: 2013/03/12, 22:42:58 »
hi  jvanandel,

Citaat
Verder stond hij inderdaad ook op US; veranderen naar EU lukt niet want: command failed: Operation not permitted (-1)
 

mja ik was vanmiddag niet echt volledig, beetje slordig zelfs..  =D
Heb me postje al aangepast...

ok hij staat op US, mooi dat is al beter dan 00,
Ik neem aan dat je dit te zien kreeg bij de opdracht:
iw reg get
goed om die fout (wat geen fout is maar een rechten melding ) te omzeilen geef je nu de opdracht:
sudo iw reg set EUff wachtwoord ingeven , op enter klikken klaar en weer controleren met :
iw reg get
Daarna nogmaals controleren met
iw list
Je zal zien dat nu de beperking :
Citaat
* 2467 MHz [12] (15.0 dBm) (passive scanning, no IBSS)
   * 2472 MHz [13] (15.0 dBm) (passive scanning, no IBSS)
Weg zijn en het zal er zo uitzien:
Citaat
Frequencies:
         * 2412 MHz [1] (20.0 dBm)
         * 2417 MHz [2] (20.0 dBm)
         * 2422 MHz [3] (20.0 dBm)
         * 2427 MHz [4] (20.0 dBm)
         * 2432 MHz [5] (20.0 dBm)
         * 2437 MHz [6] (20.0 dBm)
         * 2442 MHz [7] (20.0 dBm)
         * 2447 MHz [8] (20.0 dBm)
         * 2452 MHz [9] (20.0 dBm)
         * 2457 MHz [10] (20.0 dBm)
         * 2462 MHz [11] (20.0 dBm)
         * 2467 MHz [12] (20.0 dBm)
         * 2472 MHz [13] (20.0 dBm)
         * 2484 MHz [14] (disabled)
Dat ziet er dus al goed uit maar is geen garantie dat je kan verbinden met kanalen hoger dan 11.....

Nu het volgende probleem want waarschijnlijk zie je nu nog geen verandering met scannen omdat het proces opnieuw gestart moet worden.
dIt zal waarschijnlijk ook het euvel zijn waarom je na wijziging naar kanaal 9 in je modem/router je dit nog niet zag in Ubuntu.
Vaak is een reboot nodig om opnieuw de kernel te laden, niet altijd maar soms wel, dus als hij nog niet je netwerk wilt scannen probeer als eerste ff Wifi uit zetten en weer aanzetten kijken scannen enz (heb ff geduld)
Lukt dit niet dan ff afmelden een opnieuw aanmelden......
Lukt het dan nog niet dan rebooten....  :o

Wat wel handig is het programma "Wifi radar" je vind het in het software centrum, hier kan je ook veel instellen en je kan het gebruiken om jezelf te verbinden met Wifi.

Je kan weer ff rommelen  =D
« Laatst bewerkt op: 2013/03/13, 10:11:23 door Gandyman »
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D