Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: E: Sub-process /usr/bin/dpkg returned an error code (1)(en kennismaking :D)  (gelezen 1012 keer)

hallo, ten eerste wil ik graag wat over mezelf vertellen aangezien dit mijn 1e post is.

hallo, ik ben dave, ik ben 22 jaar en woon op het moment in limburg. ik ben altijd al met computers bezig geweest (zo heb ik rond mijn 6e jaar op een of andere manier 2 kappote apple 2's gerepareerd door onderdelen van bijde samen te voegen etc etc allemaal leuke verhaaltjes :P)

ik heb nu sinds een tijd een permanente instalatie van ubuntu op mijn computer staan naast de haast verplichte windows 7.., en heb veel plezier ermee.

nu ben ik tegen een probleem opgelopen namelijk ik had een spel geinstaleerd genaamd flightgear. dit heb ik via het software center gedaan.

het spel crashte toen ik het wilde uitvoeren. (mogelijk ongerelateerd aangezien dit een oude pc is en hij em mischien gewoon niet draaien kon).

helaas heb ik nu een permanente fout in het pakketbeheer..

ik heb het volgende geprobeert:

sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade
sudo apt-get autoremove

hier krijg ik nog altijd de volgende error:

Voorbereiden om fgfs-base 2.6.0-1 te vervangen (door .../fgfs-base_2.8.0-1~getdeb1_all.deb) ...
Uitpakken van vervangende fgfs-base ...
dpkg: error processing /var/cache/apt/archives/fgfs-base_2.8.0-1~getdeb1_all.deb (--unpack):
 trying to overwrite '/usr/share/games/flightgear/Scenery/Airports/8/Q/1/8Q1.threshold.xml', which is also in package fgfs-scenery-base 2.6.0-1
dpkg-deb: error: subprocess paste was killed by signal (Gebroken pijp)
Fouten gevonden tijdens behandelen van:
 /var/cache/apt/archives/fgfs-base_2.8.0-1~getdeb1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

eveneen heb ik de schakel optie -f geprobeert bij zowel install upgrade en zelfs
sudo apt-get remove -f fgfs-base
dit heeft allemaal geen effect.

meer info: software centrum meld problemen met pakket beheer, stel voor om te proberen te repareren, maar dit resulteerd in een crash

een stop bord in de taakbalk meld ook een fout in pakketbeheer en dat ie niet updaten kan. via hem proberen te update resulteerd ook in een crash.

met vriendelijke groet,

Dave


Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Probeer dit eens:
sudo rm -v /var/cache/apt/archives/fgfs*

Probeer dit eens:
sudo rm -v /var/cache/apt/archives/fgfs*

dit verwijdert inderdaat het update bestand, maar lost geen enkel probleem op, en bij alles wat ik wil doen wil hij of het bestand weer downloaden (wat na het uitpakken altijd mislukt te instaleren) install -f lukt daarom ook niet, en het pakkettencatalogus moet gerepareert worden, , maar als ik dit doe wil hij ook het update bestand downloaden (wat natuurlijk dus ook weer foutloopt) dit wil hij ook doen als ik apt-get -f remove gebruik.. :(

edit: de volgende error levert wat dependecies op die de fout volgens mij veroorzaken:

De afhankelijkheden van de volgende pakketten konden niet geïnstalleerd worden:

fgfs-models-base: flightgear: Depends: libgcc1 (>= 1:4.1.1) maar 1:4.7.2-2ubuntu1 is geïnstalleerd
            Depends: libstdc++6 (>= 4.6) maar 4.7.2-2ubuntu1 is geïnstalleerd
            Depends: libudev0 (>= 147) maar 175-0ubuntu13 is geïnstalleerd
            Depends: zlib1g (>= 1:1.1.4) maar 1:1.2.7.dfsg-13 is geïnstalleerd
« Laatst bewerkt op: 2013/02/20, 11:13:01 door davevanloo »

bedankt voor de sugestie, ik heb het volgende geprobeert, en het ziet er naar uit dat de updates nu weer werken.

sudo dpkg --remove --force-remove-reinstreq flightgear

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Mooi! Overigens was ik net aan het antwoorden dat je de volgende opdracht kunt proberen:
sudo apt-get -f install
 :P

Mooi! Overigens was ik net aan het antwoorden dat je de volgende opdracht kunt proberen:
sudo apt-get -f install
 :P

ja, die had ik al geprobeert, dan krijg je hetzelfde antwoord,

1 als je de update hebt staan van een vorige mislukte poging, dan pakt ie het pakket uit en gaat het fout.
2 als je de update verwijdert hebt, gaat ie em downloaden en krijg je hetzelfde als in 1