Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST] Xubuntu probleem met rechten partitie en mappen  (gelezen 805 keer)

Offline roeland

  • Lid
  • Steunpunt: Nee
[OPGELOST] Xubuntu probleem met rechten partitie en mappen
« Gepost op: 2013/02/16, 14:32:17 »
Ik heb een schone installatie van Xubuntu 12.04 gedaan maar krijg de rechten op twee partities niet zomaar goed ingesteld.

Geprobeerd:
- thunar met sudo opgestart, behalve home en bestandssysteem niets zichtbaar
- chown commando gebruikt (sudo chown 777 /media/UBUNTU2B) geen resultaat
- Gnome commander geinstalleerd en gestart als root, alle rechten voor beide partities aan iedereen toegekend.  Na meerdere keren proberen de volgende resultaten:
- een van de twee partities is soms niet zichtbaar in Thunar, soms wel na herstart, soms weer niet zichtbaar
- ´ineens´ kan ik in 1 partitie (UBUNTU2A) wel een nieuwe map maken en zijn de rechten kennelijk wel gewijzigd
- de andere partitie blijft niet toegankelijk (= geen nieuwe map is aan te maken)

In beide partities zijn  de rechten gelijk ingesteld, beide ext4 geformatteerd.  Maar partitie UBUNTU2B blijft ´gesloten´.  Ik heb voorafgaand aan alles ook niets gewijzigd in de installatie behalve uitvoering van de tips van Pjotr.

Wie help me verder?
« Laatst bewerkt op: 2013/02/18, 17:20:59 door roeland »
Ik werk al jaren met Xubuntu (na enkele jaren de gewone Ubuntu versie  gebruikt te hebben).  Als je gewoon je werk wilt doen zonder toeters en bellen in het uiterlijk en geen´top´ pc of laptop hebt is Xubuntu aan te bevelen!

Offline Paul Matthijsse

  • Lid
  • Steunpunt: Nee
Re: Xubuntu probleem met rechten partitie
« Reactie #1 Gepost op: 2013/02/16, 16:23:29 »
Hallo, je hebt het over rechten en niet-zichtbaar. Dat zijn twee verschillende zaken.
Doe eens in een terminal
$ df -h
en
$ blkid
wat zegt dat?
https://allesgimpofbijna.wordpress.com - GIMP en omstreken
https://paulsphotopalace.wordpress.com (Engelstalig) - Raw, RawTherapee, G'MIC, GIMP...

Offline Buzzin

  • Lid
  • Steunpunt: Nee
Re: Xubuntu probleem met rechten partitie
« Reactie #2 Gepost op: 2013/02/16, 16:45:28 »
Je haalt twee commando's door elkaar.
chown = eigenaar veranderen
chmod = rechten anders zetten

chown 777 betekend dus dat je de gebruiker 777 de eigenaar van het bestand maakt.

je moet de bestanden met chown van de juiste eigenaar voorzien (en groep)
en vervolgens met chmod de rechten goed zetten (777 raad ik overigens zelf NOOIT aan)
Football: A battle between two teams of mindless thugs over scraps of coloured cloth. Usually accompanied by the spectacle of 22 overpaid primadonnas kicking a ball on a field.
DebianDevuan, KDE & OperaVivaldi addict, RedHat Engineer

Offline roeland

  • Lid
  • Steunpunt: Nee
Re: Xubuntu probleem met rechten partitie
« Reactie #3 Gepost op: 2013/02/17, 17:44:38 »
Buzzin, ik was onvolledig in mijn tekst, ik heb met chown mijzelf eigenaar gemaakt en met chmod alle rechten toegekend.  Ik ben de enige gebruiker van de PC dus dat lijkt me geen probleem.

Bij beide partities had ik dus dezelfde instellingen geregeld maar ondanks dat blijft de partitie UBUNTU2B niet benaderbaar en soms verschijnt die niet in Thunar, nu overigens weer wel maar ik kan geen mappen aanmaken  e.d..

Paul, de resultaten van de commando´s zijn:

roeland@ubuntu21204:~$ df -h
Bestandssysteem Grootte Gebruikt Besch Geb% Aangekoppeld op
/dev/sda6           84G      17G   63G  21% /
udev               930M     4,0K  930M   1% /dev
tmpfs              376M     852K  375M   1% /run
none               5,0M        0  5,0M   0% /run/lock
none               939M      92K  938M   1% /run/shm
roeland@ubuntu21204:~$

roeland@ubuntu21204:~$ sudo blkid
[sudo] password for roeland:
/dev/sda1: UUID="46E82F29E82F1729" TYPE="ntfs"
/dev/sda5: LABEL="DATA HD1 WIN" UUID="5E632BB142A71739" TYPE="ntfs"
/dev/sda6: UUID="16cb631d-ff2e-4035-a003-5d039e121d62" TYPE="ext4"
/dev/sdb1: LABEL="UBUNTU2B" UUID="90003cd1-e8ab-47bd-bca9-86a5f4ff06d6" TYPE="ext4"
/dev/sdb5: LABEL="DATA HD2X" UUID="2D5C26AD15F648CE" TYPE="ntfs"
/dev/sdb6: LABEL="MUZIEK IPOD HD2X" UUID="648E0EB128E1050B" TYPE="ntfs"
/dev/sdb7: UUID="d2a8eee3-aa3d-4ae1-b804-7ce63bf22baf" TYPE="swap"
/dev/sdb8: LABEL="UBUNTU2A" UUID="b9fe8f3b-8bf7-470d-8010-97d61f9c62fe" TYPE="ext4"
roeland@ubuntu21204:~$

Mijn systeem heeft een 250Gb en een 1Tb schijf.  Op sda staan dual boot Windows XP en Xubuntu 12.04
Ik werk al jaren met Xubuntu (na enkele jaren de gewone Ubuntu versie  gebruikt te hebben).  Als je gewoon je werk wilt doen zonder toeters en bellen in het uiterlijk en geen´top´ pc of laptop hebt is Xubuntu aan te bevelen!

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Xubuntu probleem met rechten partitie
« Reactie #4 Gepost op: 2013/02/17, 18:54:41 »
Op het ogenblik dat je die commando's hebt uitgevoerd, is er geen enkele andere partitie buiten sda6, je systeempartitie, aangekoppeld.
Post hier ook eens de uitvoer van
cat /etc/fstab
sudo mount -a
Dit laatste commando zal proberen alle mounts die in fstab gedefinieerd zijn, uit te voeren. Er mag geen uitvoer zijn. Is die er wel, dan betekent dat een fout in /etc/fstab óf een technisch probleem met een partitie.

Offline roeland

  • Lid
  • Steunpunt: Nee
Re: Xubuntu probleem met rechten partitie
« Reactie #5 Gepost op: 2013/02/18, 17:19:57 »
Vanadium, commando geeft volgende output:

roeland@ubuntu21204:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda6 during installation
UUID=16cb631d-ff2e-4035-a003-5d039e121d62 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sdb7 during installation
UUID=d2a8eee3-aa3d-4ae1-b804-7ce63bf22baf none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
roeland@ubuntu21204:~$ sudo mount -a

Ik ben er na zoeken en mede na hulp van de forum antwoorden nu uit.  Ik had overigens min of meer hetzelfde probleem al eerder bij het forum neergelegd en kreeg dus bij verder zoeken mijn eigen vraag weer te zien.  Bovenstaande output wijst m.i. op een mount probleem.

Kern van mijn probleem was dat bij het maken van een nieuwe partitie die niet automatisch werd aangekoppeld en dat de toegangsrechten van de partitie en de rechten van de mappen niet goed stonden.
Dit gebeurt mij bij elke installatie of wijziging op een PC (2x oudere PC en 1x HP laptop).

De oplossing die werkt is:
- schijfbeheer installeren; er zijn er twee, als je beide installeert geef je het commando sudo palimpsest.  Hier gekeken of alle schijven/partities aangekoppeld zijn.  Zonodig gekoppeld.
- rechten aan mappen gegeven met:   sudo chmod -R 755 /media/NAAMPARTITIE
- idem voor de partie of schijf:  sudo chown -hR roeland /media/naampartitie

Bedankt voor jullie hulp en meedenken.
Ik werk al jaren met Xubuntu (na enkele jaren de gewone Ubuntu versie  gebruikt te hebben).  Als je gewoon je werk wilt doen zonder toeters en bellen in het uiterlijk en geen´top´ pc of laptop hebt is Xubuntu aan te bevelen!

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: [OPGELOST] Xubuntu probleem met rechten partitie en mappen
« Reactie #6 Gepost op: 2013/02/18, 17:39:41 »
Je hebt het zelf gevonden, inderdaad. In je /etc/fstab was er (naast de swap partitie) maar één partitie vermeld: de systeempartitie, /. De andere partities werden dus niet aangekoppeld. Leuk dat je tegenwoordig een standaard grafische tool, Disk Utility, kunt gebruiken om ook een andere partitie automatisch bij opstart te laten aankoppelen.

Offline Paul Matthijsse

  • Lid
  • Steunpunt: Nee
Re: [OPGELOST] Xubuntu probleem met rechten partitie en mappen
« Reactie #7 Gepost op: 2013/02/18, 17:47:29 »
Veel handiger (*) is om je verschillende partities aan het fstab-bestandje toe te voegen, dan heb je niets met rechten of aankoppelen te maken. Om bv. je dev/sdb1 automatisch aan te laten koppelen tijdens het opstarten, open je /etc/fstab met een editor, als root, en je voegt de volgende regel toe.

# Ubuntu 2b-partitie:
UUID=90003cd1-e8ab-47bd-bca9-86a5f4ff06d6 /media/<naam partitie> ext4 defaults 0 2

Bewaren en herstarten en je partitie is direct zichtbaar, naast sda6. Idem voor je andere partities (ext4 vervangen door ntfs waar nodig, alsmede aankoppelpunt).

(*) Vanadium, je was me voor, ik reageer op roeland.
https://allesgimpofbijna.wordpress.com - GIMP en omstreken
https://paulsphotopalace.wordpress.com (Engelstalig) - Raw, RawTherapee, G'MIC, GIMP...