Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: TVtime start niet op in VirtualBox  (gelezen 739 keer)

Offline tryer

  • Lid
  • Steunpunt: Nee
TVtime start niet op in VirtualBox
« Gepost op: 2013/01/27, 14:01:47 »
Ik heb Ubuntu 12.04 geïnstalleerd als gast in VirtualBox op host Windows 8. Bij installatie in VirtualBox worden de niet-vrije stuurprogramma's niet voorgeïnstalleerd, zodat je die niet kunt activeren. Dat is mogelijk het probleem. Virtualbox staat los van de hardware van de host.  Ik wil gebruik maken van tvtime om gebruik te kunnen maken van mijn Hauppauge TV Win 88X based PCI

Als ik tvtime start krijg ik de volgende melding:

Reading configuration from /home/naam/.tvtime/tvtime.xml
xvoutput: No XVIDEO port found which supports YUY2 images.

*** tvtime requires hardware YUY2 overlay support from your video card
*** driver.  If you are using an older NVIDIA card (TNT2), then
*** this capability is only available with their binary drivers.
*** For some ATI cards, this feature may be found in the experimental
*** GATOS drivers: http://gatos.sourceforge.net/
*** If unsure, please check with your distribution to see if your
*** X driver supports hardware overlay surfaces.


Ik heb 3d aangevinkt in VirtualBox. Ik heb een NVIDIA Geforce 7600GT grafische kaart. Geïnstalleerd is Oracle VM Virtualbox Guest Addition for Linux Module (als ik kijk bij extra stuurprogramma's) Mogelijk moet ik NVIDIA driver installeren, ik heb NVIDIA 173 deb gedownload en geinstalleerd, maar die zie ik niet terug. Bij een normale installatie van Ubuntu 12.04 als hoofdsysteem werkt tvtime wel.

Moet ik NVIDIA driver installeren ? hoe doe ik dat op een eenvoudige manier in VB ? Ik heb NVIDIA 173.deb gedownload en geactiveerd, die zie ik niet terug ?

Hoe kan ik probleem oplossen: tvtime requires hardware YUY2 overlay support from your video card *** driver ?

Hoe kan ik probleem oplossen ? Graag hulp !




Offline DeBaas

  • Lid
  • Steunpunt: Ja
Re: TVtime start niet op in VirtualBox
« Reactie #1 Gepost op: 2013/01/27, 14:22:58 »
Ik vraag me af of deze constructie kan werken, De virtual box gebruikt zijn/haar eigen drivers voor de gesimuleerde omgeving. Ten eerste, wordt de TV kaart daarin gezien ? Ten tweede, kan TVtime met de virtuele videodriver overweg ?

Probeer eerst of de TV kaart in deze virtuele omgeving wordt gezien in een terminal:
lspci
of als het een USB is eerst aankoppelen in de VirtualBox en vervolgens:
lsusb

Nogmaals, ik denk, het doet niet..............
Ik beantwoord GEEN hulpvragen via PB en/of MAIL

Offline tryer

  • Lid
  • Steunpunt: Nee
Re: TVtime start niet op in VirtualBox
« Reactie #2 Gepost op: 2013/01/27, 14:30:22 »
Zo te zien, wordt de TV-kaart PCI niet herkend: Hoe kan ik die tevoorschijn toveren ?

00:00.0 Host bridge: Intel Corporation 440FX - 82441FX PMC [Natoma] (rev 02)
00:01.0 ISA bridge: Intel Corporation 82371SB PIIX3 ISA [Natoma/Triton II]
00:01.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:02.0 VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter
00:03.0 Ethernet controller: Advanced Micro Devices [AMD] 79c970 [PCnet32 LANCE] (rev 40)
00:04.0 System peripheral: InnoTek Systemberatung GmbH VirtualBox Guest Service
00:05.0 Multimedia audio controller: Intel Corporation 82801AA AC'97 Audio Controller (rev 01)
00:06.0 USB controller: Apple Inc. KeyLargo/Intrepid USB
00:07.0 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 08)
00:0b.0 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller

Offline DeBaas

  • Lid
  • Steunpunt: Ja
Re: TVtime start niet op in VirtualBox
« Reactie #3 Gepost op: 2013/01/27, 14:41:43 »
VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter

Daar heeft het installeren van Nvidia drivers geen enkele zin.
Mogelijk het instellen van het video geheugen van de VirtualBox op een grotere waarde.

Verder zie ik niets wat op een aanwezige TV unit wijst.
Ofwel daar kan VirtualBox niets mee.
Ik beantwoord GEEN hulpvragen via PB en/of MAIL

Offline DeBaas

  • Lid
  • Steunpunt: Ja
Re: TVtime start niet op in VirtualBox
« Reactie #4 Gepost op: 2013/01/27, 15:17:16 »
Hierbij de virtuele omgeving afgezet tegen de werkelijke (door mij gebruikte) machine, daar kan TVtime, in de virtuele omgeving,  ook niets mee. Eerst de virtuele, daarna de werkelijke machine, zie de verschillen.

[guest@localhost ~]$ lspci
00:02.0 VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter
00:03.0 Ethernet controller: Intel Corporation 82540EM Gigabit Ethernet Controller (rev 02)
00:04.0 System peripheral: InnoTek Systemberatung GmbH VirtualBox Guest Service
00:05.0 Multimedia audio controller: Intel Corporation 82801AA AC'97 Audio Controller (rev 01)
00:07.0 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 08)
00:18.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f2)
00:19.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 631xESB/632xESB IDE Controller
00:1f.2 SATA controller: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) SATA Controller [AHCI mode] (rev 02)
00:1f.4 USB controller: Apple Inc. KeyLargo/Intrepid USB
00:1f.5 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller
[guest@localhost ~]$ lsusb
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
[guest@localhost ~]$

[ed@K7-2400 ~]$ lspci
00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation 4 Series Chipset PCI Express Root Port (rev 03)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 01)
00:1c.3 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 4 (rev 01)
00:1d.0 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 01)
00:1d.1 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 01)
00:1d.2 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 01)
00:1d.3 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 01)
00:1d.7 USB controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.2 IDE interface: Intel Corporation N10/ICH7 Family SATA Controller [IDE mode] (rev 01)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 01)
01:00.0 VGA compatible controller: NVIDIA Corporation G86 [GeForce 8400 GS] (rev a1)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
04:00.0 RAID bus controller: VIA Technologies, Inc. VT6421 IDE/SATA Controller (rev 50)
04:02.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 11)
04:02.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 11)
[ed@K7-2400 ~]$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 0bda:0151 Realtek Semiconductor Corp. Mass Storage Device (Multicard Reader)
Bus 001 Device 003: ID 046d:081b Logitech, Inc. Webcam C310
Bus 001 Device 004: ID 1058:1100 Western Digital Technologies, Inc.
[ed@K7-2400 ~]$

De door mij gebruikte Video kaart mag ik volgens W7 en W8 weggooien.
Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 11)
Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 11)
Gelukkig mag ik van mijn (meest gebruikt) Linuxdoosje nog steeds TV(time) kijken.

« Laatst bewerkt op: 2013/01/27, 15:23:49 door DeBaas »
Ik beantwoord GEEN hulpvragen via PB en/of MAIL

Offline tryer

  • Lid
  • Steunpunt: Nee
Re: TVtime start niet op in VirtualBox
« Reactie #5 Gepost op: 2013/01/27, 17:46:49 »
Heb ik ook gedaan om te vergelijken:

In VirtualBox het commando: lspci

00:00.0 Host bridge: Intel Corporation 440FX - 82441FX PMC [Natoma] (rev 02)
00:01.0 ISA bridge: Intel Corporation 82371SB PIIX3 ISA [Natoma/Triton II]
00:01.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:02.0 VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter
00:03.0 Ethernet controller: Advanced Micro Devices [AMD] 79c970 [PCnet32 LANCE] (rev 40)
00:04.0 System peripheral: InnoTek Systemberatung GmbH VirtualBox Guest Service
00:05.0 Multimedia audio controller: Intel Corporation 82801AA AC'97 Audio Controller (rev 01)
00:06.0 USB controller: Apple Inc. KeyLargo/Intrepid USB
00:07.0 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 08)
00:0b.0 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller


Op partitie met linux zelfde computer gemeten : lspci

00:00.0 RAM memory: NVIDIA Corporation MCP78S [GeForce 8200] Memory Controller (rev a2)
00:01.0 ISA bridge: NVIDIA Corporation MCP78S [GeForce 8200] LPC Bridge (rev a2)
00:01.1 SMBus: NVIDIA Corporation MCP78S [GeForce 8200] SMBus (rev a1)
00:01.2 RAM memory: NVIDIA Corporation MCP78S [GeForce 8200] Memory Controller (rev a1)
00:01.3 Co-processor: NVIDIA Corporation MCP78S [GeForce 8200] Co-Processor (rev a2)
00:01.4 RAM memory: NVIDIA Corporation MCP78S [GeForce 8200] Memory Controller (rev a1)
00:02.0 USB controller: NVIDIA Corporation MCP78S [GeForce 8200] OHCI USB 1.1 Controller (rev a1)
00:02.1 USB controller: NVIDIA Corporation MCP78S [GeForce 8200] EHCI USB 2.0 Controller (rev a1)
00:04.0 USB controller: NVIDIA Corporation MCP78S [GeForce 8200] OHCI USB 1.1 Controller (rev a1)
00:04.1 USB controller: NVIDIA Corporation MCP78S [GeForce 8200] EHCI USB 2.0 Controller (rev a1)
00:06.0 IDE interface: NVIDIA Corporation MCP78S [GeForce 8200] IDE (rev a1)
00:07.0 Audio device: NVIDIA Corporation MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio (rev a1)
00:08.0 PCI bridge: NVIDIA Corporation MCP78S [GeForce 8200] PCI Bridge (rev a1)
00:09.0 IDE interface: NVIDIA Corporation MCP78S [GeForce 8200] SATA Controller (non-AHCI mode) (rev a2)
00:0a.0 Ethernet controller: NVIDIA Corporation MCP77 Ethernet (rev a2)
00:10.0 PCI bridge: NVIDIA Corporation MCP78S [GeForce 8200] PCI Express Bridge (rev a1)
00:12.0 PCI bridge: NVIDIA Corporation MCP78S [GeForce 8200] PCI Express Bridge (rev a1)
00:13.0 PCI bridge: NVIDIA Corporation MCP78S [GeForce 8200] PCI Bridge (rev a1)
00:14.0 PCI bridge: NVIDIA Corporation MCP78S [GeForce 8200] PCI Bridge (rev a1)
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Link Control
01:0a.0 FireWire (IEEE 1394): LSI Corporation FW322/323 (rev 70)
01:0b.0 Multimedia video controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder (rev 05)
01:0b.1 Multimedia controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder [Audio Port] (rev 05)
02:00.0 VGA compatible controller: NVIDIA Corporation G73 [GeForce 7600 GT] (rev a1)


Dit is de Tv-kaart denk ik:

01:0b.0 Multimedia video controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder (rev 05)
01:0b.1 Multimedia controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder [Audio Port] (rev 05)

Zijn er mogelijkheden om de ontbrekende hardware te koppen aan VirtualBox ?? Je zou zeggen, dat dat technisch toch mogelijk moet zijn

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: TVtime start niet op in VirtualBox
« Reactie #6 Gepost op: 2013/01/27, 20:16:04 »
Dus eigenlijk zijn hier twee problemen. Die YUY2 melding heb ikzelf ooit ook gekregen in 2006. Alleen draaide ik geen virtualbox http://forum.nedlinux.nl/viewtopic.php?id=24050
Omdat de topic ruim zes jaar oud is, zal daarin niet veel bruikbaars staan, voor jou. Wel zou je in die virtualbox de output van commando xvinfo [Enter] kunnen checken. Eventueel zou je als alternatief xawtv kunnen proberen.

Wat het tweede probleem betreft. Hierin http://www.ehow.com/how_7353058_configure-tv-tuner-virtualbox.html lees ik, dat het niet mogelijk is, om een PCI tv-kaart in een virtualbox te gebruiken. Echter zou dit in een recenter virtualbox wel mogelijk zijn http://superuser.com/questions/140490/how-to-map-host-pci-device-to-virtualbox Check daaruit het antwoord van Goyuix.
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline tryer

  • Lid
  • Steunpunt: Nee
Re: TVtime start niet op in VirtualBox
« Reactie #7 Gepost op: 2013/01/27, 21:19:37 »
Laat ik beginnen met het koppelen / vinden van de hardware, later eventueel het YUY2 overlay support probleem.

xvinfo: 
X-Video Extension version 2.2
screen #0
 no adaptors present


tvtime-scanner:
/home/naam/.tvtime/stationlist.xml: No existing NTSC station list "Custom".
videoinput: Cannot open capture device /dev/video0: Bestand of map bestaat niet


starten xawtv:
This is xawtv-3.102, running on Linux/x86_64 (3.2.0-23-generic)
xinerama 0: 1680x946+0+0
vid-open-auto: failed to open a capture device
vid-open: could not find a suitable videodev
no video grabber device available


Dus 3 x het zelfde antwoord: de Virtualboxguest ziet de TV PCI-kaart niet.

 http://superuser.com/questions/140490/how-to-map-host-pci-device-to-virtualbox : dit gebruik is beperkt tot een paar speciale moderne moederborden van Intel.

Bedankt voor jullie antwoorden. Ik ben niet zo'n techneut, toch vind ik het raar dat het niet mogelijk is om bepaalde hardware te kunnen bereiken.

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: TVtime start niet op in VirtualBox
« Reactie #8 Gepost op: 2013/01/27, 21:31:49 »
Dat kun je vergeten met tvtime. Tvtime is niet compatibel met ivtv (xawtv en alle andere programma's die werken met YUV-invoer ook niet).

Je hebt ivtv-utils nodig. Met

ivtv-tune

kun je vervolgens afstemmen, in kHz geloof ik.

Daarna /dev/videoX (meestal 0, kan ook 1 zijn) afspelen in de speler naar keuze. Persoonlijk zou ik Tvheadend gebruiken om de kaart te bedienen en te beheren, het is het enige zowel gebruikersvriendelijk als ivtv-compatible product voor Linux. Als front-end kun je XBMC gebruiken, of gewoonweg over HTTP. Je zou dan op de host moeten kunnen kijken, dat speelt vast een stuk vloeiender af. Enkel teletekst zal niet werken. Je kunt zelfs een EPG toevoegen via xmltv.


Maar goed, ik kan geen eens een tuner vinden in je lspci-uitvoer. Heb je PCI passthrough al juist geconfigureerd? http://www.virtualbox.org/manual/ch09.html#pcipassthrough
« Laatst bewerkt op: 2013/01/27, 23:07:27 door Cumulus007 »