Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Probleem na upgrade MB: netwerk kaart 'start' niet (2de probleem).  (gelezen 378 keer)

Offline wvtienen

  • Lid
  • Steunpunt: Nee
Ik heb het moederbord vervangen van mijn computer en wil nu de oude ubuntu installatie verder gebruiken. 

Ubuntu boot op zich correct; ik zit nog wel met een probleem om grafisch aan te melden; Een terminal openen met cntrl-alt-Fx werkt. 
Maar blijkbaar is er een probleem met de netwerkkaart (realtek RTL8111/8168B ). 

Initieel wordt er geen werkende netwerk kaart aangemaakt.  Enige actieve netwerkkaart is de loopback; ifconfig geeft nog een eth1 weer. 
eth1 kan ik echter niet starten (zou niet geconfigureerd zijn).   Bij opstarten komt nog ergens de boodschap dat Ubunutu 60 seconden zal wachten tot het netwerk werkt (wat dus niet lukt). 

met dhclient3 eth1 krijg ik de netwerkkaart wel in orde. 
Ik vermoed dat de driver wel in orde is. 

Booten met een liveCD geeft een correct werkend netwerk. 

Hoe zorg ik dat die netwerk kaart direct correct werkt?

Walter

Offline wvtienen

  • Lid
  • Steunpunt: Nee
Re: Probleem na upgrade MB: netwerk kaart 'start' niet (2de probleem).
« Reactie #1 Gepost op: 2013/01/25, 19:17:28 »
ok: ik heb het probleem gevonden. 
Probleem is dat de nieuwe netwerkkaart als eth1 wordt aangemaakt.  Alleen is er geen config voor deze netwerk kaart. 
Ik heb nu de netwerk kaart toegevoegd in /etc/network/interfaces 
auto eth1
              iface eth1 inet dhcp

de info ivm met eth0 heb ik uitgecommentarieerd;

Hiermee werkt de netwerk kaart correct.

Wel jammer dat Ubuntu standaard een nieuwe netwerkkaart niet in dhcp modus zet.

Walter

Offline Buzzin

  • Lid
  • Steunpunt: Nee
Re: Probleem na upgrade MB: netwerk kaart 'start' niet (2de probleem).
« Reactie #2 Gepost op: 2013/01/26, 23:26:21 »
Een complete wissel van Hardware is iets dat geen enkel OS makkelijk vind....
Maar dit 'probleem' is eigenlijk een goede feature als je hardware wisselt en de netwerkkaart over zou zetten.
Het naampje eth0 zit namelijk gekoppeld aan het MAC (hardware) adres.

Dit staat in /etc/udev/rules.d/70-persistent-net.rules

Als je dus een andere netwerkkaart gaat gebruiken, moet je de regels in dit bestandje even aanpassen, of nog beter, helemaal leeg halen.
Dit werkt ook als je de volgorde van meerdere kaarten wilt aanpassen (erg handig in servers)

Dus bestandje leeggooien, opnieuw opstarten en de kaart heet weer gewoon eth0 :)
Football: A battle between two teams of mindless thugs over scraps of coloured cloth. Usually accompanied by the spectacle of 22 overpaid primadonnas kicking a ball on a field.
DebianDevuan, KDE & OperaVivaldi addict, RedHat Engineer

Offline wvtienen

  • Lid
  • Steunpunt: Nee
Re: Probleem na upgrade MB: netwerk kaart 'start' niet (2de probleem).
« Reactie #3 Gepost op: 2013/01/27, 00:13:02 »
ik heb helemaal geen probleem met het feit dat die 'nieuwe' netwerkkaart nu eth1 noemt. Dat mag zo blijven.  Alleen is het een verrassing dat een nieuwe netwerkkaart niet standaard op dhcp wordt gezet.  Zoals ubutu wel doet bij een nieuwe installatie van het OS.

Maar ik kan ook begrijpen dat er redenen zijn waarom er geen standaard settings worden gezet op een tweede netwerkkaart in je systeem. 

Walter