Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Onjuiste resolutie voor beeldscherm  (gelezen 778 keer)

Offline Bram

  • Lid
Onjuiste resolutie voor beeldscherm
« Gepost op: 2013/01/12, 09:57:52 »
Ik ben al een paar dagen bezig om de resolutie van mijn beeldscherm op de juiste instellingen te krijgen. Al 10 verschillende pogingen gedaan via diverse forums, maar niets werkt. Bij “schermen” in “instellingen” worden nu alleen (4:3) resoluties aangegeven. Dit terwijl ik 16: 9 wil gebruiken. Na installatie van Ubuntu wordt bij grafisch in _Details “Onbekend” aangegeven.

Als ik met extra stuurprogramma's de “niet-vrij grafisch stuurprogramma FGLRX van ATI/AMD” inschakel wordt na herstarten van het systeem de melding ”D-sub out of range 75,0 Khz 80 Hz” getoond. Verder kan ik niets behalve met CTL-ALT-F1 door naar een terminalvenster. Ik heb ook alternatieve installatie methoden geprobeerd, maar niets werkt. Wat kan hier aan de hand zijn? In Windows7 werkt alles naar behoren.

Mijn omgeving is:
Ubuntu 12.04 LTS
Intel Core i5 CPU 650 @ 3.20 GHz x 4 – 64-bit
Intern geheugen:  8 GB
Grafische kaart:  ATI Radeon HD5450
Beeldscherm: LG E2242C-BN

Ik hoop dat jullie de oplossing hebben.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Onjuiste resolutie voor beeldscherm
« Reactie #1 Gepost op: 2013/01/12, 10:37:57 »
Probeer de nieuwere Ubuntu 12.10 eens, in de Live-sessie (uitproberen zonder installeren). Is het dan wel direct goed?

Offline Bram

  • Lid
Re: Onjuiste resolutie voor beeldscherm
« Reactie #2 Gepost op: 2013/01/12, 13:34:28 »
Dat heb ik geprobeerd, maar ook daar zie ik alleen de twee te kleine resoluties.

Offline Leon_III

  • Lid
  • Steunpunt: Ja
Re: Onjuiste resolutie voor beeldscherm
« Reactie #3 Gepost op: 2013/01/12, 14:04:05 »
Amd levert ook eigen  Linux drivers op hun site, hier te downloaden: http://support.amd.com/us/gpudownload/Pages/index.aspx
Heb ze nog wel eens gebruikt  met ubuntu 10.04, gemakkelijk te installeren.
Laptops HP Probook 4720s en HP g72
Testcomputer HP Compaq dc7800p 
email: SteunpuntLeon@gmail.com

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Onjuiste resolutie voor beeldscherm
« Reactie #4 Gepost op: 2013/01/12, 14:08:23 »
Misschien wordt je monitor niet herkent, sluit eens en andere aan, en herinstalleer de driver van je videokaart.
Indien het nu wel werkt zul je de xorg moeten aanpassen en je monitor daar met de hand inzetten. Google hier op hoe je dit kunt doen.

Offline Bram

  • Lid
Re: Onjuiste resolutie voor beeldscherm
« Reactie #5 Gepost op: 2013/01/12, 14:43:05 »
@Leon_III: dat heb ik ook geprobeerd, maar hetzelfde resultaat.

Offline Bram

  • Lid
Re: Onjuiste resolutie voor beeldscherm
« Reactie #6 Gepost op: 2013/01/12, 16:31:52 »
@jan11000: Ik heb een andere monitor aangesloten, maar helaas hetzelfde resultaat.

Offline Bram

  • Lid
Re: Onjuiste resolutie voor beeldscherm
« Reactie #7 Gepost op: 2013/01/16, 12:29:57 »
Ik heb het nu min of meer werkend gekregen. Met behulp van xrandr een script gemaakt en dit op het bureaublad gezet. Na inloggen op het icoontje klikken en de resolutie is gezet. Als er een betere methode is hou ik me aanbevolen.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Onjuiste resolutie voor beeldscherm
« Reactie #8 Gepost op: 2013/01/16, 17:15:18 »
Je zou de betreffende opdrachtregel in een opstarttoepassing kunnen gooien.... Voor alle zekerheid zou je er een kleine vertraging op kunnen zetten:
sleep 10 && <je opdrachtregel>
Of (nog ingrijpender) de boel "hard" vastleggen in /etc/X11/xorg.conf

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: Onjuiste resolutie voor beeldscherm
« Reactie #9 Gepost op: 2013/01/17, 21:56:47 »
Bram,

Als ik het goed heb zal je in de sectie "Monitor" van je /etc/X11/xorg.conf, de regel:
Option "NoDDC" "True"
moeten plaatsen om de 'communicatie' tussen je monitor en VGA-kaart uit te zetten.

Een andere optie die kan helpen:
Option "IgnoreEDID" "True"

Standaard staan beide optie uit, dus  "False"
Veel testen kan ik niet meer, de ATi-kaart is allang verwisselde door een nVidia kaart.
MvG,
MauRice
Registered Linux user: 473556